source: projects/specs/trunk/d/dvdauthor/dvdauthor-vl.spec @ 521

Revision 521, 4.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1#TODO: GraphicsMagick
2
3%define with_GraphicsMagick 0
4
5Name:           dvdauthor
6Version:        0.6.14
7Release:        2%{?_dist_release}
8Summary:        Command line DVD authoring tool
9Summary(ja):     コマンドライン DVD 作成ツール
10
11Group:          Applications/Multimedia
12License:        GPLv2+
13URL:            http://dvdauthor.sourceforge.net/
14Source0:        http://downloads.sourceforge.net/dvdauthor/%{name}-%{version}.tar.gz
15# Patch0:         %{name}-0.6.14-graphicsmagick.patch
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  libdvdread-devel >= 0.9.4-4
19BuildRequires:  libpng-devel
20BuildRequires:  flex
21BuildRequires:  bison
22BuildRequires:  libxml2-devel >= 2.6.0
23BuildRequires:  fribidi-devel
24BuildRequires:  freetype-devel
25%if %{with_GraphicsMagick}
26BuildRequires:  GraphicsMagick-devel
27# autofoo etc for Patch0
28BuildRequires:  autoconf automake gettext-devel
29%else
30BuildRequires:  ImageMagick-devel
31%endif
32
33%description
34dvdauthor is a program that will generate a DVD movie from a valid
35mpeg2 stream that should play when you put it in a DVD player.
36
37
38%prep
39%setup -q
40%if %{with_GraphicsMagick}
41%patch0 -p1 -b .graphicsmagick
42autoreconf # for Patch0
43%endif
44
45# Adapt to changed header location in libdvdread 4.1.3.  *sigh*
46if [ -d %{_includedir}/libdvdread ] ; then
47    sed -i -e 's|<dvdread/|<libdvdread/|g' src/dvdunauthor.c src/dvduncompile.h
48fi
49
50
51%build
52%if %{with_GraphicsMagick}
53export MAGICKCONFIG=/bin/true # disable ImageMagick
54export LDFLAGS="$LDFLAGS -Wl,--as-needed" # avoid *Magick-config linkage bloat
55%endif
56
57%configure \
58    --disable-rpath \
59    --disable-dependency-tracking
60
61%__make %{?_smp_mflags}
62
63
64%install
65%__rm -rf $RPM_BUILD_ROOT
66%__make install DESTDIR=$RPM_BUILD_ROOT
67
68
69%clean
70%__rm -rf $RPM_BUILD_ROOT
71
72
73%files
74%defattr(-,root,root,-)
75%doc ChangeLog COPYING README TODO
76%{_bindir}/dvdauthor
77%{_bindir}/dvddirdel
78%{_bindir}/dvdunauthor
79%{_bindir}/mpeg2desc
80%{_bindir}/spumux
81%{_bindir}/spuunmux
82%{_datadir}/dvdauthor/
83%{_mandir}/man1/dvdauthor.1*
84%{_mandir}/man1/dvddirdel.1*
85%{_mandir}/man1/dvdunauthor.1*
86%{_mandir}/man1/mpeg2desc.1*
87%{_mandir}/man1/spumux.1*
88%{_mandir}/man1/spuunmux.1*
89
90
91%changelog
92* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.14-2
93- rebuilt with ImageMagick 6.4.9-2
94- added Japanese summary
95
96* Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.6.14-1
97- intial build based on Fedora development package
98
99* Tue Jul  8 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.6.14-6
100- Fix build with changed libdvdread 4.1.3 header location.
101
102* Wed Feb 13 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.6.14-5
103- Build with GraphicsMagick, drop all build time conditionals (#245155).
104- Patch to differentiate ImageMagick vs GraphicsMagick at build time, don't
105  rely on GM's IM compat things installed, fix RGBA treatment with GM.
106- Avoid linkage bloat from GraphicsMagick-config --libs.
107
108* Wed Feb 13 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.6.14-4
109- Add build time conditional for GraphicsMagick, disabled by default (#432651).
110- Get rid of need for BuildConflicts.
111
112* Fri Nov 16 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.6.14-3
113- Rebuild.
114
115* Tue Aug 14 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.6.14-2
116- License: GPLv2+
117
118* Sat Feb 24 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.6.14-1
119- 0.6.14.
120
121* Wed Jan 17 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.6.13-1
122- 0.6.13.
123
124* Mon Jan  8 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.6.12-1
125- 0.6.12.
126
127* Sun Jan  7 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.6.11-9
128- First FE build (#219103).
129
130* Thu Oct 26 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.6.11-8
131- Build without ImageMagick by default due to dependency bloat (#212478).
132- Prune pre-2006 changelog entries.
133
134* Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 0.6.11-7
135- rebuilt for unwind info generation, broken in gcc-4.1.1-21
136
137* Sun Sep 24 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.6.11-6
138- Rebuild.
139
140* Sun Jul  9 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.6.11-5
141- Rebuild for new ImageMagick (#1087).
142
143* Thu Mar 16 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.6.11-4
144- Remove -ldl hacks, BR fixed libdvdread-devel.
Note: See TracBrowser for help on using the repository browser.