source: projects/specs/trunk/d/dvdauthor/dvdauthor-vl.spec @ 8721

Revision 8721, 4.4 KB checked in by Takemikaduchi, 10 years ago (diff)

cinnamon-2.2.14, python-2.7.7, ImageMagick?-6.8.9.5

Line 
1#TODO: GraphicsMagick
2
3%define with_GraphicsMagick 0
4
5Name:           dvdauthor
6Summary:        Command line DVD authoring tool
7Summary(ja):    コマンドライン DVD 作成ツール
8Version:        0.7.1
9Release:        1%{?_dist_release}
10
11Group:          Applications/Multimedia
12License:        GPLv2+
13URL:            http://dvdauthor.sourceforge.net/
14Source0:        http://downloads.sourceforge.net/dvdauthor/%{name}-%{version}.tar.gz
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildRequires:  libdvdread-devel >= 0.9.4-4
18BuildRequires:  libpng-devel
19BuildRequires:  flex
20BuildRequires:  bison
21BuildRequires:  libxml2-devel >= 2.6.0
22BuildRequires:  fribidi-devel
23BuildRequires:  freetype2-devel
24%if %{with_GraphicsMagick}
25BuildRequires:  GraphicsMagick-devel
26%else
27BuildRequires:  ImageMagick-devel
28%endif
29
30%description
31dvdauthor is a program that will generate a DVD movie from a valid
32mpeg2 stream that should play when you put it in a DVD player.
33
34
35%prep
36%setup -q -n %{name}
37
38# Adapt to changed header location in libdvdread 4.1.3.  *sigh*
39if [ -d %{_includedir}/libdvdread ] ; then
40    sed -i -e 's|<dvdread/|<libdvdread/|g' src/dvdunauthor.c src/dvduncompile.h
41fi
42
43
44%build
45%if %{with_GraphicsMagick}
46export MAGICKCONFIG=/bin/true # disable ImageMagick
47export LDFLAGS="$LDFLAGS -Wl,--as-needed" # avoid *Magick-config linkage bloat
48%endif
49
50%configure \
51    --disable-rpath \
52    --disable-dependency-tracking
53
54%__make %{?_smp_mflags}
55
56
57%install
58%__rm -rf $RPM_BUILD_ROOT
59%__make install DESTDIR=$RPM_BUILD_ROOT
60
61
62%clean
63%__rm -rf $RPM_BUILD_ROOT
64
65
66%files
67%defattr(-,root,root,-)
68%doc ChangeLog COPYING README TODO
69%{_bindir}/dvdauthor
70%{_bindir}/dvddirdel
71%{_bindir}/dvdunauthor
72%{_bindir}/mpeg2desc
73%{_bindir}/spumux
74%{_bindir}/spuunmux
75%{_datadir}/dvdauthor/
76%{_mandir}/man1/dvdauthor.1*
77%{_mandir}/man1/dvddirdel.1*
78%{_mandir}/man1/dvdunauthor.1*
79%{_mandir}/man1/mpeg2desc.1*
80%{_mandir}/man1/spumux.1*
81%{_mandir}/man1/spuunmux.1*
82
83
84%changelog
85* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.1-1
86- update to 0.7.1
87
88* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.0-2
89- rebuild with ImageMagick-6.8.6.8
90
91* Sun Mar 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.0-1
92- update to 0.7.0
93
94* Sun Oct  3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.18-2
95- rebuilt with ImageMagick-6.6.4.8
96
97* Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.18-1
98- new upstream release
99- rebuilt with new toolchain and ImageMagick 6.6.1.5
100
101* Fri Feb  6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.14-2
102- rebuilt with ImageMagick 6.4.9-2
103- added Japanese summary
104
105* Sat Jan 24 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.6.14-1
106- intial build based on Fedora development package
107
108* Tue Jul  8 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.6.14-6
109- Fix build with changed libdvdread 4.1.3 header location.
110
111* Wed Feb 13 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.6.14-5
112- Build with GraphicsMagick, drop all build time conditionals (#245155).
113- Patch to differentiate ImageMagick vs GraphicsMagick at build time, don't
114  rely on GM's IM compat things installed, fix RGBA treatment with GM.
115- Avoid linkage bloat from GraphicsMagick-config --libs.
116
117* Wed Feb 13 2008 Ville Skyttä <ville.skytta at iki.fi> - 0.6.14-4
118- Add build time conditional for GraphicsMagick, disabled by default (#432651).
119- Get rid of need for BuildConflicts.
120
121* Fri Nov 16 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.6.14-3
122- Rebuild.
123
124* Tue Aug 14 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.6.14-2
125- License: GPLv2+
126
127* Sat Feb 24 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.6.14-1
128- 0.6.14.
129
130* Wed Jan 17 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.6.13-1
131- 0.6.13.
132
133* Mon Jan  8 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.6.12-1
134- 0.6.12.
135
136* Sun Jan  7 2007 Ville Skyttä <ville.skytta at iki.fi> - 0.6.11-9
137- First FE build (#219103).
138
139* Thu Oct 26 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.6.11-8
140- Build without ImageMagick by default due to dependency bloat (#212478).
141- Prune pre-2006 changelog entries.
142
143* Fri Oct 06 2006 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> 0.6.11-7
144- rebuilt for unwind info generation, broken in gcc-4.1.1-21
145
146* Sun Sep 24 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.6.11-6
147- Rebuild.
148
149* Sun Jul  9 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.6.11-5
150- Rebuild for new ImageMagick (#1087).
151
152* Thu Mar 16 2006 Ville Skyttä <ville.skytta at iki.fi> - 0.6.11-4
153- Remove -ldl hacks, BR fixed libdvdread-devel.
Note: See TracBrowser for help on using the repository browser.