source: projects/specs/trunk/d/doxygen/doxygen-vl.spec @ 5187

Revision 5187, 8.4 KB checked in by kenta, 12 years ago (diff)

doxygen: update to 1.7.5.1

Line 
1# Set this to "1" if you want to build doxywizard
2%define wizard 1
3
4Summary: A documentation system for C/C++.
5Summary(ja): C/C++ 向けドキュメンテーションシステム
6Name: doxygen
7Version: 1.7.5.1
8Release: 1%{?_dist_release}
9Source0: ftp://ftp.stack.nl/pub/users/dimitri/%{name}-%{version}.src.tar.gz
10Patch0: doxygen-1.7.1-config.patch
11Patch1: doxygen-1.7.5-timestamp.patch
12Group: Development/Tools
13License: GPLv2
14URL: http://www.stack.nl/~dimitri/doxygen/
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17BuildRequires: perl texlive texlive-collection-fontutils ghostscript gettext
18BuildRequires: flex bison
19%if %{wizard}
20BuildRequires: qt4-devel => 4.4
21%endif
22#Requires: libgcc libstdc++34 graphviz
23
24%description
25Doxygen can generate an online class browser (in HTML) and/or a
26reference manual (in LaTeX) from a set of documented source files. The
27documentation is extracted directly from the sources. Doxygen can
28also be configured to extract the code structure from undocumented
29source files.
30
31%package doxywizard
32Summary: A GUI for creating and editing configuration files.
33Group: Applications/Development
34Requires: %{name} = %{version}-%{release}
35
36%description doxywizard
37Doxywizard is a GUI for creating and editing configuration files that
38are used by doxygen.
39
40%prep
41%setup -q -n %{name}-%{version}
42%patch0 -p1 -b .config
43%patch1 -p1 -b .timestamp
44
45%build
46unset QTDIR
47export OLD_PO_FILE_INPUT=yes
48
49./configure \
50    --prefix %{_prefix} \
51    --shared \
52%if %{wizard}
53     --with-doxywizard \
54%endif
55     --release
56
57make %{?_smp_mflags} all
58make docs
59
60%install
61rm -rf $RPM_BUILD_ROOT
62
63export OLD_PO_FILE_INPUT=yes
64make install DESTDIR=$RPM_BUILD_ROOT
65
66%if !%{wizard}
67rm $RPM_BUILD_ROOT%{_mandir}/man1/doxywizard.*
68%endif
69
70# convert into utf-8
71iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
72touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
73mv LANGUAGE.HOWTO.new LANGUAGE.HOWTO
74
75sed -i -e "s|#!perl|#!/usr/bin/perl|" examples/tag/html/installdox
76
77%clean
78rm -rf $RPM_BUILD_ROOT
79
80%files
81%defattr(-,root,root)
82%doc LANGUAGE.HOWTO LICENSE README examples html
83%{_bindir}/doxygen
84%{_bindir}/doxytag
85%{_mandir}/man1/doxygen.*
86%{_mandir}/man1/doxytag.*
87
88%if %{wizard}
89%files doxywizard
90%defattr(-,root,root)
91%{_bindir}/doxywizard
92%{_mandir}/man1/doxywizard.*
93%endif
94
95%changelog
96* Wed Nov 02 2011 NAKAMURA Kenta <kenta@vinelinux.org> - 1.7.5.1-1
97- new upstream release
98- updated Patch0 and 1
99
100* Mon Oct 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.1-1
101- new upstream release
102- added Patch0, 1 from Fedora
103  * Mon Aug 24 2009 Than Ngo <than@redhat.com> - 1.6.0-2
104  - fix #516339, allow to enable/disable timstamp to avoid the multilib issue
105    HTMP_TIMESTAMP is disable by default
106- enabled doxywizard
107
108* Tue Dec  9 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7.1-1
109- new upstream release
110- disable doxywizard
111
112* Thu May 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.6-1
113- new upstream release
114
115* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl1
116- new upstream release
117
118* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
119- new upstream release
120
121* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl3
122- rebuild with libstdc++34
123
124* Sun Oct 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.7-0vl2
125- add BuildRequires: flex
126
127* Fri Sep 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.7-0vl1
128- new upstream release
129- changed doxygen-doxywizard Group to Applications/Development
130
131* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.4.5-0vl2
132- added doxygen-1.4.5-libdir.patch for x86_64 and ppc64 archtecture
133
134* Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.5-0vl1
135- new upstream release
136
137* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.4-0vl1
138- new upstream release
139- update Requires
140
141* Wed Jun  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
142- build for VineSeed
143
144* Wed Jun  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl1
145- new upstream release
146- build for Vine3.1
147- LANG=C when build and install
148- add man pages
149
150* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
151- new upstream release
152- BuildPrereq: qt-devel => 3.2
153
154* Tue Dec  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.9.1-0vl1
155- source upgrade
156
157* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.7-0vl1
158- source upgrade
159- remove %%{_bindir}/doxysearch from %%files
160- remove about Vine2.6
161
162* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.3-0vl2
163- build for VineSeed
164
165* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.3-0vl1
166- source upgrade
167- add BuildPrereq: graphviz and Requires: graphviz
168- change spec to build both VineSeed and Vine2.5/2.6
169
170* Sat May 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
171- source upgrade
172
173* Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl1
174- source upgrade
175
176* Wed Jan  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl0.3
177- source upgrade to 1.3-rc3
178- enable %%configure --with-doxywizard
179
180* Wed Jan  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl0.1
181- source upgrade to 1.3-rc2
182- add BuildPrereq: libpng-devel
183- add Requires: XFree86-gl libexpat to %%package doxywizard
184- add LICENSE to %%docs
185- disable %%configure --with-doxywizard
186
187* Fri Jan  3 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.18-0vl1
188- source upgrade
189- build with new toolchains
190- delete Patch2
191
192* Tue Aug  5 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.17-0vl1
193- source upgrade
194- build with qt-3.0.5
195
196* Sun Jun  9 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.16-0vl1
197- source update to 1.2.16
198
199* Thu May 09 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.15-0vl1
200- source update to 1.2.15
201
202* Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.14-3vl1
203- build for VineSeed
204- delete Epoch
205
206* Fri Mar  8 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.13-3
207- rebuild against qt 3.0.2
208
209* Tue Feb 26 2002 Than Ngo <than@redhat.com> 1.2.14-2
210- rebuild against qt 2.3.2
211
212* Tue Feb 19 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.14-1
213- 1.2.14
214
215* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
216- automated rebuild
217
218* Sun Jan 06 2002 Than Ngo <than@redhat.com> 1.2.13.1-1
219- update to 1.2.13.1
220- fixed build doxywizard with qt3
221
222* Sun Dec 30 2001 Jeff Johnson <jbj@redhat.com> 1.2.13-1
223- update to 1.2.13
224
225* Sun Nov 18 2001 Than Ngo <than@redhat.com> 1.2.12-1
226- update to 1.2.12
227- s/Copyright/License
228
229* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
230- rebuild with new gcc and binutils
231
232* Wed Jun 13 2001 Than Ngo <than@redhat.com>
233- update tp 1.2.8.1
234- make doxywizard as separat package
235- fix to use install as default
236
237* Tue Jun 05 2001 Than Ngo <than@redhat.com>
238- update to 1.2.8
239
240* Tue May 01 2001 Than Ngo <than@redhat.com>
241- update to 1.2.7
242- clean up specfile
243- patch to use RPM_OPT_FLAG
244
245* Wed Mar 14 2001 Jeff Johnson <jbj@redhat.com>
246- update to 1.2.6
247
248* Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
249- rebuild
250
251* Tue Dec 26 2000 Than Ngo <than@redhat.com>
252- update to 1.2.4
253- remove excludearch ia64
254- bzip2 sources
255
256* Mon Dec 11 2000 Than Ngo <than@redhat.com>
257- rebuild with the fixed fileutils
258
259* Mon Oct 30 2000 Jeff Johnson <jbj@redhat.com>
260- update to 1.2.3.
261
262* Sun Oct  8 2000 Jeff Johnson <jbj@redhat.com>
263- update to 1.2.2.
264- enable doxywizard.
265
266* Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
267- 1.2.1 is latest stable, so we upgrade before Winston is released.
268
269* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
270- automatic rebuild
271
272* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
273- Rebuild with new C++
274
275* Fri Jun 30 2000 Florian La Roche <laroche@redhat.de>
276- fix QTDIR detection
277
278* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
279- compile on x86 w/o optimization, revert when compiler fixed!!
280
281* Wed Jun 07 2000 Preston Brown <pbrown@redhat.com>
282- use newer RPM macros
283
284* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
285- add to distro.
286
287* Tue May  9 2000 Tim Powers <timp@redhat.com>
288- rebuilt for 7.0
289
290* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
291- recompile with current Qt (2.1.0/1.45)
292
293* Wed Jan  5 2000 Jeff Johnson <jbj@redhat.com>
294- update to 1.0.0.
295- recompile with qt-2.0.1 if available.
296- relocatable package.
297
298* Mon Nov  8 1999 Tim Powers <timp@redhat.com>
299-updated to 0.49-991106
300
301* Tue Jul 13 1999 Tim Powers <timp@redhat.com>
302- updated source
303- cleaned up some stuff in the spec file
304
305* Thu Apr 22 1999 Jeff Johnson <jbj@redhat.com>
306- Create Power Tools 6.0 package.
Note: See TracBrowser for help on using the repository browser.