source: projects/specs/trunk/d/doxygen/doxygen-vl.spec @ 12539

Revision 12539, 10.1 KB checked in by tomop, 3 years ago (diff)

updated 6 packages

chrpath-0.16-2

doxygen-1.9.1-1

libsigc++-2.10.6-1

pavucontrol-4.0-1

pulseaudio-14.2-1

xmlto-0.0.28-1

Line 
1# Set this to "1" if you want to build doxywizard
2%define wizard 1
3
4Summary: A documentation system for C/C++.
5Summary(ja): C/C++ 向けドキュメンテーションシステム
6Name: doxygen
7Version: 1.9.1
8Release: 1%{?_dist_release}
9Group: programming
10Vendor: Project Vine
11Distribution: Vine Linux
12
13License: GPLv2
14URL: https://www.doxygen.nl/
15Source0: https://doxygen.nl/files/%{name}-%{version}.src.tar.gz
16# this icon is part of kdesdk
17Source1: doxywizard.desktop
18# these icons are part of doxygen and converted from doxywizard.ico
19Source2: doxywizard-icons.tar.xz
20# upstream patches
21Patch1: doxgen-1.9.1-crash-when-parsing-config-file.patch
22Patch2: doxgen-1.9.1-crash-when-parsing-config-file-part2.patch
23Patch3: doxygen-1.9.1-Coverity_issues.patch
24Patch4: doxygen-1.9.1-crash_in_docparser.patch
25
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildRequires: perl texlive texlive-collection-fontutils ghostscript gettext
28BuildRequires: flex bison
29BuildRequires: desktop-file-utils
30BuildRequires: graphviz
31BuildRequires: python3
32BuildRequires: cmake
33%if %{wizard}
34BuildRequires: qt5-qtbase-devel
35%endif
36Requires: graphviz
37
38%description
39Doxygen can generate an online class browser (in HTML) and/or a
40reference manual (in LaTeX) from a set of documented source files. The
41documentation is extracted directly from the sources. Doxygen can
42also be configured to extract the code structure from undocumented
43source files.
44
45
46%package doxywizard
47Summary: A GUI for creating and editing configuration files.
48Group: programming
49Requires: %{name} = %{version}-%{release}
50
51%description doxywizard
52Doxywizard is a GUI for creating and editing configuration files that
53are used by doxygen.
54
55
56%debug_package
57
58
59%prep
60%autosetup -p1 -a2
61
62# convert into utf-8
63iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
64touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
65mv LANGUAGE.HOWTO.new LANGUAGE.HOWTO
66
67
68%build
69%cmake \
70      -DPYTHON_EXECUTABLE=%{_bindir}/python3 \
71      -Duse_libclang=OFF \
72      -Dbuild_doc=OFF \
73%if %{wizard}
74      -Dbuild_wizard=ON \
75%else
76      -Dbuild_wizard=OFF \
77%endif
78      -Dbuild_xmlparser=ON \
79      -Dbuild_search=OFF \
80      -DMAN_INSTALL_DIR=%{_mandir}/man1 \
81      -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
82      -DBUILD_SHARED_LIBS=OFF
83
84make %{?_smp_mflags}
85
86
87%install
88rm -rf $RPM_BUILD_ROOT
89make install DESTDIR=$RPM_BUILD_ROOT
90
91# install icons
92icondir=%{buildroot}%{_datadir}/icons/hicolor
93mkdir -m755 -p $icondir/{16x16,32x32,48x48,128x128}/apps
94install -m644 -p -D doxywizard-6.png $icondir/16x16/apps/doxywizard.png
95install -m644 -p -D doxywizard-5.png $icondir/32x32/apps/doxywizard.png
96install -m644 -p -D doxywizard-4.png $icondir/48x48/apps/doxywizard.png
97install -m644 -p -D doxywizard-3.png $icondir/128x128/apps/doxywizard.png
98
99# install man pages
100mkdir -p %{buildroot}/%{_mandir}/man1
101cp doc/*.1 %{buildroot}/%{_mandir}/man1/
102%if 0%{?_module_build}
103rm -f %{buildroot}/%{_mandir}/man1/doxywizard.1*
104%endif
105
106%if "x%{?xapian_core_support}" == "xOFF"
107rm -f %{buildroot}/%{_mandir}/man1/doxyindexer.1* %{buildroot}/%{_mandir}/man1/d
108oxysearch.1*
109%endif
110
111# remove duplicate
112rm -rf %{buildroot}/%{_docdir}/packages
113
114%if 0%{?wizard}
115desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE1}
116%endif
117
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122
123%files
124%defattr(-,root,root)
125%license LICENSE
126%doc LANGUAGE.HOWTO README.md
127%{_bindir}/doxygen
128%{_mandir}/man1/doxygen.*
129%exclude %{_mandir}/man1/doxyindexer.*
130%exclude %{_mandir}/man1/doxysearch.*
131
132%if %{wizard}
133%files doxywizard
134%defattr(-,root,root)
135%{_bindir}/doxywizard
136%{_mandir}/man1/doxywizard.*
137%{_datadir}/applications/doxywizard.desktop
138%endif
139%{_datadir}/icons/hicolor/*/apps/doxywizard.png
140
141
142%changelog
143* Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9.1-1
144- new upstream release.
145- dropped all patches.
146- imported Patch1-4 from rawhide.
147
148* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.6-2
149- rebuild with gcc-5.4.0
150
151* Tue Jan 14 2014 NAKAMURA Kenta <kenta@vinelinux.org> - 1.8.6-1
152- new upstream release
153
154* Wed Nov 02 2011 NAKAMURA Kenta <kenta@vinelinux.org> - 1.7.5.1-1
155- new upstream release
156- updated Patch0 and 1
157
158* Mon Oct 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.1-1
159- new upstream release
160- added Patch0, 1 from Fedora
161  * Mon Aug 24 2009 Than Ngo <than@redhat.com> - 1.6.0-2
162  - fix #516339, allow to enable/disable timstamp to avoid the multilib issue
163    HTMP_TIMESTAMP is disable by default
164- enabled doxywizard
165
166* Tue Dec  9 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7.1-1
167- new upstream release
168- disable doxywizard
169
170* Thu May 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.6-1
171- new upstream release
172
173* Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl1
174- new upstream release
175
176* Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
177- new upstream release
178
179* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl3
180- rebuild with libstdc++34
181
182* Sun Oct 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.7-0vl2
183- add BuildRequires: flex
184
185* Fri Sep 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.7-0vl1
186- new upstream release
187- changed doxygen-doxywizard Group to Applications/Development
188
189* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.4.5-0vl2
190- added doxygen-1.4.5-libdir.patch for x86_64 and ppc64 archtecture
191
192* Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.5-0vl1
193- new upstream release
194
195* Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.4-0vl1
196- new upstream release
197- update Requires
198
199* Wed Jun  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
200- build for VineSeed
201
202* Wed Jun  1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl1
203- new upstream release
204- build for Vine3.1
205- LANG=C when build and install
206- add man pages
207
208* Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
209- new upstream release
210- BuildPrereq: qt-devel => 3.2
211
212* Tue Dec  7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.9.1-0vl1
213- source upgrade
214
215* Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.7-0vl1
216- source upgrade
217- remove %%{_bindir}/doxysearch from %%files
218- remove about Vine2.6
219
220* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.3-0vl2
221- build for VineSeed
222
223* Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.3-0vl1
224- source upgrade
225- add BuildPrereq: graphviz and Requires: graphviz
226- change spec to build both VineSeed and Vine2.5/2.6
227
228* Sat May 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
229- source upgrade
230
231* Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl1
232- source upgrade
233
234* Wed Jan  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl0.3
235- source upgrade to 1.3-rc3
236- enable %%configure --with-doxywizard
237
238* Wed Jan  8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl0.1
239- source upgrade to 1.3-rc2
240- add BuildPrereq: libpng-devel
241- add Requires: XFree86-gl libexpat to %%package doxywizard
242- add LICENSE to %%docs
243- disable %%configure --with-doxywizard
244
245* Fri Jan  3 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.18-0vl1
246- source upgrade
247- build with new toolchains
248- delete Patch2
249
250* Mon Aug  5 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.17-0vl1
251- source upgrade
252- build with qt-3.0.5
253
254* Sun Jun  9 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.16-0vl1
255- source update to 1.2.16
256
257* Thu May 09 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.15-0vl1
258- source update to 1.2.15
259
260* Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.14-3vl1
261- build for VineSeed
262- delete Epoch
263
264* Fri Mar  8 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.13-3
265- rebuild against qt 3.0.2
266
267* Tue Feb 26 2002 Than Ngo <than@redhat.com> 1.2.14-2
268- rebuild against qt 2.3.2
269
270* Tue Feb 19 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.14-1
271- 1.2.14
272
273* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
274- automated rebuild
275
276* Sun Jan 06 2002 Than Ngo <than@redhat.com> 1.2.13.1-1
277- update to 1.2.13.1
278- fixed build doxywizard with qt3
279
280* Sun Dec 30 2001 Jeff Johnson <jbj@redhat.com> 1.2.13-1
281- update to 1.2.13
282
283* Sun Nov 18 2001 Than Ngo <than@redhat.com> 1.2.12-1
284- update to 1.2.12
285- s/Copyright/License
286
287* Wed Sep 12 2001 Tim Powers <timp@redhat.com>
288- rebuild with new gcc and binutils
289
290* Wed Jun 13 2001 Than Ngo <than@redhat.com>
291- update tp 1.2.8.1
292- make doxywizard as separat package
293- fix to use install as default
294
295* Tue Jun 05 2001 Than Ngo <than@redhat.com>
296- update to 1.2.8
297
298* Tue May 01 2001 Than Ngo <than@redhat.com>
299- update to 1.2.7
300- clean up specfile
301- patch to use RPM_OPT_FLAG
302
303* Wed Mar 14 2001 Jeff Johnson <jbj@redhat.com>
304- update to 1.2.6
305
306* Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
307- rebuild
308
309* Tue Dec 26 2000 Than Ngo <than@redhat.com>
310- update to 1.2.4
311- remove excludearch ia64
312- bzip2 sources
313
314* Mon Dec 11 2000 Than Ngo <than@redhat.com>
315- rebuild with the fixed fileutils
316
317* Mon Oct 30 2000 Jeff Johnson <jbj@redhat.com>
318- update to 1.2.3.
319
320* Sun Oct  8 2000 Jeff Johnson <jbj@redhat.com>
321- update to 1.2.2.
322- enable doxywizard.
323
324* Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
325- 1.2.1 is latest stable, so we upgrade before Winston is released.
326
327* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
328- automatic rebuild
329
330* Tue Jul  4 2000 Jakub Jelinek <jakub@redhat.com>
331- Rebuild with new C++
332
333* Fri Jun 30 2000 Florian La Roche <laroche@redhat.de>
334- fix QTDIR detection
335
336* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
337- compile on x86 w/o optimization, revert when compiler fixed!!
338
339* Wed Jun 07 2000 Preston Brown <pbrown@redhat.com>
340- use newer RPM macros
341
342* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
343- add to distro.
344
345* Tue May  9 2000 Tim Powers <timp@redhat.com>
346- rebuilt for 7.0
347
348* Wed Feb  2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
349- recompile with current Qt (2.1.0/1.45)
350
351* Wed Jan  5 2000 Jeff Johnson <jbj@redhat.com>
352- update to 1.0.0.
353- recompile with qt-2.0.1 if available.
354- relocatable package.
355
356* Mon Nov  8 1999 Tim Powers <timp@redhat.com>
357-updated to 0.49-991106
358
359* Tue Jul 13 1999 Tim Powers <timp@redhat.com>
360- updated source
361- cleaned up some stuff in the spec file
362
363* Thu Apr 22 1999 Jeff Johnson <jbj@redhat.com>
364- Create Power Tools 6.0 package.
Note: See TracBrowser for help on using the repository browser.