source: projects/specs/trunk/d/dovecot/dovecot-vl.spec @ 2490

Revision 2490, 29.2 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with openssl-1.0.0c

Line 
1Summary: Dovecot Secure imap server
2Summary(ja): Dovecot セキュア IMAP サーバ
3Name: dovecot
4Version: 1.2.15
5Release: 2%{?_dist_release}
6License: MIT and LGPLv2 and BSD with advertising
7Group: System Environment/Daemons
8
9%define build_postgres 1
10%define build_mysql 1
11%define build_sqlite 1
12%define build_ldap 1
13
14%define build_sieve 1
15%define sieve_version 1.1.8
16%define sieve_name dovecot-sieve
17
18%define build_drac 1
19
20URL: http://www.dovecot.org/
21
22Source: http://www.dovecot.org/releases/1.1/%{name}-%{version}.tar.gz
23Source1: dovecot.init
24Source2: dovecot.pam
25Source3: maildir-migration.txt
26Source4: migrate-folders
27Source5: migrate-users
28Source6: perfect_maildir.pl
29Source7: dovecot-REDHAT-FAQ.txt
30Source8: http://dovecot.org/releases/sieve/%{sieve_name}-%{sieve_version}.tar.gz
31Source9: dovecot.sysconfig
32
33Source100: http://www.dovecot.org/patches/1.1/drac.c
34Source110: README.plugin-drac
35
36Patch1: dovecot-1.2-default-settings.patch
37Patch2: dovecot-1.0.beta2-mkcert-permissions.patch
38# local filesystem rules
39Patch3: dovecot-1.0.rc7-mkcert-paths.patch
40
41Packager: iwamoto
42Vendor: Project Vine
43Distribution: Vine Linux
44
45Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
46BuildRequires: openssl-devel, pam-devel, zlib-devel
47BuildRequires: bzip2-devel, libcap-devel
48BuildRequires: libtool autoconf automake, gettext-devel
49BuildRequires: pkgconfig
50# Package includes an initscript service file,
51# needs to require initscripts package
52Requires: initscripts
53Requires(pre): /usr/sbin/useradd
54Requires(post): /sbin/chkconfig, /usr/sbin/useradd, /sbin/chkconfig
55Requires(preun): /usr/sbin/userdel, /usr/sbin/groupdel
56Requires(preun): /sbin/chkconfig, /sbin/service
57Requires(postun): /sbin/service
58
59%if %{build_postgres}
60BuildRequires: postgresql-devel
61%endif
62
63%if %{build_mysql}
64BuildRequires: mysql-devel
65%endif
66
67%if %{build_sqlite}
68BuildRequires: sqlite3-devel
69%endif
70
71%if %{build_ldap}
72BuildRequires: openldap-devel
73%endif
74
75%if %{build_drac}
76BuildRequires: dracd
77%endif
78
79%define docdir %{_docdir}/%{name}
80%define ssldir %{_sysconfdir}/pki/%{name}
81
82%description
83Dovecot is an IMAP server for Linux/UNIX-like systems, written with security
84primarily in mind.  It also contains a small POP3 server.  It supports mail
85in either of maildir or mbox formats.
86
87The SQL drivers and authentication plugins are in their subpackages.
88
89
90%if %{build_sieve}
91%package sieve
92Requires: %{name} = %{version}-%{release}
93Summary: CMU Sieve plugin for dovecot LDA
94Group: System Environment/Daemons
95License: MIT and LGPLv2+
96
97%description sieve
98This package provides the CMU Sieve plugin version %{sieve_version} for dovecot LDA.
99%endif
100
101%if %{build_postgres}
102%package pgsql
103Requires: %{name} = %{version}-%{release}
104Summary: Postgres SQL backend for dovecot
105Group: System Environment/Daemons
106%description pgsql
107This package provides the Postgres SQL backend for dovecot-auth etc.
108%endif
109
110%if %{build_mysql}
111%package mysql
112Requires: %{name} = %{version}-%{release}
113Summary: MySQL backend for dovecot
114Group: System Environment/Daemons
115%description mysql
116This package provides the MySQL backend for dovecot-auth etc.
117%endif
118
119%if %{build_sqlite}
120%package sqlite
121Requires: %{name} = %{version}-%{release}
122Summary: SQLite backend for dovecot
123Group: System Environment/Daemons
124%description sqlite
125This package provides the SQLite backend for dovecot-auth etc.
126%endif
127
128%if %{build_ldap}
129%package ldap
130Requires: %{name} = %{version}-%{release}
131Summary: LDAP auth plugin for dovecot
132Group: System Environment/Daemons
133%description ldap
134This package provides the LDAP auth plugin for dovecot-auth etc.
135%endif
136
137%if %{build_drac}
138%package drac
139Summary: Dovecot plugin module for support drac (POP before SMTP)
140Group: System Environment/Daemons
141Requires: %{name} = %{version}-%{release}
142Requires: dracd
143Obsoletes: %{name}-plugin-drac < %{version}-%{release}
144
145%description drac
146Dovecot plugin module for support drac (POP before SMTP)
147%endif
148
149%package devel
150Requires: %{name} = %{version}-%{release}
151Summary: Development files dor dovecot
152Group: Development/Libraries
153%description devel
154This package provides the development files for dovecot.
155
156
157%prep
158
159%setup -q
160
161cp %{SOURCE100} .
162cp %{SOURCE110} .
163
164%patch1 -p1 -b .default-settings
165%patch2 -p1 -b .mkcert-permissions
166%patch3 -p1 -b .mkcert-paths
167
168%if %{build_sieve}
169%setup -q -D -T -a 8
170%endif
171
172%build
173rm -f ./configure
174autoreconf -i -f
175%configure                           \
176    INSTALL_DATA="install -c -p -m644" \
177    --enable-header-install      \
178    --disable-static             \
179%if %{build_postgres}
180    --with-pgsql                 \
181%endif
182%if %{build_mysql}
183    --with-mysql                 \
184%endif
185%if %{build_sqlite}
186    --with-sqlite                \
187%endif
188    --with-sql=plugin            \
189    --with-sql-drivers           \
190    --with-ssl=openssl           \
191    --with-ssldir=%{ssldir}      \
192%if %{build_ldap}
193    --with-ldap=plugin
194%endif
195
196make %{?_smp_mflags}
197
198%if %{build_sieve}
199pushd %{sieve_name}-%{sieve_version}
200rm -f ./configure
201autoreconf -i -f
202%configure                           \
203    INSTALL_DATA="install -c -p -m644" \
204    --disable-static                 \
205    --with-dovecot=../
206
207make %{?_smp_mflags}
208popd
209%endif
210
211%if %{build_drac}
212%{__cc} -Wall -W -shared -fPIC -DHAVE_CONFIG_H \
213    -I. -I./src/lib \
214    drac.c -o drac.so -ldrac
215%endif
216
217%install
218rm -rf $RPM_BUILD_ROOT
219make install DESTDIR=$RPM_BUILD_ROOT
220rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}
221
222install -p -m 755 src/plugins/convert/convert-tool $RPM_BUILD_ROOT%{_libexecdir}/%{name}
223
224mkdir -p $RPM_BUILD_ROOT%{_initrddir}
225install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/dovecot
226
227mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/pam.d
228install -p -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/dovecot
229
230mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
231install -p -m 600 %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/dovecot
232
233# generate ghost .pem file
234mkdir -p $RPM_BUILD_ROOT%{ssldir}/certs
235mkdir -p $RPM_BUILD_ROOT%{ssldir}/private
236touch $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
237chmod 600 $RPM_BUILD_ROOT%{ssldir}/certs/dovecot.pem
238touch $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
239chmod 600 $RPM_BUILD_ROOT%{ssldir}/private/dovecot.pem
240
241mkdir -p $RPM_BUILD_ROOT/var/run/dovecot/login
242chmod 755 $RPM_BUILD_ROOT/var/run/dovecot
243chmod 700 $RPM_BUILD_ROOT/var/run/dovecot/login
244       
245# Install dovecot.conf and dovecot-openssl.cnf
246mkdir -p $RPM_BUILD_ROOT%{ssldir}
247install -p -m644 dovecot-example.conf $RPM_BUILD_ROOT%{_sysconfdir}/dovecot.conf
248rm -f $RPM_BUILD_ROOT%{_sysconfdir}/dovecot-*example.conf # dovecot seems to install this by itself
249install -p -m644 doc/dovecot-openssl.cnf $RPM_BUILD_ROOT%{ssldir}/dovecot-openssl.cnf
250
251# Install some of our own documentation
252install -p -m644 %{SOURCE7} $RPM_BUILD_ROOT%{docdir}/REDHAT-FAQ.txt
253
254# Install the licensing files into the documentation area
255install -p -m644 COPYING* $RPM_BUILD_ROOT%{docdir}
256
257mkdir -p $RPM_BUILD_ROOT%{docdir}/examples/
258install -p -m755 doc/mkcert.sh $RPM_BUILD_ROOT%{_libexecdir}/%{name}/mkcert.sh
259for f in `cd doc; echo *.conf`; do
260     install -p -m644 doc/$f $RPM_BUILD_ROOT%{docdir}/examples/$f;
261done
262
263install -p -m755 -d $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
264for f in %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6}
265do
266    install -p -m644 $f $RPM_BUILD_ROOT%{docdir}/UW-to-Dovecot-Migration
267done
268
269mv $RPM_BUILD_ROOT%{docdir} $RPM_BUILD_ROOT%{docdir}-%{version}
270mkdir -p $RPM_BUILD_ROOT/var/lib/dovecot
271
272%if %{build_sieve}
273# dovecot-sieve
274pushd %{sieve_name}-%{sieve_version}
275make install DESTDIR=$RPM_BUILD_ROOT
276popd
277%endif
278
279%if %{build_drac}
280install -m 755 drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/
281ln -s ../drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/imap/
282ln -s ../drac.so $RPM_BUILD_ROOT/%{_libdir}/dovecot/pop3/
283%endif
284
285#remove the libtool archives
286find $RPM_BUILD_ROOT%{_libdir}/%{name}/ -name '*.la' | xargs rm -f
287
288#prepare the filelist
289(
290    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -type d | sed -e "s|^|%dir |";
291    find ${RPM_BUILD_ROOT}%{_libdir}/%{name} -! -type d | \
292        grep -v 'dovecot-config\|lib90_cmusieve_plugin\.so\|libdriver_.*\.so\|libauthdb_.*\.so\|libmech_.*\.so\|drac\.so';
293) | sed -e "s|$RPM_BUILD_ROOT||" >libs.filelist
294
295
296%clean
297rm -rf $RPM_BUILD_ROOT
298
299
300%pre
301getent group dovecot >/dev/null || groupadd -r dovecot
302getent passwd dovecot >/dev/null || \
303useradd -r -g dovecot -d /usr/libexec/dovecot -s /sbin/nologin -c "Dovecot IMAP server" dovecot
304exit 0
305
306%post
307/sbin/chkconfig --add %{name}
308# generate the ssl certificates
309if [ ! -f %{ssldir}/certs/%{name}.pem ]; then
310    SSLDIR=%{ssldir} OPENSSLCONFIG=%{ssldir}/dovecot-openssl.cnf \
311         %{_libexecdir}/%{name}/mkcert.sh &> /dev/null
312fi
313
314if ! test -f /var/run/dovecot/login/ssl-parameters.dat; then
315    dovecot --build-ssl-parameters &>/dev/null
316fi
317exit 0
318
319%preun
320if [ $1 = 0 ]; then
321    /sbin/service %{name} stop > /dev/null 2>&1 || :
322    /sbin/chkconfig --del %{name} || :
323fi
324
325%postun
326if [ "$1" -ge "1" ]; then
327    /sbin/service %{name} condrestart 2>/dev/null || :
328fi
329
330
331%files -f libs.filelist
332%defattr(-,root,root,-)
333%doc %{docdir}-%{version}
334%config(noreplace) %{_sysconfdir}/dovecot.conf
335%attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/dovecot
336%{_initrddir}/dovecot
337%config(noreplace) %{_sysconfdir}/pam.d/dovecot
338%dir %{ssldir}
339%dir %{ssldir}/certs
340%dir %{ssldir}/private
341%config(noreplace) %{ssldir}/dovecot-openssl.cnf
342%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/certs/dovecot.pem
343%attr(0600,root,root) %ghost %config(missingok,noreplace) %verify(not md5 size mtime) %{ssldir}/private/dovecot.pem
344%{_libexecdir}/%{name}
345%{_sbindir}/dovecot
346%{_sbindir}/dovecotpw
347%attr(0755,root,dovecot) %dir /var/run/dovecot
348%attr(0750,root,dovecot) %dir /var/run/dovecot/login
349# %attr(0755,root,dovecot) %{_libexecdir}/%{name}/mkcert.sh
350%attr(0750,dovecot,dovecot) %dir /var/lib/dovecot
351
352%if %{build_sieve}
353%files sieve
354%defattr(-,root,root,-)
355%{_libdir}/%{name}/lda/lib90_cmusieve_plugin.so
356%endif
357
358%if %{build_mysql}
359%files mysql
360%defattr(-,root,root,-)
361%{_libdir}/%{name}/sql/libdriver_mysql.so
362%{_libdir}/%{name}/auth/libdriver_mysql.so
363%{_libdir}/%{name}/dict/libdriver_mysql.so
364%endif
365
366%if %{build_postgres}
367%files pgsql
368%defattr(-,root,root,-)
369%{_libdir}/%{name}/sql/libdriver_pgsql.so
370%{_libdir}/%{name}/auth/libdriver_pgsql.so
371%{_libdir}/%{name}/dict/libdriver_pgsql.so
372%endif
373
374%if %{build_sqlite}
375%files sqlite
376%defattr(-,root,root,-)
377%{_libdir}/%{name}/sql/libdriver_sqlite.so
378%{_libdir}/%{name}/auth/libdriver_sqlite.so
379%{_libdir}/%{name}/dict/libdriver_sqlite.so
380%endif
381
382%if %{build_ldap}
383%files ldap
384%defattr(-,root,root,-)
385%{_libdir}/%{name}/auth/libauthdb_ldap.so
386%endif
387
388%if %{build_drac}
389%files drac
390%defattr(-,root,root)
391%{_libdir}/%{name}/drac.so
392%{_libdir}/%{name}/imap/drac.so
393%{_libdir}/%{name}/pop3/drac.so
394%doc README.plugin-drac
395%endif
396
397%files devel
398%defattr(-,root,root,-)
399%{_includedir}/%{name}
400%{_libdir}/%{name}/dovecot-config
401
402
403%changelog
404* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.15-2
405- rebuild with openssl-1.0.0c
406
407* Sat Oct  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.15-1
408- new upstream release with security fixes (CVE-2010-3780,3779,3707,3706)
409- add BR: pkgconfig
410
411* Thu Mar 11 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.11-1
412- new upstream release with mbox DoS fix
413
414* Mon Jan 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-2
415- fix drac.so in libs.files
416
417* Mon Jan 25 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-1
418- new upstream release
419
420* Fri Jan  8 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.9-1
421- new upstream release
422- update to dovecot sieve 1.1.8
423
424* Thu Sep 17 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-2
425- update to dovecot sieve 1.1.7 to fix BoF
426- add BR: bzip2-devel, libcap-devel
427
428* Mon Aug 10 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.3-1
429- new upstream release
430
431* Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.2-1
432- new upstream release 
433
434* Sun Jul 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.1-1
435- new upstream release
436
437* Tue Jul  7 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.0-1
438- new upstream 1.2.x release
439- update Patch1 to fit new release
440- README.plugin-drac in UTF-8
441
442* Tue Jun  2 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.16-1
443- new upstream release
444
445* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.15-3
446- rebuilt with MySQL-5.1.34.
447
448* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-2
449- add BuildRequires gettext-devel instead of gettext
450
451* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.15-1
452- new upstream release
453- update patch1 to fix new release
454
455* Mon Apr 27 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.14-1
456- new upstream release
457
458* Sun Mar 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.1.13-2
459- rebuilt with openldap-2.4.11
460
461* Sun Mar 22 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.13-1
462- new upstream release
463
464* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.11-1
465- new upstream release
466
467* Sun Feb 01 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.10-1
468- new upstream release
469
470* Sun Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.8-1
471- new upstream release
472
473* Sat Nov 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.6-1
474- new upstream release
475
476* Tue Oct 21 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-2
477- change BuildRequires sqlite-devel -> sqlite3-devel
478
479* Mon Oct 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.1.4-1
480- new upstream release
481
482* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.3-1
483- new upstream release
484
485* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
486- new upstream release
487- split ldap plugin to subpackage
488- split sql plugins to subpackages
489- add -devel subpackage
490- update drac module, rename to -drac from -plugin-drac
491- add dovecot-sieve
492
493* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.13-0vl2
494- build for VineSeed (0vl1 is for VinePlus 4.x)
495- new upstream release
496
497* Mon Jan 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.10-0vl2
498- build for VineSeed (0vl1 is for VinePlus 4.x)
499- new upstream release with security fix (CVE-2007-6598)
500- turn on daemon stop massage (Already start message is on)
501
502* Sat Dec 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-0vl1
503- new upstream source
504
505* Wed Nov 21 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.7-0vl4
506- updated %%install section to support lib64 architecture
507
508* Sun Nov 04 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl3
509- rebuild for VineSeed (from VinePlus 4.x)
510
511  * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.5-0vl1
512  - new upstream release
513  - rebuilt with postgresql-devel 8.2.5
514
515  * Sun Aug  5 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
516  - new upstream release
517
518  * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
519  - new upstream release
520
521* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl2
522- add Require dracd tag in plugin-drac
523
524* Sat Nov 03 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.7-0vl1
525- new upstream release
526
527* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl4
528- fix drac plugin make method
529- change drac.so install method (use sym link)
530- add README.plugin-drac
531
532* Fri Oct 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl3
533- add dovecot-openssl.cnf install to doc
534- daemon restart message turn on when package is upgraded
535
536* Tue Oct 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl2
537- add drac.so (POP bedore SMTP) support
538
539* Mon Oct 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0.5-0vl1
540- new upstream release
541- drop patch500 (it is included in new release)
542- move Mysql buildreq tag to "if build_mysql" section
543- add Requires: postgresql-libs and Requires: MySQL-shared in "if-endif"
544- add Requires: openldap
545
546* Wed Aug 29 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.0-0.rc17.0vl2
547- add Patch500 to fix directory traversal vulnerability (CVE-2007-2231)
548  note that version 1.0.rc29 and up have been already fixed in upstream
549
550* Mon Jan 08 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc17.0vl1
551- new upstream RC release
552
553* Sun Jan 07 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc16.0vl1
554- new upstream RC release
555
556* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl2
557- add Vendor/Distribution tag
558
559* Sun Dec 10 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.0-0.rc15.0vl1
560- new upstream RC release
561- add BuildRequires: MySQL-shared, MySQL-devel
562- update patch100
563
564* Mon Oct 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0-0.rc7.1vl2
565- rebuilt with MySQL 5.0.27
566
567* Mon Aug 28 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc7.1vl1
568- new upstream release
569- update default settings patch (Patch100)
570- build with openldap-2.3.24
571
572* Tue Aug  1 2006 IWAI, Masaharu <iwai@alib.jp> 1.0-0.rc2.1vl1
573- first release for Vine Linux
574
575* Mon Jul 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2.1
576- reenable inotify and see what happens
577
578* Thu Jul 13 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.rc2
579- update to latest upstream release candidate
580- disable inotify for now, doesn't build -- this needs fixing though
581
582* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta8.2.1
583- rebuild
584
585* Thu Jun 08 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.2
586- put back pop3_uidl_format default that got lost
587  in the beta2->beta7 upgrade (would cause pop3 to not work
588  at all in many situations)
589
590* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta8.1
591- upgrade to latest upstream beta release (beta8)
592- contains a security fix in mbox handling
593
594* Thu May 04 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta7.1
595- upgrade to latest upstream beta release
596- fixed BR 173048
597
598* Fri Mar 17 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.8
599- fix sqlite detection in upstream configure checks, second part
600  of #182240
601
602* Wed Mar  8 2006 Bill Nottingham <notting@redhat.com> - 1.0-0.beta2.7
603- fix scriplet noise some more
604
605* Mon Mar  6 2006 Jeremy Katz <katzj@redhat.com> - 1.0-0.beta2.6
606- fix scriptlet error (mitr, #184151)
607
608* Mon Feb 27 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.5
609- fix #182240 by looking in lib64 for libs first and then lib
610- fix comment #1 in #182240 by copying over the example config files
611  to documentation directory
612
613* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.4.1
614- bump again for double-long bug on ppc(64)
615
616* Thu Feb 09 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.4
617- enable inotify as it should work now (#179431)
618
619* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0-0.beta2.3.1
620- rebuilt for new gcc4.1 snapshot and glibc changes
621
622* Thu Feb 02 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.3
623- change the compiled-in defaults and adjust the default's configfile
624  commented-out example settings to match compiled-in defaults,
625  instead of changing the defaults only in the configfile, as per #179432
626- fix #179574 by providing a default uidl_format for pop3
627- half-fix #179620 by having plaintext auth enabled by default... this
628  needs more thinking (which one we really want) and documentation
629  either way
630
631* Tue Jan 31 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.2
632- update URL in description
633- call dovecot --build-ssl-parameters in postinst as per #179430
634
635* Mon Jan 30 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2.1
636- fix spec to work with BUILD_DIR != SOURCE_DIR
637- forward-port and split pam-nocred patch
638
639* Mon Jan 23 2006 Petr Rockai <prockai@redhat.com> - 1.0-0.beta2
640- new upstream version, hopefully fixes #173928, #163550
641- fix #168866, use install -p to install documentation
642
643* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
644- rebuilt
645
646* Sat Nov 12 2005 Tom Lane <tgl@redhat.com> - 0.99.14-10.fc5
647- Rebuild due to mysql update.
648
649* Wed Nov  9 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-9.fc5
650- rebuilt with new openssl
651
652* Fri Sep 30 2005 Tomas Mraz <tmraz@redhat.com> - 0.99.14-8.fc5
653- use include instead of pam_stack in pam config
654
655* Wed Jul 27 2005 John Dennis <jdennis@redhat.com> - 0.99.14-7.fc5
656- fix bug #150888, log authenication failures with ip address
657
658* Fri Jul 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-6.fc5
659- fix bug #149673, add dummy PAM_TTY
660
661* Thu Apr 28 2005 John Dennis <jdennis@redhat.com> - 0.99.14-5.fc4
662- fix bug #156159 insecure location of restart flag file
663
664* Fri Apr 22 2005 John Dennis <jdennis@redhat.com> - 0.99.14-4.fc4
665- openssl moved its certs, CA, etc. from /usr/share/ssl to /etc/pki
666
667* Tue Apr 12 2005 Tom Lane <tgl@redhat.com> 0.99.14-3.fc4
668- Rebuild for Postgres 8.0.2 (new libpq major version).
669
670* Mon Mar  7 2005 John Dennis <jdennis@redhat.com> 0.99.14-2.fc4
671- bump rev for gcc4 build
672
673* Mon Feb 14 2005 John Dennis <jdennis@redhat.com> - 0.99.14-1.fc4
674- fix bug #147874, update to 0.99.14 release
675  v0.99.14 2005-02-11  Timo Sirainen <tss at iki.fi>
676  - Message address fields are now parsed differently, fixing some
677    issues with spaces. Affects only clients which use FETCH ENVELOPE
678    command.
679  - Message MIME parser was somewhat broken with missing MIME boundaries
680  - mbox: Don't allow X-UID headers in mails to override the UIDs we
681    would otherwise set. Too large values can break some clients and
682    cause other trouble.
683  - passwd-file userdb wasn't working
684  - PAM crashed with 64bit systems
685  - non-SSL inetd startup wasn't working
686  - If UID FETCH notices and skips an expunged message, don't return
687    a NO reply. It's not needed and only makes clients give error
688    messages.
689
690* Wed Feb  2 2005 John Dennis <jdennis@redhat.com> - 0.99.13-4.devel
691- fix bug #146198, clean up temp kerberos tickets
692
693* Mon Jan 17 2005 John Dennis <jdennis@redhat.com> 0.99.13-3.devel
694- fix bug #145214, force mbox_locks to fcntl only
695- fix bug #145241, remove prereq on postgres and mysql, allow rpm auto
696  dependency generator to pick up client lib dependency if needed.
697
698* Thu Jan 13 2005 John Dennis <jdennis@redhat.com> 0.99.13-2.devel
699- make postgres & mysql conditional build
700- remove execute bit on migration example scripts so rpm does not pull
701  in additional dependences on perl and perl modules that are not present
702  in dovecot proper.
703- add REDHAT-FAQ.txt to doc directory
704
705* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.13-1.devel
706- bring up to date with latest upstream, 0.99.13, bug #143707
707  also fix bug #14462, bad dovecot-uid macro name
708
709* Thu Jan  6 2005 John Dennis <jdennis@redhat.com> 0.99.11-10.devel
710- fix bug #133618, removed LITERAL+ capability from capability string
711
712* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-9.devel
713- fix bug #134325, stop dovecot during installation
714
715* Wed Jan  5 2005 John Dennis <jdennis@redhat.com> 0.99.11-8.devel
716- fix bug #129539, dovecot starts too early,
717  set chkconfig to 65 35 to match cyrus-imapd
718- also delete some old commented out code from SSL certificate creation
719
720* Thu Dec 23 2004 John Dennis <jdennis@redhat.com> 0.99.11-7.devel
721- add UW to Dovecot migration documentation and scripts, bug #139954
722  fix SSL documentation and scripts, add missing documentation, bug #139276
723
724* Thu Nov 15 2004 Warren Togami <wtogami@redhat.com> 0.99.11-2.FC4.1
725- rebuild against MySQL4
726
727* Thu Oct 21 2004 John Dennis <jdennis@redhat.com>
728- fix bug #136623
729  Change License field from GPL to LGPL to reflect actual license
730
731* Thu Sep 30 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.3
732- fix bug #124786, listen to ipv6 as well as ipv4
733
734* Wed Sep  8 2004 John Dennis <jdennis@redhat.com> 0.99.11-1.FC3.1
735- bring up to latest upstream,
736  comments from Timo Sirainen <tss at iki.fi> on release v0.99.11 2004-09-04 
737  + 127.* and ::1 IP addresses are treated as secured with
738    disable_plaintext_auth = yes
739  + auth_debug setting for extra authentication debugging
740  + Some documentation and error message updates
741  + Create PID file in /var/run/dovecot/master.pid
742  + home setting is now optional in static userdb
743  + Added mail setting to static userdb
744  - After APPENDing to selected mailbox Dovecot didn't always notice the
745    new mail immediately which broke some clients
746  - THREAD and SORT commands crashed with some mails
747  - If APPENDed mail ended with CR character, Dovecot aborted the saving
748  - Output streams sometimes sent data duplicated and lost part of it.
749    This could have caused various strange problems, but looks like in
750    practise it rarely caused real problems.
751
752* Wed Aug  4 2004 John Dennis <jdennis@redhat.com>
753- change release field separator from comma to dot, bump build number
754
755* Mon Aug  2 2004 John Dennis <jdennis@redhat.com> 0.99.10.9-1,FC3,1
756- bring up to date with latest upstream, fixes include:
757- LDAP support compiles now with Solaris LDAP library
758- IMAP BODY and BODYSTRUCTURE replies were wrong for MIME parts which
759  didn't contain Content-Type header.
760- MySQL and PostgreSQL auth didn't reconnect if connection was lost
761  to SQL server
762- Linking fixes for dovecot-auth with some systems
763- Last fix for disconnecting client when downloading mail longer than
764  30 seconds actually made it never disconnect client. Now it works
765  properly: disconnect when client hasn't read _any_ data for 30
766  seconds.
767- MySQL compiling got broken in last release
768- More PostgreSQL reconnection fixing
769
770
771* Mon Jul 26 2004 John Dennis <jdennis@redhat.com> 0.99.10.7-1,FC3,1
772- enable postgres and mySQL in build
773- fix configure to look for mysql in alternate locations
774- nuke configure script in tar file, recreate from configure.in using autoconf
775
776- bring up to latest upstream, which included:
777- Added outlook-pop3-no-nuls workaround to fix Outlook hang in mails with NULs.
778- Config file lines can now contain quoted strings ("value ")
779- If client didn't finish downloading a single mail in 30 seconds,
780  Dovecot closed the connection. This was supposed to work so that
781  if client hasn't read data at all in 30 seconds, it's disconnected.
782- Maildir: LIST now doesn't skip symlinks
783
784
785* Wed Jun 30 2004 John Dennis <jdennis@redhat.com>
786- bump rev for build
787- change rev for FC3 build
788
789* Fri Jun 25 2004 John Dennis <jdennis@redhat.com> - 0.99.10.6-1
790- bring up to date with upstream,
791  recent change log comments from Timo Sirainen were:
792  SHA1 password support using OpenSSL crypto library
793  mail_extra_groups setting
794  maildir_stat_dirs setting
795  Added NAMESPACE capability and command
796  Autocreate missing maildirs (instead of crashing)
797  Fixed occational crash in maildir synchronization
798  Fixed occational assertion crash in ioloop.c
799  Fixed FreeBSD compiling issue
800  Fixed issues with 64bit Solaris binary
801
802* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
803- rebuilt
804
805* Thu May 27 2004 David Woodhouse <dwmw2@redhat.com> 0.99.10.5-1
806- Update to 0.99.10.5 to fix maildir segfaults (#123022)
807
808* Fri May 07 2004 Warren Togami <wtogami@redhat.com> 0.99.10.4-4
809- default auth config that is actually usable
810- Timo Sirainen (author) suggested functionality fixes
811  maildir, imap-fetch-body-section, customflags-fix
812
813* Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com>
814- Use ':' instead of '.' as separator for chown.
815
816* Tue Feb 17 2004 Jeremy Katz <katzj@redhat.com> - 0.99.10.4-3
817- restart properly if it dies (#115594)
818
819* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
820- rebuilt
821
822* Mon Nov 24 2003 Jeremy Katz <katzj@redhat.com> 0.99.10.4-1
823- update to 0.99.10.4
824
825* Mon Oct  6 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-7
826- another patch from upstream to fix returning invalid data on partial
827  BODY[part] fetches
828- patch to avoid confusion of draft/deleted in indexes
829
830* Tue Sep 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-6
831- add some patches from upstream (#104288)
832
833* Thu Sep  4 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-5
834- fix startup with 2.6 with patch from upstream (#103801)
835
836* Tue Sep  2 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-4
837- fix assert in search code (#103383)
838
839* Tue Jul 22 2003 Nalin Dahyabhai <nalin@redhat.com> 0.99.10-3
840- rebuild
841
842* Thu Jul 17 2003 Bill Nottingham <notting@redhat.com> 0.99.10-2
843- don't run by default
844
845* Thu Jun 26 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-1
846- 0.99.10
847
848* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.2
849- 0.99.10-rc2 (includes ssl detection fix)
850- a few tweaks from fedora
851  - noreplace the config file
852  - configure --with-ldap to get LDAP enabled
853
854* Mon Jun 23 2003 Jeremy Katz <katzj@redhat.com> 0.99.10-0.1
855- 0.99.10-rc1
856- add fix for ssl detection
857- add zlib-devel to BuildRequires
858- change pam service name to dovecot
859- include pam config
860
861* Thu May  8 2003 Jeremy Katz <katzj@redhat.com> 0.99.9.1-1
862- update to 0.99.9.1
863- add patch from upstream to fix potential bug when fetching with
864  CR+LF linefeeds
865- tweak some things in the initscript and config file noticed by the
866  fedora folks
867
868* Sun Mar 16 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-2
869- fix ssl dir
870- own /var/run/dovecot/login with the correct perms
871- fix chmod/chown in post
872
873* Fri Mar 14 2003 Jeremy Katz <katzj@redhat.com> 0.99.8.1-1
874- update to 0.99.8.1
875
876* Tue Mar 11 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-2
877- add a patch to fix quoting problem from CVS
878
879* Mon Mar 10 2003 Jeremy Katz <katzj@redhat.com> 0.99.8-1
880- 0.99.8
881- add some buildrequires
882- fixup to build with openssl 0.9.7
883- now includes a pop3 daemon (off by default)
884- clean up description and %%preun
885- add dovecot user (uid/gid of 97)
886- add some buildrequires
887- move the ssl cert to %{_datadir}/ssl/certs
888- create a dummy ssl cert in %post
889- own /var/run/dovecot
890- make the config file a source so we get default mbox locks of fcntl
891
892* Sun Dec  1 2002 Seth Vidal <skvidal@phy.duke.edu>
893- 0.99.4 and fix startup so it starts imap-master not vsftpd :)
894
895* Tue Nov 26 2002 Seth Vidal <skvidal@phy.duke.edu>
896- first build
Note: See TracBrowser for help on using the repository browser.