source: projects/specs/trunk/d/docker-ce/docker-ce-vl.spec @ 12340

Revision 12340, 3.9 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

docker-ce-19.03.8-1

docker-compose-1.25.4-1

Line 
1%bcond_with build_nosrc
2
3%if !%{with build_nosrc}
4%global _disable_source_fetch 0
5%endif
6
7Name: docker-ce
8Version: 19.03.8
9Release: 1%{?_dist_release}
10Summary: The open-source application container engine
11Group: Development/Tools
12License: ASL 2.0
13URL: https://www.docker.com
14Source0: https://download.docker.com/linux/static/stable/x86_64/docker-%{version}.tgz
15Source1: https://github.com/docker/docker-ce/raw/v%{version}/README.md
16Source2: https://github.com/docker/docker-ce/raw/v%{version}/components/cli/LICENSE
17
18Source10: docker.init
19Source11: docker.sysconfig
20Source12: docker.conf
21
22%if %{with build_nosrc}
23NoSource: 0
24NoSource: 1
25NoSource: 2
26%endif
27
28Vendor: Project Vine
29Distribution: Vine Linux
30Packager: tomop
31
32# required packages on install
33Requires: /bin/sh
34Requires: libcgroup
35Requires: docker-ce-cli = %{version}-%{release}
36
37Conflicts: docker-ee
38Conflicts: docker-ee-cli
39
40%description
41Docker is is a product for you to build, ship and run any application as a
42lightweight container.
43
44Docker containers are both hardware-agnostic and platform-agnostic. This means
45they can run anywhere, from your laptop to the largest cloud compute instance and
46everything in between - and they don't require you to use a particular
47language, framework or packaging system. That makes them great building blocks
48for deploying and scaling web apps, databases, and backend services without
49depending on a particular stack or provider.
50
51%package cli
52Summary: clients for Docker
53Group: Development/Tools
54
55%description cli
56Docker is is a product for you to build, ship and run any application as a
57lightweight container.
58
59Docker containers are both hardware-agnostic and platform-agnostic. This means
60they can run anywhere, from your laptop to the largest cloud compute instance and
61everything in between - and they don't require you to use a particular
62language, framework or packaging system. That makes them great building blocks
63for deploying and scaling web apps, databases, and backend services without
64depending on a particular stack or provider.
65
66
67%prep
68%setup -q -c -n docker
69
70%build
71
72# %check
73# cli/build/docker -v
74
75%install
76# install binary
77install -d %{buildroot}%{_bindir}
78install -d %{buildroot}%{_localstatedir}/lib/docker
79install -d %{buildroot}%{_localstatedir}/run/docker
80install -d %{buildroot}%{_initdir}
81install -d %{buildroot}%{_sysconfdir}/sysconfig
82install -d %{buildroot}%{_sysconfdir}/rsyslog.d
83
84for f in docker/*; do
85  install -p -m 755 $f %{buildroot}%{_bindir}/
86done
87
88install -p -m 755 %{SOURCE10} %{buildroot}%{_initdir}/docker
89install -p -m 644 %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/docker
90install -p -m 644 %{SOURCE12} %{buildroot}%{_sysconfdir}/rsyslog.d/docker
91
92install -p -m 644 %{SOURCE1} ./
93install -p -m 644 %{SOURCE2} ./
94
95
96%clean
97rm -rf %{buildroot}
98
99%post
100if ! getent group docker > /dev/null; then
101    groupadd --system docker
102fi
103if [ $1 -eq 1 ]; then
104  /sbin/chkconfig --add docker
105fi
106
107%preun
108if [ $1 -eq 0 ]; then
109  /sbin/chkconfig docker off
110  /sbin/chkconfig --del docker
111fi
112
113# list files owned by the package here
114%files
115%defattr(-,root,root,-)
116%license LICENSE
117%doc README.md
118%{_bindir}/containerd
119%{_bindir}/containerd-shim
120%{_bindir}/ctr
121%{_bindir}/docker-init
122%{_bindir}/docker-proxy
123%{_bindir}/dockerd
124%dir %{_localstatedir}/run/docker
125%dir %{_localstatedir}/lib/docker
126%{_initdir}/docker
127%config(noreplace) %{_sysconfdir}/sysconfig/docker
128%config(noreplace) %{_sysconfdir}/rsyslog.d/docker
129
130%files cli
131%defattr(-,root,root,-)
132%license LICENSE
133%doc README.md
134%{_bindir}/docker
135%{_bindir}/runc
136
137%changelog
138* Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.08-1
139- new upstream release.
140
141* Thu Oct 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.03-1
142- new upstream release.
143
144* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.1-2
145- updated initscript: added syslog support.
146
147* Sun Aug 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.1-1
148- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.