source: projects/specs/trunk/d/docker-ce/docker-ce-vl.spec @ 12527

Revision 12527, 4.7 KB checked in by tomop, 3 years ago (diff)

updated 2 packages

docker-ce-20.10.3-1

docker-compose-1.28.2-1

Line 
1%bcond_with systemd
2%bcond_with build_nosrc
3
4%if !%{with build_nosrc}
5%global _disable_source_fetch 0
6%endif
7
8Name: docker-ce
9Summary: The open-source application container engine
10Version: 20.10.3
11Release: 1%{?_dist_release}%{?with_systemd:.systemd}
12Group: system,virtualization
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: tomop
16
17License: ASL 2.0
18URL: https://www.docker.com
19Source0: https://download.docker.com/linux/static/stable/x86_64/docker-%{version}.tgz
20Source1: https://raw.githubusercontent.com/docker/cli/v%{version}/README.md
21Source2: https://raw.githubusercontent.com/docker/cli/v%{version}/LICENSE
22
23Source10: docker.init
24Source11: docker.sysconfig
25Source12: docker.conf
26Source100: docker.service
27Source101: docker.socket
28
29%if %{with build_nosrc}
30NoSource: 0
31NoSource: 1
32NoSource: 2
33%endif
34
35# required packages on install
36Requires: /bin/sh
37Requires: libcgroup
38Requires: docker-ce-cli = %{version}-%{release}
39%if %{with systemd}
40%{?systemd_requires}
41%endif
42
43Conflicts: docker-ee
44Conflicts: docker-ee-cli
45
46%description
47Docker is is a product for you to build, ship and run any application as a
48lightweight container.
49
50Docker containers are both hardware-agnostic and platform-agnostic. This means
51they can run anywhere, from your laptop to the largest cloud compute instance and
52everything in between - and they don't require you to use a particular
53language, framework or packaging system. That makes them great building blocks
54for deploying and scaling web apps, databases, and backend services without
55depending on a particular stack or provider.
56
57
58%package cli
59Summary: clients for Docker
60Group: admin-tools,virtualization
61
62%description cli
63Docker is is a product for you to build, ship and run any application as a
64lightweight container.
65
66Docker containers are both hardware-agnostic and platform-agnostic. This means
67they can run anywhere, from your laptop to the largest cloud compute instance and
68everything in between - and they don't require you to use a particular
69language, framework or packaging system. That makes them great building blocks
70for deploying and scaling web apps, databases, and backend services without
71depending on a particular stack or provider.
72
73
74%prep
75%setup -q -c -n docker
76
77
78%build
79
80
81# %check
82# cli/build/docker -v
83
84
85%install
86# install binary
87install -d %{buildroot}%{_bindir}
88install -d %{buildroot}%{_localstatedir}/lib/docker
89install -d %{buildroot}%{_localstatedir}/run/docker
90
91for f in docker/*; do
92  install -p -m 755 $f %{buildroot}%{_bindir}/
93done
94
95%if %{with systemd}
96install -D -p -m 644 %{SOURCE100} %{buildroot}%{_unitdir}/docker.service
97install -D -p -m 755 %{SOURCE101} %{buildroot}%{_unitdir}/docker.socket
98%else
99install -D -p -m 755 %{SOURCE10} %{buildroot}%{_initdir}/docker
100install -D -p -m 644 %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/docker
101install -D -p -m 644 %{SOURCE12} %{buildroot}%{_sysconfdir}/rsyslog.d/docker
102%endif
103
104install -p -m 644 %{SOURCE1} ./
105install -p -m 644 %{SOURCE2} ./
106
107
108%clean
109rm -rf %{buildroot}
110
111%pre
112if ! getent group docker > /dev/null; then
113    groupadd --system docker
114fi
115
116%post
117%if %{with systemd}
118%systemd_post docker.service
119%else
120if [ $1 -eq 1 ]; then
121  /sbin/chkconfig --add docker
122fi
123%endif
124
125%preun
126%if %{with systemd}
127%systemd_preun docker.service
128%else
129if [ $1 -eq 0 -o -x /bin/systemctl ]; then
130  /sbin/chkconfig docker off
131  /sbin/chkconfig --del docker
132fi
133%endif
134
135%if %{with systemd}
136%postun
137%systemd_postun_with_restart docker.service
138%endif
139
140
141# list files owned by the package here
142%files
143%defattr(-,root,root,-)
144%license LICENSE
145%doc README.md
146%{_bindir}/containerd
147%{_bindir}/containerd-shim*
148%{_bindir}/ctr
149%{_bindir}/docker-init
150%{_bindir}/docker-proxy
151%{_bindir}/dockerd
152%dir %{_localstatedir}/run/docker
153%dir %{_localstatedir}/lib/docker
154%if %{with systemd}
155%{_unitdir}/docker.service
156%{_unitdir}/docker.socket
157%else
158%{_initdir}/docker
159%config(noreplace) %{_sysconfdir}/sysconfig/docker
160%config(noreplace) %{_sysconfdir}/rsyslog.d/docker
161%endif
162
163%files cli
164%defattr(-,root,root,-)
165%license LICENSE
166%doc README.md
167%{_bindir}/docker
168%{_bindir}/runc
169
170
171%changelog
172* Thu Feb 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.10.3-1
173- new upstream release.
174
175* Thu Dec 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.14-1
176- new upstream release.
177
178* Sun Jul 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.09-1
179- new upstream release.
180- added systemd support (disabled as default).
181
182* Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.08-1
183- new upstream release.
184
185* Thu Oct 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.03-1
186- new upstream release.
187
188* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.1-2
189- updated initscript: added syslog support.
190
191* Sun Aug 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.1-1
192- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.