source: projects/specs/trunk/d/docbook-style-xsl/docbook-style-xsl-vl.spec @ 8084

Revision 8084, 12.0 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1Name: docbook-style-xsl
2Version: 1.77.1
3Release: 2%{?_dist_release}
4Group: Applications/Text
5
6Summary: Norman Walsh's XSL stylesheets for DocBook XML.
7Summary(ja): DocBook XML用 XSLスタイルシート
8
9License: Copyright only
10URL: http://docbook.sourceforge.net/projects/xsl/
11
12Source0: http://downloads.sourceforge.net/docbook/docbook-xsl-%{version}.tar.bz2
13Source1: %{name}.Makefile
14Source2: http://downloads.sourceforge.net/docbook/docbook-xsl-doc-%{version}.tar.bz2
15
16# Avoid proportional-column-width for passivetex (bug #176766).
17Patch1: docbook-xsl-pagesetup.patch
18# Hard-code the margin-left work around to expect passivetex (bug #113456).
19Patch2: docbook-xsl-marginleft.patch
20# fix of #161619 - adjustColumnWidths now available
21Patch3: docbook-xsl-newmethods.patch
22# change a few non-constant expressions to constant - needed for passivetex(#366441)
23Patch4: docbook-xsl-non-constant-expressions.patch
24# added fixes for passivetex extension and list-item-body(#161371)
25Patch5: docbook-xsl-list-item-body.patch
26#workaround missing mandir section problem (#727251)
27Patch6: docbook-xsl-mandir.patch
28
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildArch: noarch
32
33Provides: docbook-xsl = %{version}
34Requires: docbook-dtd-xml
35# xml-common was using /usr/share/xml until 0.6.3-8.
36Requires: xml-common >= 0.6.3-8
37# required because of usage of /usr/bin/xmlcatalog
38Requires(post): libxml2 >= 2.4.8
39Requires(postun): libxml2 >= 2.4.8
40# PassiveTeX before 1.21 can't handle the newer stylesheets.
41Conflicts: passivetex < 1.21
42
43Vendor: Project Vine
44Distribution: Vine Linux
45
46%description
47These XSL stylesheets allow you to transform any DocBook XML document to
48other formats, such as HTML, FO, and XHMTL.  They are highly customizable.
49
50%description -l ja
51この XSL スタイルシートを使って, さまざまな DocBook XML 形式のドキュメント
52を HTML や FO や XHTML などの他のフォーマットに変換することができます.
53
54
55%prep
56%setup -q -n docbook-xsl-%{version}
57pushd ..
58tar jxf %{SOURCE2}
59popd
60%patch1 -p1 -b .pagesetup
61%patch2 -p1 -b .marginleft
62%patch3 -p1 -b .newmethods
63%patch4 -p1 -b .nonconstant
64%patch5 -p1 -b .listitembody
65%patch6 -p1 -b .mandir
66
67cp %{SOURCE1} Makefile
68
69# fix of non UTF-8 files rpmlint warnings
70for fhtml in $(find ./doc -name '*.html' -type f)
71do
72  iconv -f ISO-8859-1 -t UTF-8 "$fhtml" -o "$fhtml".tmp
73  mv -f "$fhtml".tmp "$fhtml"
74  sed -i 's/charset=ISO-8859-1/charset=UTF-8/' "$fhtml"
75done
76
77for f in $(find -name "*'*")
78do
79  mv -v "$f" $(echo "$f" | tr -d "'")
80done
81
82%build
83
84%install
85[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
86
87DESTDIR=$RPM_BUILD_ROOT
88make install BINDIR=$DESTDIR%{_bindir} DESTDIR=$DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
89cp -a VERSION.xsl $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}/VERSION.xsl
90ln -s xsl-stylesheets-%{version} \
91        $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets
92
93# Don't ship the extensions (bug #177256).
94rm -rf $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets/extensions/*
95
96%clean
97[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
98
99%post
100CATALOG=%{_sysconfdir}/xml/catalog
101%{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
102 "http://docbook.sourceforge.net/release/xsl/%{version}" \
103 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
104%{_bindir}/xmlcatalog --noout --add "rewriteURI" \
105 "http://docbook.sourceforge.net/release/xsl/%{version}" \
106 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
107%{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
108 "http://docbook.sourceforge.net/release/xsl/current" \
109 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
110%{_bindir}/xmlcatalog --noout --add "rewriteURI" \
111 "http://docbook.sourceforge.net/release/xsl/current" \
112 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
113
114%postun
115# remove entries only on removal of package
116if [ "$1" = 0 ]; then
117  CATALOG=%{_sysconfdir}/xml/catalog
118  %{_bindir}/xmlcatalog --noout --del \
119   "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
120fi
121
122
123%files
124%defattr (-,root,root)
125%doc BUGS README TODO doc
126%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
127%{_datadir}/sgml/docbook/xsl-stylesheets
128
129
130%changelog
131* Mon Dec 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.77.1-2
132- new upstream release
133
134* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.77.1-1
135- new upstream release
136- add Patch6 (docbook-xsl-mandir.patch) from fedora
137- update Source1 (%{name}.Makefile)
138- update following patches from fedora
139  - Patch1 (docbook-xsl-pagesetup.patch)
140  - Patch2 (docbook-xsl-marginleft.patch)
141  - Patch3 (docbook-xsl-newmethods.patch)
142- update spec file based on fedora package
143  * Tue Jun  5 2012 Ondrej Vasik <ovasik@redhat.com> 1.77.1-2
144  - ship VERSION.xsl file (#829014)
145  * Tue Jun  5 2012 Ondrej Vasik <ovasik@redhat.com> 1.77.1-1
146  - new stable upstream release 1.77.1
147  - defuzz patches
148  * Tue Sep  6 2011 Ondrej Vasik <ovasik@redhat.com> 1.76.1-4
149  - revert previous change, workaround the mandir links issue
150    in buildroot (#727251)
151  * Mon Aug 29 2011 Ondrej Vasik <ovasik@redhat.com> 1.76.1-3
152  - make man.output.in.separate.dir "on" by default (#727251)
153  * Tue Nov 02 2010 Ondrej Vasik <ovasik@redhat.com> 1.76.1-1
154  - new upstream release 1.76.1
155  * Mon Sep 06 2010 Ondrej Vasik <ovasik@redhat.com> 1.76.0-1
156  - new upstream release 1.76.0
157
158* Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 1.76.1-1
159- new upstream release
160- add Vendor and Distribution tags
161
162* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.75.3-6
163- updated based on FC 1.75.3-5
164  * Fri Dec 18 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.3-5
165  - comment patches purpose
166  - License Copyright only
167  * Mon May 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.0-1
168  - New upstream release 1.75.0
169  - update marginleft patch
170  * Mon Feb 23 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.2-2
171  - updated Makefile: do ship .svg images(#486849), xsl
172    stylesheets for website, xhtml-1_1, docbook -> epub
173    convertor
174  * Wed Feb 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-7
175  - fix broken varlistentry (#479683)
176  * Mon Feb 02 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-6
177  - fix improper localization for rtl languages, thanks
178    Muayyad Alsadi(#475077)
179  * Wed Jan 28 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-5
180  - fix xsl stylesheets for rtl languages(#475077)
181  * Fri Dec 12 2008 Ondrej Vasik <ovasik@redhat.com> 1.74.0-4
182  - Author_Group "<orgname>" merged between "<surname>"
183    and "<surname>" (#473019)
184  * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-3
185  - Rediffed all patches to work with patch --fuzz=0
186  * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-2
187  - Tiny changes in docbook-xsl-newmethods.patch to work with xalan
188    (#452867)
189  * Fri Dec 14 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-9
190  - added fixes for passivetex extension and list-item-body
191    (#161371)
192  * Mon Dec 03 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-6
193  - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
194    documentation for nonpassivetex processing(#307001)
195  * Tue Nov 27 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-5
196  - convert all html files in doc to UTF-8 in prep
197    (latest rpmlint gives warnings)
198  - no longer using release in style-xsl dir(#389231)
199
200* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.73.2-5vl5
201- applied new versioning policy, spec in utf-8
202
203* Fri Jan 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73.2-5vl1
204- updated to 1.73.2 based on Fedora development
205  * Tue Dec 11 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-4
206  - remove entries from xmlcatalog only on removal of package
207    (required because of the last change with droping release
208     -caused drop of catalog entries during update)
209  * Wed Dec 05 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-3
210  - change a few non-constant expressions to constant that
211    could now be handled by passivetex(#366441)
212  - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
213    documentation for nonpassivetex processing(#307001)
214    (use passivetex.extensions = 1 option in param.xsl for
215     processing with passivetex)
216  * Fri Sep  7 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-2
217  - Added PreReq of libxml2(#253962)
218
219* Sun Jul 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72.0-3vl1
220- updated to 1.72.0 based on Fedora development
221  * Mon Jun 18 2007 Ondrej Vasik <ovasik@redhat.com> 1.72.0-3
222  - patch fixing #161619 taken from upstream
223  * Tue Jan 23 2007 Tim Waugh <twaugh@redhat.com> 1.72.0-1
224  - 1.72.0.
225  * Fri Jan 19 2007 Tomas Mraz <tmraz@redhat.com> 1.71.1-2
226  - Add new wordml and especially highlighting (which is referenced
227    from html) subdirs to Makefile.
228  * Tue Jan 24 2006 Tim Waugh <twaugh@redhat.com> 1.69.1-5
229  - Don't ship docsrc/* (bug #177256).
230  - Don't ship the extensions (bug #177256).
231
232* Sat Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.69.1-1vl1
233- updated to 1.69.1 based on Fedora development
234
235* Sun Dec 19 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.67.2-2vl1
236- updated to 1.67.2 based on Fedora development
237  * Wed Dec  8 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-2
238  - Prevent expressions in passivetex output from index.xsl (bug #142229).
239  * Thu Dec  2 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-1
240  - No longer need nbsp or listblock patches.
241
242* Tue Jan 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl2
243- patch from Fedora 1.64.1-6
244  * Tue Jan 20 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-6
245  - Fix last margin-left fix (bug #113456).
246  - Reduce instances of itemized/ordered lists having misalignments.
247  * Sun Jan 18 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-5
248  - And another (bug #113456).
249  * Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-4
250  - Fixed another instance of bug #113456 in lists layout.
251  * Wed Jan 14 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-3
252  - Hard-code the margin-left work around to expect passivetex (bug #113456).
253
254* Mon Jan  5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl1
255- based on Fedora 1.64.1-2
256- fixed Japanese summary
257
258* Sat May 24 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.61.1-1vl1
259- based on Redhat Rawhide 1.61.1-1
260- add Japanese summary and description
261
262* Tue Feb  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60.1-0vl1
263- upstream release
264
265* Tue Nov 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-2vl1
266- based on Redhat Rawhide 1.57.0-2
267
268* Sat Oct 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-0vl1
269- 1.57.0
270
271* Tue Sep 24 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.55.0-0vl3
272- Rebuilded for Vine Linux (add PreReq: docbook-dtd412-xml)
273- based on rawhide 1.50.0 and source updated 1.55.0
274- use better macros
275
276* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
277- automated rebuild
278
279* Thu May 23 2002 Tim Powers <timp@redhat.com>
280- automated rebuild
281
282* Wed May  1 2002 Tim Waugh <twaugh@redhat.com> 1.50.0-1
283- 1.50.0.
284
285* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.49-1
286- 1.49.
287- Rebuild in new environment.
288
289* Fri Feb  1 2002 Tim Waugh <twaugh@redhat.com> 1.48-4
290- Put URIs instead of pathnames in the XML catalog.
291
292* Thu Jan 17 2002 Tim Waugh <twaugh@redhat.com> 1.48-3
293- Back to /usr/share/sgml.
294
295* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.48-2
296- automated rebuild
297
298* Mon Jan  7 2002 Tim Waugh <twaugh@redhat.com> 1.48-1
299- 1.48.
300
301* Sat Dec  8 2001 Tim Waugh <twaugh@redhat.com> 1.47-2
302- Conflict with PassiveTeX before 1.11.
303
304* Tue Oct 16 2001 Tim Waugh <twaugh@redhat.com> 1.47-1
305- 1.47-experimental.
306
307* Tue Oct  9 2001 Tim Waugh <twaugh@redhat.com> 1.45-2
308- Fix unversioned symlink.
309
310* Mon Oct  8 2001 Tim Waugh <twaugh@redhat.com> 1.45-1
311- XML Catalog entries.
312- Move files to /usr/share/xml.
313
314* Mon Oct  1 2001 Tim Waugh <twaugh@redhat.com> 1.45-0.1
315- 1.45.
316- Built for Red Hat Linux.
317
318* Tue Jun 26 2001 Chris Runge <crunge@pobox.com>
319- 1.40
320
321* Sat Jun 09 2001 Chris Runge <crunge@pobox.com>
322- added extensions and additional doc
323- bin added to doc; the Perl files are for Win32 Perl and so need some
324  conversion first
325
326* Fri Jun 08 2001 Chris Runge <crunge@pobox.com>
327- Initial RPM (based on docbook-style-dsssl RPM)
328- note: no catalog right now (I don't know how to do it; and not sure why
329  it is necessary)
Note: See TracBrowser for help on using the repository browser.