source: projects/specs/trunk/d/docbook-style-xsl/docbook-style-xsl-vl.spec @ 6890

Revision 6890, 11.9 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1Name: docbook-style-xsl
2Version: 1.77.1
3Release: 1%{?_dist_release}
4Group: Applications/Text
5
6Summary: Norman Walsh's XSL stylesheets for DocBook XML.
7Summary(ja): DocBook XML用 XSLスタイルシート
8
9License: Copyright only
10URL: http://docbook.sourceforge.net/projects/xsl/
11
12Source0: http://downloads.sourceforge.net/docbook/docbook-xsl-%{version}.tar.bz2
13Source1: %{name}.Makefile
14Source2: http://downloads.sourceforge.net/docbook/docbook-xsl-doc-%{version}.tar.bz2
15
16# Avoid proportional-column-width for passivetex (bug #176766).
17Patch1: docbook-xsl-pagesetup.patch
18# Hard-code the margin-left work around to expect passivetex (bug #113456).
19Patch2: docbook-xsl-marginleft.patch
20# fix of #161619 - adjustColumnWidths now available
21Patch3: docbook-xsl-newmethods.patch
22# change a few non-constant expressions to constant - needed for passivetex(#366441)
23Patch4: docbook-xsl-non-constant-expressions.patch
24# added fixes for passivetex extension and list-item-body(#161371)
25Patch5: docbook-xsl-list-item-body.patch
26#workaround missing mandir section problem (#727251)
27Patch6: docbook-xsl-mandir.patch
28
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildArch: noarch
32
33Provides: docbook-xsl = %{version}
34Requires: docbook-dtd-xml
35# xml-common was using /usr/share/xml until 0.6.3-8.
36Requires: xml-common >= 0.6.3-8
37# required because of usage of /usr/bin/xmlcatalog
38Requires(post): libxml2 >= 2.4.8
39Requires(postun): libxml2 >= 2.4.8
40# PassiveTeX before 1.21 can't handle the newer stylesheets.
41Conflicts: passivetex < 1.21
42
43Vendor: Project Vine
44Distribution: Vine Linux
45
46%description
47These XSL stylesheets allow you to transform any DocBook XML document to
48other formats, such as HTML, FO, and XHMTL.  They are highly customizable.
49
50%description -l ja
51この XSL スタイルシートを使って, さまざまな DocBook XML 形式のドキュメント
52を HTML や FO や XHTML などの他のフォーマットに変換することができます.
53
54
55%prep
56%setup -q -n docbook-xsl-%{version}
57pushd ..
58tar jxf %{SOURCE2}
59popd
60%patch1 -p1 -b .pagesetup
61%patch2 -p1 -b .marginleft
62%patch3 -p1 -b .newmethods
63%patch4 -p1 -b .nonconstant
64%patch5 -p1 -b .listitembody
65%patch6 -p1 -b .mandir
66
67cp %{SOURCE1} Makefile
68
69# fix of non UTF-8 files rpmlint warnings
70for fhtml in $(find ./doc -name '*.html' -type f)
71do
72  iconv -f ISO-8859-1 -t UTF-8 "$fhtml" -o "$fhtml".tmp
73  mv -f "$fhtml".tmp "$fhtml"
74  sed -i 's/charset=ISO-8859-1/charset=UTF-8/' "$fhtml"
75done
76
77for f in $(find -name "*'*")
78do
79  mv -v "$f" $(echo "$f" | tr -d "'")
80done
81
82%build
83
84%install
85[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
86
87DESTDIR=$RPM_BUILD_ROOT
88make install BINDIR=$DESTDIR%{_bindir} DESTDIR=$DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
89cp -a VERSION.xsl $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}/VERSION.xsl
90ln -s xsl-stylesheets-%{version} \
91        $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets
92
93# Don't ship the extensions (bug #177256).
94rm -rf $DESTDIR%{_datadir}/sgml/docbook/xsl-stylesheets/extensions/*
95
96%clean
97[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
98
99%post
100CATALOG=%{_sysconfdir}/xml/catalog
101%{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
102 "http://docbook.sourceforge.net/release/xsl/%{version}" \
103 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
104%{_bindir}/xmlcatalog --noout --add "rewriteURI" \
105 "http://docbook.sourceforge.net/release/xsl/%{version}" \
106 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
107%{_bindir}/xmlcatalog --noout --add "rewriteSystem" \
108 "http://docbook.sourceforge.net/release/xsl/current" \
109 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
110%{_bindir}/xmlcatalog --noout --add "rewriteURI" \
111 "http://docbook.sourceforge.net/release/xsl/current" \
112 "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
113
114%postun
115# remove entries only on removal of package
116if [ "$1" = 0 ]; then
117  CATALOG=%{_sysconfdir}/xml/catalog
118  %{_bindir}/xmlcatalog --noout --del \
119   "file://%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}" $CATALOG
120fi
121
122
123%files
124%defattr (-,root,root)
125%doc BUGS README TODO doc
126%{_datadir}/sgml/docbook/xsl-stylesheets-%{version}
127%{_datadir}/sgml/docbook/xsl-stylesheets
128
129
130%changelog
131* Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.77.1-1
132- new upstream release
133- add Patch6 (docbook-xsl-mandir.patch) from fedora
134- update Source1 (%{name}.Makefile)
135- update following patches from fedora
136  - Patch1 (docbook-xsl-pagesetup.patch)
137  - Patch2 (docbook-xsl-marginleft.patch)
138  - Patch3 (docbook-xsl-newmethods.patch)
139- update spec file based on fedora package
140  * Tue Jun  5 2012 Ondrej Vasik <ovasik@redhat.com> 1.77.1-2
141  - ship VERSION.xsl file (#829014)
142  * Tue Jun  5 2012 Ondrej Vasik <ovasik@redhat.com> 1.77.1-1
143  - new stable upstream release 1.77.1
144  - defuzz patches
145  * Tue Sep  6 2011 Ondrej Vasik <ovasik@redhat.com> 1.76.1-4
146  - revert previous change, workaround the mandir links issue
147    in buildroot (#727251)
148  * Mon Aug 29 2011 Ondrej Vasik <ovasik@redhat.com> 1.76.1-3
149  - make man.output.in.separate.dir "on" by default (#727251)
150  * Tue Nov 02 2010 Ondrej Vasik <ovasik@redhat.com> 1.76.1-1
151  - new upstream release 1.76.1
152  * Mon Sep 06 2010 Ondrej Vasik <ovasik@redhat.com> 1.76.0-1
153  - new upstream release 1.76.0
154
155* Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 1.76.1-1
156- new upstream release
157- add Vendor and Distribution tags
158
159* Sun Mar  7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.75.3-6
160- updated based on FC 1.75.3-5
161  * Fri Dec 18 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.3-5
162  - comment patches purpose
163  - License Copyright only
164  * Mon May 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.75.0-1
165  - New upstream release 1.75.0
166  - update marginleft patch
167  * Mon Feb 23 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.2-2
168  - updated Makefile: do ship .svg images(#486849), xsl
169    stylesheets for website, xhtml-1_1, docbook -> epub
170    convertor
171  * Wed Feb 11 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-7
172  - fix broken varlistentry (#479683)
173  * Mon Feb 02 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-6
174  - fix improper localization for rtl languages, thanks
175    Muayyad Alsadi(#475077)
176  * Wed Jan 28 2009 Ondrej Vasik <ovasik@redhat.com> 1.74.0-5
177  - fix xsl stylesheets for rtl languages(#475077)
178  * Fri Dec 12 2008 Ondrej Vasik <ovasik@redhat.com> 1.74.0-4
179  - Author_Group "<orgname>" merged between "<surname>"
180    and "<surname>" (#473019)
181  * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-3
182  - Rediffed all patches to work with patch --fuzz=0
183  * Wed Aug 06 2008 Kamil Dudka <kdudka@redhat.com> 1.74.0-2
184  - Tiny changes in docbook-xsl-newmethods.patch to work with xalan
185    (#452867)
186  * Fri Dec 14 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-9
187  - added fixes for passivetex extension and list-item-body
188    (#161371)
189  * Mon Dec 03 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-6
190  - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
191    documentation for nonpassivetex processing(#307001)
192  * Tue Nov 27 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-5
193  - convert all html files in doc to UTF-8 in prep
194    (latest rpmlint gives warnings)
195  - no longer using release in style-xsl dir(#389231)
196
197* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.73.2-5vl5
198- applied new versioning policy, spec in utf-8
199
200* Fri Jan 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.73.2-5vl1
201- updated to 1.73.2 based on Fedora development
202  * Tue Dec 11 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-4
203  - remove entries from xmlcatalog only on removal of package
204    (required because of the last change with droping release
205     -caused drop of catalog entries during update)
206  * Wed Dec 05 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-3
207  - change a few non-constant expressions to constant that
208    could now be handled by passivetex(#366441)
209  - fixed docbook-xsl-pagesetup.patch to follow Norman Walsh's
210    documentation for nonpassivetex processing(#307001)
211    (use passivetex.extensions = 1 option in param.xsl for
212     processing with passivetex)
213  * Fri Sep  7 2007 Ondrej Vasik <ovasik@redhat.com> 1.73.2-2
214  - Added PreReq of libxml2(#253962)
215
216* Sun Jul 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.72.0-3vl1
217- updated to 1.72.0 based on Fedora development
218  * Mon Jun 18 2007 Ondrej Vasik <ovasik@redhat.com> 1.72.0-3
219  - patch fixing #161619 taken from upstream
220  * Tue Jan 23 2007 Tim Waugh <twaugh@redhat.com> 1.72.0-1
221  - 1.72.0.
222  * Fri Jan 19 2007 Tomas Mraz <tmraz@redhat.com> 1.71.1-2
223  - Add new wordml and especially highlighting (which is referenced
224    from html) subdirs to Makefile.
225  * Tue Jan 24 2006 Tim Waugh <twaugh@redhat.com> 1.69.1-5
226  - Don't ship docsrc/* (bug #177256).
227  - Don't ship the extensions (bug #177256).
228
229* Sun Oct  8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.69.1-1vl1
230- updated to 1.69.1 based on Fedora development
231
232* Sun Dec 19 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.67.2-2vl1
233- updated to 1.67.2 based on Fedora development
234  * Wed Dec  8 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-2
235  - Prevent expressions in passivetex output from index.xsl (bug #142229).
236  * Thu Dec  2 2004 Tim Waugh <twaugh@redhat.com> 1.67.2-1
237  - No longer need nbsp or listblock patches.
238
239* Tue Jan 27 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl2
240- patch from Fedora 1.64.1-6
241  * Tue Jan 20 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-6
242  - Fix last margin-left fix (bug #113456).
243  - Reduce instances of itemized/ordered lists having misalignments.
244  * Sun Jan 18 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-5
245  - And another (bug #113456).
246  * Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-4
247  - Fixed another instance of bug #113456 in lists layout.
248  * Wed Jan 14 2004 Tim Waugh <twaugh@redhat.com> 1.64.1-3
249  - Hard-code the margin-left work around to expect passivetex (bug #113456).
250
251* Mon Jan  5 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.64.1-2vl1
252- based on Fedora 1.64.1-2
253- fixed Japanese summary
254
255* Sat May 24 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.61.1-1vl1
256- based on Redhat Rawhide 1.61.1-1
257- add Japanese summary and description
258
259* Tue Feb  4 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.60.1-0vl1
260- upstream release
261
262* Tue Nov 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-2vl1
263- based on Redhat Rawhide 1.57.0-2
264
265* Sat Oct 26 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.57.0-0vl1
266- 1.57.0
267
268* Tue Sep 24 2002 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.55.0-0vl3
269- Rebuilded for Vine Linux (add PreReq: docbook-dtd412-xml)
270- based on rawhide 1.50.0 and source updated 1.55.0
271- use better macros
272
273* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
274- automated rebuild
275
276* Thu May 23 2002 Tim Powers <timp@redhat.com>
277- automated rebuild
278
279* Wed May  1 2002 Tim Waugh <twaugh@redhat.com> 1.50.0-1
280- 1.50.0.
281
282* Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.49-1
283- 1.49.
284- Rebuild in new environment.
285
286* Fri Feb  1 2002 Tim Waugh <twaugh@redhat.com> 1.48-4
287- Put URIs instead of pathnames in the XML catalog.
288
289* Thu Jan 17 2002 Tim Waugh <twaugh@redhat.com> 1.48-3
290- Back to /usr/share/sgml.
291
292* Wed Jan 09 2002 Tim Powers <timp@redhat.com> 1.48-2
293- automated rebuild
294
295* Mon Jan  7 2002 Tim Waugh <twaugh@redhat.com> 1.48-1
296- 1.48.
297
298* Sat Dec  8 2001 Tim Waugh <twaugh@redhat.com> 1.47-2
299- Conflict with PassiveTeX before 1.11.
300
301* Tue Oct 16 2001 Tim Waugh <twaugh@redhat.com> 1.47-1
302- 1.47-experimental.
303
304* Tue Oct  9 2001 Tim Waugh <twaugh@redhat.com> 1.45-2
305- Fix unversioned symlink.
306
307* Mon Oct  8 2001 Tim Waugh <twaugh@redhat.com> 1.45-1
308- XML Catalog entries.
309- Move files to /usr/share/xml.
310
311* Mon Oct  1 2001 Tim Waugh <twaugh@redhat.com> 1.45-0.1
312- 1.45.
313- Built for Red Hat Linux.
314
315* Tue Jun 26 2001 Chris Runge <crunge@pobox.com>
316- 1.40
317
318* Fri Jun 09 2001 Chris Runge <crunge@pobox.com>
319- added extensions and additional doc
320- bin added to doc; the Perl files are for Win32 Perl and so need some
321  conversion first
322
323* Fri Jun 08 2001 Chris Runge <crunge@pobox.com>
324- Initial RPM (based on docbook-style-dsssl RPM)
325- note: no catalog right now (I don't know how to do it; and not sure why
326  it is necessary)
Note: See TracBrowser for help on using the repository browser.