source: projects/specs/trunk/d/dmraid/dmraid-vl.spec @ 12356

Revision 12356, 14.4 KB checked in by tomop, 4 years ago (diff)

updated 8 packages

device-mapper-multipath-0.8.2-1

dmraid-1.0.0.rc16-4

jansson-2.12-2

libbsd-0.10.0-1

libedit-3.1-4.20191231

libnsl2-1.2.0-2

libxcrypt-4.4.15-1

sgpio-1.2.1-1

Line 
1%{!?_unitdir:%global _unitdir /lib/systemd/system}
2%global _systemdscriptdir %(dirname %{_unitdir})
3
4Summary: Device-mapper RAID tool and library.
5Summary(ja): Device-mapper RAID ツールおよびライブラリ
6Name: dmraid
7Version: 1.0.0.rc16
8Release: 4%{?_dist_release}
9Group: System Environment/Base
10
11Vendor: Project Vine
12Distribution: Vine Linux
13
14License: GPL
15URL: http://people.redhat.com/heinzm/sw/dmraid
16
17Source: ftp://people.redhat.com/heinzm/sw/dmraid/src/%{name}-%{version}.tar.bz2
18Source1: dmraid-activation
19Source2: dmraid-activation.service
20
21Patch0: dmraid-1.0.0.rc16-test_devices.patch
22Patch1: ddf1_lsi_persistent_name.patch
23Patch2: pdc_raid10_failure.patch
24Patch3: return_error_wo_disks.patch
25Patch4: fix_sil_jbod.patch
26Patch5: avoid_register.patch
27Patch6: move_pattern_file_to_var.patch
28Patch7: libversion.patch
29Patch8: libversion-display.patch
30
31Patch9: bz635995-data_corruption_during_activation_volume_marked_for_rebuild.patch
32Patch11: bz626417_19-enabling_registration_degraded_volume.patch
33Patch12: bz626417_20-cleanup_some_compilation_warning.patch
34Patch13: bz626417_21-add_option_that_postpones_any_metadata_updates.patch
35
36Patch14: dmraid-fix-build-to-honour-cflags-var.patch
37Patch15: dmraid-fix-errors-and-warnings-triggered-by-CFLAGS.patch
38Patch16: dmraid-fix-destdir.patch
39Patch17: dmraid-fix-missing-destdir.patch
40Patch18: dmraid-fix-so-flags.patch
41
42Patch100: dmraid-1.0.0.rc16-libudev.patch
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
45BuildRequires: device-mapper-devel >= 1.02.22
46BuildRequires: device-mapper-event-devel
47BuildRequires: device-mapper-static
48BuildRequires: eudev-libudev-static
49BuildRequires: glibc-static
50Requires: device-mapper >= 1.02.22
51Requires(postun): ldconfig
52Requires(post): ldconfig
53
54
55%description
56DMRAID supports RAID device discovery, RAID set activation and display of
57properties for ATARAID on Linux >= 2.4 using device-mapper.
58
59%package -n dmraid-devel
60Summary: Development libraries and headers for dmraid.
61Group: Development/Libraries
62
63%description -n dmraid-devel
64dmraid-devel provides a library interface for RAID device discovery,
65RAID set activation and display of properties for ATARAID volumes.
66
67%package -n dmraid-events
68Summary: dmevent_tool (Device-mapper event tool) and DSO
69Group: System Environment/Base
70Requires: dmraid = %{version}-%{release}, sgpio
71Requires: device-mapper-event
72
73%description -n dmraid-events
74Provides a dmeventd DSO and the dmevent_tool to register devices with it
75for device monitoring.  All active RAID sets should be manually registered
76with dmevent_tool.
77
78%package -n dmraid-events-logwatch
79Summary: dmraid logwatch-based email reporting
80Group: System Environment/Base
81Requires: dmraid-events = %{version}-%{release}, logwatch, /etc/cron.d
82
83%description -n dmraid-events-logwatch
84Provides device failure reporting via logwatch-based email reporting.
85Device failure reporting has to be activated manually by activating the
86/etc/cron.d/dmeventd-logwatch entry and by calling the dmevent_tool
87(see manual page for examples) for any active RAID sets.
88
89%prep
90%setup -q -n dmraid/%{version}
91%autopatch -p1
92
93
94%build
95%configure \
96  --sbindir=/sbin \
97  --disable-libselinux --disable-static_link \
98  --enable-led --enable-intel_led
99# parallel make is broken, do not pass smp flags
100make
101
102
103%install
104rm -rf %{buildroot}
105install -m 755 -d %{buildroot}{%{_libdir},/sbin,%{_sbindir},%{_bindir},%{_libdir},%{_includedir}/dmraid/,/var/lock/dmraid,%{_sysconfdir}/cron.d/}
106install -m 755 -d %{buildroot}{%{_sysconfdir}/logwatch/conf/services/,%{_sysconfdir}/logwatch/scripts/services/,/var/cache/logwatch/dmeventd}
107make DESTDIR=%{buildroot} install
108#install -m 755 tools/dmraid.static %{buildroot}/sbin/dmraid.static
109ln -s dmraid %{buildroot}/sbin/dmraid.static
110
111# Provide convenience link from dmevent_tool
112(cd %{buildroot}/sbin ; ln -f dmevent_tool dm_dso_reg_tool)
113(cd %{buildroot}/%{_mandir}/man8 ; ln -f dmevent_tool.8 dm_dso_reg_tool.8 ; ln -f dmraid.8 dmraid.static.8)
114
115#
116install -m 644 include/dmraid/*.h %{buildroot}%{_includedir}/dmraid/
117
118# Install the libdmraid and libdmraid-events (for dmeventd) DSO
119# Create version symlink to libdmraid.so.1 we link against
120install -m 755 lib/libdmraid.so \
121        %{buildroot}%{_libdir}/libdmraid.so.%{version}
122(cd %{buildroot}/%{_libdir} ; ln -sf libdmraid.so.%{version} libdmraid.so ; ln -sf libdmraid.so.%{version} libdmraid.so.1)
123install -m 755 lib/libdmraid-events-isw.so \
124        %{buildroot}%{_libdir}/libdmraid-events-isw.so.%{version}
125(cd %{buildroot}/%{_libdir} ; ln -sf libdmraid-events-isw.so.%{version} libdmraid-events-isw.so ; ln -sf libdmraid-events-isw.so.%{version} libdmraid-events-isw.so.1)
126                 
127# Install logwatch config file and script for dmeventd
128install -m 644 logwatch/dmeventd.conf %{buildroot}%{_sysconfdir}/logwatch/conf/services/dmeventd.conf
129install -m 755 logwatch/dmeventd %{buildroot}%{_sysconfdir}/logwatch/scripts/services/dmeventd
130install -m 644 logwatch/dmeventd_cronjob.txt %{buildroot}%{_sysconfdir}/cron.d/dmeventd-logwatch
131install -m 0700 /dev/null %{buildroot}/var/cache/logwatch/dmeventd/syslogpattern.txt
132
133# Install systemd unit
134mkdir -p %{buildroot}%{_unitdir}
135install -p -m 755 %{SOURCE1} %{buildroot}%{_systemdscriptdir}/dmraid-activation
136install -p -m 444 %{SOURCE2} %{buildroot}%{_unitdir}/dmraid-activation.service
137sed -i -e 's|@systemdscriptdir@|%{_systemdscriptdir}|' %{buildroot}%{_unitdir}/dmraid-activation.service
138
139# remove static libs
140rm -f %{buildroot}/%{_libdir}/libdmraid.a
141
142%clean
143rm -rf %{buildroot}
144
145%post -p /sbin/ldconfig
146 
147%postun -p /sbin/ldconfig
148
149%files
150%defattr(-,root,root)
151%license LICENSE LICENSE_GPL LICENSE_LGPL
152%doc CHANGELOG CREDITS KNOWN_BUGS README TODO doc/dmraid_design.txt
153%{_mandir}/man8/*
154/sbin/*
155%{_libdir}/libdmraid.so*
156%{_libdir}/libdmraid-events-isw.so*
157%ghost /var/lock/dmraid
158
159%dir %{_systemdscriptdir}
160%dir %{_unitdir}
161%{_systemdscriptdir}/dmraid-activation
162%{_unitdir}/dmraid-activation.service
163
164%files -n dmraid-devel
165%defattr(-,root,root)
166%dir %{_includedir}/dmraid
167%{_includedir}/dmraid/*
168
169%files -n dmraid-events
170%defattr(-,root,root)
171/%{_mandir}/man8/dmevent_tool*
172/%{_mandir}/man8/dm_dso_reg_tool*
173/sbin/dmevent_tool
174/sbin/dm_dso_reg_tool
175
176%files -n dmraid-events-logwatch
177%defattr(-,root,root)
178%config(noreplace) %{_sysconfdir}/logwatch/*
179%config(noreplace) %{_sysconfdir}/cron.d/dmeventd-logwatch
180%dir /var/cache/logwatch/dmeventd
181%ghost /var/cache/logwatch/dmeventd/syslogpattern.txt
182
183
184%changelog
185* Sat Mar 28 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.0.rc16-4
186- imported Patch14-18 from rawhide.
187 
188* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0.rc16-3
189- change BuildRequires: eudev-libudev-static instead of libudev-static
190
191* Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.0.rc16-2
192- rebuild with VineSeed environment
193
194* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0.rc16-1
195- update to 1.0.0.rc16
196- update patches from fedora package
197- add BR: libudev-static, device-mapper-static, glibc-static
198- add BR: device-mapper-event-devel
199- add -events, -events-logwatch subpackage
200- move libdmraid.so to main package
201- use %ghost for /var/lock/dmraid
202
203* Sat Mar 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0.rc15-1
204- new upstream release
205
206* Mon Dec 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl0.rc14.1
207- initial build for Vine Linux
208- disable selinux
209- require device-mapper 1.02.22
210
211* Wed Nov 21 2007 Ian Kent <ikent@redhat.com> - 1.0.0.rc14-6
212- Bug 379911: dmraid needs to generate UUIDs for lib device-mapper
213  - add "DMRAID-" prefix to dmraid UUID string.
214
215* Wed Nov 14 2007 Ian Kent <ikent@redhat.com> - 1.0.0.rc14-5
216- Bug 379911: dmraid needs to generate UUIDs for lib device-mapper
217- Bug 379951: dmraid needs to activate device-mapper mirror resynchronization error handling
218
219* Mon Oct 22 2007 Ian Kent <ikent@redhat.com> - 1.0.0.rc14-4
220- Fix SEGV on "dmraid -r -E" (bz 236891).
221
222* Wed Apr 18 2007 Peter Jones <pjones@redhat.com> - 1.0.0.rc14-3
223- Fix jmicron name parsing (#219058)
224
225* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 1.0.0.rc14-2
226- Add build dependency on new device-mapper-devel package.
227- Add dependency on device-mapper.
228- Add post and postun ldconfig.
229- Update BuildRoot and Summary.
230
231* Wed Nov 08 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc14-1
232- asr.c: fixed Adaptec HostRAID DDF1 metadata discovery (bz#211016)
233- ddf1_crc.c: added crc() routine to avoid linking to zlib alltogether,
234              because Ubuntu had problems with this
235- dropped zlib build requirement
236
237* Thu Oct 26 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc14-bz211016-1
238- ddf1.c: get_size() fixed (bz#211016)
239- ddf1_lib.c: ddf1_cr_off_maxpds_helper() fixed (bz#211016)
240
241* Wed Oct 11 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc13-1
242- metadata.c: fixed bug returning wrang unified RAID type (bz#210085)
243- pdc.c: fixed magic number check
244
245* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc12-7
246- rebuilt for unwind info generation, broken in gcc-4.1.1-21
247
248* Fri Sep 22 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc12-1
249- sil.c: quorate() OBO fix
250- activate.c: handler() OBO fix
251- added SNIA DDF1 support
252- added reload functionality to devmapper.c
253- added log_zero_sectors() to various metadata format handlers
254- sil.[ch]: added JBOD support
255
256* Fri Sep  1 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-4
257- Require kpartx, so initscripts doesn't have to if you're not using dmraid
258
259* Thu Aug 17 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc11-3
260- Change Release to follow guidelines, and add dist tag.
261
262* Thu Aug 17 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-FC6.3
263- No more excludearch for s390/s390x
264
265* Fri Jul 28 2006 Peter Jones <pjones@redhat.com> - 1.0.0.rc11-FC6.2
266- Fix bounds checking on hpt37x error log
267- Only build the .so, not the .a
268- Fix asc.c duplication in makefile rule
269
270* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc11-FC6.1.1
271- rebuild
272
273* Fri Jul  7 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC6.1
274- rebuilt for FC6 with dos partition discovery fix (#197573)
275
276* Tue May 16 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC6
277- rebuilt for FC6 with better tag
278
279* Tue May 16 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC5_7.2
280- rebuilt for FC5
281
282* Tue May 16 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc11-FC5_7.1
283- jm.c: checksum() calculation
284- misc.c: support "%d" in p_fmt and fix segfault with wrong format identifier
285- nv.c: size fix in setup_rd()
286- activate.c:
287        o striped devices could end on non-chunk boundaries
288        o calc_region_size() calculated too small sizes causing large
289          dirty logs in memory
290- isw.c: set raid5 type to left asymmetric
291- toollib.c: fixed 'No RAID...' message
292- support selection of RAID5 allocation algorithm in metadata format handlers
293- build
294
295* Mon Mar 27 2006 Milan Broz <mbroz@redhat.com> - 1.0.0.rc10-FC5_6.2
296- fixed /var/lock/dmraid in specfile (#168195)
297
298* Fri Feb 17 2006 Heinz Mauelshagen <heinzm@redhat.com> - 1.0.0.rc10-FC5_6
299- add doc/dmraid_design.txt to %doc (#181885)
300- add --enable-libselinux --enable-libsepol to configure
301- rebuilt
302
303* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc9-FC5_5.2
304- bump again for double-long bug on ppc(64)
305
306* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.0.0.rc9-FC5_5.1
307- rebuilt for new gcc4.1 snapshot and glibc changes
308
309* Sun Jan 22 2006 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_5
310- Add selinux build deps
311- Don't set owner during make install
312
313* Fri Dec  9 2005 Jesse Keating <jkeating@redhat.com> 1.0.0.rc9-FC5_4.1
314- rebuilt
315
316* Sat Dec  3 2005 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_4
317- rebuild for device-mapper-1.02.02-2
318
319* Fri Dec  2 2005 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_3
320- rebuild for device-mapper-1.02.02-1
321
322* Thu Nov 10 2005 Peter Jones <pjones@redhat.com> 1.0.0.rc9-FC5_2
323- update to 1.0.0.rc9
324- make "make install" do the right thing with the DSO
325- eliminate duplicate definitions in the headers
326- export more symbols in the DSO
327- add api calls to retrieve dm tables
328- fix DESTDIR for 'make install'
329- add api calls to identify degraded devices
330- remove several arch excludes
331
332* Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
333- add -lselinux -lsepol for new device-mapper deps
334
335* Fri May 20 2005 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc8-FC4_2
336- specfile change to build static and dynamic binray into one package
337- rebuilt
338
339* Thu May 19 2005 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc8-FC4_1
340- nv.c: fixed stripe size
341- sil.c: avoid incarnation_no in name creation, because the Windows
342         driver changes it every time
343- added --ignorelocking option to avoid taking out locks in early boot
344  where no read/write access to /var is given
345
346* Wed Mar 16 2005 Elliot Lee <sopwith@redhat.com>
347- rebuilt
348
349* Tue Mar 15 2005 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc6.1-4_FC4
350- VIA metadata format handler
351- added RAID10 to lsi metadata format handler
352- "dmraid -rD": file device size into {devicename}_{formatname}.size
353- "dmraid -tay": pretty print multi-line tables ala "dmsetup table"
354- "dmraid -l": display supported RAID levels + manual update
355- _sil_read() used LOG_NOTICE rather than LOG_INFO in order to
356  avoid messages about valid metadata areas being displayed
357  during "dmraid -vay".
358- isw, sil filed metadata offset on "-r -D" in sectors rather than in bytes.
359- isw needed dev_sort() to sort RAID devices in sets correctly.
360- pdc metadata format handler name creation. Lead to
361  wrong RAID set grouping logic in some configurations.
362- pdc RAID1 size calculation fixed (rc6.1)
363- dos.c: partition table code fixes by Paul Moore
364- _free_dev_pointers(): fixed potential OOB error
365- hpt37x_check: deal with raid_disks = 1 in mirror sets
366- pdc_check: status & 0x80 doesn't always show a failed device;
367  removed that check for now. Status definitions needed.
368- sil addition of RAID sets to global list of sets
369- sil spare device memory leak
370- group_set(): removal of RAID set in case of error
371- hpt37x: handle total_secs > device size
372- allow -p with -f
373- enhanced error message by checking target type against list of
374  registered target types
375
376* Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> 1.0.0.rc5f-2
377- Rebuild to pick up new libdevmapper.
378
379* Fri Nov 26 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0.rc5f
380- specfile cleanup
381
382* Fri Aug 20 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0-rc4-pre1
383- Removed make flag after fixing make.tmpl.in
384
385* Wed Aug 18 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0-rc3
386- Added make flag to prevent make 3.80 from looping infinitely
387
388* Thu Jun 17 2004 Heinz Mauelshagen <heinzm@redhat.com> 1.0.0-pre1
389- Created
Note: See TracBrowser for help on using the repository browser.