source: projects/specs/trunk/d/device-mapper-multipath/device-mapper-multipath-vl.spec @ 3734

Revision 3734, 7.3 KB checked in by daisuke, 13 years ago (diff)

device-mapper-multipath: fix multipath library path

Line 
1Summary: Tools to manage multipath devices using device-mapper
2Name: device-mapper-multipath
3Version: 0.4.9
4Release: 2%{?_dist_release}
5License: GPL
6Group: System Environment/Base
7URL: http://christophe.varoqui.free.fr/
8Source0: multipath-tools-%{version}.tar.bz2
9Source1: multipath.conf
10
11Requires: kpartx = %{version}-%{release}
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13Requires(post): chkconfig
14Requires(preun): chkconfig
15Requires: device-mapper >= 1.02.02-2
16BuildRequires: sysfsutils-devel, device-mapper-devel
17#BuildRequires: libselinux-devel, libsepol-devel
18BuildRequires: readline-devel, ncurses-devel
19BuildRequires: libaio-devel
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: daisuke
24
25%description
26%{name} provides tools to manage multipath devices by instructing the
27device-mapper multipath kernel module what to do.
28The tools are :
29* multipath :   Scan the system for multipath devices and assemble them.
30* multipathd :  Detects when paths fail and execs multipath to update things.
31
32
33%package -n kpartx
34Summary: Partition device manager for device-mapper devices
35Group: System Environment/Base
36Provides: kpartx = %{version}-%{release}
37
38
39%description -n kpartx
40kpartx manages partition creation and removal for device-mapper devices.
41
42
43%prep
44%setup -q -c
45
46
47%build
48make LIB=%{_lib}
49
50%install
51rm -rf $RPM_BUILD_ROOT
52make install \
53  DESTDIR=$RPM_BUILD_ROOT \
54  bindir=%{_syssbindir} \
55  syslibdir=/%{_lib} \
56  libdir=/%{_lib}/multipath \
57  rcdir=%{_initrddir}
58
59install -d %{buildroot}/etc/multipath
60install -m644 %{SOURCE1} %{buildroot}/etc/multipath.conf
61
62install -m755 multipathd/multipathd.init.redhat %{buildroot}%{_initrddir}/multipathd
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67
68%post
69/sbin/ldconfig
70/sbin/chkconfig --add multipathd
71if [ "$1" -gt "1" -a ! -e /etc/multipath/bindings -a \
72    -f /var/lib/multipath/bindings ]; then
73       mv /var/lib/multipath/bindings /etc/multipath/bindings
74       ln -s /etc/multipath/bindings /var/lib/multipath/bindings
75fi
76
77%preun
78if [ "$1" = 0 ]; then
79        /sbin/service multipathd stop /dev/null 2>&1
80        /sbin/chkconfig --del multipathd
81fi
82
83
84%postun
85/sbin/ldconfig
86if [ "$1" -ge "1" ]; then
87        /sbin/service multipathd condrestart >/dev/null 2>&1 || :
88fi
89
90
91%files
92%defattr(-,root,root,-)
93%doc AUTHOR COPYING README* FAQ
94%doc multipath.conf.annotated multipath.conf.defaults
95%doc multipath.conf.synthetic
96%{_syssbindir}/multipath
97%{_syssbindir}/multipathd
98%config /etc/udev/rules.d/multipath.rules
99%{_mandir}/man8/multipath.8.gz
100%{_mandir}/man8/multipathd.8.gz
101%{_mandir}/man5/multipath.conf.5.gz
102%config /etc/rc.d/init.d/multipathd
103%config(noreplace) /etc/multipath.conf
104%dir /etc/multipath
105/%{_lib}/libmultipath.so*
106%dir /%{_lib}/multipath
107/%{_lib}/multipath/*
108
109%files -n kpartx
110%defattr(-,root,root,-)
111%{_syssbindir}/kpartx
112/lib/udev/kpartx_id
113%config /etc/udev/rules.d/kpartx.rules
114%{_mandir}/man8/kpartx.8.gz
115
116
117%changelog
118* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-2
119- install multipath libraries to %%{_lib}/multipath
120
121* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-1
122- update to 0.4.9
123- drop static version
124- add BR: libaio-devel
125
126* Sun Sep 07 2008 Shu KONNO <owa@bg.wakwak.com> 0.4.7-12vl5
127- applied new versioning policy
128
129* Thu Feb 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.7-11vl1
130- initial build for VineSeed
131- add Patch100 to disable linking to libselinux and libsepol
132
133* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 0.4.7-11.fc7
134- Add build dependency on new device-mapper-devel package.
135- Add dependency on device-mapper.
136
137* Wed Jan 31 2007 Benjamin Marzinksi <bmarzins@redhat.com> - 0.4.7-10.fc7
138- Update BuildRoot and PreReq lines.
139
140* Mon Jan 15 2007 Benjamin Marzinksi <bmarzins@redhat.com> - 0.4.7-9.fc7
141- Fixed spec file.
142
143* Mon Jan 15 2007 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.7-8.fc7
144- Update to latest code (t0_4_7_head2)
145
146* Wed Dec 13 2006 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.7-7.fc7
147- Update to latest code (t0_4_7_head1)
148
149* Thu Sep  7 2006 Peter Jones <pjones@redhat.com> - 0.4.7-5
150- Fix kpartx to handle with drives >2TB correctly.
151
152* Thu Aug 31 2006 Peter Jones <pjones@redhat.com> - 0.4.7-4.1
153- Split kpartx out into its own package so dmraid can use it without
154  installing multipathd
155- Fix a segfault in kpartx
156
157* Mon Jul 17 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-4.0
158- Updated to latest source. Fixes bug in default multipath.conf
159
160* Wed Jul 12 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-3.1
161- Added ncurses-devel to BuildRequires
162
163* Wed Jul 12 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-3.0
164- Updated to latest source. deals with change in libsysfs API
165
166* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.4.7-2.2.1
167- rebuild
168
169* Mon Jul 10 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.2
170- fix tagging issue.
171
172* Mon Jul 10 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.1
173- changed BuildRequires from sysfsutils-devel to libsysfs-devel
174
175* Wed Jun 28 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.0
176- Updated to latest upstream source, fixes kpartx udev rule issue
177
178* Mon Jun 06 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-1.0
179- Updated to Christophe's latest source
180
181* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 0.4.5-16.0
182- Newer upstream source (t0_4_5_post59).
183
184* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 0.4.5-12.3
185- BuildRequires: libsepol-devel, readline-devel
186
187* Mon Feb 27 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.5-12.2
188- Prereq: chkconfig
189
190* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 0.4.5-12.1
191- BuildRequires: libselinux-devel
192
193* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.4.5-12.0.1
194- bump again for double-long bug on ppc(64)
195
196* Tue Feb 07 2006 Benjamin Marzinski <bmarzins@redhat.com> -0.4.5-12.0
197- Updated to latest upstream source (t0_4_5_post56)
198
199* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.4.5-9.1.1
200- rebuilt for new gcc4.1 snapshot and glibc changes
201
202* Mon Dec 19 2005 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.5-9.1
203- added patch for fedora changes
204
205* Fri Dec 16 2005 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.5-9.0
206- Updated to latest upstream source (t)_4_5_post52)
207
208* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
209- rebuilt
210
211* Sun Dec  4 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.6
212- rebuild for newer libs
213
214* Tue Nov 15 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.5
215- unsplit kpartx.  parted knows how to do this now, so we don't
216  need this in a separate package.
217
218* Tue Nov 15 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.4
219- split kpartx out into its own package
220
221* Fri May 06 2005 Bill Nottingham <notting@redhat.com> - 0.4.4-2.3
222- Fix last fix.
223
224* Thu May 05 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.2
225- Fix last fix.
226
227* Wed May 04 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.1
228- By default, disable the multipathd service.
229
230* Tue Apr 19 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.0
231- Fix core dump from last build.
232
233* Tue Apr 19 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-1.0
234- Move cache file into /var/cache/multipath.
235
236* Fri Apr 08 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-0.pre8.1
237- Remove pp_balance_units.
238
239* Mon Apr 04 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-0.pre8.0
240- Incorporate numerous upstream fixes.
241- Update init script to distribution standards.
242
243* Tue Mar 01 2005 Alasdair Kergon <agk@redhat.com> - 0.4.2-1.0
244- Initial import based on Christophe Varoqui's spec file.
Note: See TracBrowser for help on using the repository browser.