source: projects/specs/trunk/d/device-mapper-multipath/device-mapper-multipath-vl.spec @ 3589

Revision 3589, 7.2 KB checked in by daisuke, 13 years ago (diff)

device-mapper-multipath: update to 0.4.9, drop static, add BR: libaio-devel

Line 
1Summary: Tools to manage multipath devices using device-mapper
2Name: device-mapper-multipath
3Version: 0.4.9
4Release: 1%{?_dist_release}
5License: GPL
6Group: System Environment/Base
7URL: http://christophe.varoqui.free.fr/
8Source0: multipath-tools-%{version}.tar.bz2
9Source1: multipath.conf
10
11Requires: kpartx = %{version}-%{release}
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13Requires(post): chkconfig
14Requires(preun): chkconfig
15Requires: device-mapper >= 1.02.02-2
16BuildRequires: sysfsutils-devel, device-mapper-devel
17#BuildRequires: libselinux-devel, libsepol-devel
18BuildRequires: readline-devel, ncurses-devel
19BuildRequires: libaio-devel
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: daisuke
24
25%description
26%{name} provides tools to manage multipath devices by instructing the
27device-mapper multipath kernel module what to do.
28The tools are :
29* multipath :   Scan the system for multipath devices and assemble them.
30* multipathd :  Detects when paths fail and execs multipath to update things.
31
32
33%package -n kpartx
34Summary: Partition device manager for device-mapper devices
35Group: System Environment/Base
36Provides: kpartx = %{version}-%{release}
37
38
39%description -n kpartx
40kpartx manages partition creation and removal for device-mapper devices.
41
42
43%prep
44%setup -q -c
45
46
47%build
48make LIB=%{_lib}
49
50%install
51rm -rf $RPM_BUILD_ROOT
52make install \
53  DESTDIR=$RPM_BUILD_ROOT \
54  bindir=%{_syssbindir} \
55  syslibdir=/%{_lib} \
56  libdir=%{_libdir}/multipath \
57  rcdir=%{_initrddir}
58
59install -d %{buildroot}/etc/multipath
60install -m644 %{SOURCE1} %{buildroot}/etc/multipath.conf
61
62install -m755 multipathd/multipathd.init.redhat %{buildroot}%{_initrddir}/multipathd
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67
68%post
69/sbin/ldconfig
70/sbin/chkconfig --add multipathd
71if [ "$1" -gt "1" -a ! -e /etc/multipath/bindings -a \
72    -f /var/lib/multipath/bindings ]; then
73       mv /var/lib/multipath/bindings /etc/multipath/bindings
74       ln -s /etc/multipath/bindings /var/lib/multipath/bindings
75fi
76
77%preun
78if [ "$1" = 0 ]; then
79        /sbin/service multipathd stop /dev/null 2>&1
80        /sbin/chkconfig --del multipathd
81fi
82
83
84%postun
85/sbin/ldconfig
86if [ "$1" -ge "1" ]; then
87        /sbin/service multipathd condrestart >/dev/null 2>&1 || :
88fi
89
90
91%files
92%defattr(-,root,root,-)
93%doc AUTHOR COPYING README* FAQ
94%doc multipath.conf.annotated multipath.conf.defaults
95%doc multipath.conf.synthetic
96%{_syssbindir}/multipath
97%{_syssbindir}/multipathd
98%config /etc/udev/rules.d/multipath.rules
99%{_mandir}/man8/multipath.8.gz
100%{_mandir}/man8/multipathd.8.gz
101%{_mandir}/man5/multipath.conf.5.gz
102%config /etc/rc.d/init.d/multipathd
103%config(noreplace) /etc/multipath.conf
104%dir /etc/multipath
105/%{_lib}/libmultipath.so*
106%dir %{_libdir}/multipath
107%{_libdir}/multipath/*
108
109%files -n kpartx
110%defattr(-,root,root,-)
111%{_syssbindir}/kpartx
112/lib/udev/kpartx_id
113%config /etc/udev/rules.d/kpartx.rules
114%{_mandir}/man8/kpartx.8.gz
115
116
117%changelog
118* Wed Apr 20 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.9-13
119- update to 0.4.9
120- drop static version
121- add BR: libaio-devel
122
123* Sun Sep 07 2008 Shu KONNO <owa@bg.wakwak.com> 0.4.7-12vl5
124- applied new versioning policy
125
126* Thu Feb 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.7-11vl1
127- initial build for VineSeed
128- add Patch100 to disable linking to libselinux and libsepol
129
130* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 0.4.7-11.fc7
131- Add build dependency on new device-mapper-devel package.
132- Add dependency on device-mapper.
133
134* Wed Jan 31 2007 Benjamin Marzinksi <bmarzins@redhat.com> - 0.4.7-10.fc7
135- Update BuildRoot and PreReq lines.
136
137* Mon Jan 15 2007 Benjamin Marzinksi <bmarzins@redhat.com> - 0.4.7-9.fc7
138- Fixed spec file.
139
140* Mon Jan 15 2007 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.7-8.fc7
141- Update to latest code (t0_4_7_head2)
142
143* Wed Dec 13 2006 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.7-7.fc7
144- Update to latest code (t0_4_7_head1)
145
146* Thu Sep  7 2006 Peter Jones <pjones@redhat.com> - 0.4.7-5
147- Fix kpartx to handle with drives >2TB correctly.
148
149* Thu Aug 31 2006 Peter Jones <pjones@redhat.com> - 0.4.7-4.1
150- Split kpartx out into its own package so dmraid can use it without
151  installing multipathd
152- Fix a segfault in kpartx
153
154* Mon Jul 17 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-4.0
155- Updated to latest source. Fixes bug in default multipath.conf
156
157* Wed Jul 12 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-3.1
158- Added ncurses-devel to BuildRequires
159
160* Wed Jul 12 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-3.0
161- Updated to latest source. deals with change in libsysfs API
162
163* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.4.7-2.2.1
164- rebuild
165
166* Mon Jul 10 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.2
167- fix tagging issue.
168
169* Mon Jul 10 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.1
170- changed BuildRequires from sysfsutils-devel to libsysfs-devel
171
172* Wed Jun 28 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.0
173- Updated to latest upstream source, fixes kpartx udev rule issue
174
175* Mon Jun 06 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-1.0
176- Updated to Christophe's latest source
177
178* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 0.4.5-16.0
179- Newer upstream source (t0_4_5_post59).
180
181* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 0.4.5-12.3
182- BuildRequires: libsepol-devel, readline-devel
183
184* Mon Feb 27 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.5-12.2
185- Prereq: chkconfig
186
187* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 0.4.5-12.1
188- BuildRequires: libselinux-devel
189
190* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.4.5-12.0.1
191- bump again for double-long bug on ppc(64)
192
193* Tue Feb 07 2006 Benjamin Marzinski <bmarzins@redhat.com> -0.4.5-12.0
194- Updated to latest upstream source (t0_4_5_post56)
195
196* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.4.5-9.1.1
197- rebuilt for new gcc4.1 snapshot and glibc changes
198
199* Mon Dec 19 2005 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.5-9.1
200- added patch for fedora changes
201
202* Fri Dec 16 2005 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.5-9.0
203- Updated to latest upstream source (t)_4_5_post52)
204
205* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
206- rebuilt
207
208* Sun Dec  4 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.6
209- rebuild for newer libs
210
211* Tue Nov 15 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.5
212- unsplit kpartx.  parted knows how to do this now, so we don't
213  need this in a separate package.
214
215* Tue Nov 15 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.4
216- split kpartx out into its own package
217
218* Fri May 06 2005 Bill Nottingham <notting@redhat.com> - 0.4.4-2.3
219- Fix last fix.
220
221* Thu May 05 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.2
222- Fix last fix.
223
224* Wed May 04 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.1
225- By default, disable the multipathd service.
226
227* Tue Apr 19 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.0
228- Fix core dump from last build.
229
230* Tue Apr 19 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-1.0
231- Move cache file into /var/cache/multipath.
232
233* Fri Apr 08 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-0.pre8.1
234- Remove pp_balance_units.
235
236* Mon Apr 04 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-0.pre8.0
237- Incorporate numerous upstream fixes.
238- Update init script to distribution standards.
239
240* Tue Mar 01 2005 Alasdair Kergon <agk@redhat.com> - 0.4.2-1.0
241- Initial import based on Christophe Varoqui's spec file.
Note: See TracBrowser for help on using the repository browser.