source: projects/specs/trunk/d/device-mapper-multipath/device-mapper-multipath-vl.spec @ 521

Revision 521, 6.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Tools to manage multipath devices using device-mapper
2Name: device-mapper-multipath
3Version: 0.4.7
4Release: 12%{?_dist_release}
5License: GPL
6Group: System Environment/Base
7URL: http://christophe.varoqui.free.fr/
8Source0: multipath-tools-0.4.7.head2.tgz
9Patch100: multipath-tools-0.4.7.head2_without_selinux.patch
10Requires: kpartx = %{version}-%{release}
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
12Requires(post): chkconfig
13Requires(preun): chkconfig
14Requires: device-mapper >= 1.02.02-2
15#BuildRequires: libsysfs-devel, device-mapper-devel
16BuildRequires: sysfsutils-devel, device-mapper-devel
17#BuildRequires: libselinux-devel, libsepol-devel
18BuildRequires: readline-devel, ncurses-devel
19
20
21%description
22%{name} provides tools to manage multipath devices by instructing the
23device-mapper multipath kernel module what to do.
24The tools are :
25* multipath :   Scan the system for multipath devices and assemble them.
26* multipathd :  Detects when paths fail and execs multipath to update things.
27
28
29%package -n kpartx
30Summary: Partition device manager for device-mapper devices
31Group: System Environment/Base
32Provides: kpartx = %{version}-%{release}
33
34
35%description -n kpartx
36kpartx manages partition creation and removal for device-mapper devices.
37
38
39%prep
40%setup -q -n multipath-tools-0.4.7.head2
41
42%patch100 -p1
43
44
45%build
46make DESTDIR=$RPM_BUILD_ROOT
47
48
49%install
50rm -rf $RPM_BUILD_ROOT
51make install DESTDIR=$RPM_BUILD_ROOT bindir=/sbin rcdir=/etc/rc.d/init.d
52
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57
58%post
59/sbin/chkconfig --add multipathd
60
61
62%preun
63if [ "$1" = 0 ]; then
64        /sbin/chkconfig --del multipathd
65fi
66
67
68%files
69%defattr(-,root,root,-)
70%doc AUTHOR COPYING README* FAQ Multipath-usage.txt
71%doc multipath.conf.annotated multipath.conf.defaults multipath.conf.synthetic
72/sbin/multipath
73/sbin/multipath.static
74/sbin/multipathd
75/sbin/mpath_prio_alua
76/sbin/mpath_prio_emc
77/sbin/mpath_prio_netapp
78/sbin/mpath_prio_hds_modular
79/sbin/mpath_prio_tpc
80/sbin/mpath_wait
81/sbin/mpath_ctl
82/etc/udev/rules.d/40-multipath.rules
83%{_mandir}/man8/mpath_prio_alua.8.gz
84%{_mandir}/man8/multipath.8.gz
85%{_mandir}/man8/multipathd.8.gz
86%config /etc/rc.d/init.d/multipathd
87%config(noreplace) /etc/multipath.conf
88%dir /var/lib/multipath
89
90
91%files -n kpartx
92%defattr(-,root,root,-)
93/sbin/kpartx
94/sbin/kpartx.static
95%{_mandir}/man8/kpartx.8.gz
96
97
98%changelog
99* Sun Sep 07 2008 Shu KONNO <owa@bg.wakwak.com> 0.4.7-12vl5
100- applied new versioning policy
101
102* Thu Feb 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.7-11vl1
103- initial build for VineSeed
104- add Patch100 to disable linking to libselinux and libsepol
105
106* Mon Feb 05 2007 Alasdair Kergon <agk@redhat.com> - 0.4.7-11.fc7
107- Add build dependency on new device-mapper-devel package.
108- Add dependency on device-mapper.
109
110* Wed Jan 31 2007 Benjamin Marzinksi <bmarzins@redhat.com> - 0.4.7-10.fc7
111- Update BuildRoot and PreReq lines.
112
113* Mon Jan 15 2007 Benjamin Marzinksi <bmarzins@redhat.com> - 0.4.7-9.fc7
114- Fixed spec file.
115
116* Mon Jan 15 2007 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.7-8.fc7
117- Update to latest code (t0_4_7_head2)
118
119* Wed Dec 13 2006 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.7-7.fc7
120- Update to latest code (t0_4_7_head1)
121
122* Thu Sep  7 2006 Peter Jones <pjones@redhat.com> - 0.4.7-5
123- Fix kpartx to handle with drives >2TB correctly.
124
125* Thu Aug 31 2006 Peter Jones <pjones@redhat.com> - 0.4.7-4.1
126- Split kpartx out into its own package so dmraid can use it without
127  installing multipathd
128- Fix a segfault in kpartx
129
130* Mon Jul 17 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-4.0
131- Updated to latest source. Fixes bug in default multipath.conf
132
133* Wed Jul 12 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-3.1
134- Added ncurses-devel to BuildRequires
135
136* Wed Jul 12 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-3.0
137- Updated to latest source. deals with change in libsysfs API
138
139* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.4.7-2.2.1
140- rebuild
141
142* Mon Jul 10 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.2
143- fix tagging issue.
144
145* Mon Jul 10 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.1
146- changed BuildRequires from sysfsutils-devel to libsysfs-devel
147
148* Wed Jun 28 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-2.0
149- Updated to latest upstream source, fixes kpartx udev rule issue
150
151* Mon Jun 06 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.7-1.0
152- Updated to Christophe's latest source
153
154* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 0.4.5-16.0
155- Newer upstream source (t0_4_5_post59).
156
157* Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 0.4.5-12.3
158- BuildRequires: libsepol-devel, readline-devel
159
160* Mon Feb 27 2006 Benjamin Marzinski <bmarzins@redhat.com> 0.4.5-12.2
161- Prereq: chkconfig
162
163* Mon Feb 20 2006 Karsten Hopp <karsten@redhat.de> 0.4.5-12.1
164- BuildRequires: libselinux-devel
165
166* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.4.5-12.0.1
167- bump again for double-long bug on ppc(64)
168
169* Tue Feb 07 2006 Benjamin Marzinski <bmarzins@redhat.com> -0.4.5-12.0
170- Updated to latest upstream source (t0_4_5_post56)
171
172* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.4.5-9.1.1
173- rebuilt for new gcc4.1 snapshot and glibc changes
174
175* Mon Dec 19 2005 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.5-9.1
176- added patch for fedora changes
177
178* Fri Dec 16 2005 Benjamin Marzinski <bmarzins@redhat.com> - 0.4.5-9.0
179- Updated to latest upstream source (t)_4_5_post52)
180
181* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
182- rebuilt
183
184* Sun Dec  4 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.6
185- rebuild for newer libs
186
187* Tue Nov 15 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.5
188- unsplit kpartx.  parted knows how to do this now, so we don't
189  need this in a separate package.
190
191* Tue Nov 15 2005 Peter Jones <pjones@redhat.com> - 0.4.4-2.4
192- split kpartx out into its own package
193
194* Fri May 06 2005 Bill Nottingham <notting@redhat.com> - 0.4.4-2.3
195- Fix last fix.
196
197* Thu May 05 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.2
198- Fix last fix.
199
200* Wed May 04 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.1
201- By default, disable the multipathd service.
202
203* Tue Apr 19 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-2.0
204- Fix core dump from last build.
205
206* Tue Apr 19 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-1.0
207- Move cache file into /var/cache/multipath.
208
209* Fri Apr 08 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-0.pre8.1
210- Remove pp_balance_units.
211
212* Mon Apr 04 2005 Alasdair Kergon <agk@redhat.com> - 0.4.4-0.pre8.0
213- Incorporate numerous upstream fixes.
214- Update init script to distribution standards.
215
216* Tue Mar 01 2005 Alasdair Kergon <agk@redhat.com> - 0.4.2-1.0
217- Initial import based on Christophe Varoqui's spec file.
Note: See TracBrowser for help on using the repository browser.