source: projects/specs/trunk/d/deluge/deluge-vl.spec @ 943

Revision 943, 22.5 KB checked in by kudoh, 14 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           deluge
5Version:        1.2.3
6Release:        1%{?_dist_release}
7Summary:        A GTK+ BitTorrent client with support for DHT, UPnP, and PEX
8Summary(ja):    DHT・UPnP・PEX をサポートした GTK+ BitTorrent クライアント
9Group:          Applications/Internet
10License:        GPLv3 with exceptions
11URL:            http://deluge-torrent.org/           
12
13Source0:        http://download.deluge-torrent.org/source/%{version}/%{name}-%{version}.tar.bz2
14
15## The scalable icon needs to be installed to the proper place.
16Patch0:         %{name}-scalable-icon-dir.diff
17Patch1:         010_new_release_check.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20BuildArch:      noarch
21
22BuildRequires:  desktop-file-utils
23BuildRequires:  python-devel
24BuildRequires:  python-setuptools
25## The build script checks for the libtorrent module and skips compiling the
26## in-tarball one if this is found.
27BuildRequires:  libtorrent-rasterbar-python >= 0.14.9
28
29Requires:       gnome-python
30## Required for the proper ownership of icon dirs.
31Requires:       hicolor-icon-theme
32Requires:       notify-python
33Requires:       pygtk2-libglade
34Requires:       pyOpenSSL
35Requires:       python-chardet
36Requires:       python-mako
37Requires:       python-setuptools
38Requires:       python-simplejson
39Requires:       python-twisted
40Requires:       pyxdg
41Requires:       libtorrent-rasterbar-python >= 0.14.9
42
43%description
44Deluge is a new BitTorrent client, created using Python and GTK+. It is
45intended to bring a native, full-featured client to Linux GTK+ desktop
46environments such as GNOME and Xfce.
47
48%description -l ja
49Deluge は Python と GTK+ を用いて作成された新しい BitTorrent クライアントです。
50GNOME や Xfce のような Linux の GTK+ デスクトップ環境にネイティブかつフル機能の
51クライアントを提供することを意図しています。
52
53
54%package        flags
55Summary:        Country flags for peer location display in Deluge
56Group:          Applications/Internet
57License:        GPLv3
58Requires:       %{name} = %{version}-%{release}
59
60%description    flags
61The %{name}-flags package contains optional country flags which are used to
62display the location of peers in the "Peers" information tab.
63
64
65%prep
66%setup -qn "%{name}-%{version}"
67%patch0 -p0 -b .fix-scalable-icon-dir
68%patch1 -p1
69
70
71%build
72CFLAGS="%{optflags}" %{__python} setup.py build
73
74
75%install
76rm -rf %{buildroot}
77%{__python} setup.py install -O1 --skip-build --root %{buildroot}
78desktop-file-install --vendor vine                      \
79        --dir %{buildroot}%{_datadir}/applications      \
80        --copy-name-to-generic-name                     \
81        --add-mime-type=application/x-bittorrent        \
82        --delete-original                               \
83        --remove-category=Application                   \
84        %{buildroot}%{_datadir}/applications/%{name}.desktop
85
86## NOTE: The lang files should REEEAALLLY be in a standard place such as
87##       /usr/share/locale or similar. It'd make things so much nicer for
88##       the packaging. :O
89## A bit of sed magic to mark the translation files with %%lang, taken from
90## find-lang.sh (part of the rpm-build package) and tweaked somewhat. We
91## cannot (unfortunately) call find-lang directly since it's not on a
92## "$PREFIX/share/locale/"-ish directory tree.
93pushd %{buildroot}
94        find -type f -o -type l \
95                | sed '
96                        s:%{buildroot}%{python_sitelib}::
97                        s:^\.::
98                        s:\(.*/deluge/i18n/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:
99                        s:^\([^%].*\)::
100                        s:%lang(C) ::
101                        /^$/d' \
102        > %{name}.filelist
103
104## We've got the .mo files now; but we need the rest of the files in those
105## dirs. We can't just glob in the %%files, as that would add duplicate
106## entries for the .mo files which we've already marked with appropriate
107## %%lang-fu.
108        find ./%{python_sitelib}/%{name} -not -iname '%{name}.mo' -type f \
109                | grep -v 'pixmaps/flags' | sed 's:^\./::' >> %{name}.filelist
110        find ./%{python_sitelib}/%{name} -type d  | grep -v 'pixmaps/flags' \
111                | sed 's:^\./:%%dir :' >> %{name}.filelist
112
113## Now we move that list back to our sources, so that '%%files -f' can find it
114## properly.
115popd && mv %{buildroot}/%{name}.filelist .
116
117
118%clean
119rm -rf %{buildroot}
120
121
122%files -f %{name}.filelist
123%defattr(-,root,root,-)
124%doc ChangeLog LICENSE README
125%{python_sitelib}/%{name}-%{version}-py?.?.egg-info/
126%{_bindir}/%{name}
127%{_bindir}/%{name}-*
128%{_bindir}/%{name}d
129%{_datadir}/applications/vine-%{name}.desktop
130%{_datadir}/pixmaps/%{name}.*
131%{_datadir}/icons/hicolor/*/apps/%{name}.*
132%{_mandir}/man?/%{name}*
133
134%files  flags
135%defattr(-,root,root,-)
136%doc LICENSE
137%{python_sitelib}/%{name}/data/pixmaps/flags/
138
139
140%post
141update-desktop-database &>/dev/null ||:
142touch --no-create %{_datadir}/icons/hicolor
143if [ -x %{_bindir}/gtk-update-icon-cache ]; then
144        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
145fi
146
147
148%postun
149update-desktop-database &> /dev/null ||:
150touch --no-create %{_datadir}/icons/hicolor
151if [ -x %{_bindir}/gtk-update-icon-cache ]; then
152        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
153fi
154
155
156%changelog
157* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.3-1
158- new upstream release
159
160* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.1-1
161- new upstream release
162- added Requires: python-mako, notify-python, gnome-python
163- removed Requires: /bin/sh, dbus-python, dbus-x11
164- changed BuildRequires and Requires: libtorrent-rasterbar-python >= 0.14.9
165- applied new naming policy to spec
166
167* Tue Feb 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
168- rebuilt with python-2.6.4
169
170* Tue Jan 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
171- new upstream release
172- added Patch1 from Debian to disable update
173- added Requires: python-twisted, python-simplejson
174
175* Mon Sep 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.9-1
176- initial build for VineSeed
177
178* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
179- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
180
181* Wed Jul 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-2
182- Fixed rb_libtorrent-python dependency, so as not to use the
183  %%min_rblibtorrent_ver macro any more (#510264).
184
185* Wed Jun 17 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-1
186- Update to new upstream bug-fix release (1.1.9).
187- Do not hard-code minimum rb_libtorrent version. (We're only building against
188  the system rb_libtorrent for Fedora 11+, which already has the necessary
189  version.)
190
191* Wed May 27 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.8-1
192- Update to new upstream release (1.1.8) for bug-fixes and some translation
193  updates. Adds dependency on chardet for fixing lots of bugs with torrents
194  which are not encoded as UTF-8.
195- Add back the flags, in an optional -flags subpackage as per the new Flags
196  policy (Package_Maintainers_Flags_Policy on the wiki).
197- Add LICENSE and README to installed documentation.
198
199* Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-2
200- Rebuild for the Boost 1.39.0 update.
201
202* Sat May 02 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-1
203- Update to new upstream bug-fix release (1.1.7).
204
205* Mon Apr 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.6-1
206- Update to new upstream bug-fix release (1.1.6)
207- Fix GPL version, add OpenSSL exception to License.
208- Remove libtool, openssl-devel, and boost-devel BuildRequires (were only
209  necessary when building the in-tarball libtorrent copy).
210
211* Mon Mar 16 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.5-1
212- Update to new upstream bug-fix release (1.1.5)
213- Remove FIXME comment about parallel-compilation. We're not building the
214  in-tarball libtorrent copy anymore, so no compilation (other than the python
215  bytecode) happens and we no longer need to worry about this.
216
217* Tue Mar 10 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-2
218- Fix the installed location of the scalable (SVG) icon (#483443).
219  + scalable-icon-dir.diff
220
221* Mon Mar 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-1
222- Update to new upstream bug-fix release (1.1.4)
223
224* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
225- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
226
227* Sun Feb 15 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.3-1
228- Update to new upstream bug-fix release (1.1.3)
229
230* Sun Feb 01 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-2
231- Fix scalable icon directory ownership (#483443).
232
233* Sat Jan 31 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-1
234- Update to new upstream bug-fix release (1.1.2)
235
236* Sun Jan 25 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.1-1
237- Update to new upstream bug-fix release (1.1.1)
238
239* Sun Jan 11 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-1
240- Update to new upstream release (1.1.0 Final - yay!)
241- Drop the get_tracker_host patch (fixed upstream):
242  - fix-get_tracker-host-if-no-tracker.patch
243 
244* Fri Jan 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.4.rc3
245- Do not package the country flags data.
246- Resolves: #479265 (country flags should not be used in Deluge)
247
248* Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.3.rc3
249- Add patch from upstream SVN to fix an error where torrents are not shown (or
250  possibly shown in "Error" states) due to a bad inet_aton call:
251  + fix-get_tracker-host-if-no-tracker.patch
252- Resolves: #479097 (No torrent shown in menu); thanks to Mamoru Tasaka for
253  the bug report.
254- Fix day of previous %%changelog entry.
255
256* Tue Jan 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.2.rc3
257- Update to new upstream release candidate (1.1.0 RC3)
258- Build against the system rb_libtorrent instead of using the in-tarball copy
259  (requires rb_libtorrent 0.14+), and adjust dependencies accordingly. Drop
260  the hacked setup.py script formerly used to enable this (fixed upstream):
261  - fixed-setup.py
262- Make it a noarch package now that it's just python scripts and related
263  data files (translations, images, etc.)
264
265* Mon Dec 29 2008 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.1.rc2
266- Update to new upstream release candidate (1.1.0 RC2)
267
268* Thu Dec 18 2008 Petr Machata <pmachata@redhat.com> - 1.0.7-2
269- Rebuild for new boost.
270
271* Tue Dec 16 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.7-1
272- Update to new upstream bug-fix release (1.0.7)
273- Remove CC-BY-SA license (the Tango WebUI images have been replaced by upstream).
274
275* Mon Dec 01 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.6-1
276- Update to new upstream release (1.0.6)
277- Adds Tango images to the WebUI data (CC-BY-SA) and some man pages.
278- Properly mark translation files with %%lang.
279
280* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-3
281- Fix locations for Python 2.6
282
283* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-2
284- Rebuild for Python 2.6
285
286* Thu Nov 13 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.5-1
287- Update to new upstream release (1.0.5)
288
289* Fri Oct 31 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.4-1
290- Update to new upstream release (1.0.4).
291
292* Fri Oct 24 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.3-1
293- Update to new upstream release (1.0.3)
294
295* Sun Oct 12 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.2-1
296- Update to new upstream release (1.0.2)
297- Drop multithreaded boost compilation patch (fixed upstream, again).
298  - mt-boost-fix.patch
299 
300* Sat Sep 27 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.0-1
301- Update to new upstream release (1.0.0 Final)
302- Apply patch from Mamoru Tasaka to build against the multi-threaded Boost
303  libraries once more:
304  + mt-boost-fix.patch
305- Resolves: #464151 (About 1.0.0 build failure)
306
307* Tue Sep 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.09-1
308- Update to new upstream release candidate (1.0.0 RC9)
309- Drop mt-boost patch (fixed upstream):
310  - use-mt-boost.patch
311
312* Sun Sep 07 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.08-1
313- Update to new upstream release candidate (1.0.0 RC8)
314- Drop state_upgrade script from the documentation. (This is now handled
315  automatically.)
316- Fix version in previous %%changelog entry.
317
318* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.07-1
319- Update to new upstream release candidate (1.0.0 RC7)
320- Drop desktop file icon name hack (fixed upstream).
321
322* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.06-1
323- Update to new upstream release candidate (1.0.0 RC6)
324- Drop desktop file icon name hack (fixed upstream).
325
326* Fri Aug 01 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.04-1
327- Update to new upstream release candidate (1.0.0 RC4)
328
329* Wed Jul 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-2
330- Add setuptools runtime dependency, to fix "No module named pkg_resources"
331  error messages.
332
333* Mon Jul 21 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-1
334- Update to new upstream release candidate (1.0.0 RC3)
335- Re-add the blocklist plugin, at upstream's suggestion. (The rewrite is
336  complete.)
337
338* Tue Jul 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.02-1
339- Update to new upstream release candidate (1.0.0 RC2)
340- Force building against the multithreaded Boost libs.
341  + use-mt-boost.patch
342- Remove python-libtorrent Obsoletes. (It's been dead for 3 releases now; and
343  is just clutter.)
344- Remove the blocklist plugin, at upstream's recommendation.
345
346* Tue Jun 24 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.3-1
347- Update to new upstream release (0.5.9.3)
348
349* Fri May 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.1-1
350- Update to new upstream release (0.5.9.1)
351
352* Fri May 02 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.0-1
353- Update to new upstream release (0.5.9.0)
354- Drop upstreamed default-preferences patch for disabling new version
355  notifications:
356  - default-prefs-no-release-notifications.patch
357
358* Tue Apr 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.9-1
359- Update to new upstream release (0.5.8.9)
360
361* Wed Mar 26 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.7-1
362- Update to new upstream release (0.5.8.7)
363
364* Mon Mar 17 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.6-1
365- Update to new upstream release (0.5.8.6)
366
367* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.5-1
368- Update to new upstream release (0.5.8.5)
369
370* Sat Feb 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.4-1
371- Update to new upstream release (0.5.8.4)
372- Rebuild for GCC 4.3
373
374* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.3-1
375- Update to new upstream security fix release (0.5.8.3), which includes a fix
376  for a potential remotely-exploitable stack overflow with a malformed
377  bencoded message.
378
379* Sat Jan 19 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.1-1
380- Update to new upstream bugfix release (0.5.8.1)
381
382* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8-3
383- Add runtime dependency on dbus-x11 for the dbus-launch utility. Fixes bug
384  428106 (Missing BR dbus-x11).
385- Bump release to 3 to maintain a proper F8->F9+ upgrade path.
386
387* Mon Dec 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.8-1
388- Update to new upstream release (0.5.8)
389- Merge Mamoru Tasaka's no-release-notification patch into the default-prefs
390  patch.
391 
392* Sat Dec 29 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.98-1
393- Update to new upstream release candidate (0.5.8 RC2)
394
395* Mon Dec 24 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.95-1
396- Update to new upstream release candidate (0.5.8 RC1)
397- Completely suppress updates notification (bug 299601, 426642)
398
399* Sun Dec 09 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-2
400- Add missing icon cache %%post and %%postun scriptlets.
401- Add missing egg-info to the %%files list.
402
403* Fri Dec 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-1
404- Update to new upstream bug-fix release (0.5.7.1).
405- Sort %%files list (aesthetic-only change).
406
407* Wed Dec 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-3
408- Fix previous %%changelog Version.
409- Cleanup the installed .desktop file. Fixes bug 413101 (deluge fails to build
410  in rawhide  bad .desktop file.)
411
412* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.7-2
413- Rebuild for deps
414
415* Tue Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-1
416- Update to new upstream release (0.5.7)
417
418* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.96-1
419- Update to new upstream release candidate (0.5.7 RC2)
420- Drop plugin error patch (fixed upstream):
421  - plugin-not-found-OK.patch
422
423* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.95-1
424- Update to new upstream release candidate (0.5.7 RC)
425- Update Source0 url
426- Add upstream patch to prevent dying if plugin in prefs.state is not found on
427  the filesystem:
428  + plugin-not-found-OK.patch
429
430* Wed Oct 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.2-1
431- Update to new upstream bug-fix release (0.5.6.2)
432
433* Tue Oct 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.1-1
434- Update to new upstream bug-fix release (0.5.6.1)
435- Drop use-mt-boost build script patch (fixed upstream):
436  - use-mt-boost.patch
437
438* Sat Oct 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6-1
439- Update to new upstream release (0.5.6)
440
441* Wed Oct 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5.95-1
442- Update to new upstream release candidate (0.5.6 RC1)
443
444* Thu Sep 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-2
445- Fix release on previous %%changelog entry.
446- Disable the version update notifications by default:
447  + default-prefs-no-release-notifications.patch
448  (Resolves bug 299601: Deluge alerts of new versions)
449
450* Wed Sep 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-1
451- Update to new upstream release (0.5.5)
452
453* Mon Sep 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1.95-1
454- Update to new upstream release candidate (0.5.5 RC1)
455
456* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1-1
457- Update to new upstream release (0.5.4.1)
458- Build with new binutils to gain BuildID debugging goodness.
459
460* Mon Aug 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4-1
461- Update to new upstream release (0.5.4)
462
463* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-2
464- Update License tag (GPLv2+).
465- Rebuild against new Boost libraries, adding a patch to build against the
466  multi-threaded ("*-mt") libraries:
467  + use-mt-boost.patch
468
469* Wed Jul 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-1
470- Update to new upstream release candidate (0.5.3)
471- Drop %%ifarch invocations for 64-bit builds. The internal setup script now
472  properly determines this and adds the AMD64 compiler definition if necessary.
473
474* Fri Jul 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2.90-1
475- Update to new upstream release candidate (0.5.3 RC1)
476- Drop stale persistence fix patch (applied upstream):
477  - fix-persistence-upgrade-rhbz_247927.patch
478
479* Wed Jul 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-2
480- Add patch to fix the existence of stale persistence files by automatically
481  updating the deluge.deluge module name to deluge.core, or removing them if
482  empty (bug 247927):
483  + fix-persistence-upgrade-rhbz_247927.patch
484
485* Sun Jul 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-1
486- Update to new upstream release (0.5.2)
487- Update Summary and %%description to reflect new µTorrent-compatible Peer
488  Exchange ("PEX") functionality.
489
490* Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0.90.2-2
491- Update to new upstream release (0.5.1 Beta 2)
492
493* Sun Apr 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-2
494- Make Deluge the upgrade path of the now-orphaned python-libtorrent package.
495 
496* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-1
497- Update to new upstream release (0.5.0).
498
499* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.2-1
500- Update to new upstream release (0.5 RC2).
501- Drop IndexError exception-handling fix (applied upstream):
502  - delugegtk.py-fix-IndexError-exception-handling.patch
503- Use the system libtool instead of the one from the sources to ensure
504  that no unnecessary RPATH hacks are added to the final build.
505
506* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-3
507- Add a patch (submitted upstream) to properly catch a thrown IndexError in
508  state message updates. This should resolve the bug wherein the UI stops
509  updating its details and torrent listing.
510  + delugegtk.py-fix-IndexError-exception-handling.patch
511 
512* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-2
513- Drop unneeded 64bit-python_long patch; as it seems to cause more trouble than
514  it's worth. Instead, pass -DAMD64 as a compiler flag on 64-bit arches.
515  - 64bit-python_long patch
516  (This should fix the bug where, even though torrents are active, they are not
517  shown in the GtkTreeView listing.)
518
519* Tue Mar 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-1
520- Update to new upstream release (0.5 RC1).
521- Use rewritten setup.py instead of patching it so much, since it's easier to
522  maintain across version upgrades and whatnot:
523  + fixed-setup.py
524- Remove the setup.py patches (no longer needed, since I'm packaging my own):
525  - setup.py-dont-store-the-install-dir.patch
526  - setup.py-build-against-system-libtorrent.patch
527
528* Fri Mar 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.3-1
529- Update to new upstream release (0.5 Beta 3).
530- Add patch to fix storing of installation directory:
531  + setup.py-dont-store-the-install-dir.patch
532    (to be applied after setup.py-build-against-system-libtorrent.patch)
533
534* Sun Feb 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-2
535- Add patch to fix 64-bit python_long type.
536  +  64bit-python_long.patch
537
538* Sat Feb 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-1
539- Update to new upstream release (0.5 Beta 2)
540- Add patch to force building against system copy of rb_libtorrent:
541  + setup.py-build-against-system-libtorrent.patch
542- Remove python-libtorrent and a few other dependencies that are no longer
543  used.
544
545* Fri Feb 23 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-6
546- Fix Source0 URL.
547
548* Wed Feb 21 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-5
549- Make notify-python dependency conditional (FC6+ only)
550- Strip the unneeded shebang lines from the plugin scripts, since they are not
551  meant to be directly executed.
552
553* Wed Feb 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-4
554- Update .desktop file: Icon should not have the "-256" size suffix.
555- Add Requires: notify-python
556- Remove strict dependency on python 2.3+, since we're targetting FC5+
557  only, which has 2.4+.
558
559* Wed Jan 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-3
560- Use install instead of the cp/find/chmod fiasco of earlier releases for
561  clarity and proper permissions setting.
562- Be more consistent about use of %%{name} and other macros in file naming as
563  well as whitespace between sections.
564
565* Sun Jan 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-2
566- Bump python-libtorrent dependency to 0.3.0-4, which contains a fix for
567  64-bit systems.
568
569* Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-1
570- Initial packaging for Fedora Extras.
Note: See TracBrowser for help on using the repository browser.