source: projects/specs/trunk/d/deluge/deluge-vl.spec @ 1832

Revision 1832, 22.5 KB checked in by kudoh, 14 years ago (diff)
Line 
1%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
3
4Name:           deluge
5Version:        1.3.0
6Release:        1%{?_dist_release}
7Summary:        A GTK+ BitTorrent client with support for DHT, UPnP, and PEX
8Summary(ja):    DHT・UPnP・PEX をサポートした GTK+ BitTorrent クライアント
9Group:          Applications/Internet
10License:        GPLv3 with exceptions
11URL:            http://deluge-torrent.org/
12
13Source0:        http://download.deluge-torrent.org/source/%{version}/%{name}-%{version}.tar.bz2
14
15## The scalable icon needs to be installed to the proper place.
16Patch0:         %{name}-scalable-icon-dir.diff
17Patch1:         010_new_release_check.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20BuildArch:      noarch
21
22BuildRequires:  desktop-file-utils
23BuildRequires:  python-devel
24BuildRequires:  python-setuptools
25## The build script checks for the libtorrent module and skips compiling the
26## in-tarball one if this is found.
27BuildRequires:  libtorrent-rasterbar-python >= 0.14.9
28
29Requires:       gnome-python
30## Required for the proper ownership of icon dirs.
31Requires:       hicolor-icon-theme
32Requires:       notify-python
33Requires:       pygtk2-libglade
34Requires:       pyOpenSSL
35Requires:       python-chardet
36Requires:       python-mako
37Requires:       python-setuptools
38Requires:       python-simplejson
39Requires:       python-twisted
40Requires:       pyxdg
41Requires:       libtorrent-rasterbar-python >= 0.14.9
42
43%description
44Deluge is a new BitTorrent client, created using Python and GTK+. It is
45intended to bring a native, full-featured client to Linux GTK+ desktop
46environments such as GNOME and Xfce.
47
48%description -l ja
49Deluge は Python と GTK+ を用いて作成された新しい BitTorrent クライアントです。
50GNOME や Xfce のような Linux の GTK+ デスクトップ環境にネイティブかつフル機能の
51クライアントを提供することを意図しています。
52
53
54%package        flags
55Summary:        Country flags for peer location display in Deluge
56Group:          Applications/Internet
57License:        GPLv3
58Requires:       %{name} = %{version}-%{release}
59
60%description    flags
61The %{name}-flags package contains optional country flags which are used to
62display the location of peers in the "Peers" information tab.
63
64
65%prep
66%setup -qn "%{name}-%{version}"
67%patch0 -p0 -b .fix-scalable-icon-dir
68%patch1 -p1
69
70
71%build
72CFLAGS="%{optflags}" %{__python} setup.py build
73
74
75%install
76rm -rf %{buildroot}
77%{__python} setup.py install -O1 --skip-build --root %{buildroot}
78desktop-file-install --vendor vine                      \
79        --dir %{buildroot}%{_datadir}/applications      \
80        --copy-name-to-generic-name                     \
81        --add-mime-type=application/x-bittorrent        \
82        --delete-original                               \
83        --remove-category=Application                   \
84        %{buildroot}%{_datadir}/applications/%{name}.desktop
85
86## NOTE: The lang files should REEEAALLLY be in a standard place such as
87##       /usr/share/locale or similar. It'd make things so much nicer for
88##       the packaging. :O
89## A bit of sed magic to mark the translation files with %%lang, taken from
90## find-lang.sh (part of the rpm-build package) and tweaked somewhat. We
91## cannot (unfortunately) call find-lang directly since it's not on a
92## "$PREFIX/share/locale/"-ish directory tree.
93pushd %{buildroot}
94        find -type f -o -type l \
95                | sed '
96                        s:%{buildroot}%{python_sitelib}::
97                        s:^\.::
98                        s:\(.*/deluge/i18n/\)\([^/_]\+\)\(.*\.mo$\):%lang(\2) \1\2\3:
99                        s:^\([^%].*\)::
100                        s:%lang(C) ::
101                        /^$/d' \
102        > %{name}.filelist
103
104## We've got the .mo files now; but we need the rest of the files in those
105## dirs. We can't just glob in the %%files, as that would add duplicate
106## entries for the .mo files which we've already marked with appropriate
107## %%lang-fu.
108        find ./%{python_sitelib}/%{name} -not -iname '%{name}.mo' -type f \
109                | grep -v 'pixmaps/flags' | sed -e 's:^\./::' -e 's| |*|g' >> %{name}.filelist
110        find ./%{python_sitelib}/%{name} -type d  | grep -v 'pixmaps/flags' \
111                | sed 's:^\./:%%dir :' >> %{name}.filelist
112
113## Now we move that list back to our sources, so that '%%files -f' can find it
114## properly.
115popd && mv %{buildroot}/%{name}.filelist .
116
117
118%clean
119rm -rf %{buildroot}
120
121
122%files -f %{name}
123%defattr(-,root,root,-)
124%doc ChangeLog LICENSE README
125%{python_sitelib}/
126%{_bindir}/%{name}
127%{_bindir}/%{name}-*
128%{_bindir}/%{name}d
129%{_datadir}/applications/vine-%{name}.desktop
130%{_datadir}/pixmaps/%{name}.*
131%{_datadir}/icons/hicolor/*/apps/%{name}.*
132%{_mandir}/man?/%{name}*
133
134%files  flags
135%defattr(-,root,root,-)
136%doc LICENSE
137%{python_sitelib}/%{name}/data/pixmaps/flags/
138
139
140%post
141update-desktop-database &>/dev/null ||:
142touch --no-create %{_datadir}/icons/hicolor
143if [ -x %{_bindir}/gtk-update-icon-cache ]; then
144        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
145fi
146
147
148%postun
149update-desktop-database &> /dev/null ||:
150touch --no-create %{_datadir}/icons/hicolor
151if [ -x %{_bindir}/gtk-update-icon-cache ]; then
152        %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
153fi
154
155
156%changelog
157* Sun Sep 19 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.3.0-1
158- new upstream release
159
160* Tue May 4 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.3-1
161- new upstream release
162
163* Thu Mar 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.1-1
164- new upstream release
165- added Requires: python-mako, notify-python, gnome-python
166- removed Requires: /bin/sh, dbus-python, dbus-x11
167- changed BuildRequires and Requires: libtorrent-rasterbar-python >= 0.14.9
168- applied new naming policy to spec
169
170* Tue Feb 9 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-2
171- rebuilt with python-2.6.4
172
173* Tue Jan 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.0-1
174- new upstream release
175- added Patch1 from Debian to disable update
176- added Requires: python-twisted, python-simplejson
177
178* Mon Sep 21 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.1.9-1
179- initial build for VineSeed
180
181* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.9-3
182- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
183
184* Wed Jul 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-2
185- Fixed rb_libtorrent-python dependency, so as not to use the
186  %%min_rblibtorrent_ver macro any more (#510264).
187
188* Wed Jun 17 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.9-1
189- Update to new upstream bug-fix release (1.1.9).
190- Do not hard-code minimum rb_libtorrent version. (We're only building against
191  the system rb_libtorrent for Fedora 11+, which already has the necessary
192  version.)
193
194* Wed May 27 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.8-1
195- Update to new upstream release (1.1.8) for bug-fixes and some translation
196  updates. Adds dependency on chardet for fixing lots of bugs with torrents
197  which are not encoded as UTF-8.
198- Add back the flags, in an optional -flags subpackage as per the new Flags
199  policy (Package_Maintainers_Flags_Policy on the wiki).
200- Add LICENSE and README to installed documentation.
201
202* Fri May 08 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-2
203- Rebuild for the Boost 1.39.0 update.
204
205* Sat May 02 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.7-1
206- Update to new upstream bug-fix release (1.1.7).
207
208* Mon Apr 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.6-1
209- Update to new upstream bug-fix release (1.1.6)
210- Fix GPL version, add OpenSSL exception to License.
211- Remove libtool, openssl-devel, and boost-devel BuildRequires (were only
212  necessary when building the in-tarball libtorrent copy).
213
214* Mon Mar 16 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.5-1
215- Update to new upstream bug-fix release (1.1.5)
216- Remove FIXME comment about parallel-compilation. We're not building the
217  in-tarball libtorrent copy anymore, so no compilation (other than the python
218  bytecode) happens and we no longer need to worry about this.
219
220* Tue Mar 10 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-2
221- Fix the installed location of the scalable (SVG) icon (#483443).
222  + scalable-icon-dir.diff
223
224* Mon Mar 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.4-1
225- Update to new upstream bug-fix release (1.1.4)
226
227* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.3-2
228- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
229
230* Sun Feb 15 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.3-1
231- Update to new upstream bug-fix release (1.1.3)
232
233* Sun Feb 01 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-2
234- Fix scalable icon directory ownership (#483443).
235
236* Sat Jan 31 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.2-1
237- Update to new upstream bug-fix release (1.1.2)
238
239* Sun Jan 25 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.1-1
240- Update to new upstream bug-fix release (1.1.1)
241
242* Sun Jan 11 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-1
243- Update to new upstream release (1.1.0 Final - yay!)
244- Drop the get_tracker_host patch (fixed upstream):
245  - fix-get_tracker-host-if-no-tracker.patch
246 
247* Fri Jan 09 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.4.rc3
248- Do not package the country flags data.
249- Resolves: #479265 (country flags should not be used in Deluge)
250
251* Wed Jan 07 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.3.rc3
252- Add patch from upstream SVN to fix an error where torrents are not shown (or
253  possibly shown in "Error" states) due to a bad inet_aton call:
254  + fix-get_tracker-host-if-no-tracker.patch
255- Resolves: #479097 (No torrent shown in menu); thanks to Mamoru Tasaka for
256  the bug report.
257- Fix day of previous %%changelog entry.
258
259* Tue Jan 06 2009 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.2.rc3
260- Update to new upstream release candidate (1.1.0 RC3)
261- Build against the system rb_libtorrent instead of using the in-tarball copy
262  (requires rb_libtorrent 0.14+), and adjust dependencies accordingly. Drop
263  the hacked setup.py script formerly used to enable this (fixed upstream):
264  - fixed-setup.py
265- Make it a noarch package now that it's just python scripts and related
266  data files (translations, images, etc.)
267
268* Mon Dec 29 2008 Peter Gordon <peter@thecodergeek.com> - 1.1.0-0.1.rc2
269- Update to new upstream release candidate (1.1.0 RC2)
270
271* Thu Dec 18 2008 Petr Machata <pmachata@redhat.com> - 1.0.7-2
272- Rebuild for new boost.
273
274* Tue Dec 16 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.7-1
275- Update to new upstream bug-fix release (1.0.7)
276- Remove CC-BY-SA license (the Tango WebUI images have been replaced by upstream).
277
278* Mon Dec 01 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.6-1
279- Update to new upstream release (1.0.6)
280- Adds Tango images to the WebUI data (CC-BY-SA) and some man pages.
281- Properly mark translation files with %%lang.
282
283* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-3
284- Fix locations for Python 2.6
285
286* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.0.5-2
287- Rebuild for Python 2.6
288
289* Thu Nov 13 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.5-1
290- Update to new upstream release (1.0.5)
291
292* Fri Oct 31 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.4-1
293- Update to new upstream release (1.0.4).
294
295* Fri Oct 24 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.3-1
296- Update to new upstream release (1.0.3)
297
298* Sun Oct 12 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.2-1
299- Update to new upstream release (1.0.2)
300- Drop multithreaded boost compilation patch (fixed upstream, again).
301  - mt-boost-fix.patch
302 
303* Sat Sep 27 2008 Peter Gordon <peter@thecodergeek.com> - 1.0.0-1
304- Update to new upstream release (1.0.0 Final)
305- Apply patch from Mamoru Tasaka to build against the multi-threaded Boost
306  libraries once more:
307  + mt-boost-fix.patch
308- Resolves: #464151 (About 1.0.0 build failure)
309
310* Tue Sep 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.09-1
311- Update to new upstream release candidate (1.0.0 RC9)
312- Drop mt-boost patch (fixed upstream):
313  - use-mt-boost.patch
314
315* Sun Sep 07 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.08-1
316- Update to new upstream release candidate (1.0.0 RC8)
317- Drop state_upgrade script from the documentation. (This is now handled
318  automatically.)
319- Fix version in previous %%changelog entry.
320
321* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.07-1
322- Update to new upstream release candidate (1.0.0 RC7)
323- Drop desktop file icon name hack (fixed upstream).
324
325* Wed Aug 13 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.06-1
326- Update to new upstream release candidate (1.0.0 RC6)
327- Drop desktop file icon name hack (fixed upstream).
328
329* Fri Aug 01 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.04-1
330- Update to new upstream release candidate (1.0.0 RC4)
331
332* Wed Jul 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-2
333- Add setuptools runtime dependency, to fix "No module named pkg_resources"
334  error messages.
335
336* Mon Jul 21 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.03-1
337- Update to new upstream release candidate (1.0.0 RC3)
338- Re-add the blocklist plugin, at upstream's suggestion. (The rewrite is
339  complete.)
340
341* Tue Jul 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.9.02-1
342- Update to new upstream release candidate (1.0.0 RC2)
343- Force building against the multithreaded Boost libs.
344  + use-mt-boost.patch
345- Remove python-libtorrent Obsoletes. (It's been dead for 3 releases now; and
346  is just clutter.)
347- Remove the blocklist plugin, at upstream's recommendation.
348
349* Tue Jun 24 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.3-1
350- Update to new upstream release (0.5.9.3)
351
352* Fri May 23 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.1-1
353- Update to new upstream release (0.5.9.1)
354
355* Fri May 02 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.9.0-1
356- Update to new upstream release (0.5.9.0)
357- Drop upstreamed default-preferences patch for disabling new version
358  notifications:
359  - default-prefs-no-release-notifications.patch
360
361* Tue Apr 15 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.9-1
362- Update to new upstream release (0.5.8.9)
363
364* Wed Mar 26 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.7-1
365- Update to new upstream release (0.5.8.7)
366
367* Mon Mar 17 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.6-1
368- Update to new upstream release (0.5.8.6)
369
370* Fri Feb 29 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.5-1
371- Update to new upstream release (0.5.8.5)
372
373* Sat Feb 16 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.4-1
374- Update to new upstream release (0.5.8.4)
375- Rebuild for GCC 4.3
376
377* Mon Jan 28 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.3-1
378- Update to new upstream security fix release (0.5.8.3), which includes a fix
379  for a potential remotely-exploitable stack overflow with a malformed
380  bencoded message.
381
382* Sat Jan 19 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8.1-1
383- Update to new upstream bugfix release (0.5.8.1)
384
385* Wed Jan 09 2008 Peter Gordon <peter@thecodergeek.com> - 0.5.8-3
386- Add runtime dependency on dbus-x11 for the dbus-launch utility. Fixes bug
387  428106 (Missing BR dbus-x11).
388- Bump release to 3 to maintain a proper F8->F9+ upgrade path.
389
390* Mon Dec 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.8-1
391- Update to new upstream release (0.5.8)
392- Merge Mamoru Tasaka's no-release-notification patch into the default-prefs
393  patch.
394 
395* Sat Dec 29 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.98-1
396- Update to new upstream release candidate (0.5.8 RC2)
397
398* Mon Dec 24 2007 Mamoru Tasaka <mtasaka@ioa.s.u-tokyo.ac.jp> - 0.5.7.95-1
399- Update to new upstream release candidate (0.5.8 RC1)
400- Completely suppress updates notification (bug 299601, 426642)
401
402* Sun Dec 09 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-2
403- Add missing icon cache %%post and %%postun scriptlets.
404- Add missing egg-info to the %%files list.
405
406* Fri Dec 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7.1-1
407- Update to new upstream bug-fix release (0.5.7.1).
408- Sort %%files list (aesthetic-only change).
409
410* Wed Dec 05 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-3
411- Fix previous %%changelog Version.
412- Cleanup the installed .desktop file. Fixes bug 413101 (deluge fails to build
413  in rawhide  bad .desktop file.)
414
415* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.7-2
416- Rebuild for deps
417
418* Tue Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.7-1
419- Update to new upstream release (0.5.7)
420
421* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.96-1
422- Update to new upstream release candidate (0.5.7 RC2)
423- Drop plugin error patch (fixed upstream):
424  - plugin-not-found-OK.patch
425
426* Sat Nov 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.95-1
427- Update to new upstream release candidate (0.5.7 RC)
428- Update Source0 url
429- Add upstream patch to prevent dying if plugin in prefs.state is not found on
430  the filesystem:
431  + plugin-not-found-OK.patch
432
433* Wed Oct 31 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.2-1
434- Update to new upstream bug-fix release (0.5.6.2)
435
436* Tue Oct 30 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6.1-1
437- Update to new upstream bug-fix release (0.5.6.1)
438- Drop use-mt-boost build script patch (fixed upstream):
439  - use-mt-boost.patch
440
441* Sat Oct 27 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.6-1
442- Update to new upstream release (0.5.6)
443
444* Wed Oct 17 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5.95-1
445- Update to new upstream release candidate (0.5.6 RC1)
446
447* Thu Sep 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-2
448- Fix release on previous %%changelog entry.
449- Disable the version update notifications by default:
450  + default-prefs-no-release-notifications.patch
451  (Resolves bug 299601: Deluge alerts of new versions)
452
453* Wed Sep 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.5-1
454- Update to new upstream release (0.5.5)
455
456* Mon Sep 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1.95-1
457- Update to new upstream release candidate (0.5.5 RC1)
458
459* Mon Aug 13 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4.1-1
460- Update to new upstream release (0.5.4.1)
461- Build with new binutils to gain BuildID debugging goodness.
462
463* Mon Aug 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.4-1
464- Update to new upstream release (0.5.4)
465
466* Fri Aug 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-2
467- Update License tag (GPLv2+).
468- Rebuild against new Boost libraries, adding a patch to build against the
469  multi-threaded ("*-mt") libraries:
470  + use-mt-boost.patch
471
472* Wed Jul 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.3-1
473- Update to new upstream release candidate (0.5.3)
474- Drop %%ifarch invocations for 64-bit builds. The internal setup script now
475  properly determines this and adds the AMD64 compiler definition if necessary.
476
477* Fri Jul 20 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2.90-1
478- Update to new upstream release candidate (0.5.3 RC1)
479- Drop stale persistence fix patch (applied upstream):
480  - fix-persistence-upgrade-rhbz_247927.patch
481
482* Wed Jul 11 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-2
483- Add patch to fix the existence of stale persistence files by automatically
484  updating the deluge.deluge module name to deluge.core, or removing them if
485  empty (bug 247927):
486  + fix-persistence-upgrade-rhbz_247927.patch
487
488* Sun Jul 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.2-1
489- Update to new upstream release (0.5.2)
490- Update Summary and %%description to reflect new µTorrent-compatible Peer
491  Exchange ("PEX") functionality.
492
493* Thu Jun 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0.90.2-2
494- Update to new upstream release (0.5.1 Beta 2)
495
496* Sun Apr 08 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-2
497- Make Deluge the upgrade path of the now-orphaned python-libtorrent package.
498 
499* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.5.0-1
500- Update to new upstream release (0.5.0).
501
502* Mon Mar 12 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.2-1
503- Update to new upstream release (0.5 RC2).
504- Drop IndexError exception-handling fix (applied upstream):
505  - delugegtk.py-fix-IndexError-exception-handling.patch
506- Use the system libtool instead of the one from the sources to ensure
507  that no unnecessary RPATH hacks are added to the final build.
508
509* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-3
510- Add a patch (submitted upstream) to properly catch a thrown IndexError in
511  state message updates. This should resolve the bug wherein the UI stops
512  updating its details and torrent listing.
513  + delugegtk.py-fix-IndexError-exception-handling.patch
514 
515* Wed Mar 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-2
516- Drop unneeded 64bit-python_long patch; as it seems to cause more trouble than
517  it's worth. Instead, pass -DAMD64 as a compiler flag on 64-bit arches.
518  - 64bit-python_long patch
519  (This should fix the bug where, even though torrents are active, they are not
520  shown in the GtkTreeView listing.)
521
522* Tue Mar 06 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.99.1-1
523- Update to new upstream release (0.5 RC1).
524- Use rewritten setup.py instead of patching it so much, since it's easier to
525  maintain across version upgrades and whatnot:
526  + fixed-setup.py
527- Remove the setup.py patches (no longer needed, since I'm packaging my own):
528  - setup.py-dont-store-the-install-dir.patch
529  - setup.py-build-against-system-libtorrent.patch
530
531* Fri Mar 02 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.3-1
532- Update to new upstream release (0.5 Beta 3).
533- Add patch to fix storing of installation directory:
534  + setup.py-dont-store-the-install-dir.patch
535    (to be applied after setup.py-build-against-system-libtorrent.patch)
536
537* Sun Feb 25 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-2
538- Add patch to fix 64-bit python_long type.
539  +  64bit-python_long.patch
540
541* Sat Feb 24 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.90.2-1
542- Update to new upstream release (0.5 Beta 2)
543- Add patch to force building against system copy of rb_libtorrent:
544  + setup.py-build-against-system-libtorrent.patch
545- Remove python-libtorrent and a few other dependencies that are no longer
546  used.
547
548* Fri Feb 23 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-6
549- Fix Source0 URL.
550
551* Wed Feb 21 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-5
552- Make notify-python dependency conditional (FC6+ only)
553- Strip the unneeded shebang lines from the plugin scripts, since they are not
554  meant to be directly executed.
555
556* Wed Feb 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-4
557- Update .desktop file: Icon should not have the "-256" size suffix.
558- Add Requires: notify-python
559- Remove strict dependency on python 2.3+, since we're targetting FC5+
560  only, which has 2.4+.
561
562* Wed Jan 10 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-3
563- Use install instead of the cp/find/chmod fiasco of earlier releases for
564  clarity and proper permissions setting.
565- Be more consistent about use of %%{name} and other macros in file naming as
566  well as whitespace between sections.
567
568* Sun Jan 07 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-2
569- Bump python-libtorrent dependency to 0.3.0-4, which contains a fix for
570  64-bit systems.
571
572* Wed Jan 03 2007 Peter Gordon <peter@thecodergeek.com> - 0.4.1-1
573- Initial packaging for Fedora Extras.
Note: See TracBrowser for help on using the repository browser.