source: projects/specs/trunk/d/dejagnu/dejagnu-vl.spec @ 521

Revision 521, 4.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:       A front end for testing other programs.
2Summary(ja):   各種プログラムをテストするためのフロントエンド
3Name:          dejagnu
4Version:       1.4.4
5Release:       1%{?_dist_release}
6Epoch:         1
7License:       GPL
8Source:        ftp://ftp.gnu.org/gnu/dejagnu/dejagnu-1.4.4.tar.gz
9Source2:       dejagnu.texi
10Patch0:        doc-Makefile.patch
11Patch1:        dejagnu-1.4.2-makefile-style-arg.patch
12Group:         Development/Tools
13Requires:      tcl >= 8.0, expect >= 5.21
14BuildRoot:     %{_tmppath}/%{name}-%{version}-root
15BuildArch:     noarch
16BuildRequires: jadetex docbook-utils-pdf
17Patch1:        dejagnu-1.4.4-smp-1.patch
18Patch3:        dejagnu-1.4.4-testsuite.patch
19Patch4:        dejagnu-1.4.4-runtest.patch
20
21Vendor:       Project Vine
22Distribution: Vine Linux
23Packager:     MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
24
25
26%description
27DejaGnu is an Expect/Tcl based framework for testing other programs.
28DejaGnu has several purposes: to make it easy to write tests for any
29program; to allow you to write tests which will be portable to any
30host or target where a program must be tested; and to standardize the
31output format of all tests (making it easier to integrate the testing
32into software development).
33
34
35%prep
36%setup -q -n dejagnu-%{version}
37find . -name \*.rej -exec rm {} \;
38%patch1 -p1
39%patch3 -p1
40%patch4 -p1
41
42
43%build
44%configure -v
45makeinfo %{SOURCE2} -o doc/%{name}.info
46
47make
48mv doc/html doc/overview
49echo ============TESTING===============
50LANG=C make -k check RUNTESTFLAGS="RUNTEST=`pwd`/runtest" || :
51echo ============END TESTING===========
52
53
54%install
55rm -rf $RPM_BUILD_ROOT
56%makeinstall
57chmod a-x $RPM_BUILD_ROOT/%{_datadir}/dejagnu/runtest.exp
58
59pushd doc
60make man1dir=%{buildroot}%{_mandir}/man1 install-man
61install -D -m 644 dejagnu.info ${RPM_BUILD_ROOT}/%{_infodir}/%{name}.info
62popd
63
64mv $RPM_BUILD_ROOT%{_libexecdir}/config.guess $RPM_BUILD_ROOT%{_datadir}/dejagnu                                                                               
65rm -rf $RPM_BUILD_ROOT%{_libexecdir}
66
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71
72%post
73/sbin/install-info %{_infodir}/%{name}.info.gz --dir-file=%{_infodir}/dir ||:
74
75
76%preun
77if [ $1 = 0 ]; then
78    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
79fi
80
81
82%files
83%defattr(-,root,root)
84%doc COPYING NEWS README AUTHORS INSTALL ChangeLog doc/overview.pdf
85%{_bindir}/runtest
86%{_datadir}/dejagnu
87%{_includedir}/dejagnu.h
88%{_mandir}/*/*
89%{_infodir}/*
90
91 
92%changelog
93* Fri Sep 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.4-1
94- new versioning policy; spec in UTF-8
95- add Source2, Patch3 and Patch4 from Fedora 1.4.4-13
96
97* Sun Mar 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl3
98- rebuilt with gcc-4.1.x
99- imported Patch1 from FC 1.4.4-5
100
101* Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.4.4-0vl2
102- use License instead of Copyright
103
104* Tue Mar 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
105- updated to 1.4.4
106
107* Sun May 09 2004 Satoshi MACHINO <machino@vinelinux.org> 1.4.2-6vl2
108- moved %%{_libexecdir}/config.guess into %%{_datadir}/dejagnu
109- included overview docs
110- added BuildRequires
111
112* Sun Nov 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.2-6vl1
113- based on 1.4.2-6 from Rawhide and built for Vine Linux
114
115* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
116- automated rebuild
117
118* Thu May 23 2002 Tim Powers <timp@redhat.com>
119- automated rebuild
120
121* Mon Apr 29 2002 Jakub Jelinek <jakub@redhat.com> 1.4.2-4
122- fix makefile style variable passing (#63984)
123
124* Thu Feb 28 2002 Jakub Jelinek <jakub@redhat.com> 1.4.2-3
125- rebuild
126
127* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
128- automated rebuild
129
130* Wed Nov 28 2001 Jakub Jelinek <jakub@redhat.com> 1.4.2-1
131- update to 1.4.2, mainly so that it can be built with gcc3+
132
133* Fri Sep  7 2001 Jakub Jelinek <jakub@redhat.com> 1.4.1-3
134- make it noarch again
135
136* Wed Aug 29 2001 Jakub Jelinek <jakub@redhat.com>
137- fix a typo (#52404)
138
139* Thu Jun 28 2001 Tim Powers <timp@redhat.com>
140- rebuilt for the distro
141
142* Tue Feb 27 2001 Tim Powers <timp@redhat.com>
143- minor modifications to the spec file. Built for Powertools.
144- added Epoch
145
146* Wed Feb 21 2001 Rob Savoye <rob@welcomehome.org>
147- Fixed Requires line, and changed the URL to the new ftp site.
148
149* Sun Oct 31 1999 Rob Savoye <rob@welcomehome.org>
150- updated to the latest snapshot
151- added doc files
152- added the site.exp config file
153
154* Mon Jul 12 1999 Tim Powers <timp@redhat.com>
155- updated to 19990628
156- updated patches as needed
157- added %defattr in files section
158
159* Wed Mar 10 1999 Jeff Johnson <jbj@redhat.com>
160- add alpha expect patch (#989)
161- use %configure
162
163* Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com>
164- Update to 19981215.
165
166* Thu Nov 12 1998 Jeff Johnson <jbj@redhat.com>
167- Update to 1998-10-29.
168
169* Wed Jul  8 1998 Jeff Johnson <jbj@redhat.com>
170- Update to 1998-05-28.
171
172* Sun Feb  1 1998 Jeff Johnson <jbj@jbj.org>
173- Create.
174 
Note: See TracBrowser for help on using the repository browser.