source: projects/specs/trunk/d/dejagnu/dejagnu-vl.spec @ 8166

Revision 8166, 5.1 KB checked in by shaolin, 10 years ago (diff)
  • dejagnu: new upstream release
Line 
1Summary:       A front end for testing other programs.
2Summary(ja):   各種プログラムをテストするためのフロントエンド
3Name:          dejagnu
4Version:       1.5.1
5Release:       1%{?_dist_release}
6Epoch:         1
7
8Group:         Development/Tools
9License:       GPLv2
10
11Source:        ftp://ftp.gnu.org/gnu/dejagnu/dejagnu-%{version}.tar.gz
12Patch1:        dejagnu-1.5-smp-1.patch
13Patch2:        dejagnu-1.5-runtest.patch
14Patch3:        dejagnu-1.5-usrmove.patch
15Patch4:        dejagnu-1.5-gfortran.patch
16Patch5:        dejagnu-1.5-aarch64.patch
17
18Requires:      tcl >= 8.0, expect >= 5.21
19BuildRoot:     %{_tmppath}/%{name}-%{version}-root
20BuildArch:     noarch
21BuildRequires: expect screen texinfo
22
23Vendor:       Project Vine
24Distribution: Vine Linux
25Packager:     shaolin
26
27
28%description
29DejaGnu is an Expect/Tcl based framework for testing other programs.
30DejaGnu has several purposes: to make it easy to write tests for any
31program; to allow you to write tests which will be portable to any
32host or target where a program must be tested; and to standardize the
33output format of all tests (making it easier to integrate the testing
34into software development).
35
36
37%prep
38%setup -q -n dejagnu-%{version}
39find . -name \*.rej -exec rm {} \;
40%patch1 -p1
41%patch2 -p1
42%patch3 -p1
43%patch4 -p1
44%patch5 -p1
45
46
47%build
48%configure -v
49
50%check
51echo ============TESTING===============
52# Dejagnu test suite also has to test reporting to user.  It needs a
53# terminal for that.  That doesn't compute in mock.  Work around it by
54# running the test under screen and communicating back to test runner
55# via temporary file.  If you have better idea, we accept patches.
56TMP=`mktemp`
57screen -D -m sh -c '(make check RUNTESTFLAGS="RUNTEST=`pwd`/runtest"; echo $?) >> '$TMP
58RESULT=`tail -n 1 $TMP`
59cat $TMP
60rm -f $TMP
61echo ============END TESTING===========
62exit $RESULT
63
64%install
65rm -rf %{buildroot}
66%makeinstall
67rm -f %{buildroot}%{_infodir}/dir
68chmod a-x %{buildroot}/%{_datadir}/dejagnu/runtest.exp
69make DESTDIR=%{buildroot} install-man
70install -D -m 644 doc/dejagnu.info %{buildroot}/%{_infodir}/%{name}.info
71
72
73%clean
74rm -rf %{buildroot}
75
76
77%post
78/sbin/install-info %{_infodir}/%{name}.info.gz --dir-file=%{_infodir}/dir ||:
79
80
81%preun
82if [ $1 = 0 ]; then
83    /sbin/install-info --delete %{_infodir}/%{name}.info %{_infodir}/dir ||:
84fi
85
86
87%files
88%defattr(-,root,root)
89%doc COPYING NEWS README AUTHORS INSTALL ChangeLog doc/dejagnu.texi
90%{_bindir}/runtest
91%{_datadir}/dejagnu
92%{_includedir}/dejagnu.h
93%{_mandir}/*/*
94%{_infodir}/*
95
96 
97%changelog
98* Mon Jan 13 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1:1.5.1-1
99- updated to 1.5.1; import patches from Fedora; spec cleanup
100
101* Sun May 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.4-2
102- rebuilt with current VineSeed
103- added BR: texinfo
104
105* Fri Sep 26 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.4-1
106- new versioning policy; spec in UTF-8
107- add Source2, Patch3 and Patch4 from Fedora 1.4.4-13
108
109* Tue Mar 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl3
110- rebuilt with gcc-4.1.x
111- imported Patch1 from FC 1.4.4-5
112
113* Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.4.4-0vl2
114- use License instead of Copyright
115
116* Tue Mar 08 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
117- updated to 1.4.4
118
119* Sun May 09 2004 Satoshi MACHINO <machino@vinelinux.org> 1.4.2-6vl2
120- moved %%{_libexecdir}/config.guess into %%{_datadir}/dejagnu
121- included overview docs
122- added BuildRequires
123
124* Sun Nov 10 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.2-6vl1
125- based on 1.4.2-6 from Rawhide and built for Vine Linux
126
127* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
128- automated rebuild
129
130* Thu May 23 2002 Tim Powers <timp@redhat.com>
131- automated rebuild
132
133* Mon Apr 29 2002 Jakub Jelinek <jakub@redhat.com> 1.4.2-4
134- fix makefile style variable passing (#63984)
135
136* Thu Feb 28 2002 Jakub Jelinek <jakub@redhat.com> 1.4.2-3
137- rebuild
138
139* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
140- automated rebuild
141
142* Wed Nov 28 2001 Jakub Jelinek <jakub@redhat.com> 1.4.2-1
143- update to 1.4.2, mainly so that it can be built with gcc3+
144
145* Fri Sep  7 2001 Jakub Jelinek <jakub@redhat.com> 1.4.1-3
146- make it noarch again
147
148* Wed Aug 29 2001 Jakub Jelinek <jakub@redhat.com>
149- fix a typo (#52404)
150
151* Thu Jun 28 2001 Tim Powers <timp@redhat.com>
152- rebuilt for the distro
153
154* Tue Feb 27 2001 Tim Powers <timp@redhat.com>
155- minor modifications to the spec file. Built for Powertools.
156- added Epoch
157
158* Wed Feb 21 2001 Rob Savoye <rob@welcomehome.org>
159- Fixed Requires line, and changed the URL to the new ftp site.
160
161* Sun Oct 31 1999 Rob Savoye <rob@welcomehome.org>
162- updated to the latest snapshot
163- added doc files
164- added the site.exp config file
165
166* Mon Jul 12 1999 Tim Powers <timp@redhat.com>
167- updated to 19990628
168- updated patches as needed
169- added %defattr in files section
170
171* Wed Mar 10 1999 Jeff Johnson <jbj@redhat.com>
172- add alpha expect patch (#989)
173- use %configure
174
175* Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com>
176- Update to 19981215.
177
178* Thu Nov 12 1998 Jeff Johnson <jbj@redhat.com>
179- Update to 1998-10-29.
180
181* Wed Jul  8 1998 Jeff Johnson <jbj@redhat.com>
182- Update to 1998-05-28.
183
184* Sun Feb  1 1998 Jeff Johnson <jbj@jbj.org>
185- Create.
186 
Note: See TracBrowser for help on using the repository browser.