source: projects/specs/trunk/d/dbus/dbus-vl.spec @ 8758

Revision 8758, 19.2 KB checked in by Takemikaduchi, 10 years ago (diff)

update or rebuild

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gettext_package dbus
4%define expat_version           2.0.1
5%define dbus_user_uid           81
6
7%define _localstatedir %{_var}
8
9Summary: D-BUS message bus
10Summary(ja): D-BUS メッセージバスシステム
11Name: dbus
12Version: 1.6.22
13Release: 1%{?_dist_release}
14URL: http://www.freedesktop.org/software/dbus/
15License: AFL/GPLv2
16Group: System Environment/Libraries
17
18Source0: %{name}-%{version}.tar.gz
19Source1: doxygen_to_devhelp.xsl
20
21# from fedora package
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24Requires(post): chkconfig >= 1.3.34
25Requires(preun): chkconfig >= 1.3.34
26Requires(pre): shadow-utils
27BuildRequires: libtool
28BuildRequires: expat-devel >= %{expat_version}
29BuildRequires: libxml2-devel
30BuildRequires: python-devel
31BuildRequires: doxygen
32BuildRequires: xmlto
33BuildRequires: libxslt
34BuildRequires: gettext
35BuildRequires: libX11-devel
36BuildRequires: libSM-devel
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42D-BUS is a system for sending messages between applications. It is
43used both for the systemwide message bus service, and as a
44per-user-login-session messaging facility.
45
46%description -l ja
47D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
48システム全体のメッセージバスサービスとしても利用されますが、同様に
49ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
50
51%package devel
52Summary: Libraries and headers for D-BUS
53Summary(ja): D-BUS 用のライブラリとヘッダファイル
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56
57%description devel
58Headers and static libraries for D-BUS.
59
60%package x11
61Summary: X11-requiring add-ons for D-BUS
62Summary(ja): X11 を利用する D-BUS 用ツール
63Group: Applications/System
64Requires: %{name} = %{version}-%{release}
65
66%description x11
67D-BUS contains some tools that require Xlib to be installed, those are
68in this separate package so server systems need not install X.
69
70%package doc
71Summary: Developer documentation for D-BUS
72Group: Documentation
73Requires: %{name} = %{version}-%{release}
74BuildArch: noarch
75
76%description doc
77This package contains developer documentation for D-Bus along with
78other supporting documentation such as the introspect dtd file.
79
80# compat32
81%package -n compat32-%{name}
82Summary: D-BUS message bus
83Summary(ja): D-BUS メッセージバスシステム
84Group: System Environment/Libraries
85
86%description -n compat32-%{name}
87D-BUS is a system for sending messages between applications. It is
88used both for the systemwide message bus service, and as a
89per-user-login-session messaging facility.
90
91%description -n compat32-%{name} -l ja
92D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
93システム全体のメッセージバスサービスとしても利用されますが、同様に
94ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
95
96%package -n compat32-%{name}-devel
97Summary: Libraries and headers for D-BUS
98Summary(ja): D-BUS 用のライブラリとヘッダファイル
99Group: Development/Libraries
100Requires: compat32-%{name} = %{version}-%{release}
101Requires: %{name}-devel = %{version}-%{release}
102
103%description -n compat32-%{name}-devel
104Headers and static libraries for D-BUS.
105
106%prep
107%setup -q
108
109%build
110autoreconf -f -i
111
112COMMON_ARGS="--enable-selinux=no \
113                --disable-libaudit \
114                --with-init-scripts=redhat \
115                --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
116                --with-dbus-user=dbus \
117                --libdir=/%{_lib} --bindir=/bin \
118                --libexecdir=/%{_lib}/dbus-1 \
119                --sysconfdir=%{_sysconfdir} --exec-prefix=/"
120
121%configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
122%__make
123
124doxygen Doxyfile
125
126xsltproc -o dbus.devhelp %{SOURCE1} doc/api/xml/index.xml
127
128%install
129rm -rf %{buildroot}
130
131%__make install DESTDIR=$RPM_BUILD_ROOT
132
133mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
134
135#change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
136sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
137rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
138
139mkdir -p $RPM_BUILD_ROOT/%{_bindir}
140mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}
141mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
142mv -f $RPM_BUILD_ROOT/%{_lib}/dbus-1.0/include/* $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
143rm -rf $RPM_BUILD_ROOT/%{_lib}/dbus-1.0
144
145rm -f $RPM_BUILD_ROOT/%{_lib}/*.a
146rm -f $RPM_BUILD_ROOT/%{_lib}/*.la
147
148mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
149mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
150
151cp dbus.devhelp $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
152cp doc/dbus-specification.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
153cp doc/dbus-faq.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
154cp doc/dbus-tutorial.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
155cp doc/api/html/* $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
156
157## %find_lang %{gettext_package}
158
159mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/interfaces
160
161%clean
162rm -rf %{buildroot}
163
164%pre
165# Add the "dbus" user
166/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
167        -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
168
169%post
170/sbin/ldconfig
171/sbin/chkconfig --add messagebus
172/sbin/chkconfig messagebus resetpriorities
173
174%preun
175if [ $1 = 0 ]; then
176    service messagebus stop > /dev/null 2>&1
177    /sbin/chkconfig --del messagebus
178fi
179
180%postun
181/sbin/ldconfig
182
183%post -n compat32-%{name} -p /sbin/ldconfig
184
185%postun -n compat32-%{name} -p /sbin/ldconfig
186
187%files
188%defattr(-,root,root)
189%doc COPYING ChangeLog NEWS
190%dir %{_sysconfdir}/dbus-1
191%config %{_sysconfdir}/dbus-1/*.conf
192%{_sysconfdir}/rc.d/init.d/*
193%dir %{_sysconfdir}/dbus-1/system.d
194%dir %{_sysconfdir}/dbus-1/session.d
195%dir %{_localstatedir}/run/dbus
196%dir %{_localstatedir}/lib/dbus/
197/bin/dbus-daemon
198/bin/dbus-send
199/bin/dbus-cleanup-sockets
200/bin/dbus-monitor
201/bin/dbus-uuidgen
202/%{_lib}/*dbus-1*.so.*
203%{_datadir}/man/man*/dbus-cleanup-sockets.1.gz
204%{_datadir}/man/man*/dbus-daemon.1.gz
205%{_datadir}/man/man*/dbus-monitor.1.gz
206%{_datadir}/man/man*/dbus-send.1.gz
207%{_datadir}/man/man*/dbus-uuidgen.1.gz
208%dir %{_datadir}/dbus-1
209%{_datadir}/dbus-1/services
210%{_datadir}/dbus-1/system-services
211%{_datadir}/dbus-1/interfaces
212%dir /%{_lib}/dbus-1
213%attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
214
215%files devel
216%defattr(-,root,root)
217/%{_lib}/lib*.so
218%{_libdir}/dbus-1.0/include
219%{_libdir}/pkgconfig/*
220%{_includedir}/*
221%{_datadir}/devhelp/books/dbus
222
223%files x11
224%defattr(-,root,root)
225%{_bindir}/dbus-launch
226%{_datadir}/man/man*/dbus-launch.1.gz
227
228%files doc
229%defattr(-,root,root)
230%doc %{_docdir}/dbus
231
232# compat32
233%if %{build_compat32}
234%files -n compat32-%{name}
235/%{_lib}/*dbus-1*.so.*
236
237%files -n compat32-%{name}-devel
238%defattr(-,root,root)
239/%{_lib}/lib*.so
240%{_libdir}/dbus-1.0/include
241%endif
242
243%changelog
244* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.22-1
245- new upstream release
246
247* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.20-1
248- new upstream release
249
250* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.18-1
251- new upstream release
252
253* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
254- new upstream release
255
256* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
257- new upstream release
258
259* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-2
260- remove BuildRequires: audit-libs-devel, libcap-ng-devel
261
262* Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
263- new upstream release
264- remove old patches
265
266* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.20-1
267- new upstream release
268- add BuildRequires: audit-libs-devel, libcap-ng-devel
269
270* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.18-1
271- new upstream release
272- remove Requires: libxml2-python
273
274* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.16-1
275- new upstream release
276
277* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
278- new upstream release
279- drop Patch1
280- create -doc sub package
281
282* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
283- new upstream release
284
285* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
286- new upstream release
287
288* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
289- add BuildRequires: libSM-devel
290
291* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
292- rebuilt with rpm-4.8.1
293
294* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
295- new upstream release
296- drop Patch0
297
298* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
299- rebuilt with new toolchain
300
301* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
302- new upstream release
303
304* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
305- new upstream release
306- do not restart dbus on upgrade
307
308* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
309- added compat32 package for x86_64 arch support
310
311* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
312- add Patch10 for workaround deny send_interface
313  http://bugs.freedesktop.org/show_bug.cgi?id=18961
314  Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
315  Bare <deny send_interface=""/> rules have a far larger impact than one would think.
316  It's really always wrong to use them without also using send_destination.
317  - XXX: this should be fixed in each dbus configuration.
318
319* Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
320- new upstream release with security fix (CVE-2008-4311)
321
322* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
323- new upstream release with security fix (CVE-2008-3834)
324
325* Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
326- new upstream release
327
328* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
329- own the directories /usr/share/dbus-1/{system-services,interfaces}
330- set 'dbus' instead of '81' to --with-dbus-user
331 
332* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
333- import some patches from fedora
334- move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
335
336* Wed May  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
337- new upstream release
338
339* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
340- new upstream release
341
342* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
343- rebuild with expat-2.0.1
344
345* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
346- rebuild with new environment/toolchain
347
348* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
349- require new chkconfig to reset initscript priorities
350
351* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
352- new upstream release
353- split out bindings
354- move base binaries and libraries to /bin and /%{_lib}
355
356* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
357- rebuilt for VineSeed
358
359* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
360- add Vendor/Distribution tag
361
362* Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
363- add patch100 for fix CVE-2006-6107
364
365* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
366- new upstream release
367
368* Sat Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
369- disabled dbus-qt
370- added BuildConflicts: qt-devel
371- removed work around for 64 bit archs
372
373* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
374- new upstream release
375
376* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
377- new upstream release
378
379* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
380- new upstream release
381
382* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
383- new upstream release
384- enable python bindings
385
386* Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
387- initial build for Vine Linux based on FC package
388- disable python bindings
389- disable selinux
390
391* Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
392- Explicitly pass in the pid file location to ./configure instead of
393  letting it guess based on the build enviornment
394
395* Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
396- Add patch to fix random users from connecting to a users session bus
397
398* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
399- Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
400
401* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
402- Update to upstream version 0.23
403- Drop all patches except for the UDI patch as they have been
404  integrated upstream
405- List of API changes:
406      * add setgroups() to drop supplementary groups
407      * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
408      * added support for int64 and uint64 to the python bindings
409      * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
410
411* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
412- rebuild against python 2.4
413
414* Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
415- Add a requires for glib2-devel in the devel package
416- Add SE-Linux backport from Colin Walters that fixes
417  messages getting lost in SE-Linux contexts
418
419* Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
420- Bump up release and rebuild
421
422* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
423- Run /sbin/ldconfig for glib sub-package (bug #134062).
424
425* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
426- Fixed patch to use dbus-1 instead of dbus-1.0
427- (configure.in): Exported just the datadir instead of
428  the full path to the dbus datadir for consistency
429
430* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
431- Adding patch to move /usr/lib/dbus-1.0/services to
432  /usr/share/dbus-1.0/services
433
434* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
435- reverting BuildRequires: redhat-release because of issues with build system
436- added precompiled version of the messagebus init script
437
438* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
439- changed /etc/redhat-release to the package redhat-release
440
441* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
442- added python int64 patch from davidz
443
444* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
445- added BuildRequires: /etc/redhat-release (RH Bug #132436)
446
447* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
448- Added Steve Grubb's spec file patch (RH Bug #130201)
449
450* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
451- Disabled dbus-gtk since dbus-viewer doesn't do anything right now
452
453* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
454- Moved dbus-viewer to new dbus-gtk package so that dbus-glib
455  no longer requires X or GTK libraries. (RH Bug #130029)
456
457* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
458- Update to new 0.22 release
459
460* Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
461- Added BuildRequires for libselinux-devel and Requires for libselinux
462
463* Mon Aug 02 2004 Colin Walters <walters@redhat.com>
464- Add SE-DBus patch
465
466* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
467- Added lib64 workaround for python bindings installing to
468  the wrong lib directory on 64 bit archs
469
470* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
471- Updated console-auth patch
472- rebuild
473 
474* Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
475- Update to upstream CVS build
476- Added console-auth patch
477
478* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
479- Workaround added to fix gcc-3.4 bug on ia64
480
481* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
482- require new Pyrex version and see if it builds this time
483
484* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
485- rebuild with updated Pyrex (0.9.2.1)
486
487* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
488- rebuilt
489
490* Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
491- Moved dbus-viewer, dbus-monitor and dbus-glib-tool
492  into the dbus-glib package so that the main dbus
493  package does not depend on glib (Bug #125285)
494
495* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
496- rebuilt
497
498* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
499- added my Python patch
500- took out the qt build requires
501- added a gtk+ build requires
502
503* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
504- Changed build requirement to version 0.9-3 of Pyrex
505  to fix problem with builing on x86_64
506
507* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
508- update to upstream 0.21
509- removed dbus-0.20-varargs.patch patch (fixed upstream)
510
511* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
512- added a dbus-python package to generate python bindings
513- added Pyrex build dependacy
514
515* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
516- rebuilt
517
518* Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
519- fix dbus error functions on x86-64 (#116324)
520- add prereq (#112027)
521
522* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
523- rebuilt
524
525* Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
526- Conflict with cups prior to configuration file change, so that the
527  %%postun service condrestart works.
528
529* Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
530- rebuild in fc2, cups now updated
531
532* Wed Jan  7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
533- update to upstream 0.20
534
535* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
536- hmm, dbus doesn't support uids in the config file. fix.
537
538* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
539- put uid instead of username in the config file, to keep things working with name change
540
541* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
542- make subpackages require the specific release, not just version, of base package
543
544* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
545- change system user "messagebus" -> "dbus" to be under 8 chars
546
547* Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
548- see if removing qt subpackage for now will get us through the build system,
549  qt bindings not useful yet anyway
550
551* Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
552- 0.13 fixes a little security oops
553
554* Mon Aug  4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
555- break the tiny dbus-launch that depends on X into separate package
556  so a CUPS server doesn't need X installed
557
558* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
559- rebuilt
560
561* Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
562- 0.11.91 cvs snap properly merges system.d
563
564* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
565- build a cvs snap with a few more fixes
566
567* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
568- fix a crash that was breaking cups
569
570* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
571- 0.11
572
573* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
574- use rc.d/init.d not init.d, bug #90192
575- include the new man pages
576
577* Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
578- 0.9
579- export QTDIR explicitly
580- re-enable qt, the problem was most likely D-BUS configure
581
582* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
583- update from CVS with a fix to set uid after gid
584
585* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
586- new cvs snap that actually forks to background and changes
587  user it's running as and so forth
588- create our system user in pre
589
590* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
591- fix for "make check" test that required a home directory
592
593* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
594- disable qt for now because beehive hates me
595- pull a slightly newer cvs snap that creates socket directory
596- cat the make check log after make check fails
597
598* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
599- initial build
600
Note: See TracBrowser for help on using the repository browser.