source: projects/specs/trunk/d/dbus/dbus-vl.spec @ 12000

Revision 12000, 22.7 KB checked in by tomop, 5 years ago (diff)

new: elogind-239.3 (and packages that depends on elogind)

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define _unpackaged_files_terminate_build 1
4%bcond_with systemd
5
6%define gettext_package dbus
7%define expat_version           2.0.1
8%define dbus_user_uid           81
9
10%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
11%define _localstatedir %{_var}
12
13Summary: D-BUS message bus
14Summary(ja): D-BUS メッセージバスシステム
15Name: dbus
16Version: 1.12.12
17Release: 1%{?_dist_release}
18URL: http://www.freedesktop.org/software/dbus/
19License: AFL/GPLv2
20Group: System Environment/Libraries
21
22Source0: %{name}-%{version}.tar.gz
23Source1: 00-start-message-bus.sh
24Source2: dbus.init
25
26# from fedora package
27
28# from gentoo
29Patch1000: dbus-enable-elogind.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32Requires(post): chkconfig >= 1.3.34
33Requires(preun): chkconfig >= 1.3.34
34Requires(pre): shadow-utils
35BuildRequires: autoconf-archive
36BuildRequires: libtool
37BuildRequires: expat-devel >= %{expat_version}
38BuildRequires: libxml2-devel
39BuildRequires: python-devel
40BuildRequires: doxygen
41BuildRequires: xmlto
42BuildRequires: libxslt
43BuildRequires: gettext
44BuildRequires: libX11-devel
45BuildRequires: libSM-devel
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51D-BUS is a system for sending messages between applications. It is
52used both for the systemwide message bus service, and as a
53per-user-login-session messaging facility.
54
55%description -l ja
56D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
57システム全体のメッセージバスサービスとしても利用されますが、同様に
58ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
59
60%package devel
61Summary: Libraries and headers for D-BUS
62Summary(ja): D-BUS 用のライブラリとヘッダファイル
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65Requires: xml-common
66
67%description devel
68Headers and static libraries for D-BUS.
69
70%package x11
71Summary: X11-requiring add-ons for D-BUS
72Summary(ja): X11 を利用する D-BUS 用ツール
73Group: Applications/System
74Requires: %{name} = %{version}-%{release}
75
76%description x11
77D-BUS contains some tools that require Xlib to be installed, those are
78in this separate package so server systems need not install X.
79
80%package doc
81Summary: Developer documentation for D-BUS
82Group: Documentation
83Requires: %{name} = %{version}-%{release}
84BuildArch: noarch
85
86%description doc
87This package contains developer documentation for D-Bus along with
88other supporting documentation such as the introspect dtd file.
89
90# compat32
91%package -n compat32-%{name}
92Summary: D-BUS message bus
93Summary(ja): D-BUS メッセージバスシステム
94Group: System Environment/Libraries
95
96%description -n compat32-%{name}
97D-BUS is a system for sending messages between applications. It is
98used both for the systemwide message bus service, and as a
99per-user-login-session messaging facility.
100
101%description -n compat32-%{name} -l ja
102D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
103システム全体のメッセージバスサービスとしても利用されますが、同様に
104ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
105
106%package -n compat32-%{name}-devel
107Summary: Libraries and headers for D-BUS
108Summary(ja): D-BUS 用のライブラリとヘッダファイル
109Group: Development/Libraries
110Requires: compat32-%{name} = %{version}-%{release}
111Requires: %{name}-devel = %{version}-%{release}
112
113%description -n compat32-%{name}-devel
114Headers and static libraries for D-BUS.
115
116%prep
117%autosetup -p1
118
119%build
120# Avoid rpath.
121if test -f autogen.sh; then env NOCONFIGURE=1 ./autogen.sh; else autoreconf --ve
122rbose --force --install; fi
123
124COMMON_ARGS="--enable-selinux=no \
125                --enable-elogind \
126                --disable-libaudit \
127                --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
128                --with-dbus-user=dbus \
129                --libdir=/%{_lib} --bindir=/bin \
130                --libexecdir=/%{_lib}/dbus-1 \
131                --docdir=%{_pkgdocdir} \
132                --sysconfdir=%{_sysconfdir} --exec-prefix=/"
133
134%configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
135make V=1 %{?_smp_mflags}
136
137%install
138rm -rf %{buildroot}
139
140%__make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
141
142find %{buildroot} -name '*.a' -type f -delete
143find %{buildroot} -name '*.la' -type f -delete
144
145install -Dp -m755 %{SOURCE1} %{buildroot}%{_sysconfdir}/X11/xinit/xinitrc.d/00-start-message-bus.sh
146
147# Obsolete, but still widely used, for drop-in configuration snippets.
148install --directory %{buildroot}%{_sysconfdir}/dbus-1/session.d
149install --directory %{buildroot}%{_sysconfdir}/dbus-1/system.d
150
151install --directory %{buildroot}%{_datadir}/dbus-1/interfaces
152
153%if %{with systemd}
154# Make sure that when somebody asks for D-Bus under the name of the
155# old SysV script, that he ends up with the standard dbus.service name
156# now.
157ln -s dbus.service %{buildroot}%{_unitdir}/messagebus.service
158
159## %find_lang %{gettext_package}
160# Delete the old legacy sysv init script
161rm -rf %{buildroot}%{_initrddir}
162%else
163rm -rf %{buildroot}%{_sysconfdir}/systemd
164install -Dm755 %{SOURCE2} %{buildroot}%{_initrddir}/messagebus
165%endif
166
167install --directory %{buildroot}/var/lib/dbus
168
169install --directory %{buildroot}%{_pkgdocdir}
170install -pm 644 -t %{buildroot}%{_pkgdocdir} \
171    doc/introspect.dtd doc/introspect.xsl doc/system-activation.txt
172
173# Make sure that the documentation shows up in Devhelp.
174install --directory %{buildroot}%{_datadir}/gtk-doc/html
175ln -s %{_pkgdocdir} %{buildroot}%{_datadir}/gtk-doc/html/dbus
176
177# Shell wrapper for installed tests, modified from Debian package.
178cat > dbus-run-installed-tests <<EOF
179#!/bin/sh
180# installed-tests wrapper for dbus. Outputs TAP format because why not
181
182set -e
183
184timeout="timeout 300s"
185ret=0
186i=0
187tmpdir=\$(mktemp --directory --tmpdir dbus-run-installed-tests.XXXXXX)
188
189for t in /%{_lib}/dbus-1/installed-tests/dbus/test-*; do
190    i=\$(( \$i + 1 ))
191    echo "# \$i - \$t ..."
192    echo "x" > "\$tmpdir/result"
193    ( set +e; \$timeout \$t; echo "\$?" > "\$tmpdir/result" ) 2>&1 | sed 's/^/#/'
194    e="\$(cat "\$tmpdir/result")"
195    case "\$e" in
196        (0)
197            echo "ok \$i - \$t"
198            ;;
199        (77)
200            echo "ok \$i # SKIP \$t"
201            ;;
202        (*)
203            echo "not ok \$i - \$t (\$e)"
204            ret=1
205            ;;
206    esac
207done
208
209rm -rf tmpdir
210echo "1..\$i"
211exit \$ret
212EOF
213
214install -pm 755 -t %{buildroot}/%{_lib}/dbus-1 dbus-run-installed-tests
215
216## vine stuff
217
218mkdir -p %{buildroot}%{_libdir}/cmake/DBus1
219mv -f \
220  %{buildroot}/%{_lib}/cmake/DBus1/DBus1Config.cmake \
221  %{buildroot}/%{_lib}/cmake/DBus1/DBus1ConfigVersion.cmake \
222  %{buildroot}%{_libdir}/cmake/DBus1/
223
224mkdir -p $RPM_BUILD_ROOT/%{_bindir}
225mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}/
226
227mkdir -p %{buildroot}/%{_libdir}/dbus-1.0
228mv %{buildroot}/%{_lib}/dbus-1.0/include %{buildroot}/%{_libdir}/dbus-1.0/
229
230mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
231#change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
232sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
233rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
234
235rm -f $RPM_BUILD_ROOT/%{_lib}/dbus-1/dbus-run-installed-tests
236
237%clean
238rm -rf %{buildroot}
239
240%pre
241# Add the "dbus" user
242/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
243        -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
244
245%post
246/sbin/ldconfig
247/sbin/chkconfig --add messagebus
248/sbin/chkconfig messagebus resetpriorities
249
250%preun
251if [ $1 = 0 ]; then
252    service messagebus stop > /dev/null 2>&1
253    /sbin/chkconfig --del messagebus
254fi
255
256%postun
257/sbin/ldconfig
258
259%post -n compat32-%{name} -p /sbin/ldconfig
260
261%postun -n compat32-%{name} -p /sbin/ldconfig
262
263%files
264%defattr(-,root,root)
265%{!?_licensedir:%global license %%doc}
266%license COPYING
267%doc AUTHORS ChangeLog NEWS README
268%dir %{_sysconfdir}/dbus-1
269%config %{_sysconfdir}/dbus-1/*.conf
270%ghost %dir /run/%{name}
271%{_sysconfdir}/rc.d/init.d/*
272%dir %{_sysconfdir}/dbus-1/system.d
273%dir %{_sysconfdir}/dbus-1/session.d
274%dir %{_localstatedir}/run/dbus
275%dir %{_localstatedir}/lib/dbus/
276/bin/dbus-daemon
277/bin/dbus-send
278/bin/dbus-cleanup-sockets
279/bin/dbus-monitor
280/bin/dbus-run-session
281/bin/dbus-test-tool
282/bin/dbus-update-activation-environment
283/bin/dbus-uuidgen
284/%{_lib}/*dbus-1*.so.*
285%{_mandir}/man*/dbus-cleanup-sockets.1.gz
286%{_mandir}/man*/dbus-daemon.1.gz
287%{_mandir}/man*/dbus-monitor.1.gz
288%{_mandir}/man*/dbus-run-session.1.gz
289%{_mandir}/man*/dbus-send.1.gz
290%{_mandir}/man1/dbus-test-tool.1.gz
291%{_mandir}/man1/dbus-update-activation-environment.1.gz
292%{_mandir}/man*/dbus-uuidgen.1.gz
293%dir %{_datadir}/dbus-1
294%{_datadir}/dbus-1/session.conf
295%{_datadir}/dbus-1/system.conf
296%{_datadir}/dbus-1/services
297%{_datadir}/dbus-1/system-services
298%{_datadir}/dbus-1/interfaces
299%dir /%{_lib}/dbus-1
300%attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
301
302%files devel
303%defattr(-,root,root)
304/%{_lib}/lib*.so
305%{_libdir}/dbus-1.0/include
306%{_libdir}/pkgconfig/*
307%{_includedir}/*
308%dir %{_libdir}/cmake/DBus1
309%{_libdir}/cmake/DBus1/*
310%dir %{_datadir}/xml
311%dir %{_datadir}/xml/dbus-1
312%{_datadir}/xml/dbus-1/*
313
314%files x11
315%defattr(-,root,root)
316%{_bindir}/dbus-launch
317%{_datadir}/man/man*/dbus-launch.1.gz
318%{_sysconfdir}/X11/xinit/xinitrc.d/00-start-message-bus.sh
319
320%files doc
321%defattr(-,root,root)
322%{_pkgdocdir}/*
323%{_datadir}/gtk-doc
324%exclude %{_pkgdocdir}/AUTHORS
325%exclude %{_pkgdocdir}/ChangeLog
326%exclude %{_pkgdocdir}/NEWS
327%exclude %{_pkgdocdir}/README
328
329# compat32
330%if %{build_compat32}
331%files -n compat32-%{name}
332/%{_lib}/*dbus-1*.so.*
333
334%files -n compat32-%{name}-devel
335%defattr(-,root,root)
336/%{_lib}/lib*.so
337%{_libdir}/dbus-1.0/include
338%endif
339
340%changelog
341* Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.12.12-1
342- new upstream release.
343- added elogind support.
344
345* Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.22-1
346- new upstream release.
347
348* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.20-1
349- new upstream release
350
351* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.18-1
352- new upstream release
353
354* Sun Mar 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.16-1
355- new upstream release
356
357* Sat Jan 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.14-1
358- new upstream release
359
360* Mon Dec 01 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.28-1
361- new upstream release
362
363* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.24-1
364- new upstream release
365
366* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.22-1
367- new upstream release
368
369* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.20-1
370- new upstream release
371
372* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.18-1
373- new upstream release
374
375* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
376- new upstream release
377
378* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
379- new upstream release
380
381* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-2
382- remove BuildRequires: audit-libs-devel, libcap-ng-devel
383
384* Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
385- new upstream release
386- remove old patches
387
388* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.20-1
389- new upstream release
390- add BuildRequires: audit-libs-devel, libcap-ng-devel
391
392* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.18-1
393- new upstream release
394- remove Requires: libxml2-python
395
396* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.16-1
397- new upstream release
398
399* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
400- new upstream release
401- drop Patch1
402- create -doc sub package
403
404* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
405- new upstream release
406
407* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
408- new upstream release
409
410* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
411- add BuildRequires: libSM-devel
412
413* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
414- rebuilt with rpm-4.8.1
415
416* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
417- new upstream release
418- drop Patch0
419
420* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
421- rebuilt with new toolchain
422
423* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
424- new upstream release
425
426* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
427- new upstream release
428- do not restart dbus on upgrade
429
430* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
431- added compat32 package for x86_64 arch support
432
433* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
434- add Patch10 for workaround deny send_interface
435  http://bugs.freedesktop.org/show_bug.cgi?id=18961
436  Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
437  Bare <deny send_interface=""/> rules have a far larger impact than one would think.
438  It's really always wrong to use them without also using send_destination.
439  - XXX: this should be fixed in each dbus configuration.
440
441* Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
442- new upstream release with security fix (CVE-2008-4311)
443
444* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
445- new upstream release with security fix (CVE-2008-3834)
446
447* Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
448- new upstream release
449
450* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
451- own the directories /usr/share/dbus-1/{system-services,interfaces}
452- set 'dbus' instead of '81' to --with-dbus-user
453 
454* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
455- import some patches from fedora
456- move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
457
458* Wed May  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
459- new upstream release
460
461* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
462- new upstream release
463
464* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
465- rebuild with expat-2.0.1
466
467* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
468- rebuild with new environment/toolchain
469
470* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
471- require new chkconfig to reset initscript priorities
472
473* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
474- new upstream release
475- split out bindings
476- move base binaries and libraries to /bin and /%{_lib}
477
478* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
479- rebuilt for VineSeed
480
481* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
482- add Vendor/Distribution tag
483
484* Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
485- add patch100 for fix CVE-2006-6107
486
487* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
488- new upstream release
489
490* Sat Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
491- disabled dbus-qt
492- added BuildConflicts: qt-devel
493- removed work around for 64 bit archs
494
495* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
496- new upstream release
497
498* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
499- new upstream release
500
501* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
502- new upstream release
503
504* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
505- new upstream release
506- enable python bindings
507
508* Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
509- initial build for Vine Linux based on FC package
510- disable python bindings
511- disable selinux
512
513* Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
514- Explicitly pass in the pid file location to ./configure instead of
515  letting it guess based on the build enviornment
516
517* Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
518- Add patch to fix random users from connecting to a users session bus
519
520* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
521- Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
522
523* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
524- Update to upstream version 0.23
525- Drop all patches except for the UDI patch as they have been
526  integrated upstream
527- List of API changes:
528      * add setgroups() to drop supplementary groups
529      * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
530      * added support for int64 and uint64 to the python bindings
531      * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
532
533* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
534- rebuild against python 2.4
535
536* Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
537- Add a requires for glib2-devel in the devel package
538- Add SE-Linux backport from Colin Walters that fixes
539  messages getting lost in SE-Linux contexts
540
541* Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
542- Bump up release and rebuild
543
544* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
545- Run /sbin/ldconfig for glib sub-package (bug #134062).
546
547* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
548- Fixed patch to use dbus-1 instead of dbus-1.0
549- (configure.in): Exported just the datadir instead of
550  the full path to the dbus datadir for consistency
551
552* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
553- Adding patch to move /usr/lib/dbus-1.0/services to
554  /usr/share/dbus-1.0/services
555
556* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
557- reverting BuildRequires: redhat-release because of issues with build system
558- added precompiled version of the messagebus init script
559
560* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
561- changed /etc/redhat-release to the package redhat-release
562
563* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
564- added python int64 patch from davidz
565
566* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
567- added BuildRequires: /etc/redhat-release (RH Bug #132436)
568
569* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
570- Added Steve Grubb's spec file patch (RH Bug #130201)
571
572* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
573- Disabled dbus-gtk since dbus-viewer doesn't do anything right now
574
575* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
576- Moved dbus-viewer to new dbus-gtk package so that dbus-glib
577  no longer requires X or GTK libraries. (RH Bug #130029)
578
579* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
580- Update to new 0.22 release
581
582* Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
583- Added BuildRequires for libselinux-devel and Requires for libselinux
584
585* Mon Aug 02 2004 Colin Walters <walters@redhat.com>
586- Add SE-DBus patch
587
588* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
589- Added lib64 workaround for python bindings installing to
590  the wrong lib directory on 64 bit archs
591
592* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
593- Updated console-auth patch
594- rebuild
595 
596* Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
597- Update to upstream CVS build
598- Added console-auth patch
599
600* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
601- Workaround added to fix gcc-3.4 bug on ia64
602
603* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
604- require new Pyrex version and see if it builds this time
605
606* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
607- rebuild with updated Pyrex (0.9.2.1)
608
609* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
610- rebuilt
611
612* Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
613- Moved dbus-viewer, dbus-monitor and dbus-glib-tool
614  into the dbus-glib package so that the main dbus
615  package does not depend on glib (Bug #125285)
616
617* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
618- rebuilt
619
620* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
621- added my Python patch
622- took out the qt build requires
623- added a gtk+ build requires
624
625* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
626- Changed build requirement to version 0.9-3 of Pyrex
627  to fix problem with builing on x86_64
628
629* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
630- update to upstream 0.21
631- removed dbus-0.20-varargs.patch patch (fixed upstream)
632
633* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
634- added a dbus-python package to generate python bindings
635- added Pyrex build dependacy
636
637* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
638- rebuilt
639
640* Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
641- fix dbus error functions on x86-64 (#116324)
642- add prereq (#112027)
643
644* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
645- rebuilt
646
647* Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
648- Conflict with cups prior to configuration file change, so that the
649  %%postun service condrestart works.
650
651* Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
652- rebuild in fc2, cups now updated
653
654* Wed Jan  7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
655- update to upstream 0.20
656
657* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
658- hmm, dbus doesn't support uids in the config file. fix.
659
660* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
661- put uid instead of username in the config file, to keep things working with name change
662
663* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
664- make subpackages require the specific release, not just version, of base package
665
666* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
667- change system user "messagebus" -> "dbus" to be under 8 chars
668
669* Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
670- see if removing qt subpackage for now will get us through the build system,
671  qt bindings not useful yet anyway
672
673* Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
674- 0.13 fixes a little security oops
675
676* Mon Aug  4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
677- break the tiny dbus-launch that depends on X into separate package
678  so a CUPS server doesn't need X installed
679
680* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
681- rebuilt
682
683* Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
684- 0.11.91 cvs snap properly merges system.d
685
686* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
687- build a cvs snap with a few more fixes
688
689* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
690- fix a crash that was breaking cups
691
692* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
693- 0.11
694
695* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
696- use rc.d/init.d not init.d, bug #90192
697- include the new man pages
698
699* Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
700- 0.9
701- export QTDIR explicitly
702- re-enable qt, the problem was most likely D-BUS configure
703
704* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
705- update from CVS with a fix to set uid after gid
706
707* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
708- new cvs snap that actually forks to background and changes
709  user it's running as and so forth
710- create our system user in pre
711
712* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
713- fix for "make check" test that required a home directory
714
715* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
716- disable qt for now because beehive hates me
717- pull a slightly newer cvs snap that creates socket directory
718- cat the make check log after make check fails
719
720* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
721- initial build
722
Note: See TracBrowser for help on using the repository browser.