source: projects/specs/trunk/d/dbus/dbus-vl.spec @ 7981

Revision 7981, 19.0 KB checked in by Takemikaduchi, 11 years ago (diff)

new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gettext_package dbus
4%define expat_version           2.0.1
5%define dbus_user_uid           81
6
7%define _localstatedir %{_var}
8
9Summary: D-BUS message bus
10Summary(ja): D-BUS メッセージバスシステム
11Name: dbus
12Version: 1.6.18
13Release: 1%{?_dist_release}
14URL: http://www.freedesktop.org/software/dbus/
15License: AFL/GPLv2
16Group: System Environment/Libraries
17
18Source0: %{name}-%{version}.tar.gz
19Source1: doxygen_to_devhelp.xsl
20
21# from fedora package
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24Requires(post): chkconfig >= 1.3.34
25Requires(preun): chkconfig >= 1.3.34
26Requires(pre): shadow-utils
27BuildRequires: libtool
28BuildRequires: expat-devel >= %{expat_version}
29BuildRequires: libxml2-devel
30BuildRequires: python-devel
31BuildRequires: doxygen
32BuildRequires: xmlto
33BuildRequires: libxslt
34BuildRequires: gettext
35BuildRequires: libX11-devel
36BuildRequires: libSM-devel
37
38Vendor: Project Vine
39Distribution: Vine Linux
40
41%description
42D-BUS is a system for sending messages between applications. It is
43used both for the systemwide message bus service, and as a
44per-user-login-session messaging facility.
45
46%description -l ja
47D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
48システム全体のメッセージバスサービスとしても利用されますが、同様に
49ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
50
51%package devel
52Summary: Libraries and headers for D-BUS
53Summary(ja): D-BUS 用のライブラリとヘッダファイル
54Group: Development/Libraries
55Requires: %{name} = %{version}-%{release}
56
57%description devel
58Headers and static libraries for D-BUS.
59
60%package x11
61Summary: X11-requiring add-ons for D-BUS
62Summary(ja): X11 を利用する D-BUS 用ツール
63Group: Applications/System
64Requires: %{name} = %{version}-%{release}
65
66%description x11
67D-BUS contains some tools that require Xlib to be installed, those are
68in this separate package so server systems need not install X.
69
70%package doc
71Summary: Developer documentation for D-BUS
72Group: Documentation
73Requires: %{name} = %{version}-%{release}
74BuildArch: noarch
75
76%description doc
77This package contains developer documentation for D-Bus along with
78other supporting documentation such as the introspect dtd file.
79
80# compat32
81%package -n compat32-%{name}
82Summary: D-BUS message bus
83Summary(ja): D-BUS メッセージバスシステム
84Group: System Environment/Libraries
85
86%description -n compat32-%{name}
87D-BUS is a system for sending messages between applications. It is
88used both for the systemwide message bus service, and as a
89per-user-login-session messaging facility.
90
91%description -n compat32-%{name} -l ja
92D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
93システム全体のメッセージバスサービスとしても利用されますが、同様に
94ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
95
96%package -n compat32-%{name}-devel
97Summary: Libraries and headers for D-BUS
98Summary(ja): D-BUS 用のライブラリとヘッダファイル
99Group: Development/Libraries
100Requires: compat32-%{name} = %{version}-%{release}
101Requires: %{name}-devel = %{version}-%{release}
102
103%description -n compat32-%{name}-devel
104Headers and static libraries for D-BUS.
105
106%prep
107%setup -q
108
109%build
110autoreconf -f -i
111
112COMMON_ARGS="--enable-selinux=no \
113                --disable-libaudit \
114                --with-init-scripts=redhat \
115                --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
116                --with-dbus-user=dbus \
117                --libdir=/%{_lib} --bindir=/bin \
118                --libexecdir=/%{_lib}/dbus-1 \
119                --sysconfdir=%{_sysconfdir} --exec-prefix=/"
120
121%configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
122%__make
123
124doxygen Doxyfile
125
126xsltproc -o dbus.devhelp %{SOURCE1} doc/api/xml/index.xml
127
128%install
129rm -rf %{buildroot}
130
131%__make install DESTDIR=$RPM_BUILD_ROOT
132
133mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
134
135#change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
136sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
137rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
138
139mkdir -p $RPM_BUILD_ROOT/%{_bindir}
140mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}
141mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
142mv -f $RPM_BUILD_ROOT/%{_lib}/dbus-1.0/include/* $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
143rm -rf $RPM_BUILD_ROOT/%{_lib}/dbus-1.0
144
145rm -f $RPM_BUILD_ROOT/%{_lib}/*.a
146rm -f $RPM_BUILD_ROOT/%{_lib}/*.la
147
148mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
149mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
150
151cp dbus.devhelp $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
152cp doc/dbus-specification.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
153cp doc/dbus-faq.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
154cp doc/dbus-tutorial.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
155cp doc/api/html/* $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
156
157## %find_lang %{gettext_package}
158
159mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/interfaces
160
161%clean
162rm -rf %{buildroot}
163
164%pre
165# Add the "dbus" user
166/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
167        -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
168
169%post
170/sbin/ldconfig
171/sbin/chkconfig --add messagebus
172/sbin/chkconfig messagebus resetpriorities
173
174%preun
175if [ $1 = 0 ]; then
176    service messagebus stop > /dev/null 2>&1
177    /sbin/chkconfig --del messagebus
178fi
179
180%postun
181/sbin/ldconfig
182
183%post -n compat32-%{name} -p /sbin/ldconfig
184
185%postun -n compat32-%{name} -p /sbin/ldconfig
186
187%files
188%defattr(-,root,root)
189%doc COPYING ChangeLog NEWS
190%dir %{_sysconfdir}/dbus-1
191%config %{_sysconfdir}/dbus-1/*.conf
192%{_sysconfdir}/rc.d/init.d/*
193%dir %{_sysconfdir}/dbus-1/system.d
194%dir %{_sysconfdir}/dbus-1/session.d
195%dir %{_localstatedir}/run/dbus
196%dir %{_localstatedir}/lib/dbus/
197/bin/dbus-daemon
198/bin/dbus-send
199/bin/dbus-cleanup-sockets
200/bin/dbus-monitor
201/bin/dbus-uuidgen
202/%{_lib}/*dbus-1*.so.*
203%{_datadir}/man/man*/dbus-cleanup-sockets.1.gz
204%{_datadir}/man/man*/dbus-daemon.1.gz
205%{_datadir}/man/man*/dbus-monitor.1.gz
206%{_datadir}/man/man*/dbus-send.1.gz
207%{_datadir}/man/man*/dbus-uuidgen.1.gz
208%dir %{_datadir}/dbus-1
209%{_datadir}/dbus-1/services
210%{_datadir}/dbus-1/system-services
211%{_datadir}/dbus-1/interfaces
212%dir /%{_lib}/dbus-1
213%attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
214
215%files devel
216%defattr(-,root,root)
217/%{_lib}/lib*.so
218%{_libdir}/dbus-1.0/include
219%{_libdir}/pkgconfig/*
220%{_includedir}/*
221%{_datadir}/devhelp/books/dbus
222
223%files x11
224%defattr(-,root,root)
225%{_bindir}/dbus-launch
226%{_datadir}/man/man*/dbus-launch.1.gz
227
228%files doc
229%defattr(-,root,root)
230%doc %{_docdir}/dbus
231
232# compat32
233%if %{build_compat32}
234%files -n compat32-%{name}
235/%{_lib}/*dbus-1*.so.*
236
237%files -n compat32-%{name}-devel
238%defattr(-,root,root)
239/%{_lib}/lib*.so
240%{_libdir}/dbus-1.0/include
241%endif
242
243%changelog
244* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.18-1
245- new upstream release
246
247* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
248- new upstream release
249
250* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
251- new upstream release
252
253* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-2
254- remove BuildRequires: audit-libs-devel, libcap-ng-devel
255
256* Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
257- new upstream release
258- remove old patches
259
260* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.20-1
261- new upstream release
262- add BuildRequires: audit-libs-devel, libcap-ng-devel
263
264* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.18-1
265- new upstream release
266- remove Requires: libxml2-python
267
268* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.16-1
269- new upstream release
270
271* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
272- new upstream release
273- drop Patch1
274- create -doc sub package
275
276* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
277- new upstream release
278
279* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
280- new upstream release
281
282* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
283- add BuildRequires: libSM-devel
284
285* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
286- rebuilt with rpm-4.8.1
287
288* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
289- new upstream release
290- drop Patch0
291
292* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
293- rebuilt with new toolchain
294
295* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
296- new upstream release
297
298* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
299- new upstream release
300- do not restart dbus on upgrade
301
302* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
303- added compat32 package for x86_64 arch support
304
305* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
306- add Patch10 for workaround deny send_interface
307  http://bugs.freedesktop.org/show_bug.cgi?id=18961
308  Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
309  Bare <deny send_interface=""/> rules have a far larger impact than one would think.
310  It's really always wrong to use them without also using send_destination.
311  - XXX: this should be fixed in each dbus configuration.
312
313* Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
314- new upstream release with security fix (CVE-2008-4311)
315
316* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
317- new upstream release with security fix (CVE-2008-3834)
318
319* Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
320- new upstream release
321
322* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
323- own the directories /usr/share/dbus-1/{system-services,interfaces}
324- set 'dbus' instead of '81' to --with-dbus-user
325 
326* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
327- import some patches from fedora
328- move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
329
330* Wed May  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
331- new upstream release
332
333* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
334- new upstream release
335
336* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
337- rebuild with expat-2.0.1
338
339* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
340- rebuild with new environment/toolchain
341
342* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
343- require new chkconfig to reset initscript priorities
344
345* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
346- new upstream release
347- split out bindings
348- move base binaries and libraries to /bin and /%{_lib}
349
350* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
351- rebuilt for VineSeed
352
353* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
354- add Vendor/Distribution tag
355
356* Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
357- add patch100 for fix CVE-2006-6107
358
359* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
360- new upstream release
361
362* Sat Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
363- disabled dbus-qt
364- added BuildConflicts: qt-devel
365- removed work around for 64 bit archs
366
367* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
368- new upstream release
369
370* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
371- new upstream release
372
373* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
374- new upstream release
375
376* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
377- new upstream release
378- enable python bindings
379
380* Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
381- initial build for Vine Linux based on FC package
382- disable python bindings
383- disable selinux
384
385* Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
386- Explicitly pass in the pid file location to ./configure instead of
387  letting it guess based on the build enviornment
388
389* Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
390- Add patch to fix random users from connecting to a users session bus
391
392* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
393- Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
394
395* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
396- Update to upstream version 0.23
397- Drop all patches except for the UDI patch as they have been
398  integrated upstream
399- List of API changes:
400      * add setgroups() to drop supplementary groups
401      * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
402      * added support for int64 and uint64 to the python bindings
403      * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
404
405* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
406- rebuild against python 2.4
407
408* Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
409- Add a requires for glib2-devel in the devel package
410- Add SE-Linux backport from Colin Walters that fixes
411  messages getting lost in SE-Linux contexts
412
413* Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
414- Bump up release and rebuild
415
416* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
417- Run /sbin/ldconfig for glib sub-package (bug #134062).
418
419* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
420- Fixed patch to use dbus-1 instead of dbus-1.0
421- (configure.in): Exported just the datadir instead of
422  the full path to the dbus datadir for consistency
423
424* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
425- Adding patch to move /usr/lib/dbus-1.0/services to
426  /usr/share/dbus-1.0/services
427
428* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
429- reverting BuildRequires: redhat-release because of issues with build system
430- added precompiled version of the messagebus init script
431
432* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
433- changed /etc/redhat-release to the package redhat-release
434
435* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
436- added python int64 patch from davidz
437
438* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
439- added BuildRequires: /etc/redhat-release (RH Bug #132436)
440
441* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
442- Added Steve Grubb's spec file patch (RH Bug #130201)
443
444* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
445- Disabled dbus-gtk since dbus-viewer doesn't do anything right now
446
447* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
448- Moved dbus-viewer to new dbus-gtk package so that dbus-glib
449  no longer requires X or GTK libraries. (RH Bug #130029)
450
451* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
452- Update to new 0.22 release
453
454* Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
455- Added BuildRequires for libselinux-devel and Requires for libselinux
456
457* Mon Aug 02 2004 Colin Walters <walters@redhat.com>
458- Add SE-DBus patch
459
460* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
461- Added lib64 workaround for python bindings installing to
462  the wrong lib directory on 64 bit archs
463
464* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
465- Updated console-auth patch
466- rebuild
467 
468* Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
469- Update to upstream CVS build
470- Added console-auth patch
471
472* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
473- Workaround added to fix gcc-3.4 bug on ia64
474
475* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
476- require new Pyrex version and see if it builds this time
477
478* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
479- rebuild with updated Pyrex (0.9.2.1)
480
481* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
482- rebuilt
483
484* Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
485- Moved dbus-viewer, dbus-monitor and dbus-glib-tool
486  into the dbus-glib package so that the main dbus
487  package does not depend on glib (Bug #125285)
488
489* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
490- rebuilt
491
492* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
493- added my Python patch
494- took out the qt build requires
495- added a gtk+ build requires
496
497* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
498- Changed build requirement to version 0.9-3 of Pyrex
499  to fix problem with builing on x86_64
500
501* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
502- update to upstream 0.21
503- removed dbus-0.20-varargs.patch patch (fixed upstream)
504
505* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
506- added a dbus-python package to generate python bindings
507- added Pyrex build dependacy
508
509* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
510- rebuilt
511
512* Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
513- fix dbus error functions on x86-64 (#116324)
514- add prereq (#112027)
515
516* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
517- rebuilt
518
519* Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
520- Conflict with cups prior to configuration file change, so that the
521  %%postun service condrestart works.
522
523* Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
524- rebuild in fc2, cups now updated
525
526* Wed Jan  7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
527- update to upstream 0.20
528
529* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
530- hmm, dbus doesn't support uids in the config file. fix.
531
532* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
533- put uid instead of username in the config file, to keep things working with name change
534
535* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
536- make subpackages require the specific release, not just version, of base package
537
538* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
539- change system user "messagebus" -> "dbus" to be under 8 chars
540
541* Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
542- see if removing qt subpackage for now will get us through the build system,
543  qt bindings not useful yet anyway
544
545* Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
546- 0.13 fixes a little security oops
547
548* Mon Aug  4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
549- break the tiny dbus-launch that depends on X into separate package
550  so a CUPS server doesn't need X installed
551
552* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
553- rebuilt
554
555* Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
556- 0.11.91 cvs snap properly merges system.d
557
558* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
559- build a cvs snap with a few more fixes
560
561* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
562- fix a crash that was breaking cups
563
564* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
565- 0.11
566
567* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
568- use rc.d/init.d not init.d, bug #90192
569- include the new man pages
570
571* Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
572- 0.9
573- export QTDIR explicitly
574- re-enable qt, the problem was most likely D-BUS configure
575
576* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
577- update from CVS with a fix to set uid after gid
578
579* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
580- new cvs snap that actually forks to background and changes
581  user it's running as and so forth
582- create our system user in pre
583
584* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
585- fix for "make check" test that required a home directory
586
587* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
588- disable qt for now because beehive hates me
589- pull a slightly newer cvs snap that creates socket directory
590- cat the make check log after make check fails
591
592* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
593- initial build
594
Note: See TracBrowser for help on using the repository browser.