source: projects/specs/trunk/d/dbus/dbus-vl.spec @ 6890

Revision 6890, 18.8 KB checked in by Takemikaduchi, 12 years ago (diff)

GNOME-3.6.0 & Cinnamon-1.6.1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gettext_package dbus
4%define expat_version           2.0.1
5%define dbus_user_uid           81
6
7%define _localstatedir %{_var}
8
9Summary: D-BUS message bus
10Summary(ja): D-BUS メッセージバスシステム
11Name: dbus
12Version: 1.6.8
13Release: 1%{?_dist_release}
14URL: http://www.freedesktop.org/software/dbus/
15License: AFL/GPLv2
16Group: System Environment/Libraries
17
18Source0: %{name}-%{version}.tar.gz
19Source1: doxygen_to_devhelp.xsl
20
21# from fedora package
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24Requires(post): chkconfig >= 1.3.34
25Requires(preun): chkconfig >= 1.3.34
26Requires(pre): shadow-utils
27BuildRequires: libtool
28BuildRequires: expat-devel >= %{expat_version}
29BuildRequires: libxml2-devel
30BuildRequires: python-devel
31BuildRequires: doxygen
32BuildRequires: xmlto
33BuildRequires: libxslt
34BuildRequires: gettext
35BuildRequires: libX11-devel
36BuildRequires: audit-libs-devel
37BuildRequires: libcap-ng-devel
38BuildRequires: libSM-devel
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%description
44D-BUS is a system for sending messages between applications. It is
45used both for the systemwide message bus service, and as a
46per-user-login-session messaging facility.
47
48%description -l ja
49D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
50システム全体のメッセージバスサービスとしても利用されますが、同様に
51ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
52
53%package devel
54Summary: Libraries and headers for D-BUS
55Summary(ja): D-BUS 用のライブラリとヘッダファイル
56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
58
59%description devel
60Headers and static libraries for D-BUS.
61
62%package x11
63Summary: X11-requiring add-ons for D-BUS
64Summary(ja): X11 を利用する D-BUS 用ツール
65Group: Applications/System
66Requires: %{name} = %{version}-%{release}
67
68%description x11
69D-BUS contains some tools that require Xlib to be installed, those are
70in this separate package so server systems need not install X.
71
72%package doc
73Summary: Developer documentation for D-BUS
74Group: Documentation
75Requires: %{name} = %{version}-%{release}
76BuildArch: noarch
77
78%description doc
79This package contains developer documentation for D-Bus along with
80other supporting documentation such as the introspect dtd file.
81
82# compat32
83%package -n compat32-%{name}
84Summary: D-BUS message bus
85Summary(ja): D-BUS メッセージバスシステム
86Group: System Environment/Libraries
87
88%description -n compat32-%{name}
89D-BUS is a system for sending messages between applications. It is
90used both for the systemwide message bus service, and as a
91per-user-login-session messaging facility.
92
93%description -n compat32-%{name} -l ja
94D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
95システム全体のメッセージバスサービスとしても利用されますが、同様に
96ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
97
98%package -n compat32-%{name}-devel
99Summary: Libraries and headers for D-BUS
100Summary(ja): D-BUS 用のライブラリとヘッダファイル
101Group: Development/Libraries
102Requires: compat32-%{name} = %{version}-%{release}
103Requires: %{name}-devel = %{version}-%{release}
104
105%description -n compat32-%{name}-devel
106Headers and static libraries for D-BUS.
107
108%prep
109%setup -q
110
111%build
112autoreconf -f -i
113
114COMMON_ARGS="--enable-selinux=no \
115             --enable-libaudit \
116             --with-init-scripts=redhat \
117             --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
118             --with-dbus-user=dbus \
119             --libdir=/%{_lib} --bindir=/bin \
120             --libexecdir=/%{_lib}/dbus-1 \
121             --sysconfdir=%{_sysconfdir} --exec-prefix=/"
122
123%configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
124%__make
125
126doxygen Doxyfile
127
128xsltproc -o dbus.devhelp %{SOURCE1} doc/api/xml/index.xml
129
130%install
131rm -rf %{buildroot}
132
133%__make install DESTDIR=$RPM_BUILD_ROOT
134
135mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
136
137#change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
138sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
139rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
140
141mkdir -p $RPM_BUILD_ROOT/%{_bindir}
142mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}
143mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
144mv -f $RPM_BUILD_ROOT/%{_lib}/dbus-1.0/include/* $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
145rm -rf $RPM_BUILD_ROOT/%{_lib}/dbus-1.0
146
147rm -f $RPM_BUILD_ROOT/%{_lib}/*.a
148rm -f $RPM_BUILD_ROOT/%{_lib}/*.la
149
150mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
151mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
152
153cp dbus.devhelp $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
154cp doc/dbus-specification.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
155cp doc/dbus-faq.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
156cp doc/dbus-tutorial.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
157cp doc/api/html/* $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
158
159## %find_lang %{gettext_package}
160
161mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/interfaces
162
163%clean
164rm -rf %{buildroot}
165
166%pre
167# Add the "dbus" user
168/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
169        -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
170
171%post
172/sbin/ldconfig
173/sbin/chkconfig --add messagebus
174/sbin/chkconfig messagebus resetpriorities
175
176%preun
177if [ $1 = 0 ]; then
178    service messagebus stop > /dev/null 2>&1
179    /sbin/chkconfig --del messagebus
180fi
181
182%postun
183/sbin/ldconfig
184
185%post -n compat32-%{name} -p /sbin/ldconfig
186
187%postun -n compat32-%{name} -p /sbin/ldconfig
188
189%files
190%defattr(-,root,root)
191%doc COPYING ChangeLog NEWS
192%dir %{_sysconfdir}/dbus-1
193%config %{_sysconfdir}/dbus-1/*.conf
194%{_sysconfdir}/rc.d/init.d/*
195%dir %{_sysconfdir}/dbus-1/system.d
196%dir %{_sysconfdir}/dbus-1/session.d
197%dir %{_localstatedir}/run/dbus
198%dir %{_localstatedir}/lib/dbus/
199/bin/dbus-daemon
200/bin/dbus-send
201/bin/dbus-cleanup-sockets
202/bin/dbus-monitor
203/bin/dbus-uuidgen
204/%{_lib}/*dbus-1*.so.*
205%{_datadir}/man/man*/dbus-cleanup-sockets.1.gz
206%{_datadir}/man/man*/dbus-daemon.1.gz
207%{_datadir}/man/man*/dbus-monitor.1.gz
208%{_datadir}/man/man*/dbus-send.1.gz
209%{_datadir}/man/man*/dbus-uuidgen.1.gz
210%dir %{_datadir}/dbus-1
211%{_datadir}/dbus-1/services
212%{_datadir}/dbus-1/system-services
213%{_datadir}/dbus-1/interfaces
214%dir /%{_lib}/dbus-1
215%attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
216
217%files devel
218%defattr(-,root,root)
219/%{_lib}/lib*.so
220%{_libdir}/dbus-1.0/include
221%{_libdir}/pkgconfig/*
222%{_includedir}/*
223%{_datadir}/devhelp/books/dbus
224
225%files x11
226%defattr(-,root,root)
227%{_bindir}/dbus-launch
228%{_datadir}/man/man*/dbus-launch.1.gz
229
230%files doc
231%defattr(-,root,root)
232%doc %{_docdir}/dbus
233
234# compat32
235%if %{build_compat32}
236%files -n compat32-%{name}
237/%{_lib}/*dbus-1*.so.*
238
239%files -n compat32-%{name}-devel
240%defattr(-,root,root)
241/%{_lib}/lib*.so
242%{_libdir}/dbus-1.0/include
243%endif
244
245%changelog
246* Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
247- new upstream release
248- remove old patches
249
250* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.20-1
251- new upstream release
252- add BuildRequires: audit-libs-devel, libcap-ng-devel
253
254* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.18-1
255- new upstream release
256- remove Requires: libxml2-python
257
258* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.16-1
259- new upstream release
260
261* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
262- new upstream release
263- drop Patch1
264- create -doc sub package
265
266* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
267- new upstream release
268
269* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
270- new upstream release
271
272* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
273- add BuildRequires: libSM-devel
274
275* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
276- rebuilt with rpm-4.8.1
277
278* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
279- new upstream release
280- drop Patch0
281
282* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
283- rebuilt with new toolchain
284
285* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
286- new upstream release
287
288* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
289- new upstream release
290- do not restart dbus on upgrade
291
292* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
293- added compat32 package for x86_64 arch support
294
295* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
296- add Patch10 for workaround deny send_interface
297  http://bugs.freedesktop.org/show_bug.cgi?id=18961
298  Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
299  Bare <deny send_interface=""/> rules have a far larger impact than one would think.
300  It's really always wrong to use them without also using send_destination.
301  - XXX: this should be fixed in each dbus configuration.
302
303* Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
304- new upstream release with security fix (CVE-2008-4311)
305
306* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
307- new upstream release with security fix (CVE-2008-3834)
308
309* Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
310- new upstream release
311
312* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
313- own the directories /usr/share/dbus-1/{system-services,interfaces}
314- set 'dbus' instead of '81' to --with-dbus-user
315 
316* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
317- import some patches from fedora
318- move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
319
320* Wed May  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
321- new upstream release
322
323* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
324- new upstream release
325
326* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
327- rebuild with expat-2.0.1
328
329* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
330- rebuild with new environment/toolchain
331
332* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
333- require new chkconfig to reset initscript priorities
334
335* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
336- new upstream release
337- split out bindings
338- move base binaries and libraries to /bin and /%{_lib}
339
340* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
341- rebuilt for VineSeed
342
343* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
344- add Vendor/Distribution tag
345
346* Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
347- add patch100 for fix CVE-2006-6107
348
349* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
350- new upstream release
351
352* Sun Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
353- disabled dbus-qt
354- added BuildConflicts: qt-devel
355- removed work around for 64 bit archs
356
357* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
358- new upstream release
359
360* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
361- new upstream release
362
363* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
364- new upstream release
365
366* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
367- new upstream release
368- enable python bindings
369
370* Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
371- initial build for Vine Linux based on FC package
372- disable python bindings
373- disable selinux
374
375* Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
376- Explicitly pass in the pid file location to ./configure instead of
377  letting it guess based on the build enviornment
378
379* Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
380- Add patch to fix random users from connecting to a users session bus
381
382* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
383- Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
384
385* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
386- Update to upstream version 0.23
387- Drop all patches except for the UDI patch as they have been
388  integrated upstream
389- List of API changes:
390      * add setgroups() to drop supplementary groups
391      * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
392      * added support for int64 and uint64 to the python bindings
393      * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
394
395* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
396- rebuild against python 2.4
397
398* Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
399- Add a requires for glib2-devel in the devel package
400- Add SE-Linux backport from Colin Walters that fixes
401  messages getting lost in SE-Linux contexts
402
403* Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
404- Bump up release and rebuild
405
406* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
407- Run /sbin/ldconfig for glib sub-package (bug #134062).
408
409* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
410- Fixed patch to use dbus-1 instead of dbus-1.0
411- (configure.in): Exported just the datadir instead of
412  the full path to the dbus datadir for consistency
413
414* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
415- Adding patch to move /usr/lib/dbus-1.0/services to
416  /usr/share/dbus-1.0/services
417
418* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
419- reverting BuildRequires: redhat-release because of issues with build system
420- added precompiled version of the messagebus init script
421
422* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
423- changed /etc/redhat-release to the package redhat-release
424
425* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
426- added python int64 patch from davidz
427
428* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
429- added BuildRequires: /etc/redhat-release (RH Bug #132436)
430
431* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
432- Added Steve Grubb's spec file patch (RH Bug #130201)
433
434* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
435- Disabled dbus-gtk since dbus-viewer doesn't do anything right now
436
437* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
438- Moved dbus-viewer to new dbus-gtk package so that dbus-glib
439  no longer requires X or GTK libraries. (RH Bug #130029)
440
441* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
442- Update to new 0.22 release
443
444* Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
445- Added BuildRequires for libselinux-devel and Requires for libselinux
446
447* Tue Aug 02 2004 Colin Walters <walters@redhat.com>
448- Add SE-DBus patch
449
450* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
451- Added lib64 workaround for python bindings installing to
452  the wrong lib directory on 64 bit archs
453
454* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
455- Updated console-auth patch
456- rebuild
457 
458* Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
459- Update to upstream CVS build
460- Added console-auth patch
461
462* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
463- Workaround added to fix gcc-3.4 bug on ia64
464
465* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
466- require new Pyrex version and see if it builds this time
467
468* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
469- rebuild with updated Pyrex (0.9.2.1)
470
471* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
472- rebuilt
473
474* Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
475- Moved dbus-viewer, dbus-monitor and dbus-glib-tool
476  into the dbus-glib package so that the main dbus
477  package does not depend on glib (Bug #125285)
478
479* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
480- rebuilt
481
482* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
483- added my Python patch
484- took out the qt build requires
485- added a gtk+ build requires
486
487* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
488- Changed build requirement to version 0.9-3 of Pyrex
489  to fix problem with builing on x86_64
490
491* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
492- update to upstream 0.21
493- removed dbus-0.20-varargs.patch patch (fixed upstream)
494
495* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
496- added a dbus-python package to generate python bindings
497- added Pyrex build dependacy
498
499* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
500- rebuilt
501
502* Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
503- fix dbus error functions on x86-64 (#116324)
504- add prereq (#112027)
505
506* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
507- rebuilt
508
509* Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
510- Conflict with cups prior to configuration file change, so that the
511  %%postun service condrestart works.
512
513* Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
514- rebuild in fc2, cups now updated
515
516* Wed Jan  7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
517- update to upstream 0.20
518
519* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
520- hmm, dbus doesn't support uids in the config file. fix.
521
522* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
523- put uid instead of username in the config file, to keep things working with name change
524
525* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
526- make subpackages require the specific release, not just version, of base package
527
528* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
529- change system user "messagebus" -> "dbus" to be under 8 chars
530
531* Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
532- see if removing qt subpackage for now will get us through the build system,
533  qt bindings not useful yet anyway
534
535* Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
536- 0.13 fixes a little security oops
537
538* Mon Aug  4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
539- break the tiny dbus-launch that depends on X into separate package
540  so a CUPS server doesn't need X installed
541
542* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
543- rebuilt
544
545* Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
546- 0.11.91 cvs snap properly merges system.d
547
548* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
549- build a cvs snap with a few more fixes
550
551* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
552- fix a crash that was breaking cups
553
554* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
555- 0.11
556
557* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
558- use rc.d/init.d not init.d, bug #90192
559- include the new man pages
560
561* Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
562- 0.9
563- export QTDIR explicitly
564- re-enable qt, the problem was most likely D-BUS configure
565
566* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
567- update from CVS with a fix to set uid after gid
568
569* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
570- new cvs snap that actually forks to background and changes
571  user it's running as and so forth
572- create our system user in pre
573
574* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
575- fix for "make check" test that required a home directory
576
577* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
578- disable qt for now because beehive hates me
579- pull a slightly newer cvs snap that creates socket directory
580- cat the make check log after make check fails
581
582* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
583- initial build
584
Note: See TracBrowser for help on using the repository browser.