source: projects/specs/trunk/d/dbus/dbus-vl.spec @ 5701

Revision 5701, 18.9 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gettext_package dbus
4%define expat_version           2.0.1
5%define pyrex_version           0.9.9
6%define dbus_user_uid           81
7
8%define _localstatedir %{_var}
9
10Summary: D-BUS message bus
11Summary(ja): D-BUS メッセージバスシステム
12Name: dbus
13Version: 1.4.18
14Release: 1%{?_dist_release}
15URL: http://www.freedesktop.org/software/dbus/
16License: AFL/GPLv2
17Group: System Environment/Libraries
18
19Source0: %{name}-%{version}.tar.gz
20Source1: doxygen_to_devhelp.xsl
21
22# from fedora package
23Patch0: dbus-0.60-start-early.patch
24Patch1: dbus-1.0.1-generate-xml-docs.patch
25Patch6: dbus-1.2.1-increase-timeout.patch
26
27# Workaround for deny send_interface
28# http://bugs.freedesktop.org/show_bug.cgi?id=18961
29Patch10: dbus-1.2.12-workaround-deny-sendinterface.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32Requires(post): chkconfig >= 1.3.34
33Requires(preun): chkconfig >= 1.3.34
34Requires(pre): shadow-utils
35BuildRequires: libtool
36BuildRequires: expat-devel >= %{expat_version}
37BuildRequires: libxml2-devel
38BuildRequires: python-pyrex >= %{pyrex_version}
39BuildRequires: doxygen
40BuildRequires: xmlto
41BuildRequires: libxslt
42BuildRequires: gettext
43BuildRequires: libX11-devel
44BuildRequires: libcap
45BuildRequires: libSM-devel
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51D-BUS is a system for sending messages between applications. It is
52used both for the systemwide message bus service, and as a
53per-user-login-session messaging facility.
54
55%description -l ja
56D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
57システム全体のメッセージバスサービスとしても利用されますが、同様に
58ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
59
60%package devel
61Summary: Libraries and headers for D-BUS
62Summary(ja): D-BUS 用のライブラリとヘッダファイル
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65
66%description devel
67Headers and static libraries for D-BUS.
68
69%package x11
70Summary: X11-requiring add-ons for D-BUS
71Summary(ja): X11 を利用する D-BUS 用ツール
72Group: Applications/System
73Requires: %{name} = %{version}-%{release}
74
75%description x11
76D-BUS contains some tools that require Xlib to be installed, those are
77in this separate package so server systems need not install X.
78
79%package doc
80Summary: Developer documentation for D-BUS
81Group: Documentation
82Requires: %{name} = %{version}-%{release}
83BuildArch: noarch
84
85%description doc
86This package contains developer documentation for D-Bus along with
87other supporting documentation such as the introspect dtd file.
88
89# compat32
90%package -n compat32-%{name}
91Summary: D-BUS message bus
92Summary(ja): D-BUS メッセージバスシステム
93Group: System Environment/Libraries
94
95%description -n compat32-%{name}
96D-BUS is a system for sending messages between applications. It is
97used both for the systemwide message bus service, and as a
98per-user-login-session messaging facility.
99
100%description -n compat32-%{name} -l ja
101D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
102システム全体のメッセージバスサービスとしても利用されますが、同様に
103ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
104
105%package -n compat32-%{name}-devel
106Summary: Libraries and headers for D-BUS
107Summary(ja): D-BUS 用のライブラリとヘッダファイル
108Group: Development/Libraries
109Requires: compat32-%{name} = %{version}-%{release}
110Requires: %{name}-devel = %{version}-%{release}
111
112%description -n compat32-%{name}-devel
113Headers and static libraries for D-BUS.
114
115%prep
116%setup -q
117## %patch0 -p1 -b .start-early
118## %patch1 -p1 -b .generate-xml-docs
119%patch6 -p1 -b .increase-timeout
120
121%patch10 -p1 -b .workaround-dbus-sendinterface
122
123%build
124autoreconf -f -i
125
126COMMON_ARGS="--enable-selinux=no \
127             --with-init-scripts=redhat \
128             --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
129             --with-dbus-user=dbus \
130             --libdir=/%{_lib} --bindir=/bin \
131             --libexecdir=/%{_lib}/dbus-1 \
132             --sysconfdir=%{_sysconfdir} --exec-prefix=/"
133
134%configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
135%__make
136
137doxygen Doxyfile
138
139xsltproc -o dbus.devhelp %{SOURCE1} doc/api/xml/index.xml
140
141%install
142rm -rf %{buildroot}
143
144%__make install DESTDIR=$RPM_BUILD_ROOT
145
146mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
147
148#change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
149sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
150rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
151
152mkdir -p $RPM_BUILD_ROOT/%{_bindir}
153mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}
154mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
155mv -f $RPM_BUILD_ROOT/%{_lib}/dbus-1.0/include/* $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
156rm -rf $RPM_BUILD_ROOT/%{_lib}/dbus-1.0
157
158rm -f $RPM_BUILD_ROOT/%{_lib}/*.a
159rm -f $RPM_BUILD_ROOT/%{_lib}/*.la
160
161mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
162mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
163
164cp dbus.devhelp $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
165cp doc/dbus-specification.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
166cp doc/dbus-faq.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
167cp doc/dbus-tutorial.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
168cp doc/api/html/* $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
169
170## %find_lang %{gettext_package}
171
172mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/interfaces
173
174%clean
175rm -rf %{buildroot}
176
177%pre
178# Add the "dbus" user
179/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
180        -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
181
182%post
183/sbin/ldconfig
184/sbin/chkconfig --add messagebus
185/sbin/chkconfig messagebus resetpriorities
186
187%preun
188if [ $1 = 0 ]; then
189    service messagebus stop > /dev/null 2>&1
190    /sbin/chkconfig --del messagebus
191fi
192
193%postun
194/sbin/ldconfig
195
196%post -n compat32-%{name} -p /sbin/ldconfig
197
198%postun -n compat32-%{name} -p /sbin/ldconfig
199
200%files
201%defattr(-,root,root)
202%doc COPYING ChangeLog NEWS
203%dir %{_sysconfdir}/dbus-1
204%config %{_sysconfdir}/dbus-1/*.conf
205%{_sysconfdir}/rc.d/init.d/*
206%dir %{_sysconfdir}/dbus-1/system.d
207%dir %{_sysconfdir}/dbus-1/session.d
208%dir %{_localstatedir}/run/dbus
209%dir %{_localstatedir}/lib/dbus/
210/bin/dbus-daemon
211/bin/dbus-send
212/bin/dbus-cleanup-sockets
213/bin/dbus-monitor
214/bin/dbus-uuidgen
215/%{_lib}/*dbus-1*.so.*
216%{_datadir}/man/man*/dbus-cleanup-sockets.1.gz
217%{_datadir}/man/man*/dbus-daemon.1.gz
218%{_datadir}/man/man*/dbus-monitor.1.gz
219%{_datadir}/man/man*/dbus-send.1.gz
220%{_datadir}/man/man*/dbus-uuidgen.1.gz
221%dir %{_datadir}/dbus-1
222%{_datadir}/dbus-1/services
223%{_datadir}/dbus-1/system-services
224%{_datadir}/dbus-1/interfaces
225%dir /%{_lib}/dbus-1
226%attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
227
228%files devel
229%defattr(-,root,root)
230/%{_lib}/lib*.so
231%{_libdir}/dbus-1.0/include
232%{_libdir}/pkgconfig/*
233%{_includedir}/*
234%{_datadir}/devhelp/books/dbus
235
236%files x11
237%defattr(-,root,root)
238%{_bindir}/dbus-launch
239%{_datadir}/man/man*/dbus-launch.1.gz
240
241%files doc
242%defattr(-,root,root)
243%doc %{_docdir}/dbus
244
245# compat32
246%if %{build_compat32}
247%files -n compat32-%{name}
248/%{_lib}/*dbus-1*.so.*
249
250%files -n compat32-%{name}-devel
251%defattr(-,root,root)
252/%{_lib}/lib*.so
253%{_libdir}/dbus-1.0/include
254%{_libdir}/pkgconfig/*
255%endif
256
257%changelog
258* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.18-1
259- new upstream release
260- remove Requires: libxml2-python
261
262* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.16-1
263- new upstream release
264
265* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
266- new upstream release
267- drop Patch1
268- create -doc sub package
269
270* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
271- new upstream release
272
273* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
274- new upstream release
275
276* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
277- add BuildRequires: libSM-devel
278
279* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
280- rebuilt with rpm-4.8.1
281
282* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
283- new upstream release
284- drop Patch0
285
286* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
287- rebuilt with new toolchain
288
289* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
290- new upstream release
291
292* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
293- new upstream release
294- do not restart dbus on upgrade
295
296* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
297- added compat32 package for x86_64 arch support
298
299* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
300- add Patch10 for workaround deny send_interface
301  http://bugs.freedesktop.org/show_bug.cgi?id=18961
302  Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
303  Bare <deny send_interface=""/> rules have a far larger impact than one would think.
304  It's really always wrong to use them without also using send_destination.
305  - XXX: this should be fixed in each dbus configuration.
306
307* Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
308- new upstream release with security fix (CVE-2008-4311)
309
310* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
311- new upstream release with security fix (CVE-2008-3834)
312
313* Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
314- new upstream release
315
316* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
317- own the directories /usr/share/dbus-1/{system-services,interfaces}
318- set 'dbus' instead of '81' to --with-dbus-user
319 
320* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
321- import some patches from fedora
322- move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
323
324* Wed May  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
325- new upstream release
326
327* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
328- new upstream release
329
330* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
331- rebuild with expat-2.0.1
332
333* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
334- rebuild with new environment/toolchain
335
336* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
337- require new chkconfig to reset initscript priorities
338
339* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
340- new upstream release
341- split out bindings
342- move base binaries and libraries to /bin and /%{_lib}
343
344* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
345- rebuilt for VineSeed
346
347* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
348- add Vendor/Distribution tag
349
350* Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
351- add patch100 for fix CVE-2006-6107
352
353* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
354- new upstream release
355
356* Sun Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
357- disabled dbus-qt
358- added BuildConflicts: qt-devel
359- removed work around for 64 bit archs
360
361* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
362- new upstream release
363
364* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
365- new upstream release
366
367* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
368- new upstream release
369
370* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
371- new upstream release
372- enable python bindings
373
374* Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
375- initial build for Vine Linux based on FC package
376- disable python bindings
377- disable selinux
378
379* Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
380- Explicitly pass in the pid file location to ./configure instead of
381  letting it guess based on the build enviornment
382
383* Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
384- Add patch to fix random users from connecting to a users session bus
385
386* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
387- Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
388
389* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
390- Update to upstream version 0.23
391- Drop all patches except for the UDI patch as they have been
392  integrated upstream
393- List of API changes:
394      * add setgroups() to drop supplementary groups
395      * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
396      * added support for int64 and uint64 to the python bindings
397      * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
398
399* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
400- rebuild against python 2.4
401
402* Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
403- Add a requires for glib2-devel in the devel package
404- Add SE-Linux backport from Colin Walters that fixes
405  messages getting lost in SE-Linux contexts
406
407* Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
408- Bump up release and rebuild
409
410* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
411- Run /sbin/ldconfig for glib sub-package (bug #134062).
412
413* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
414- Fixed patch to use dbus-1 instead of dbus-1.0
415- (configure.in): Exported just the datadir instead of
416  the full path to the dbus datadir for consistency
417
418* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
419- Adding patch to move /usr/lib/dbus-1.0/services to
420  /usr/share/dbus-1.0/services
421
422* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
423- reverting BuildRequires: redhat-release because of issues with build system
424- added precompiled version of the messagebus init script
425
426* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
427- changed /etc/redhat-release to the package redhat-release
428
429* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
430- added python int64 patch from davidz
431
432* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
433- added BuildRequires: /etc/redhat-release (RH Bug #132436)
434
435* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
436- Added Steve Grubb's spec file patch (RH Bug #130201)
437
438* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
439- Disabled dbus-gtk since dbus-viewer doesn't do anything right now
440
441* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
442- Moved dbus-viewer to new dbus-gtk package so that dbus-glib
443  no longer requires X or GTK libraries. (RH Bug #130029)
444
445* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
446- Update to new 0.22 release
447
448* Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
449- Added BuildRequires for libselinux-devel and Requires for libselinux
450
451* Tue Aug 02 2004 Colin Walters <walters@redhat.com>
452- Add SE-DBus patch
453
454* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
455- Added lib64 workaround for python bindings installing to
456  the wrong lib directory on 64 bit archs
457
458* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
459- Updated console-auth patch
460- rebuild
461 
462* Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
463- Update to upstream CVS build
464- Added console-auth patch
465
466* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
467- Workaround added to fix gcc-3.4 bug on ia64
468
469* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
470- require new Pyrex version and see if it builds this time
471
472* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
473- rebuild with updated Pyrex (0.9.2.1)
474
475* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
476- rebuilt
477
478* Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
479- Moved dbus-viewer, dbus-monitor and dbus-glib-tool
480  into the dbus-glib package so that the main dbus
481  package does not depend on glib (Bug #125285)
482
483* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
484- rebuilt
485
486* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
487- added my Python patch
488- took out the qt build requires
489- added a gtk+ build requires
490
491* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
492- Changed build requirement to version 0.9-3 of Pyrex
493  to fix problem with builing on x86_64
494
495* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
496- update to upstream 0.21
497- removed dbus-0.20-varargs.patch patch (fixed upstream)
498
499* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
500- added a dbus-python package to generate python bindings
501- added Pyrex build dependacy
502
503* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
504- rebuilt
505
506* Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
507- fix dbus error functions on x86-64 (#116324)
508- add prereq (#112027)
509
510* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
511- rebuilt
512
513* Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
514- Conflict with cups prior to configuration file change, so that the
515  %%postun service condrestart works.
516
517* Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
518- rebuild in fc2, cups now updated
519
520* Wed Jan  7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
521- update to upstream 0.20
522
523* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
524- hmm, dbus doesn't support uids in the config file. fix.
525
526* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
527- put uid instead of username in the config file, to keep things working with name change
528
529* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
530- make subpackages require the specific release, not just version, of base package
531
532* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
533- change system user "messagebus" -> "dbus" to be under 8 chars
534
535* Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
536- see if removing qt subpackage for now will get us through the build system,
537  qt bindings not useful yet anyway
538
539* Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
540- 0.13 fixes a little security oops
541
542* Mon Aug  4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
543- break the tiny dbus-launch that depends on X into separate package
544  so a CUPS server doesn't need X installed
545
546* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
547- rebuilt
548
549* Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
550- 0.11.91 cvs snap properly merges system.d
551
552* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
553- build a cvs snap with a few more fixes
554
555* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
556- fix a crash that was breaking cups
557
558* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
559- 0.11
560
561* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
562- use rc.d/init.d not init.d, bug #90192
563- include the new man pages
564
565* Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
566- 0.9
567- export QTDIR explicitly
568- re-enable qt, the problem was most likely D-BUS configure
569
570* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
571- update from CVS with a fix to set uid after gid
572
573* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
574- new cvs snap that actually forks to background and changes
575  user it's running as and so forth
576- create our system user in pre
577
578* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
579- fix for "make check" test that required a home directory
580
581* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
582- disable qt for now because beehive hates me
583- pull a slightly newer cvs snap that creates socket directory
584- cat the make check log after make check fails
585
586* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
587- initial build
588
Note: See TracBrowser for help on using the repository browser.