source: projects/specs/trunk/d/dbus/dbus-vl.spec @ 4812

Revision 4812, 18.8 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.92

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gettext_package dbus
4%define expat_version           2.0.1
5%define pyrex_version           0.9.9
6%define dbus_user_uid           81
7
8%define _localstatedir %{_var}
9
10Summary: D-BUS message bus
11Summary(ja): D-BUS メッセージバスシステム
12Name: dbus
13Version: 1.4.16
14Release: 1%{?_dist_release}
15URL: http://www.freedesktop.org/software/dbus/
16License: AFL/GPLv2
17Group: System Environment/Libraries
18
19Source0: %{name}-%{version}.tar.gz
20Source1: doxygen_to_devhelp.xsl
21
22# from fedora package
23Patch0: dbus-0.60-start-early.patch
24Patch1: dbus-1.0.1-generate-xml-docs.patch
25Patch6: dbus-1.2.1-increase-timeout.patch
26
27# Workaround for deny send_interface
28# http://bugs.freedesktop.org/show_bug.cgi?id=18961
29Patch10: dbus-1.2.12-workaround-deny-sendinterface.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32Requires(post): chkconfig >= 1.3.34
33Requires(preun): chkconfig >= 1.3.34
34Requires(pre): shadow-utils
35BuildRequires: libtool
36BuildRequires: expat-devel >= %{expat_version}
37BuildRequires: libxml2-devel
38BuildRequires: python-pyrex >= %{pyrex_version}
39BuildRequires: doxygen
40BuildRequires: xmlto
41BuildRequires: libxslt
42BuildRequires: gettext
43BuildRequires: libX11-devel
44BuildRequires: libcap
45BuildRequires: libSM-devel
46Requires: libxml2-python
47
48Vendor: Project Vine
49Distribution: Vine Linux
50
51%description
52D-BUS is a system for sending messages between applications. It is
53used both for the systemwide message bus service, and as a
54per-user-login-session messaging facility.
55
56%description -l ja
57D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
58システム全体のメッセージバスサービスとしても利用されますが、同様に
59ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
60
61%package devel
62Summary: Libraries and headers for D-BUS
63Summary(ja): D-BUS 用のライブラリとヘッダファイル
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
66
67%description devel
68Headers and static libraries for D-BUS.
69
70%package x11
71Summary: X11-requiring add-ons for D-BUS
72Summary(ja): X11 を利用する D-BUS 用ツール
73Group: Applications/System
74Requires: %{name} = %{version}-%{release}
75
76%description x11
77D-BUS contains some tools that require Xlib to be installed, those are
78in this separate package so server systems need not install X.
79
80%package doc
81Summary: Developer documentation for D-BUS
82Group: Documentation
83Requires: %{name} = %{version}-%{release}
84BuildArch: noarch
85
86%description doc
87This package contains developer documentation for D-Bus along with
88other supporting documentation such as the introspect dtd file.
89
90# compat32
91%package -n compat32-%{name}
92Summary: D-BUS message bus
93Summary(ja): D-BUS メッセージバスシステム
94Group: System Environment/Libraries
95
96%description -n compat32-%{name}
97D-BUS is a system for sending messages between applications. It is
98used both for the systemwide message bus service, and as a
99per-user-login-session messaging facility.
100
101%description -n compat32-%{name} -l ja
102D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
103システム全体のメッセージバスサービスとしても利用されますが、同様に
104ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
105
106%package -n compat32-%{name}-devel
107Summary: Libraries and headers for D-BUS
108Summary(ja): D-BUS 用のライブラリとヘッダファイル
109Group: Development/Libraries
110Requires: compat32-%{name} = %{version}-%{release}
111Requires: %{name}-devel = %{version}-%{release}
112
113%description -n compat32-%{name}-devel
114Headers and static libraries for D-BUS.
115
116%prep
117%setup -q
118## %patch0 -p1 -b .start-early
119## %patch1 -p1 -b .generate-xml-docs
120%patch6 -p1 -b .increase-timeout
121
122%patch10 -p1 -b .workaround-dbus-sendinterface
123
124%build
125autoreconf -f -i
126
127COMMON_ARGS="--enable-selinux=no \
128             --with-init-scripts=redhat \
129             --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
130             --with-dbus-user=dbus \
131             --libdir=/%{_lib} --bindir=/bin \
132             --libexecdir=/%{_lib}/dbus-1 \
133             --sysconfdir=%{_sysconfdir} --exec-prefix=/"
134
135%configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
136%__make
137
138doxygen Doxyfile
139
140xsltproc -o dbus.devhelp %{SOURCE1} doc/api/xml/index.xml
141
142%install
143rm -rf %{buildroot}
144
145%__make install DESTDIR=$RPM_BUILD_ROOT
146
147mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
148
149#change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
150sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
151rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
152
153mkdir -p $RPM_BUILD_ROOT/%{_bindir}
154mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}
155mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
156mv -f $RPM_BUILD_ROOT/%{_lib}/dbus-1.0/include/* $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
157rm -rf $RPM_BUILD_ROOT/%{_lib}/dbus-1.0
158
159rm -f $RPM_BUILD_ROOT/%{_lib}/*.a
160rm -f $RPM_BUILD_ROOT/%{_lib}/*.la
161
162mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
163mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
164
165cp dbus.devhelp $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
166cp doc/dbus-specification.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
167cp doc/dbus-faq.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
168cp doc/dbus-tutorial.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
169cp doc/api/html/* $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
170
171## %find_lang %{gettext_package}
172
173mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/interfaces
174
175%clean
176rm -rf %{buildroot}
177
178%pre
179# Add the "dbus" user
180/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
181        -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
182
183%post
184/sbin/ldconfig
185/sbin/chkconfig --add messagebus
186/sbin/chkconfig messagebus resetpriorities
187
188%preun
189if [ $1 = 0 ]; then
190    service messagebus stop > /dev/null 2>&1
191    /sbin/chkconfig --del messagebus
192fi
193
194%postun
195/sbin/ldconfig
196
197%post -n compat32-%{name} -p /sbin/ldconfig
198
199%postun -n compat32-%{name} -p /sbin/ldconfig
200
201%files
202%defattr(-,root,root)
203%doc COPYING ChangeLog NEWS
204%dir %{_sysconfdir}/dbus-1
205%config %{_sysconfdir}/dbus-1/*.conf
206%{_sysconfdir}/rc.d/init.d/*
207%dir %{_sysconfdir}/dbus-1/system.d
208%dir %{_sysconfdir}/dbus-1/session.d
209%dir %{_localstatedir}/run/dbus
210%dir %{_localstatedir}/lib/dbus/
211/bin/dbus-daemon
212/bin/dbus-send
213/bin/dbus-cleanup-sockets
214/bin/dbus-monitor
215/bin/dbus-uuidgen
216/%{_lib}/*dbus-1*.so.*
217%{_datadir}/man/man*/dbus-cleanup-sockets.1.gz
218%{_datadir}/man/man*/dbus-daemon.1.gz
219%{_datadir}/man/man*/dbus-monitor.1.gz
220%{_datadir}/man/man*/dbus-send.1.gz
221%{_datadir}/man/man*/dbus-uuidgen.1.gz
222%dir %{_datadir}/dbus-1
223%{_datadir}/dbus-1/services
224%{_datadir}/dbus-1/system-services
225%{_datadir}/dbus-1/interfaces
226%dir /%{_lib}/dbus-1
227%attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
228
229%files devel
230%defattr(-,root,root)
231/%{_lib}/lib*.so
232%{_libdir}/dbus-1.0/include
233%{_libdir}/pkgconfig/*
234%{_includedir}/*
235%{_datadir}/devhelp/books/dbus
236
237%files x11
238%defattr(-,root,root)
239%{_bindir}/dbus-launch
240%{_datadir}/man/man*/dbus-launch.1.gz
241
242%files doc
243%defattr(-,root,root)
244%doc %{_docdir}/dbus
245
246# compat32
247%if %{build_compat32}
248%files -n compat32-%{name}
249/%{_lib}/*dbus-1*.so.*
250
251%files -n compat32-%{name}-devel
252%defattr(-,root,root)
253/%{_lib}/lib*.so
254%{_libdir}/dbus-1.0/include
255%{_libdir}/pkgconfig/*
256%endif
257
258%changelog
259* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.16-1
260- new upstream release
261
262* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
263- new upstream release
264- drop Patch1
265- create -doc sub package
266
267* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
268- new upstream release
269
270* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
271- new upstream release
272
273* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
274- add BuildRequires: libSM-devel
275
276* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
277- rebuilt with rpm-4.8.1
278
279* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
280- new upstream release
281- drop Patch0
282
283* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
284- rebuilt with new toolchain
285
286* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
287- new upstream release
288
289* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
290- new upstream release
291- do not restart dbus on upgrade
292
293* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
294- added compat32 package for x86_64 arch support
295
296* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
297- add Patch10 for workaround deny send_interface
298  http://bugs.freedesktop.org/show_bug.cgi?id=18961
299  Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
300  Bare <deny send_interface=""/> rules have a far larger impact than one would think.
301  It's really always wrong to use them without also using send_destination.
302  - XXX: this should be fixed in each dbus configuration.
303
304* Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
305- new upstream release with security fix (CVE-2008-4311)
306
307* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
308- new upstream release with security fix (CVE-2008-3834)
309
310* Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
311- new upstream release
312
313* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
314- own the directories /usr/share/dbus-1/{system-services,interfaces}
315- set 'dbus' instead of '81' to --with-dbus-user
316 
317* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
318- import some patches from fedora
319- move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
320
321* Wed May  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
322- new upstream release
323
324* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
325- new upstream release
326
327* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
328- rebuild with expat-2.0.1
329
330* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
331- rebuild with new environment/toolchain
332
333* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
334- require new chkconfig to reset initscript priorities
335
336* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
337- new upstream release
338- split out bindings
339- move base binaries and libraries to /bin and /%{_lib}
340
341* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
342- rebuilt for VineSeed
343
344* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
345- add Vendor/Distribution tag
346
347* Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
348- add patch100 for fix CVE-2006-6107
349
350* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
351- new upstream release
352
353* Sun Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
354- disabled dbus-qt
355- added BuildConflicts: qt-devel
356- removed work around for 64 bit archs
357
358* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
359- new upstream release
360
361* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
362- new upstream release
363
364* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
365- new upstream release
366
367* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
368- new upstream release
369- enable python bindings
370
371* Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
372- initial build for Vine Linux based on FC package
373- disable python bindings
374- disable selinux
375
376* Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
377- Explicitly pass in the pid file location to ./configure instead of
378  letting it guess based on the build enviornment
379
380* Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
381- Add patch to fix random users from connecting to a users session bus
382
383* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
384- Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
385
386* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
387- Update to upstream version 0.23
388- Drop all patches except for the UDI patch as they have been
389  integrated upstream
390- List of API changes:
391      * add setgroups() to drop supplementary groups
392      * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
393      * added support for int64 and uint64 to the python bindings
394      * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
395
396* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
397- rebuild against python 2.4
398
399* Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
400- Add a requires for glib2-devel in the devel package
401- Add SE-Linux backport from Colin Walters that fixes
402  messages getting lost in SE-Linux contexts
403
404* Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
405- Bump up release and rebuild
406
407* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
408- Run /sbin/ldconfig for glib sub-package (bug #134062).
409
410* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
411- Fixed patch to use dbus-1 instead of dbus-1.0
412- (configure.in): Exported just the datadir instead of
413  the full path to the dbus datadir for consistency
414
415* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
416- Adding patch to move /usr/lib/dbus-1.0/services to
417  /usr/share/dbus-1.0/services
418
419* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
420- reverting BuildRequires: redhat-release because of issues with build system
421- added precompiled version of the messagebus init script
422
423* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
424- changed /etc/redhat-release to the package redhat-release
425
426* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
427- added python int64 patch from davidz
428
429* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
430- added BuildRequires: /etc/redhat-release (RH Bug #132436)
431
432* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
433- Added Steve Grubb's spec file patch (RH Bug #130201)
434
435* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
436- Disabled dbus-gtk since dbus-viewer doesn't do anything right now
437
438* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
439- Moved dbus-viewer to new dbus-gtk package so that dbus-glib
440  no longer requires X or GTK libraries. (RH Bug #130029)
441
442* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
443- Update to new 0.22 release
444
445* Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
446- Added BuildRequires for libselinux-devel and Requires for libselinux
447
448* Tue Aug 02 2004 Colin Walters <walters@redhat.com>
449- Add SE-DBus patch
450
451* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
452- Added lib64 workaround for python bindings installing to
453  the wrong lib directory on 64 bit archs
454
455* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
456- Updated console-auth patch
457- rebuild
458 
459* Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
460- Update to upstream CVS build
461- Added console-auth patch
462
463* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
464- Workaround added to fix gcc-3.4 bug on ia64
465
466* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
467- require new Pyrex version and see if it builds this time
468
469* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
470- rebuild with updated Pyrex (0.9.2.1)
471
472* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
473- rebuilt
474
475* Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
476- Moved dbus-viewer, dbus-monitor and dbus-glib-tool
477  into the dbus-glib package so that the main dbus
478  package does not depend on glib (Bug #125285)
479
480* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
481- rebuilt
482
483* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
484- added my Python patch
485- took out the qt build requires
486- added a gtk+ build requires
487
488* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
489- Changed build requirement to version 0.9-3 of Pyrex
490  to fix problem with builing on x86_64
491
492* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
493- update to upstream 0.21
494- removed dbus-0.20-varargs.patch patch (fixed upstream)
495
496* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
497- added a dbus-python package to generate python bindings
498- added Pyrex build dependacy
499
500* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
501- rebuilt
502
503* Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
504- fix dbus error functions on x86-64 (#116324)
505- add prereq (#112027)
506
507* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
508- rebuilt
509
510* Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
511- Conflict with cups prior to configuration file change, so that the
512  %%postun service condrestart works.
513
514* Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
515- rebuild in fc2, cups now updated
516
517* Wed Jan  7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
518- update to upstream 0.20
519
520* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
521- hmm, dbus doesn't support uids in the config file. fix.
522
523* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
524- put uid instead of username in the config file, to keep things working with name change
525
526* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
527- make subpackages require the specific release, not just version, of base package
528
529* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
530- change system user "messagebus" -> "dbus" to be under 8 chars
531
532* Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
533- see if removing qt subpackage for now will get us through the build system,
534  qt bindings not useful yet anyway
535
536* Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
537- 0.13 fixes a little security oops
538
539* Mon Aug  4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
540- break the tiny dbus-launch that depends on X into separate package
541  so a CUPS server doesn't need X installed
542
543* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
544- rebuilt
545
546* Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
547- 0.11.91 cvs snap properly merges system.d
548
549* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
550- build a cvs snap with a few more fixes
551
552* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
553- fix a crash that was breaking cups
554
555* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
556- 0.11
557
558* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
559- use rc.d/init.d not init.d, bug #90192
560- include the new man pages
561
562* Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
563- 0.9
564- export QTDIR explicitly
565- re-enable qt, the problem was most likely D-BUS configure
566
567* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
568- update from CVS with a fix to set uid after gid
569
570* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
571- new cvs snap that actually forks to background and changes
572  user it's running as and so forth
573- create our system user in pre
574
575* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
576- fix for "make check" test that required a home directory
577
578* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
579- disable qt for now because beehive hates me
580- pull a slightly newer cvs snap that creates socket directory
581- cat the make check log after make check fails
582
583* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
584- initial build
585
Note: See TracBrowser for help on using the repository browser.