source: projects/specs/trunk/d/dbus/dbus-vl.spec @ 521

Revision 521, 17.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gettext_package dbus
4%define expat_version           2.0.1
5%define pyrex_version           0.9.8
6%define dbus_user_uid           81
7
8%define _localstatedir %{_var}
9
10Summary: D-BUS message bus
11Summary(ja): D-BUS メッセージバスシステム
12Name: dbus
13Version: 1.2.16
14Release: 2%{?_dist_release}
15URL: http://www.freedesktop.org/software/dbus/
16License: AFL/GPLv2
17Group: System Environment/Libraries
18
19Source0: %{name}-%{version}.tar.gz
20Source1: doxygen_to_devhelp.xsl
21
22# from fedora package
23Patch0: dbus-0.60-start-early.patch
24Patch1: dbus-1.0.1-generate-xml-docs.patch
25Patch6: dbus-1.2.1-increase-timeout.patch
26
27# Workaround for deny send_interface
28# http://bugs.freedesktop.org/show_bug.cgi?id=18961
29Patch10: dbus-1.2.12-workaround-deny-sendinterface.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32Requires(post): chkconfig >= 1.3.34
33Requires(preun): chkconfig >= 1.3.34
34Requires(pre): shadow-utils
35BuildRequires: libtool
36BuildRequires: expat-devel >= %{expat_version}
37BuildRequires: libxml2-devel
38BuildRequires: python-pyrex >= %{pyrex_version}
39BuildRequires: doxygen
40BuildRequires: xmlto
41BuildRequires: libxslt
42BuildRequires: gettext
43BuildRequires: libX11-devel
44BuildRequires: libcap
45Requires: libxml2-python
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51D-BUS is a system for sending messages between applications. It is
52used both for the systemwide message bus service, and as a
53per-user-login-session messaging facility.
54
55%description -l ja
56D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
57システム全体のメッセージバスサービスとしても利用されますが、同様に
58ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
59
60%package devel
61Summary: Libraries and headers for D-BUS
62Summary(ja): D-BUS 用のライブラリとヘッダファイル
63Group: Development/Libraries
64Requires: %{name} = %{version}-%{release}
65Requires: glib2-devel
66
67%description devel
68Headers and static libraries for D-BUS.
69
70%package x11
71Summary: X11-requiring add-ons for D-BUS
72Summary(ja): X11 を利用する D-BUS 用ツール
73Group: Applications/System
74Requires: %{name} = %{version}-%{release}
75
76%description x11
77D-BUS contains some tools that require Xlib to be installed, those are
78in this separate package so server systems need not install X.
79
80# compat32
81%package -n compat32-%{name}
82Summary: D-BUS message bus
83Summary(ja): D-BUS メッセージバスシステム
84Group: System Environment/Libraries
85
86%description -n compat32-%{name}
87D-BUS is a system for sending messages between applications. It is
88used both for the systemwide message bus service, and as a
89per-user-login-session messaging facility.
90
91%description -n compat32-%{name} -l ja
92D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
93システム全体のメッセージバスサービスとしても利用されますが、同様に
94ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
95
96%package -n compat32-%{name}-devel
97Summary: Libraries and headers for D-BUS
98Summary(ja): D-BUS 用のライブラリとヘッダファイル
99Group: Development/Libraries
100Requires: compat32-%{name} = %{version}-%{release}
101Requires: %{name}-devel = %{version}-%{release}
102Requires: compat32-glib2-devel
103
104%description -n compat32-%{name}-devel
105Headers and static libraries for D-BUS.
106
107%prep
108%setup -q
109%patch0 -p1 -b .start-early
110%patch1 -p1 -b .generate-xml-docs
111%patch6 -p1 -b .increase-timeout
112
113%patch10 -p1 -b .workaround-dbus-sendinterface
114
115%build
116autoreconf -f -i
117
118COMMON_ARGS="--enable-selinux=no \
119             --with-init-scripts=redhat \
120             --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
121             --with-dbus-user=dbus \
122             --libdir=/%{_lib} --bindir=/bin \
123             --libexecdir=/%{_lib}/dbus-1 \
124             --sysconfdir=%{_sysconfdir} --exec-prefix=/"
125
126%configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
127%__make
128
129doxygen Doxyfile
130
131xsltproc -o dbus.devhelp %{SOURCE1} doc/api/xml/index.xml
132
133%install
134rm -rf %{buildroot}
135
136%__make install DESTDIR=$RPM_BUILD_ROOT
137
138mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
139
140#change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
141sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
142rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
143
144mkdir -p $RPM_BUILD_ROOT/%{_bindir}
145mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}
146mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
147mv -f $RPM_BUILD_ROOT/%{_lib}/dbus-1.0/include/* $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
148rm -rf $RPM_BUILD_ROOT/%{_lib}/dbus-1.0
149
150rm -f $RPM_BUILD_ROOT/%{_lib}/*.a
151rm -f $RPM_BUILD_ROOT/%{_lib}/*.la
152
153mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
154mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
155
156cp dbus.devhelp $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
157cp doc/dbus-specification.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
158cp doc/dbus-faq.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
159cp doc/dbus-tutorial.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
160cp doc/api/html/* $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
161
162## %find_lang %{gettext_package}
163
164mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/interfaces
165
166%clean
167rm -rf %{buildroot}
168
169%pre
170# Add the "dbus" user
171/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
172        -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
173
174%post
175/sbin/ldconfig
176/sbin/chkconfig --add messagebus
177/sbin/chkconfig messagebus resetpriorities
178
179%preun
180if [ $1 = 0 ]; then
181    service messagebus stop > /dev/null 2>&1
182    /sbin/chkconfig --del messagebus
183fi
184
185%postun
186/sbin/ldconfig
187
188%post -n compat32-%{name} -p /sbin/ldconfig
189
190%postun -n compat32-%{name} -p /sbin/ldconfig
191
192%files
193%defattr(-,root,root)
194%doc COPYING ChangeLog NEWS
195%dir %{_sysconfdir}/dbus-1
196%config %{_sysconfdir}/dbus-1/*.conf
197%{_sysconfdir}/rc.d/init.d/*
198%dir %{_sysconfdir}/dbus-1/system.d
199%dir %{_sysconfdir}/dbus-1/session.d
200%dir %{_localstatedir}/run/dbus
201%dir %{_localstatedir}/lib/dbus/
202/bin/dbus-daemon
203/bin/dbus-send
204/bin/dbus-cleanup-sockets
205/bin/dbus-monitor
206/bin/dbus-uuidgen
207/%{_lib}/*dbus-1*.so.*
208%{_datadir}/man/man*/dbus-cleanup-sockets.1.gz
209%{_datadir}/man/man*/dbus-daemon.1.gz
210%{_datadir}/man/man*/dbus-monitor.1.gz
211%{_datadir}/man/man*/dbus-send.1.gz
212%{_datadir}/man/man*/dbus-uuidgen.1.gz
213%dir %{_datadir}/dbus-1
214%{_datadir}/dbus-1/services
215%{_datadir}/dbus-1/system-services
216%{_datadir}/dbus-1/interfaces
217%dir /%{_lib}/dbus-1
218%attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
219
220%files devel
221%defattr(-,root,root)
222/%{_lib}/lib*.so
223%{_libdir}/dbus-1.0/include
224%{_libdir}/pkgconfig/*
225%{_includedir}/*
226%{_datadir}/devhelp/books/dbus
227
228%files x11
229%defattr(-,root,root)
230%{_bindir}/dbus-launch
231%{_datadir}/man/man*/dbus-launch.1.gz
232
233# compat32
234%if %{build_compat32}
235%files -n compat32-%{name}
236/%{_lib}/*dbus-1*.so.*
237
238%files -n compat32-%{name}-devel
239%defattr(-,root,root)
240/%{_lib}/lib*.so
241%{_libdir}/dbus-1.0/include
242%{_libdir}/pkgconfig/*
243%endif
244
245%changelog
246* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
247- rebuilt with new toolchain
248
249* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
250- new upstream release
251
252* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
253- new upstream release
254- do not restart dbus on upgrade
255
256* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
257- added compat32 package for x86_64 arch support
258
259* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
260- add Patch10 for workaround deny send_interface
261  http://bugs.freedesktop.org/show_bug.cgi?id=18961
262  Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
263  Bare <deny send_interface=""/> rules have a far larger impact than one would think.
264  It's really always wrong to use them without also using send_destination.
265  - XXX: this should be fixed in each dbus configuration.
266
267* Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
268- new upstream release with security fix (CVE-2008-4311)
269
270* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
271- new upstream release with security fix (CVE-2008-3834)
272
273* Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
274- new upstream release
275
276* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
277- own the directories /usr/share/dbus-1/{system-services,interfaces}
278- set 'dbus' instead of '81' to --with-dbus-user
279 
280* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
281- import some patches from fedora
282- move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
283
284* Wed May  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
285- new upstream release
286
287* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
288- new upstream release
289
290* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
291- rebuild with expat-2.0.1
292
293* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
294- rebuild with new environment/toolchain
295
296* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
297- require new chkconfig to reset initscript priorities
298
299* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
300- new upstream release
301- split out bindings
302- move base binaries and libraries to /bin and /%{_lib}
303
304* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
305- rebuilt for VineSeed
306
307* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
308- add Vendor/Distribution tag
309
310* Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
311- add patch100 for fix CVE-2006-6107
312
313* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
314- new upstream release
315
316* Sun Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
317- disabled dbus-qt
318- added BuildConflicts: qt-devel
319- removed work around for 64 bit archs
320
321* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
322- new upstream release
323
324* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
325- new upstream release
326
327* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
328- new upstream release
329
330* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
331- new upstream release
332- enable python bindings
333
334* Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
335- initial build for Vine Linux based on FC package
336- disable python bindings
337- disable selinux
338
339* Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
340- Explicitly pass in the pid file location to ./configure instead of
341  letting it guess based on the build enviornment
342
343* Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
344- Add patch to fix random users from connecting to a users session bus
345
346* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
347- Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
348
349* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
350- Update to upstream version 0.23
351- Drop all patches except for the UDI patch as they have been
352  integrated upstream
353- List of API changes:
354      * add setgroups() to drop supplementary groups
355      * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
356      * added support for int64 and uint64 to the python bindings
357      * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
358
359* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
360- rebuild against python 2.4
361
362* Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
363- Add a requires for glib2-devel in the devel package
364- Add SE-Linux backport from Colin Walters that fixes
365  messages getting lost in SE-Linux contexts
366
367* Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
368- Bump up release and rebuild
369
370* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
371- Run /sbin/ldconfig for glib sub-package (bug #134062).
372
373* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
374- Fixed patch to use dbus-1 instead of dbus-1.0
375- (configure.in): Exported just the datadir instead of
376  the full path to the dbus datadir for consistency
377
378* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
379- Adding patch to move /usr/lib/dbus-1.0/services to
380  /usr/share/dbus-1.0/services
381
382* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
383- reverting BuildRequires: redhat-release because of issues with build system
384- added precompiled version of the messagebus init script
385
386* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
387- changed /etc/redhat-release to the package redhat-release
388
389* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
390- added python int64 patch from davidz
391
392* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
393- added BuildRequires: /etc/redhat-release (RH Bug #132436)
394
395* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
396- Added Steve Grubb's spec file patch (RH Bug #130201)
397
398* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
399- Disabled dbus-gtk since dbus-viewer doesn't do anything right now
400
401* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
402- Moved dbus-viewer to new dbus-gtk package so that dbus-glib
403  no longer requires X or GTK libraries. (RH Bug #130029)
404
405* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
406- Update to new 0.22 release
407
408* Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
409- Added BuildRequires for libselinux-devel and Requires for libselinux
410
411* Tue Aug 02 2004 Colin Walters <walters@redhat.com>
412- Add SE-DBus patch
413
414* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
415- Added lib64 workaround for python bindings installing to
416  the wrong lib directory on 64 bit archs
417
418* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
419- Updated console-auth patch
420- rebuild
421 
422* Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
423- Update to upstream CVS build
424- Added console-auth patch
425
426* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
427- Workaround added to fix gcc-3.4 bug on ia64
428
429* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
430- require new Pyrex version and see if it builds this time
431
432* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
433- rebuild with updated Pyrex (0.9.2.1)
434
435* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
436- rebuilt
437
438* Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
439- Moved dbus-viewer, dbus-monitor and dbus-glib-tool
440  into the dbus-glib package so that the main dbus
441  package does not depend on glib (Bug #125285)
442
443* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
444- rebuilt
445
446* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
447- added my Python patch
448- took out the qt build requires
449- added a gtk+ build requires
450
451* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
452- Changed build requirement to version 0.9-3 of Pyrex
453  to fix problem with builing on x86_64
454
455* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
456- update to upstream 0.21
457- removed dbus-0.20-varargs.patch patch (fixed upstream)
458
459* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
460- added a dbus-python package to generate python bindings
461- added Pyrex build dependacy
462
463* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
464- rebuilt
465
466* Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
467- fix dbus error functions on x86-64 (#116324)
468- add prereq (#112027)
469
470* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
471- rebuilt
472
473* Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
474- Conflict with cups prior to configuration file change, so that the
475  %%postun service condrestart works.
476
477* Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
478- rebuild in fc2, cups now updated
479
480* Wed Jan  7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
481- update to upstream 0.20
482
483* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
484- hmm, dbus doesn't support uids in the config file. fix.
485
486* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
487- put uid instead of username in the config file, to keep things working with name change
488
489* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
490- make subpackages require the specific release, not just version, of base package
491
492* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
493- change system user "messagebus" -> "dbus" to be under 8 chars
494
495* Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
496- see if removing qt subpackage for now will get us through the build system,
497  qt bindings not useful yet anyway
498
499* Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
500- 0.13 fixes a little security oops
501
502* Mon Aug  4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
503- break the tiny dbus-launch that depends on X into separate package
504  so a CUPS server doesn't need X installed
505
506* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
507- rebuilt
508
509* Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
510- 0.11.91 cvs snap properly merges system.d
511
512* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
513- build a cvs snap with a few more fixes
514
515* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
516- fix a crash that was breaking cups
517
518* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
519- 0.11
520
521* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
522- use rc.d/init.d not init.d, bug #90192
523- include the new man pages
524
525* Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
526- 0.9
527- export QTDIR explicitly
528- re-enable qt, the problem was most likely D-BUS configure
529
530* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
531- update from CVS with a fix to set uid after gid
532
533* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
534- new cvs snap that actually forks to background and changes
535  user it's running as and so forth
536- create our system user in pre
537
538* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
539- fix for "make check" test that required a home directory
540
541* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
542- disable qt for now because beehive hates me
543- pull a slightly newer cvs snap that creates socket directory
544- cat the make check log after make check fails
545
546* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
547- initial build
548
Note: See TracBrowser for help on using the repository browser.