source: projects/specs/trunk/d/dbus/dbus-vl.spec @ 4616

Revision 4616, 18.7 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gettext_package dbus
4%define expat_version           2.0.1
5%define pyrex_version           0.9.9
6%define dbus_user_uid           81
7
8%define _localstatedir %{_var}
9
10Summary: D-BUS message bus
11Summary(ja): D-BUS メッセージバスシステム
12Name: dbus
13Version: 1.4.14
14Release: 1%{?_dist_release}
15URL: http://www.freedesktop.org/software/dbus/
16License: AFL/GPLv2
17Group: System Environment/Libraries
18
19Source0: %{name}-%{version}.tar.gz
20Source1: doxygen_to_devhelp.xsl
21
22# from fedora package
23Patch0: dbus-0.60-start-early.patch
24Patch1: dbus-1.0.1-generate-xml-docs.patch
25Patch6: dbus-1.2.1-increase-timeout.patch
26
27# Workaround for deny send_interface
28# http://bugs.freedesktop.org/show_bug.cgi?id=18961
29Patch10: dbus-1.2.12-workaround-deny-sendinterface.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32Requires(post): chkconfig >= 1.3.34
33Requires(preun): chkconfig >= 1.3.34
34Requires(pre): shadow-utils
35BuildRequires: libtool
36BuildRequires: expat-devel >= %{expat_version}
37BuildRequires: libxml2-devel
38BuildRequires: python-pyrex >= %{pyrex_version}
39BuildRequires: doxygen
40BuildRequires: xmlto
41BuildRequires: libxslt
42BuildRequires: gettext
43BuildRequires: libX11-devel
44BuildRequires: libcap
45BuildRequires: libSM-devel
46Requires: libxml2-python
47
48Vendor: Project Vine
49Distribution: Vine Linux
50
51%description
52D-BUS is a system for sending messages between applications. It is
53used both for the systemwide message bus service, and as a
54per-user-login-session messaging facility.
55
56%description -l ja
57D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
58システム全体のメッセージバスサービスとしても利用されますが、同様に
59ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
60
61%package devel
62Summary: Libraries and headers for D-BUS
63Summary(ja): D-BUS 用のライブラリとヘッダファイル
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
66
67%description devel
68Headers and static libraries for D-BUS.
69
70%package x11
71Summary: X11-requiring add-ons for D-BUS
72Summary(ja): X11 を利用する D-BUS 用ツール
73Group: Applications/System
74Requires: %{name} = %{version}-%{release}
75
76%description x11
77D-BUS contains some tools that require Xlib to be installed, those are
78in this separate package so server systems need not install X.
79
80%package doc
81Summary: Developer documentation for D-BUS
82Group: Documentation
83Requires: %{name} = %{version}-%{release}
84BuildArch: noarch
85
86%description doc
87This package contains developer documentation for D-Bus along with
88other supporting documentation such as the introspect dtd file.
89
90# compat32
91%package -n compat32-%{name}
92Summary: D-BUS message bus
93Summary(ja): D-BUS メッセージバスシステム
94Group: System Environment/Libraries
95
96%description -n compat32-%{name}
97D-BUS is a system for sending messages between applications. It is
98used both for the systemwide message bus service, and as a
99per-user-login-session messaging facility.
100
101%description -n compat32-%{name} -l ja
102D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
103システム全体のメッセージバスサービスとしても利用されますが、同様に
104ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
105
106%package -n compat32-%{name}-devel
107Summary: Libraries and headers for D-BUS
108Summary(ja): D-BUS 用のライブラリとヘッダファイル
109Group: Development/Libraries
110Requires: compat32-%{name} = %{version}-%{release}
111Requires: %{name}-devel = %{version}-%{release}
112
113%description -n compat32-%{name}-devel
114Headers and static libraries for D-BUS.
115
116%prep
117%setup -q
118## %patch0 -p1 -b .start-early
119## %patch1 -p1 -b .generate-xml-docs
120%patch6 -p1 -b .increase-timeout
121
122%patch10 -p1 -b .workaround-dbus-sendinterface
123
124%build
125autoreconf -f -i
126
127COMMON_ARGS="--enable-selinux=no \
128             --with-init-scripts=redhat \
129             --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
130             --with-dbus-user=dbus \
131             --libdir=/%{_lib} --bindir=/bin \
132             --libexecdir=/%{_lib}/dbus-1 \
133             --sysconfdir=%{_sysconfdir} --exec-prefix=/"
134
135%configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
136%__make
137
138doxygen Doxyfile
139
140xsltproc -o dbus.devhelp %{SOURCE1} doc/api/xml/index.xml
141
142%install
143rm -rf %{buildroot}
144
145%__make install DESTDIR=$RPM_BUILD_ROOT
146
147mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
148
149#change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
150sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
151rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
152
153mkdir -p $RPM_BUILD_ROOT/%{_bindir}
154mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}
155mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
156mv -f $RPM_BUILD_ROOT/%{_lib}/dbus-1.0/include/* $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
157rm -rf $RPM_BUILD_ROOT/%{_lib}/dbus-1.0
158
159rm -f $RPM_BUILD_ROOT/%{_lib}/*.a
160rm -f $RPM_BUILD_ROOT/%{_lib}/*.la
161
162mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
163mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
164
165cp dbus.devhelp $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
166cp doc/dbus-specification.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
167cp doc/dbus-faq.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
168cp doc/dbus-tutorial.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
169cp doc/api/html/* $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
170
171## %find_lang %{gettext_package}
172
173mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/interfaces
174
175%clean
176rm -rf %{buildroot}
177
178%pre
179# Add the "dbus" user
180/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
181        -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
182
183%post
184/sbin/ldconfig
185/sbin/chkconfig --add messagebus
186/sbin/chkconfig messagebus resetpriorities
187
188%preun
189if [ $1 = 0 ]; then
190    service messagebus stop > /dev/null 2>&1
191    /sbin/chkconfig --del messagebus
192fi
193
194%postun
195/sbin/ldconfig
196
197%post -n compat32-%{name} -p /sbin/ldconfig
198
199%postun -n compat32-%{name} -p /sbin/ldconfig
200
201%files
202%defattr(-,root,root)
203%doc COPYING ChangeLog NEWS
204%dir %{_sysconfdir}/dbus-1
205%config %{_sysconfdir}/dbus-1/*.conf
206%{_sysconfdir}/rc.d/init.d/*
207%dir %{_sysconfdir}/dbus-1/system.d
208%dir %{_sysconfdir}/dbus-1/session.d
209%dir %{_localstatedir}/run/dbus
210%dir %{_localstatedir}/lib/dbus/
211/bin/dbus-daemon
212/bin/dbus-send
213/bin/dbus-cleanup-sockets
214/bin/dbus-monitor
215/bin/dbus-uuidgen
216/%{_lib}/*dbus-1*.so.*
217%{_datadir}/man/man*/dbus-cleanup-sockets.1.gz
218%{_datadir}/man/man*/dbus-daemon.1.gz
219%{_datadir}/man/man*/dbus-monitor.1.gz
220%{_datadir}/man/man*/dbus-send.1.gz
221%{_datadir}/man/man*/dbus-uuidgen.1.gz
222%dir %{_datadir}/dbus-1
223%{_datadir}/dbus-1/services
224%{_datadir}/dbus-1/system-services
225%{_datadir}/dbus-1/interfaces
226%dir /%{_lib}/dbus-1
227%attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
228
229%files devel
230%defattr(-,root,root)
231/%{_lib}/lib*.so
232%{_libdir}/dbus-1.0/include
233%{_libdir}/pkgconfig/*
234%{_includedir}/*
235%{_datadir}/devhelp/books/dbus
236
237%files x11
238%defattr(-,root,root)
239%{_bindir}/dbus-launch
240%{_datadir}/man/man*/dbus-launch.1.gz
241
242%files doc
243%defattr(-,root,root)
244%doc %{_docdir}/dbus
245
246# compat32
247%if %{build_compat32}
248%files -n compat32-%{name}
249/%{_lib}/*dbus-1*.so.*
250
251%files -n compat32-%{name}-devel
252%defattr(-,root,root)
253/%{_lib}/lib*.so
254%{_libdir}/dbus-1.0/include
255%{_libdir}/pkgconfig/*
256%endif
257
258%changelog
259* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
260- new upstream release
261- drop Patch1
262- create -doc sub package
263
264* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
265- new upstream release
266
267* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
268- new upstream release
269
270* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
271- add BuildRequires: libSM-devel
272
273* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
274- rebuilt with rpm-4.8.1
275
276* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
277- new upstream release
278- drop Patch0
279
280* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
281- rebuilt with new toolchain
282
283* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
284- new upstream release
285
286* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
287- new upstream release
288- do not restart dbus on upgrade
289
290* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
291- added compat32 package for x86_64 arch support
292
293* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
294- add Patch10 for workaround deny send_interface
295  http://bugs.freedesktop.org/show_bug.cgi?id=18961
296  Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
297  Bare <deny send_interface=""/> rules have a far larger impact than one would think.
298  It's really always wrong to use them without also using send_destination.
299  - XXX: this should be fixed in each dbus configuration.
300
301* Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
302- new upstream release with security fix (CVE-2008-4311)
303
304* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
305- new upstream release with security fix (CVE-2008-3834)
306
307* Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
308- new upstream release
309
310* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
311- own the directories /usr/share/dbus-1/{system-services,interfaces}
312- set 'dbus' instead of '81' to --with-dbus-user
313 
314* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
315- import some patches from fedora
316- move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
317
318* Wed May  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
319- new upstream release
320
321* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
322- new upstream release
323
324* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
325- rebuild with expat-2.0.1
326
327* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
328- rebuild with new environment/toolchain
329
330* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
331- require new chkconfig to reset initscript priorities
332
333* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
334- new upstream release
335- split out bindings
336- move base binaries and libraries to /bin and /%{_lib}
337
338* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
339- rebuilt for VineSeed
340
341* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
342- add Vendor/Distribution tag
343
344* Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
345- add patch100 for fix CVE-2006-6107
346
347* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
348- new upstream release
349
350* Sun Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
351- disabled dbus-qt
352- added BuildConflicts: qt-devel
353- removed work around for 64 bit archs
354
355* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
356- new upstream release
357
358* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
359- new upstream release
360
361* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
362- new upstream release
363
364* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
365- new upstream release
366- enable python bindings
367
368* Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
369- initial build for Vine Linux based on FC package
370- disable python bindings
371- disable selinux
372
373* Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
374- Explicitly pass in the pid file location to ./configure instead of
375  letting it guess based on the build enviornment
376
377* Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
378- Add patch to fix random users from connecting to a users session bus
379
380* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
381- Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
382
383* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
384- Update to upstream version 0.23
385- Drop all patches except for the UDI patch as they have been
386  integrated upstream
387- List of API changes:
388      * add setgroups() to drop supplementary groups
389      * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
390      * added support for int64 and uint64 to the python bindings
391      * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
392
393* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
394- rebuild against python 2.4
395
396* Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
397- Add a requires for glib2-devel in the devel package
398- Add SE-Linux backport from Colin Walters that fixes
399  messages getting lost in SE-Linux contexts
400
401* Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
402- Bump up release and rebuild
403
404* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
405- Run /sbin/ldconfig for glib sub-package (bug #134062).
406
407* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
408- Fixed patch to use dbus-1 instead of dbus-1.0
409- (configure.in): Exported just the datadir instead of
410  the full path to the dbus datadir for consistency
411
412* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
413- Adding patch to move /usr/lib/dbus-1.0/services to
414  /usr/share/dbus-1.0/services
415
416* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
417- reverting BuildRequires: redhat-release because of issues with build system
418- added precompiled version of the messagebus init script
419
420* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
421- changed /etc/redhat-release to the package redhat-release
422
423* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
424- added python int64 patch from davidz
425
426* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
427- added BuildRequires: /etc/redhat-release (RH Bug #132436)
428
429* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
430- Added Steve Grubb's spec file patch (RH Bug #130201)
431
432* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
433- Disabled dbus-gtk since dbus-viewer doesn't do anything right now
434
435* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
436- Moved dbus-viewer to new dbus-gtk package so that dbus-glib
437  no longer requires X or GTK libraries. (RH Bug #130029)
438
439* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
440- Update to new 0.22 release
441
442* Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
443- Added BuildRequires for libselinux-devel and Requires for libselinux
444
445* Tue Aug 02 2004 Colin Walters <walters@redhat.com>
446- Add SE-DBus patch
447
448* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
449- Added lib64 workaround for python bindings installing to
450  the wrong lib directory on 64 bit archs
451
452* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
453- Updated console-auth patch
454- rebuild
455 
456* Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
457- Update to upstream CVS build
458- Added console-auth patch
459
460* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
461- Workaround added to fix gcc-3.4 bug on ia64
462
463* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
464- require new Pyrex version and see if it builds this time
465
466* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
467- rebuild with updated Pyrex (0.9.2.1)
468
469* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
470- rebuilt
471
472* Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
473- Moved dbus-viewer, dbus-monitor and dbus-glib-tool
474  into the dbus-glib package so that the main dbus
475  package does not depend on glib (Bug #125285)
476
477* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
478- rebuilt
479
480* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
481- added my Python patch
482- took out the qt build requires
483- added a gtk+ build requires
484
485* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
486- Changed build requirement to version 0.9-3 of Pyrex
487  to fix problem with builing on x86_64
488
489* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
490- update to upstream 0.21
491- removed dbus-0.20-varargs.patch patch (fixed upstream)
492
493* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
494- added a dbus-python package to generate python bindings
495- added Pyrex build dependacy
496
497* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
498- rebuilt
499
500* Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
501- fix dbus error functions on x86-64 (#116324)
502- add prereq (#112027)
503
504* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
505- rebuilt
506
507* Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
508- Conflict with cups prior to configuration file change, so that the
509  %%postun service condrestart works.
510
511* Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
512- rebuild in fc2, cups now updated
513
514* Wed Jan  7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
515- update to upstream 0.20
516
517* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
518- hmm, dbus doesn't support uids in the config file. fix.
519
520* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
521- put uid instead of username in the config file, to keep things working with name change
522
523* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
524- make subpackages require the specific release, not just version, of base package
525
526* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
527- change system user "messagebus" -> "dbus" to be under 8 chars
528
529* Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
530- see if removing qt subpackage for now will get us through the build system,
531  qt bindings not useful yet anyway
532
533* Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
534- 0.13 fixes a little security oops
535
536* Mon Aug  4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
537- break the tiny dbus-launch that depends on X into separate package
538  so a CUPS server doesn't need X installed
539
540* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
541- rebuilt
542
543* Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
544- 0.11.91 cvs snap properly merges system.d
545
546* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
547- build a cvs snap with a few more fixes
548
549* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
550- fix a crash that was breaking cups
551
552* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
553- 0.11
554
555* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
556- use rc.d/init.d not init.d, bug #90192
557- include the new man pages
558
559* Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
560- 0.9
561- export QTDIR explicitly
562- re-enable qt, the problem was most likely D-BUS configure
563
564* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
565- update from CVS with a fix to set uid after gid
566
567* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
568- new cvs snap that actually forks to background and changes
569  user it's running as and so forth
570- create our system user in pre
571
572* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
573- fix for "make check" test that required a home directory
574
575* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
576- disable qt for now because beehive hates me
577- pull a slightly newer cvs snap that creates socket directory
578- cat the make check log after make check fails
579
580* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
581- initial build
582
Note: See TracBrowser for help on using the repository browser.