source: projects/specs/trunk/d/dbus/dbus-vl.spec @ 1857

Revision 1857, 18.2 KB checked in by iwaim, 14 years ago (diff)

dbus 1.2.24-3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define gettext_package dbus
4%define expat_version           2.0.1
5%define pyrex_version           0.9.8
6%define dbus_user_uid           81
7
8%define _localstatedir %{_var}
9
10Summary: D-BUS message bus
11Summary(ja): D-BUS メッセージバスシステム
12Name: dbus
13Version: 1.2.24
14Release: 3%{?_dist_release}
15URL: http://www.freedesktop.org/software/dbus/
16License: AFL/GPLv2
17Group: System Environment/Libraries
18
19Source0: %{name}-%{version}.tar.gz
20Source1: doxygen_to_devhelp.xsl
21
22# from fedora package
23Patch0: dbus-0.60-start-early.patch
24Patch1: dbus-1.0.1-generate-xml-docs.patch
25Patch6: dbus-1.2.1-increase-timeout.patch
26
27# Workaround for deny send_interface
28# http://bugs.freedesktop.org/show_bug.cgi?id=18961
29Patch10: dbus-1.2.12-workaround-deny-sendinterface.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32Requires(post): chkconfig >= 1.3.34
33Requires(preun): chkconfig >= 1.3.34
34Requires(pre): shadow-utils
35BuildRequires: libtool
36BuildRequires: expat-devel >= %{expat_version}
37BuildRequires: libxml2-devel
38BuildRequires: python-pyrex >= %{pyrex_version}
39BuildRequires: doxygen
40BuildRequires: xmlto
41BuildRequires: libxslt
42BuildRequires: gettext
43BuildRequires: libX11-devel
44BuildRequires: libcap
45BuildRequires: libSM-devel
46Requires: libxml2-python
47
48Vendor: Project Vine
49Distribution: Vine Linux
50
51%description
52D-BUS is a system for sending messages between applications. It is
53used both for the systemwide message bus service, and as a
54per-user-login-session messaging facility.
55
56%description -l ja
57D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
58システム全体のメッセージバスサービスとしても利用されますが、同様に
59ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
60
61%package devel
62Summary: Libraries and headers for D-BUS
63Summary(ja): D-BUS 用のライブラリとヘッダファイル
64Group: Development/Libraries
65Requires: %{name} = %{version}-%{release}
66Requires: glib2-devel
67
68%description devel
69Headers and static libraries for D-BUS.
70
71%package x11
72Summary: X11-requiring add-ons for D-BUS
73Summary(ja): X11 を利用する D-BUS 用ツール
74Group: Applications/System
75Requires: %{name} = %{version}-%{release}
76
77%description x11
78D-BUS contains some tools that require Xlib to be installed, those are
79in this separate package so server systems need not install X.
80
81# compat32
82%package -n compat32-%{name}
83Summary: D-BUS message bus
84Summary(ja): D-BUS メッセージバスシステム
85Group: System Environment/Libraries
86
87%description -n compat32-%{name}
88D-BUS is a system for sending messages between applications. It is
89used both for the systemwide message bus service, and as a
90per-user-login-session messaging facility.
91
92%description -n compat32-%{name} -l ja
93D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
94システム全体のメッセージバスサービスとしても利用されますが、同様に
95ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
96
97%package -n compat32-%{name}-devel
98Summary: Libraries and headers for D-BUS
99Summary(ja): D-BUS 用のライブラリとヘッダファイル
100Group: Development/Libraries
101Requires: compat32-%{name} = %{version}-%{release}
102Requires: %{name}-devel = %{version}-%{release}
103Requires: compat32-glib2-devel
104
105%description -n compat32-%{name}-devel
106Headers and static libraries for D-BUS.
107
108%prep
109%setup -q
110## %patch0 -p1 -b .start-early
111%patch1 -p1 -b .generate-xml-docs
112%patch6 -p1 -b .increase-timeout
113
114%patch10 -p1 -b .workaround-dbus-sendinterface
115
116%build
117autoreconf -f -i
118
119COMMON_ARGS="--enable-selinux=no \
120             --with-init-scripts=redhat \
121             --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
122             --with-dbus-user=dbus \
123             --libdir=/%{_lib} --bindir=/bin \
124             --libexecdir=/%{_lib}/dbus-1 \
125             --sysconfdir=%{_sysconfdir} --exec-prefix=/"
126
127%configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
128%__make
129
130doxygen Doxyfile
131
132xsltproc -o dbus.devhelp %{SOURCE1} doc/api/xml/index.xml
133
134%install
135rm -rf %{buildroot}
136
137%__make install DESTDIR=$RPM_BUILD_ROOT
138
139mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
140
141#change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
142sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
143rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
144
145mkdir -p $RPM_BUILD_ROOT/%{_bindir}
146mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}
147mkdir -p $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
148mv -f $RPM_BUILD_ROOT/%{_lib}/dbus-1.0/include/* $RPM_BUILD_ROOT/%{_libdir}/dbus-1.0/include/
149rm -rf $RPM_BUILD_ROOT/%{_lib}/dbus-1.0
150
151rm -f $RPM_BUILD_ROOT/%{_lib}/*.a
152rm -f $RPM_BUILD_ROOT/%{_lib}/*.la
153
154mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
155mkdir -p $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
156
157cp dbus.devhelp $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
158cp doc/dbus-specification.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
159cp doc/dbus-faq.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
160cp doc/dbus-tutorial.html $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus
161cp doc/api/html/* $RPM_BUILD_ROOT%{_datadir}/devhelp/books/dbus/api
162
163## %find_lang %{gettext_package}
164
165mkdir -p $RPM_BUILD_ROOT%{_datadir}/dbus-1/interfaces
166
167%clean
168rm -rf %{buildroot}
169
170%pre
171# Add the "dbus" user
172/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
173        -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
174
175%post
176/sbin/ldconfig
177/sbin/chkconfig --add messagebus
178/sbin/chkconfig messagebus resetpriorities
179
180%preun
181if [ $1 = 0 ]; then
182    service messagebus stop > /dev/null 2>&1
183    /sbin/chkconfig --del messagebus
184fi
185
186%postun
187/sbin/ldconfig
188
189%post -n compat32-%{name} -p /sbin/ldconfig
190
191%postun -n compat32-%{name} -p /sbin/ldconfig
192
193%files
194%defattr(-,root,root)
195%doc COPYING ChangeLog NEWS
196%dir %{_sysconfdir}/dbus-1
197%config %{_sysconfdir}/dbus-1/*.conf
198%{_sysconfdir}/rc.d/init.d/*
199%dir %{_sysconfdir}/dbus-1/system.d
200%dir %{_sysconfdir}/dbus-1/session.d
201%dir %{_localstatedir}/run/dbus
202%dir %{_localstatedir}/lib/dbus/
203/bin/dbus-daemon
204/bin/dbus-send
205/bin/dbus-cleanup-sockets
206/bin/dbus-monitor
207/bin/dbus-uuidgen
208/%{_lib}/*dbus-1*.so.*
209%{_datadir}/man/man*/dbus-cleanup-sockets.1.gz
210%{_datadir}/man/man*/dbus-daemon.1.gz
211%{_datadir}/man/man*/dbus-monitor.1.gz
212%{_datadir}/man/man*/dbus-send.1.gz
213%{_datadir}/man/man*/dbus-uuidgen.1.gz
214%dir %{_datadir}/dbus-1
215%{_datadir}/dbus-1/services
216%{_datadir}/dbus-1/system-services
217%{_datadir}/dbus-1/interfaces
218%dir /%{_lib}/dbus-1
219%attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
220
221%files devel
222%defattr(-,root,root)
223/%{_lib}/lib*.so
224%{_libdir}/dbus-1.0/include
225%{_libdir}/pkgconfig/*
226%{_includedir}/*
227%{_datadir}/devhelp/books/dbus
228
229%files x11
230%defattr(-,root,root)
231%{_bindir}/dbus-launch
232%{_datadir}/man/man*/dbus-launch.1.gz
233
234# compat32
235%if %{build_compat32}
236%files -n compat32-%{name}
237/%{_lib}/*dbus-1*.so.*
238
239%files -n compat32-%{name}-devel
240%defattr(-,root,root)
241/%{_lib}/lib*.so
242%{_libdir}/dbus-1.0/include
243%{_libdir}/pkgconfig/*
244%endif
245
246%changelog
247* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
248- add BuildRequires: libSM-devel
249
250* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
251- rebuilt with rpm-4.8.1
252
253* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
254- new upstream release
255- drop Patch0
256
257* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
258- rebuilt with new toolchain
259
260* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
261- new upstream release
262
263* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
264- new upstream release
265- do not restart dbus on upgrade
266
267* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
268- added compat32 package for x86_64 arch support
269
270* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
271- add Patch10 for workaround deny send_interface
272  http://bugs.freedesktop.org/show_bug.cgi?id=18961
273  Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
274  Bare <deny send_interface=""/> rules have a far larger impact than one would think.
275  It's really always wrong to use them without also using send_destination.
276  - XXX: this should be fixed in each dbus configuration.
277
278* Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
279- new upstream release with security fix (CVE-2008-4311)
280
281* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
282- new upstream release with security fix (CVE-2008-3834)
283
284* Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
285- new upstream release
286
287* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
288- own the directories /usr/share/dbus-1/{system-services,interfaces}
289- set 'dbus' instead of '81' to --with-dbus-user
290 
291* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
292- import some patches from fedora
293- move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
294
295* Wed May  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
296- new upstream release
297
298* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
299- new upstream release
300
301* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
302- rebuild with expat-2.0.1
303
304* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
305- rebuild with new environment/toolchain
306
307* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
308- require new chkconfig to reset initscript priorities
309
310* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
311- new upstream release
312- split out bindings
313- move base binaries and libraries to /bin and /%{_lib}
314
315* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
316- rebuilt for VineSeed
317
318* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
319- add Vendor/Distribution tag
320
321* Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
322- add patch100 for fix CVE-2006-6107
323
324* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
325- new upstream release
326
327* Sun Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
328- disabled dbus-qt
329- added BuildConflicts: qt-devel
330- removed work around for 64 bit archs
331
332* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
333- new upstream release
334
335* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
336- new upstream release
337
338* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
339- new upstream release
340
341* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
342- new upstream release
343- enable python bindings
344
345* Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
346- initial build for Vine Linux based on FC package
347- disable python bindings
348- disable selinux
349
350* Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
351- Explicitly pass in the pid file location to ./configure instead of
352  letting it guess based on the build enviornment
353
354* Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
355- Add patch to fix random users from connecting to a users session bus
356
357* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
358- Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
359
360* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
361- Update to upstream version 0.23
362- Drop all patches except for the UDI patch as they have been
363  integrated upstream
364- List of API changes:
365      * add setgroups() to drop supplementary groups
366      * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
367      * added support for int64 and uint64 to the python bindings
368      * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
369
370* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
371- rebuild against python 2.4
372
373* Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
374- Add a requires for glib2-devel in the devel package
375- Add SE-Linux backport from Colin Walters that fixes
376  messages getting lost in SE-Linux contexts
377
378* Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
379- Bump up release and rebuild
380
381* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
382- Run /sbin/ldconfig for glib sub-package (bug #134062).
383
384* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
385- Fixed patch to use dbus-1 instead of dbus-1.0
386- (configure.in): Exported just the datadir instead of
387  the full path to the dbus datadir for consistency
388
389* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
390- Adding patch to move /usr/lib/dbus-1.0/services to
391  /usr/share/dbus-1.0/services
392
393* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
394- reverting BuildRequires: redhat-release because of issues with build system
395- added precompiled version of the messagebus init script
396
397* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
398- changed /etc/redhat-release to the package redhat-release
399
400* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
401- added python int64 patch from davidz
402
403* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
404- added BuildRequires: /etc/redhat-release (RH Bug #132436)
405
406* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
407- Added Steve Grubb's spec file patch (RH Bug #130201)
408
409* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
410- Disabled dbus-gtk since dbus-viewer doesn't do anything right now
411
412* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
413- Moved dbus-viewer to new dbus-gtk package so that dbus-glib
414  no longer requires X or GTK libraries. (RH Bug #130029)
415
416* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
417- Update to new 0.22 release
418
419* Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
420- Added BuildRequires for libselinux-devel and Requires for libselinux
421
422* Tue Aug 02 2004 Colin Walters <walters@redhat.com>
423- Add SE-DBus patch
424
425* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
426- Added lib64 workaround for python bindings installing to
427  the wrong lib directory on 64 bit archs
428
429* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
430- Updated console-auth patch
431- rebuild
432 
433* Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
434- Update to upstream CVS build
435- Added console-auth patch
436
437* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
438- Workaround added to fix gcc-3.4 bug on ia64
439
440* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
441- require new Pyrex version and see if it builds this time
442
443* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
444- rebuild with updated Pyrex (0.9.2.1)
445
446* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
447- rebuilt
448
449* Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
450- Moved dbus-viewer, dbus-monitor and dbus-glib-tool
451  into the dbus-glib package so that the main dbus
452  package does not depend on glib (Bug #125285)
453
454* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
455- rebuilt
456
457* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
458- added my Python patch
459- took out the qt build requires
460- added a gtk+ build requires
461
462* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
463- Changed build requirement to version 0.9-3 of Pyrex
464  to fix problem with builing on x86_64
465
466* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
467- update to upstream 0.21
468- removed dbus-0.20-varargs.patch patch (fixed upstream)
469
470* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
471- added a dbus-python package to generate python bindings
472- added Pyrex build dependacy
473
474* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
475- rebuilt
476
477* Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
478- fix dbus error functions on x86-64 (#116324)
479- add prereq (#112027)
480
481* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
482- rebuilt
483
484* Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
485- Conflict with cups prior to configuration file change, so that the
486  %%postun service condrestart works.
487
488* Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
489- rebuild in fc2, cups now updated
490
491* Wed Jan  7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
492- update to upstream 0.20
493
494* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
495- hmm, dbus doesn't support uids in the config file. fix.
496
497* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
498- put uid instead of username in the config file, to keep things working with name change
499
500* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
501- make subpackages require the specific release, not just version, of base package
502
503* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
504- change system user "messagebus" -> "dbus" to be under 8 chars
505
506* Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
507- see if removing qt subpackage for now will get us through the build system,
508  qt bindings not useful yet anyway
509
510* Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
511- 0.13 fixes a little security oops
512
513* Mon Aug  4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
514- break the tiny dbus-launch that depends on X into separate package
515  so a CUPS server doesn't need X installed
516
517* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
518- rebuilt
519
520* Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
521- 0.11.91 cvs snap properly merges system.d
522
523* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
524- build a cvs snap with a few more fixes
525
526* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
527- fix a crash that was breaking cups
528
529* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
530- 0.11
531
532* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
533- use rc.d/init.d not init.d, bug #90192
534- include the new man pages
535
536* Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
537- 0.9
538- export QTDIR explicitly
539- re-enable qt, the problem was most likely D-BUS configure
540
541* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
542- update from CVS with a fix to set uid after gid
543
544* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
545- new cvs snap that actually forks to background and changes
546  user it's running as and so forth
547- create our system user in pre
548
549* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
550- fix for "make check" test that required a home directory
551
552* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
553- disable qt for now because beehive hates me
554- pull a slightly newer cvs snap that creates socket directory
555- cat the make check log after make check fails
556
557* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
558- initial build
559
Note: See TracBrowser for help on using the repository browser.