source: projects/specs/trunk/d/dbus/dbus-vl.spec @ 11183

Revision 11183, 22.1 KB checked in by tomop, 7 years ago (diff)

dbus-1.10.22-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define _unpackaged_files_terminate_build 1
4%bcond_with systemd
5
6%define gettext_package dbus
7%define expat_version           2.0.1
8%define dbus_user_uid           81
9
10%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
11%define _localstatedir %{_var}
12
13Summary: D-BUS message bus
14Summary(ja): D-BUS メッセージバスシステム
15Name: dbus
16Version: 1.10.22
17Release: 1%{?_dist_release}
18URL: http://www.freedesktop.org/software/dbus/
19License: AFL/GPLv2
20Group: System Environment/Libraries
21
22Source0: %{name}-%{version}.tar.gz
23Source1: 00-start-message-bus.sh
24
25# from fedora package
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28Requires(post): chkconfig >= 1.3.34
29Requires(preun): chkconfig >= 1.3.34
30Requires(pre): shadow-utils
31BuildRequires: libtool
32BuildRequires: expat-devel >= %{expat_version}
33BuildRequires: libxml2-devel
34BuildRequires: python-devel
35BuildRequires: doxygen
36BuildRequires: xmlto
37BuildRequires: libxslt
38BuildRequires: gettext
39BuildRequires: libX11-devel
40BuildRequires: libSM-devel
41
42Vendor: Project Vine
43Distribution: Vine Linux
44
45%description
46D-BUS is a system for sending messages between applications. It is
47used both for the systemwide message bus service, and as a
48per-user-login-session messaging facility.
49
50%description -l ja
51D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
52システム全体のメッセージバスサービスとしても利用されますが、同様に
53ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
54
55%package devel
56Summary: Libraries and headers for D-BUS
57Summary(ja): D-BUS 用のライブラリとヘッダファイル
58Group: Development/Libraries
59Requires: %{name} = %{version}-%{release}
60
61%description devel
62Headers and static libraries for D-BUS.
63
64%package x11
65Summary: X11-requiring add-ons for D-BUS
66Summary(ja): X11 を利用する D-BUS 用ツール
67Group: Applications/System
68Requires: %{name} = %{version}-%{release}
69
70%description x11
71D-BUS contains some tools that require Xlib to be installed, those are
72in this separate package so server systems need not install X.
73
74%package doc
75Summary: Developer documentation for D-BUS
76Group: Documentation
77Requires: %{name} = %{version}-%{release}
78BuildArch: noarch
79
80%description doc
81This package contains developer documentation for D-Bus along with
82other supporting documentation such as the introspect dtd file.
83
84# compat32
85%package -n compat32-%{name}
86Summary: D-BUS message bus
87Summary(ja): D-BUS メッセージバスシステム
88Group: System Environment/Libraries
89
90%description -n compat32-%{name}
91D-BUS is a system for sending messages between applications. It is
92used both for the systemwide message bus service, and as a
93per-user-login-session messaging facility.
94
95%description -n compat32-%{name} -l ja
96D-BUS はアプリケーション間でメッセージを送受信するためのシステムです。
97システム全体のメッセージバスサービスとしても利用されますが、同様に
98ユーザ毎のログインセッションにおけるメッセージ基盤としても利用されます。
99
100%package -n compat32-%{name}-devel
101Summary: Libraries and headers for D-BUS
102Summary(ja): D-BUS 用のライブラリとヘッダファイル
103Group: Development/Libraries
104Requires: compat32-%{name} = %{version}-%{release}
105Requires: %{name}-devel = %{version}-%{release}
106
107%description -n compat32-%{name}-devel
108Headers and static libraries for D-BUS.
109
110%prep
111%setup -q
112
113%build
114# Avoid rpath.
115if test -f autogen.sh; then env NOCONFIGURE=1 ./autogen.sh; else autoreconf --ve
116rbose --force --install; fi
117
118COMMON_ARGS="--enable-selinux=no \
119                --disable-libaudit \
120                --with-init-scripts=redhat \
121                --with-system-pid-file=%{_localstatedir}/run/messagebus.pid \
122                --with-dbus-user=dbus \
123                --libdir=/%{_lib} --bindir=/bin \
124                --libexecdir=/%{_lib}/dbus-1 \
125                --docdir=%{_pkgdocdir} \
126                --sysconfdir=%{_sysconfdir} --exec-prefix=/"
127
128%configure $COMMON_ARGS --disable-tests --disable-verbose-mode --disable-asserts --enable-doxygen-docs --enable-xml-docs
129make V=1 %{?_smp_mflags}
130
131%install
132rm -rf %{buildroot}
133
134%__make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
135
136find %{buildroot} -name '*.a' -type f -delete
137find %{buildroot} -name '*.la' -type f -delete
138
139install -Dp -m755 %{SOURCE1} %{buildroot}%{_sysconfdir}/X11/xinit/xinitrc.d/00-start-message-bus.sh
140
141# Obsolete, but still widely used, for drop-in configuration snippets.
142install --directory %{buildroot}%{_sysconfdir}/dbus-1/session.d
143install --directory %{buildroot}%{_sysconfdir}/dbus-1/system.d
144
145install --directory %{buildroot}%{_datadir}/dbus-1/interfaces
146
147%if %{with systemd}
148# Make sure that when somebody asks for D-Bus under the name of the
149# old SysV script, that he ends up with the standard dbus.service name
150# now.
151ln -s dbus.service %{buildroot}%{_unitdir}/messagebus.service
152
153## %find_lang %{gettext_package}
154# Delete the old legacy sysv init script
155rm -rf %{buildroot}%{_initrddir}
156%else
157rm -rf %{buildroot}%{_sysconfdir}/systemd
158%endif
159
160install --directory %{buildroot}/var/lib/dbus
161
162install --directory %{buildroot}%{_pkgdocdir}
163install -pm 644 -t %{buildroot}%{_pkgdocdir} \
164    doc/introspect.dtd doc/introspect.xsl doc/system-activation.txt
165
166# Make sure that the documentation shows up in Devhelp.
167install --directory %{buildroot}%{_datadir}/gtk-doc/html
168ln -s %{_pkgdocdir} %{buildroot}%{_datadir}/gtk-doc/html/dbus
169
170# Shell wrapper for installed tests, modified from Debian package.
171cat > dbus-run-installed-tests <<EOF
172#!/bin/sh
173# installed-tests wrapper for dbus. Outputs TAP format because why not
174
175set -e
176
177timeout="timeout 300s"
178ret=0
179i=0
180tmpdir=\$(mktemp --directory --tmpdir dbus-run-installed-tests.XXXXXX)
181
182for t in /%{_lib}/dbus-1/installed-tests/dbus/test-*; do
183    i=\$(( \$i + 1 ))
184    echo "# \$i - \$t ..."
185    echo "x" > "\$tmpdir/result"
186    ( set +e; \$timeout \$t; echo "\$?" > "\$tmpdir/result" ) 2>&1 | sed 's/^/#/'
187    e="\$(cat "\$tmpdir/result")"
188    case "\$e" in
189        (0)
190            echo "ok \$i - \$t"
191            ;;
192        (77)
193            echo "ok \$i # SKIP \$t"
194            ;;
195        (*)
196            echo "not ok \$i - \$t (\$e)"
197            ret=1
198            ;;
199    esac
200done
201
202rm -rf tmpdir
203echo "1..\$i"
204exit \$ret
205EOF
206
207install -pm 755 -t %{buildroot}/%{_lib}/dbus-1 dbus-run-installed-tests
208
209## vine stuff
210
211mkdir -p $RPM_BUILD_ROOT/%{_bindir}
212mv -f $RPM_BUILD_ROOT/bin/dbus-launch $RPM_BUILD_ROOT/%{_bindir}/
213
214mkdir -p %{buildroot}/%{_libdir}/dbus-1.0
215mv %{buildroot}/%{_lib}/dbus-1.0/include %{buildroot}/%{_libdir}/dbus-1.0/
216
217mkdir -p $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
218#change the arch-deps.h include directory to /usr/lib[64] instead of /lib[64]
219sed -e 's@-I${libdir}@-I${prefix}/%{_lib}@' $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc > $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/dbus-1.pc
220rm -f $RPM_BUILD_ROOT/%{_lib}/pkgconfig/dbus-1.pc
221
222rm -f $RPM_BUILD_ROOT/%{_lib}/dbus-1/dbus-run-installed-tests
223
224%clean
225rm -rf %{buildroot}
226
227%pre
228# Add the "dbus" user
229/usr/sbin/useradd -c 'System message bus' -u %{dbus_user_uid} \
230        -s /sbin/nologin -r -d '/' dbus 2> /dev/null || :
231
232%post
233/sbin/ldconfig
234/sbin/chkconfig --add messagebus
235/sbin/chkconfig messagebus resetpriorities
236
237%preun
238if [ $1 = 0 ]; then
239    service messagebus stop > /dev/null 2>&1
240    /sbin/chkconfig --del messagebus
241fi
242
243%postun
244/sbin/ldconfig
245
246%post -n compat32-%{name} -p /sbin/ldconfig
247
248%postun -n compat32-%{name} -p /sbin/ldconfig
249
250%files
251%defattr(-,root,root)
252%{!?_licensedir:%global license %%doc}
253%license COPYING
254%doc AUTHORS ChangeLog HACKING NEWS README
255%dir %{_sysconfdir}/dbus-1
256%config %{_sysconfdir}/dbus-1/*.conf
257%ghost %dir /run/%{name}
258%{_sysconfdir}/rc.d/init.d/*
259%dir %{_sysconfdir}/dbus-1/system.d
260%dir %{_sysconfdir}/dbus-1/session.d
261%dir %{_localstatedir}/run/dbus
262%dir %{_localstatedir}/lib/dbus/
263/bin/dbus-daemon
264/bin/dbus-send
265/bin/dbus-cleanup-sockets
266/bin/dbus-monitor
267/bin/dbus-run-session
268/bin/dbus-test-tool
269/bin/dbus-update-activation-environment
270/bin/dbus-uuidgen
271/%{_lib}/*dbus-1*.so.*
272%{_mandir}/man*/dbus-cleanup-sockets.1.gz
273%{_mandir}/man*/dbus-daemon.1.gz
274%{_mandir}/man*/dbus-monitor.1.gz
275%{_mandir}/man*/dbus-run-session.1.gz
276%{_mandir}/man*/dbus-send.1.gz
277%{_mandir}/man1/dbus-test-tool.1.gz
278%{_mandir}/man1/dbus-update-activation-environment.1.gz
279%{_mandir}/man*/dbus-uuidgen.1.gz
280%dir %{_datadir}/dbus-1
281%{_datadir}/dbus-1/session.conf
282%{_datadir}/dbus-1/system.conf
283%{_datadir}/dbus-1/services
284%{_datadir}/dbus-1/system-services
285%{_datadir}/dbus-1/interfaces
286%dir /%{_lib}/dbus-1
287%attr(4750,root,dbus) /%{_lib}/dbus-1/dbus-daemon-launch-helper
288
289%files devel
290%defattr(-,root,root)
291/%{_lib}/lib*.so
292%{_libdir}/dbus-1.0/include
293%{_libdir}/pkgconfig/*
294%{_includedir}/*
295
296%files x11
297%defattr(-,root,root)
298%{_bindir}/dbus-launch
299%{_datadir}/man/man*/dbus-launch.1.gz
300%{_sysconfdir}/X11/xinit/xinitrc.d/00-start-message-bus.sh
301
302%files doc
303%defattr(-,root,root)
304%{_pkgdocdir}/*
305%{_datadir}/gtk-doc
306%exclude %{_pkgdocdir}/AUTHORS
307%exclude %{_pkgdocdir}/ChangeLog
308%exclude %{_pkgdocdir}/HACKING
309%exclude %{_pkgdocdir}/NEWS
310%exclude %{_pkgdocdir}/README
311
312# compat32
313%if %{build_compat32}
314%files -n compat32-%{name}
315/%{_lib}/*dbus-1*.so.*
316
317%files -n compat32-%{name}-devel
318%defattr(-,root,root)
319/%{_lib}/lib*.so
320%{_libdir}/dbus-1.0/include
321%endif
322
323%changelog
324* Sun Sep 10 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.22-1
325- new upstream release.
326
327* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.20-1
328- new upstream release
329
330* Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.18-1
331- new upstream release
332
333* Sun Mar 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.16-1
334- new upstream release
335
336* Sat Jan 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.14-1
337- new upstream release
338
339* Mon Dec 01 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.28-1
340- new upstream release
341
342* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.24-1
343- new upstream release
344
345* Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.22-1
346- new upstream release
347
348* Wed Jun 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.20-1
349- new upstream release
350
351* Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.18-1
352- new upstream release
353
354* Fri Sep 06 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.14-1
355- new upstream release
356
357* Sun Apr 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-1
358- new upstream release
359
360* Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-2
361- remove BuildRequires: audit-libs-devel, libcap-ng-devel
362
363* Sat Oct 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.8-1
364- new upstream release
365- remove old patches
366
367* Sun Apr 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.20-1
368- new upstream release
369- add BuildRequires: audit-libs-devel, libcap-ng-devel
370
371* Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.18-1
372- new upstream release
373- remove Requires: libxml2-python
374
375* Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.16-1
376- new upstream release
377
378* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.14-1
379- new upstream release
380- drop Patch1
381- create -doc sub package
382
383* Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
384- new upstream release
385
386* Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
387- new upstream release
388
389* Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.2.24-3
390- add BuildRequires: libSM-devel
391
392* Tue Sep 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.24-2
393- rebuilt with rpm-4.8.1
394
395* Wed Mar 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.24-1
396- new upstream release
397- drop Patch0
398
399* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.16-2
400- rebuilt with new toolchain
401
402* Sat Sep 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.16-1
403- new upstream release
404
405* Mon Jul 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.14-1
406- new upstream release
407- do not restart dbus on upgrade
408
409* Sun May 10 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.12-3
410- added compat32 package for x86_64 arch support
411
412* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.12-2
413- add Patch10 for workaround deny send_interface
414  http://bugs.freedesktop.org/show_bug.cgi?id=18961
415  Bug 18961: Skip bare <deny send_interface=""/> for not (method_call|signal)
416  Bare <deny send_interface=""/> rules have a far larger impact than one would think.
417  It's really always wrong to use them without also using send_destination.
418  - XXX: this should be fixed in each dbus configuration.
419
420* Tue Mar 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.12-1
421- new upstream release with security fix (CVE-2008-4311)
422
423* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.4-1
424- new upstream release with security fix (CVE-2008-3834)
425
426* Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-1
427- new upstream release
428
429* Thu Aug 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-3
430- own the directories /usr/share/dbus-1/{system-services,interfaces}
431- set 'dbus' instead of '81' to --with-dbus-user
432 
433* Sun Aug 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
434- import some patches from fedora
435- move dbus-daemon-launch-helper to /%%{_lib}/dbus-1/
436
437* Wed May  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
438- new upstream release
439
440* Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.20-1vl5
441- new upstream release
442
443* Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.0.2-0vl4
444- rebuild with expat-2.0.1
445
446* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl3
447- rebuild with new environment/toolchain
448
449* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
450- require new chkconfig to reset initscript priorities
451
452* Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
453- new upstream release
454- split out bindings
455- move base binaries and libraries to /bin and /%{_lib}
456
457* Wed Dec 27 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.62-0vl2
458- rebuilt for VineSeed
459
460* Thu Dec 21 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.2
461- add Vendor/Distribution tag
462
463* Thu Dec 14 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.62-0vl1.1
464- add patch100 for fix CVE-2006-6107
465
466* Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.62-0vl1
467- new upstream release
468
469* Sat Jun 10 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.61-0vl2
470- disabled dbus-qt
471- added BuildConflicts: qt-devel
472- removed work around for 64 bit archs
473
474* Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.61-0vl1
475- new upstream release
476
477* Fri Jan 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.60-0vl1
478- new upstream release
479
480* Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
481- new upstream release
482
483* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.34-0vl1
484- new upstream release
485- enable python bindings
486
487* Sat Mar 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.23-4vl1
488- initial build for Vine Linux based on FC package
489- disable python bindings
490- disable selinux
491
492* Tue Feb 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-4
493- Explicitly pass in the pid file location to ./configure instead of
494  letting it guess based on the build enviornment
495
496* Mon Jan 31 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-3
497- Add patch to fix random users from connecting to a users session bus
498
499* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-2
500- Add Steve Grubb's SE-Linux audit patch (Bug# 144920)
501
502* Fri Jan 21 2005 John (J5) Palmieri <johnp@redhat.com> - 0.23-1
503- Update to upstream version 0.23
504- Drop all patches except for the UDI patch as they have been
505  integrated upstream
506- List of API changes:
507      * add setgroups() to drop supplementary groups
508      * removed dbus_bug_get_with_g_main since it's been replaced by dbus_g_bus_get
509      * added support for int64 and uint64 to the python bindings
510      * use SerivceOwnerChanges signal instead of ServiceCreated and ServiceDeleted
511
512* Mon Nov  8 2004 Jeremy Katz <katzj@redhat.com> - 0.22-12
513- rebuild against python 2.4
514
515* Tue Nov 02 2004 John (J5) Palmieri <johnp@redhat.com>
516- Add a requires for glib2-devel in the devel package
517- Add SE-Linux backport from Colin Walters that fixes
518  messages getting lost in SE-Linux contexts
519
520* Wed Oct 13 2004 John (J5) Palmieri <johnp@redhat.com>
521- Bump up release and rebuild
522
523* Mon Oct 11 2004 Tim Waugh <twaugh@redhat.com>
524- Run /sbin/ldconfig for glib sub-package (bug #134062).
525
526* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
527- Fixed patch to use dbus-1 instead of dbus-1.0
528- (configure.in): Exported just the datadir instead of
529  the full path to the dbus datadir for consistency
530
531* Wed Sep 22 2004 John (J5) Palmieri <johnp@redhat.com>
532- Adding patch to move /usr/lib/dbus-1.0/services to
533  /usr/share/dbus-1.0/services
534
535* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
536- reverting BuildRequires: redhat-release because of issues with build system
537- added precompiled version of the messagebus init script
538
539* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
540- changed /etc/redhat-release to the package redhat-release
541
542* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
543- added python int64 patch from davidz
544
545* Thu Sep 16 2004 John (J5) Palmieri <johnp@redhat.com>
546- added BuildRequires: /etc/redhat-release (RH Bug #132436)
547
548* Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com>
549- Added Steve Grubb's spec file patch (RH Bug #130201)
550
551* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
552- Disabled dbus-gtk since dbus-viewer doesn't do anything right now
553
554* Mon Aug 16 2004 John (J5) Palmieri <johnp@redhat.com>
555- Moved dbus-viewer to new dbus-gtk package so that dbus-glib
556  no longer requires X or GTK libraries. (RH Bug #130029)
557
558* Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com>
559- Update to new 0.22 release
560
561* Thu Aug 05 2004 John (J5) Palmieri <johnp@redhat.com>
562- Added BuildRequires for libselinux-devel and Requires for libselinux
563
564* Mon Aug 02 2004 Colin Walters <walters@redhat.com>
565- Add SE-DBus patch
566
567* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
568- Added lib64 workaround for python bindings installing to
569  the wrong lib directory on 64 bit archs
570
571* Fri Jul 30 2004 John (J5) Palmieri <johnp@redhat.com>
572- Updated console-auth patch
573- rebuild
574 
575* Thu Jul 22 2004 John (J5) Palmieri <johnp@redhat.com>
576- Update to upstream CVS build
577- Added console-auth patch
578
579* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
580- Workaround added to fix gcc-3.4 bug on ia64
581
582* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
583- require new Pyrex version and see if it builds this time
584
585* Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com>
586- rebuild with updated Pyrex (0.9.2.1)
587
588* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
589- rebuilt
590
591* Fri Jun 04 2004 John (J5) Palmieri <johnp@redhat.com>
592- Moved dbus-viewer, dbus-monitor and dbus-glib-tool
593  into the dbus-glib package so that the main dbus
594  package does not depend on glib (Bug #125285)
595
596* Thu Jun 03 2004 John (J5) Palmieri <johnp@redhat.com>
597- rebuilt
598
599* Thu May 27 2004 John (J5) Palmieri <johnp@redhat.com>
600- added my Python patch
601- took out the qt build requires
602- added a gtk+ build requires
603
604* Fri Apr 23 2004 John (J5) Palmieri <johnp@redhat.com>
605- Changed build requirement to version 0.9-3 of Pyrex
606  to fix problem with builing on x86_64
607
608* Tue Apr 20 2004 John (J5) Palmieri <johnp@redhat.com>
609- update to upstream 0.21
610- removed dbus-0.20-varargs.patch patch (fixed upstream)
611
612* Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com>
613- added a dbus-python package to generate python bindings
614- added Pyrex build dependacy
615
616* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
617- rebuilt
618
619* Wed Feb 25 2004 Bill Nottingham <notting@redhat.com> 0.20-4
620- fix dbus error functions on x86-64 (#116324)
621- add prereq (#112027)
622
623* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
624- rebuilt
625
626* Fri Feb 13 2004 Tim Waugh <twaugh@redhat.com>
627- Conflict with cups prior to configuration file change, so that the
628  %%postun service condrestart works.
629
630* Wed Feb 11 2004 Havoc Pennington <hp@redhat.com> 0.20-2
631- rebuild in fc2, cups now updated
632
633* Wed Jan  7 2004 Bill Nottingham <notting@redhat.com> 0.20-1
634- update to upstream 0.20
635
636* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-6
637- hmm, dbus doesn't support uids in the config file. fix.
638
639* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-5
640- put uid instead of username in the config file, to keep things working with name change
641
642* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-4
643- make subpackages require the specific release, not just version, of base package
644
645* Thu Oct 16 2003 Havoc Pennington <hp@redhat.com> 0.13-3
646- change system user "messagebus" -> "dbus" to be under 8 chars
647
648* Mon Sep 29 2003 Havoc Pennington <hp@redhat.com> 0.13-2
649- see if removing qt subpackage for now will get us through the build system,
650  qt bindings not useful yet anyway
651
652* Sun Sep 28 2003 Havoc Pennington <hp@redhat.com> 0.13-1
653- 0.13 fixes a little security oops
654
655* Mon Aug  4 2003 Havoc Pennington <hp@redhat.com> 0.11.91-3
656- break the tiny dbus-launch that depends on X into separate package
657  so a CUPS server doesn't need X installed
658
659* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
660- rebuilt
661
662* Sat May 17 2003 Havoc Pennington <hp@redhat.com> 0.11.91-1
663- 0.11.91 cvs snap properly merges system.d
664
665* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11.90-1
666- build a cvs snap with a few more fixes
667
668* Fri May 16 2003 Havoc Pennington <hp@redhat.com> 0.11-2
669- fix a crash that was breaking cups
670
671* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.11-1
672- 0.11
673
674* Thu May 15 2003 Havoc Pennington <hp@redhat.com> 0.10.90-1
675- use rc.d/init.d not init.d, bug #90192
676- include the new man pages
677
678* Fri Apr 11 2003 Havoc Pennington <hp@redhat.com> 0.9-1
679- 0.9
680- export QTDIR explicitly
681- re-enable qt, the problem was most likely D-BUS configure
682
683* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.94-1
684- update from CVS with a fix to set uid after gid
685
686* Tue Apr  1 2003 Havoc Pennington <hp@redhat.com> 0.6.93-1
687- new cvs snap that actually forks to background and changes
688  user it's running as and so forth
689- create our system user in pre
690
691* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.92-1
692- fix for "make check" test that required a home directory
693
694* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.91-1
695- disable qt for now because beehive hates me
696- pull a slightly newer cvs snap that creates socket directory
697- cat the make check log after make check fails
698
699* Mon Mar 31 2003 Havoc Pennington <hp@redhat.com> 0.6.90-1
700- initial build
701
Note: See TracBrowser for help on using the repository browser.