source: projects/specs/trunk/d/davfs2/davfs2-vl.spec @ 9913

Revision 9913, 4.2 KB checked in by tomop, 8 years ago (diff)

davfs2-1.5.2-1

Line 
1Name:           davfs2
2Version:        1.5.2
3Release:        1%{?_dist_release}
4Summary:        A filesystem driver for WebDAV
5Summary(ja):    WebDAV 用のファイルシステムドライバ
6Group:          System Environment/Base
7License:        GPLv2+
8URL:            http://savannah.nongnu.org/projects/davfs2
9Source0:        http://download.savannah.gnu.org/releases/davfs2/davfs2-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
11
12BuildRequires:  gettext
13BuildRequires:  neon-devel
14BuildRequires:  krb5-devel
15Requires(pre):  shadow-utils
16
17%define cachedir /var/cache/davfs2
18%define piddir /var/run/mount.davfs
19%define username davfs2
20%define groupname %{username}
21
22%description
23davfs2 is a Linux file system driver that allows you to mount a WebDAV server
24as a disk drive.
25
26%prep
27%setup -q
28
29%build
30# ad-hoc fix for building with neon 0.30.0
31#sed -i -e 's/27 28 29/27 28 29 30/g' configure
32
33%configure
34make
35
36
37%install
38rm -rf $RPM_BUILD_ROOT
39make install DESTDIR=$RPM_BUILD_ROOT
40%find_lang %{name}
41# Create directories used by mount.davfs
42install -d $RPM_BUILD_ROOT%{cachedir} $RPM_BUILD_ROOT%{piddir}
43# Fix symlinks
44ln -sf ../usr/sbin/mount.davfs $RPM_BUILD_ROOT/sbin/mount.davfs
45ln -sf ../usr/sbin/umount.davfs $RPM_BUILD_ROOT/sbin/umount.davfs
46# Don't need this - we'll do our own doc install, thanks
47rm -rf $RPM_BUILD_ROOT/usr/share/doc/davfs2
48# Remove duplicate files. (Why is it installing these in the first place?)
49rm -rf $RPM_BUILD_ROOT/usr/share/davfs2 # same files in /etc/davfs2
50# Remove suid bit, to work around a problem with brp-strip on suid binaries
51chmod 0755 $RPM_BUILD_ROOT/%{_sbindir}/mount.davfs
52# UTF8ify translated man pages
53find $RPM_BUILD_ROOT/%{_mandir}/{de,es} -name "*.[58].gz" | while read m; do
54  gzip -dc $m | iconv -f "ISO8859-15" -t "UTF-8" - -o - | gzip -c9 > $m.utf8
55  mv -f $m.utf8 $m
56done
57
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%pre
63getent group  %{groupname} >/dev/null || groupadd -r %{groupname}
64getent passwd %{username} >/dev/null || \
65  useradd -r -g %{groupname} -d %{cachedir} -s /sbin/nologin \
66          -c "User account for %{name}" %{username}
67exit 0
68
69
70%files -f %{name}.lang
71%defattr(-,root,root,-)
72# Docs
73%doc AUTHORS BUGS COPYING ChangeLog FAQ INSTALL NEWS README README.translators THANKS TODO
74%{_mandir}/man5/*.gz
75%{_mandir}/man8/*.gz
76# localized man pages
77%{_mandir}/*/man5/*.gz
78%{_mandir}/*/man8/*.gz
79
80# Configfiles etc.
81%config(noreplace) %{_sysconfdir}/davfs2/davfs2.conf
82%config(noreplace) %{_sysconfdir}/davfs2/secrets
83%dir %{_sysconfdir}/davfs2/certs/private/
84%dir %{_sysconfdir}/davfs2/certs/
85%dir %{_sysconfdir}/davfs2/
86
87# Binaries
88%{_sbindir}/umount.davfs
89# re-apply suid bit to mount.davfs
90%attr (4755,root,root) %{_sbindir}/mount.davfs
91# symlinks to files in %{_sbindir}
92/sbin/mount.davfs
93/sbin/umount.davfs
94
95# Extra dirs needed by mount.davfs
96%dir %attr(00775,root,%{groupname}) %{cachedir}
97%dir %attr(01775,root,%{groupname}) %{piddir}
98
99%changelog
100* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.2-1
101- new upstream release.
102- built with gnutls-3.4.x.
103- removed patch0 (no longer needed).
104
105* Fri Dec 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.5-3
106- rebuilt on current VineSeed
107- fixed spec to built with neon 0.30
108
109* Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-2
110- rebuild with krb5-1.8.2
111- add BR: krb5-devel
112
113* Wed Jan 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-1
114- initial build for Vine Linux
115
116* Mon Feb 15 2010 Will Woods <wwoods@redhat.com> - 1.4.5-2
117- Add davfs2-1.4.5-sys_stat_h.patch to fix building on F13
118
119* Wed Jan 13 2010 Will Woods <wwoods@redhat.com> - 1.4.5-1
120- New upstream release (fixes rebuild failure, see bug 538913)
121- NOTE: 1.4.x has different config file syntax. Read the NEWS file!
122
123* Thu Sep 17 2009 Peter Lemenkov <lemenkov@gmail.com> - 1.3.3-5
124- bump
125
126* Thu Sep 17 2009 Peter Lemenkov <lemenkov@gmail.com> - 1.3.3-4
127- Rebuilt with new fuse
128
129* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-3
130- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
131
132* Wed Mar 11 2009 Will Woods <wwoods@redhat.com> - 1.3.3-2
133- Passed package review (#488858)
134- Ensure that package owns /etc/davfs2 and /etc/davfs2/certs
135
136* Mon Mar 02 2009 Will Woods <wwoods@redhat.com> - 1.3.3-1
137- Initial packaging
138- Fix open() with O_CREAT and no mode
Note: See TracBrowser for help on using the repository browser.