source: projects/specs/trunk/d/davfs2/davfs2-vl.spec @ 12219

Revision 12219, 4.4 KB checked in by tomop, 5 years ago (diff)

davfs2-1.5.5-1

Line 
1Name:           davfs2
2Version:        1.5.5
3Release:        1%{?_dist_release}
4Summary:        A filesystem driver for WebDAV
5Summary(ja):    WebDAV 用のファイルシステムドライバ
6Group:          System Environment/Base
7License:        GPLv2+
8Vendor:         Project Vine
9Distribution:   Vine Linux
10URL:            http://savannah.nongnu.org/projects/davfs2
11Source0:        http://download.savannah.gnu.org/releases/davfs2/davfs2-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildRequires:  gettext
15BuildRequires:  neon-devel
16BuildRequires:  krb5-devel
17Requires(pre):  shadow-utils
18
19%define cachedir /var/cache/davfs2
20%define piddir /var/run/mount.davfs
21%define username davfs2
22%define groupname %{username}
23
24%description
25davfs2 is a Linux file system driver that allows you to mount a WebDAV server
26as a disk drive.
27
28%prep
29%setup -q
30
31%build
32# ad-hoc fix for building with neon 0.30.0
33#sed -i -e 's/27 28 29/27 28 29 30/g' configure
34
35%configure
36make
37
38
39%install
40rm -rf $RPM_BUILD_ROOT
41make install DESTDIR=$RPM_BUILD_ROOT
42%find_lang %{name}
43# Create directories used by mount.davfs
44install -d $RPM_BUILD_ROOT%{cachedir} $RPM_BUILD_ROOT%{piddir}
45# Fix symlinks
46ln -sf ../usr/sbin/mount.davfs $RPM_BUILD_ROOT/sbin/mount.davfs
47ln -sf ../usr/sbin/umount.davfs $RPM_BUILD_ROOT/sbin/umount.davfs
48# Don't need this - we'll do our own doc install, thanks
49rm -rf $RPM_BUILD_ROOT/usr/share/doc/davfs2
50# Remove duplicate files. (Why is it installing these in the first place?)
51rm -rf $RPM_BUILD_ROOT/usr/share/davfs2 # same files in /etc/davfs2
52# Remove suid bit, to work around a problem with brp-strip on suid binaries
53chmod 0755 $RPM_BUILD_ROOT/%{_sbindir}/mount.davfs
54# UTF8ify translated man pages
55find $RPM_BUILD_ROOT/%{_mandir}/{de,es} -name "*.[58].gz" | while read m; do
56  gzip -dc $m | iconv -f "ISO8859-15" -t "UTF-8" - -o - | gzip -c9 > $m.utf8
57  mv -f $m.utf8 $m
58done
59
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%pre
65getent group  %{groupname} >/dev/null || groupadd -r %{groupname}
66getent passwd %{username} >/dev/null || \
67  useradd -r -g %{groupname} -d %{cachedir} -s /sbin/nologin \
68          -c "User account for %{name}" %{username}
69exit 0
70
71
72%files -f %{name}.lang
73%defattr(-,root,root,-)
74%license COPYING
75# Docs
76%doc AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README README.translators THANKS TODO
77%{_mandir}/man5/*.gz
78%{_mandir}/man8/*.gz
79# localized man pages
80%{_mandir}/*/man5/*.gz
81%{_mandir}/*/man8/*.gz
82
83# Configfiles etc.
84%config(noreplace) %{_sysconfdir}/davfs2/davfs2.conf
85%config(noreplace) %{_sysconfdir}/davfs2/secrets
86%dir %{_sysconfdir}/davfs2/certs/private/
87%dir %{_sysconfdir}/davfs2/certs/
88%dir %{_sysconfdir}/davfs2/
89
90# Binaries
91%{_sbindir}/umount.davfs
92# re-apply suid bit to mount.davfs
93%attr (4755,root,root) %{_sbindir}/mount.davfs
94# symlinks to files in %{_sbindir}
95/sbin/mount.davfs
96/sbin/umount.davfs
97
98# Extra dirs needed by mount.davfs
99%dir %attr(00775,root,%{groupname}) %{cachedir}
100%dir %attr(01775,root,%{groupname}) %{piddir}
101
102%changelog
103* Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.5-1
104- new upstream release.
105
106* Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.2-1
107- new upstream release.
108- built with gnutls-3.4.x.
109- removed patch0 (no longer needed).
110
111* Fri Dec 26 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.5-3
112- rebuilt on current VineSeed
113- fixed spec to built with neon 0.30
114
115* Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-2
116- rebuild with krb5-1.8.2
117- add BR: krb5-devel
118
119* Wed Jan 19 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.5-1
120- initial build for Vine Linux
121
122* Mon Feb 15 2010 Will Woods <wwoods@redhat.com> - 1.4.5-2
123- Add davfs2-1.4.5-sys_stat_h.patch to fix building on F13
124
125* Wed Jan 13 2010 Will Woods <wwoods@redhat.com> - 1.4.5-1
126- New upstream release (fixes rebuild failure, see bug 538913)
127- NOTE: 1.4.x has different config file syntax. Read the NEWS file!
128
129* Thu Sep 17 2009 Peter Lemenkov <lemenkov@gmail.com> - 1.3.3-5
130- bump
131
132* Thu Sep 17 2009 Peter Lemenkov <lemenkov@gmail.com> - 1.3.3-4
133- Rebuilt with new fuse
134
135* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-3
136- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
137
138* Wed Mar 11 2009 Will Woods <wwoods@redhat.com> - 1.3.3-2
139- Passed package review (#488858)
140- Ensure that package owns /etc/davfs2 and /etc/davfs2/certs
141
142* Mon Mar 02 2009 Will Woods <wwoods@redhat.com> - 1.3.3-1
143- Initial packaging
144- Fix open() with O_CREAT and no mode
Note: See TracBrowser for help on using the repository browser.