source: projects/specs/trunk/d/dash/dash-vl.spec @ 521

Revision 521, 8.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:       The Debian Almquist Shell (formerly NetBSD's ash)
2Summary(ja):   Bourne シェル (sh) の機能縮小版 (Debian 版 ash)
3Name:          dash
4Version:       0.5.5.1
5Release:       1%{?_dist_release}
6License:       BSD
7Group:         System Environment/Shells
8Source:        ftp://ftp.debian.org/debian/pool/main/d/shells/%{name}_%{version}.orig.tar.gz
9BuildRequires: bison
10BuildRequires: dietlibc
11Requires(pre): fileutils grep
12Obsoletes:     ash <= 0.4
13Provides:      ash = %{version}-%{release}
14Buildroot:     %{_tmppath}/%{name}-%{version}-root
15Conflicts:     mkinitrd <= 1.7
16
17
18%description
19"dash" is a POSIX compliant shell that is much smaller than "bash".
20Dash supports many features that a real sh shell would support, however
21it is much smaller in size. This becomes an advantage in situations
22where there is a lack of memery (initial ram-disks, etc). dash does
23lack a few features, like command line history.
24
25dash is the continuation of the original NetBSD ash fork. dash is much
26more up-to-date, and properly maintained.
27
28
29%description -l ja
30"dash" は POSIX 互換シェルで、"bash" よりサイズが大変小さいものです。
31dash は、sh シェルコマンドをすべてサポートしており、かつ sh より比較的
32サイズが小さく収まっています。そのため、起動直後の RAM ディスクで使う
33など、使用可能メモリ量が制限されるような状況で有効に使うことができます。
34ただし dash にはコマンドライン履歴などのいくつかの機能が備わっていません。
35
36dash はオリジナルの NetBSD ash から分岐したもので、
37ash とは異なり現在でも適切にメンテナンスされ続けています。
38
39
40%package static
41Summary:       The Debian Almquist Shell (statically compiled)
42Summary(ja):   Bourne シェル (sh) の機能縮小版 (静的リンク版)
43Group:         System Environment/Shells
44Obsoletes:     ash <= 0.4
45Provides:      ash-static = %{version}-%{release}
46
47
48%description static
49"dash" is a POSIX compliant shell that is much smaller than "bash".
50Dash supports many features that a real sh shell would support, however
51it is much smaller in size. This becomes an advantage in situations
52where there is a lack of memery (initial ram-disks, etc). dash does
53lack a few features, like command line history.
54
55dash is the continuation of the original NetBSD ash fork. dash is much
56more up-to-date, and properly maintained.
57
58This version is statically compiled.
59
60
61%description static -l ja
62"dash" は POSIX 互換シェルで、"bash" よりサイズが大変小さいものです。
63dash は、sh シェルコマンドをすべてサポートしており、かつ sh より比較的
64サイズが小さく収まっています。そのため、起動直後の RAM ディスクで使う
65など、使用可能メモリ量が制限されるような状況で有効に使うことができます。
66ただし dash にはコマンドライン履歴などのいくつかの機能が備わっていません。
67
68dash はオリジナルの NetBSD ash から分岐したもので、
69ash とは異なり現在でも適切にメンテナンスされ続けています。
70
71このパッケージは静的リンクされたバージョンです。
72
73
74%prep
75%setup -q
76
77
78%build
79%configure
80
81# building dynamically linked dash
82make
83mv src/dash src/dash.dynamic
84
85# building statically linked dietlibc dash
86make clean
87%configure CC="diet gcc"
88make CC="diet gcc"
89mv src/dash src/dash.static
90
91
92%install
93rm -rf %{buildroot}
94mkdir -p %{buildroot}/bin
95mkdir -p %{buildroot}%{_mandir}/man1
96
97install -m 755 src/dash.dynamic %{buildroot}/bin/dash
98install -m 644 src/dash.1 %{buildroot}%{_mandir}/man1/dash.1
99ln -sf dash.1 %{buildroot}%{_mandir}/man1/bsh.1
100ln -sf dash %{buildroot}/bin/bsh
101ln -sf dash.1 %{buildroot}%{_mandir}/man1/ash.1
102ln -sf dash %{buildroot}/bin/ash
103
104install -m 755 src/dash.static %{buildroot}/bin/dash.static
105ln -sf dash.static %{buildroot}/bin/bsh.static
106ln -sf dash.static %{buildroot}/bin/ash.static
107
108
109%post
110if [ ! -f /etc/shells ]; then
111        echo "/bin/dash" > /etc/shells
112        echo "/bin/ash" >> /etc/shells
113        echo "/bin/bsh" >> /etc/shells
114else
115        if ! grep '^/bin/dash$' /etc/shells > /dev/null; then
116                echo "/bin/dash" >> /etc/shells
117        fi
118        if ! grep '^/bin/ash$' /etc/shells > /dev/null; then
119                echo "/bin/ash" >> /etc/shells
120        fi
121        if ! grep '^/bin/bsh$' /etc/shells > /dev/null; then
122                echo "/bin/bsh" >> /etc/shells
123        fi
124fi
125
126
127%postun
128if [ "$1" = "0" ]; then
129        grep -v '^/bin/ash' < /etc/shells | grep -v '^/bin/dash' | grep -v '^/bin/bsh' > /etc/shells.new
130        mv /etc/shells.new /etc/shells
131fi
132
133
134%triggerpostun -- ash
135if ! grep '^/bin/ash$' /etc/shells > /dev/null; then
136        echo "/bin/ash" >> /etc/shells
137fi
138if ! grep '^/bin/bsh$' /etc/shells > /dev/null; then
139        echo "/bin/bsh" >> /etc/shells
140fi
141
142%verifyscript
143
144for n in dash ash bsh; do
145    echo -n "Looking for $n in /etc/shells... "
146    if ! grep "^/bin/${n}\$" /etc/shells > /dev/null; then
147        echo "missing"
148        echo "${n} missing from /etc/shells" >&2
149    else
150        echo "found"
151    fi
152done
153
154
155%clean
156rm -rf %{buildroot}
157
158
159%files
160%defattr(-,root,root)
161/bin/dash
162/bin/ash
163/bin/bsh
164%{_mandir}/man1/*
165
166%files static
167%defattr(-,root,root)
168/bin/dash.static
169/bin/ash.static
170/bin/bsh.static
171
172
173%changelog
174* Wed Mar 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.5.1-1
175- now ash (not maintained anymore?) replaced with dash
176- provide ash/bsh symlinks for compatibility
177- split statically-linked version into subpackage
178
179* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.3.8-6vl5
180- applied new versioning policy, spec in utf-8
181
182* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-5vl3
183- rebuild to add gpg sign
184
185* Mon Apr 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.3.8-5v2
186- rebuild
187
188* Fri Dec 06 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3.8-5vl1
189- based on 0.3.8-5 from Rawhide and built for Vine Linux
190- added Japanese summary and description
191
192* Wed Jul 17 2002 Trond Eivind Glomsr <teg@redhat.com> 0.3.8-5
193- Update to -38 diff
194- man page fixes (#63528)
195
196* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
197- automated rebuild
198
199* Thu May 23 2002 Tim Powers <timp@redhat.com>
200- automated rebuild
201
202* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
203- automated rebuild
204
205* Tue Dec 11 2001 Trond Eivind Glomsr <teg@redhat.com> 0.3.8-1
206- 0.3.8
207- Patch to make it build
208- workaround for oddities in the alpha compiler
209
210* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
211- Bump release + rebuild.
212
213* Mon Jan 08 2001 Preston Brown <pbrown@redhat.com>
214- ported much newer version from Debian
215- alpha is miscompiling mkinit helper utility; work around w/o optimization
216
217* Thu Dec  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
218- intial rebuild for 7.1
219
220* Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
221- rebuild to cope with glibc locale binary incompatibility, again
222
223* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
224- rebuild to cope with glibc locale binary incompatibility
225
226* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
227- automatic rebuild
228
229* Wed Jun 21 2000 Jakub Jelinek <jakub@redhat.com>
230- mksyntax had undefined behaviour, make it conforming.
231
232* Mon Jun 12 2000 Preston Brown <pbrown@redhat.com>
233- FHS fixes
234- had to disable optimization for sparc, was producing a mksyntax binary that
235  infinitely looped!  FIX ME.
236
237* Wed Mar 29 2000 Bill Nottingham <notting@redhat.com>
238- fix bug in 'ash -e' handling
239
240* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
241- gzipped man pages
242
243* Mon Oct 04 1999 Cristian Gafton <gafton@redhat.com>
244- rebuild against the lastest glibc in the sparc tree
245
246* Sat Sep 11 1999 Bill Nottingham <notting@redhat.com>
247- fix bogosity with fd's > 0
248- fix builtin echo to understand -n & -e at the same time
249
250* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
251- auto rebuild in the new build environment (release 17)
252
253* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
254- Injected new description and group.
255
256* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
257- build on glibc 2.1
258
259* Fri Nov 06 1998 Preston Brown <pbrown@redhat.com>
260- updated to correct path on SunSITE.
261
262* Fri Aug 28 1998 Jeff Johnson <jbj@redhat.com>
263- recompile statically linked binary for 5.2/sparc
264
265* Tue May 05 1998 Prospector System <bugs@redhat.com>
266- translations modified for de, fr, tr
267
268* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
269- made /bin/ash built shared
270- added ash.static
271- uses a buildroot and %attr
272
273* Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
274- built against glibc
275- statically linked
276
277* Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
278- fixed preinstall script to >> /etc/shells for bsh.
Note: See TracBrowser for help on using the repository browser.