source: projects/specs/trunk/d/dash/dash-vl.spec @ 8915

Revision 8915, 8.7 KB checked in by Takemikaduchi, 10 years ago (diff)

dash,liboil,libutempter,virtuoso-opensource,wavpack: new upstream release
others: rebuild

Line 
1Summary:       The Debian Almquist Shell (formerly NetBSD's ash)
2Summary(ja):   Bourne シェル (sh) の機能縮小版 (Debian 版 ash)
3Name:          dash
4Version:       0.5.7
5Release:       1%{?_dist_release}
6
7License:       BSD
8Group:         System Environment/Shells
9URL:           http://gondor.apana.org.au/~herbert/dash/
10
11Source:        http://gondor.apana.org.au/~herbert/dash/files/%{name}-%{version}.tar.gz
12
13Buildroot:     %{_tmppath}/%{name}-%{version}-root
14BuildRequires: bison
15BuildRequires: dietlibc >= 0.32
16Requires(pre): fileutils grep
17Obsoletes:     ash <= 0.4
18Provides:      ash = %{version}-%{release}
19Conflicts:     mkinitrd <= 1.7
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: shaolin,daisuke
24
25%description
26"dash" is a POSIX compliant shell that is much smaller than "bash".
27Dash supports many features that a real sh shell would support, however
28it is much smaller in size. This becomes an advantage in situations
29where there is a lack of memery (initial ram-disks, etc). dash does
30lack a few features, like command line history.
31
32dash is the continuation of the original NetBSD ash fork. dash is much
33more up-to-date, and properly maintained.
34
35
36%description -l ja
37"dash" は POSIX 互換シェルで、"bash" よりサイズが大変小さいものです。
38dash は、sh シェルコマンドをすべてサポートしており、かつ sh より比較的
39サイズが小さく収まっています。そのため、起動直後の RAM ディスクで使う
40など、使用可能メモリ量が制限されるような状況で有効に使うことができます。
41ただし dash にはコマンドライン履歴などのいくつかの機能が備わっていません。
42
43dash はオリジナルの NetBSD ash から分岐したもので、
44ash とは異なり現在でも適切にメンテナンスされ続けています。
45
46
47%package static
48Summary:       The Debian Almquist Shell (statically compiled)
49Summary(ja):   Bourne シェル (sh) の機能縮小版 (静的リンク版)
50Group:         System Environment/Shells
51Obsoletes:     ash <= 0.4
52Provides:      ash-static = %{version}-%{release}
53
54
55%description static
56"dash" is a POSIX compliant shell that is much smaller than "bash".
57Dash supports many features that a real sh shell would support, however
58it is much smaller in size. This becomes an advantage in situations
59where there is a lack of memery (initial ram-disks, etc). dash does
60lack a few features, like command line history.
61
62dash is the continuation of the original NetBSD ash fork. dash is much
63more up-to-date, and properly maintained.
64
65This version is statically compiled.
66
67
68%description static -l ja
69"dash" は POSIX 互換シェルで、"bash" よりサイズが大変小さいものです。
70dash は、sh シェルコマンドをすべてサポートしており、かつ sh より比較的
71サイズが小さく収まっています。そのため、起動直後の RAM ディスクで使う
72など、使用可能メモリ量が制限されるような状況で有効に使うことができます。
73ただし dash にはコマンドライン履歴などのいくつかの機能が備わっていません。
74
75dash はオリジナルの NetBSD ash から分岐したもので、
76ash とは異なり現在でも適切にメンテナンスされ続けています。
77
78このパッケージは静的リンクされたバージョンです。
79
80
81%prep
82%setup -q
83
84
85%build
86%configure
87
88# building dynamically linked dash
89make
90mv src/dash src/dash.dynamic
91
92# building statically linked dietlibc dash
93make clean
94%configure CC="diet gcc"
95make CC="diet gcc"
96mv src/dash src/dash.static
97
98
99%install
100rm -rf %{buildroot}
101mkdir -p %{buildroot}/bin
102mkdir -p %{buildroot}%{_mandir}/man1
103
104install -m 755 src/dash.dynamic %{buildroot}/bin/dash
105install -m 644 src/dash.1 %{buildroot}%{_mandir}/man1/dash.1
106ln -sf dash.1 %{buildroot}%{_mandir}/man1/bsh.1
107ln -sf dash %{buildroot}/bin/bsh
108ln -sf dash.1 %{buildroot}%{_mandir}/man1/ash.1
109ln -sf dash %{buildroot}/bin/ash
110
111install -m 755 src/dash.static %{buildroot}/bin/dash.static
112ln -sf dash.static %{buildroot}/bin/bsh.static
113ln -sf dash.static %{buildroot}/bin/ash.static
114
115
116%post
117if [ ! -f /etc/shells ]; then
118        echo "/bin/dash" > /etc/shells
119        echo "/bin/ash" >> /etc/shells
120        echo "/bin/bsh" >> /etc/shells
121else
122        if ! grep '^/bin/dash$' /etc/shells > /dev/null; then
123                echo "/bin/dash" >> /etc/shells
124        fi
125        if ! grep '^/bin/ash$' /etc/shells > /dev/null; then
126                echo "/bin/ash" >> /etc/shells
127        fi
128        if ! grep '^/bin/bsh$' /etc/shells > /dev/null; then
129                echo "/bin/bsh" >> /etc/shells
130        fi
131fi
132
133
134%postun
135if [ "$1" = "0" ]; then
136        grep -v '^/bin/ash' < /etc/shells | grep -v '^/bin/dash' | grep -v '^/bin/bsh' > /etc/shells.new
137        mv /etc/shells.new /etc/shells
138fi
139
140
141%triggerpostun -- ash
142if ! grep '^/bin/ash$' /etc/shells > /dev/null; then
143        echo "/bin/ash" >> /etc/shells
144fi
145if ! grep '^/bin/bsh$' /etc/shells > /dev/null; then
146        echo "/bin/bsh" >> /etc/shells
147fi
148
149%verifyscript
150
151for n in dash ash bsh; do
152    echo -n "Looking for $n in /etc/shells... "
153    if ! grep "^/bin/${n}\$" /etc/shells > /dev/null; then
154        echo "missing"
155        echo "${n} missing from /etc/shells" >&2
156    else
157        echo "found"
158    fi
159done
160
161
162%clean
163rm -rf %{buildroot}
164
165
166%files
167%defattr(-,root,root)
168/bin/dash
169/bin/ash
170/bin/bsh
171%{_mandir}/man1/*
172
173%files static
174%defattr(-,root,root)
175/bin/dash.static
176/bin/ash.static
177/bin/bsh.static
178
179
180%changelog
181* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.7-1
182- update to 0.5.7
183
184* Sat Apr 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.6-2
185- update to 0.5.6
186- BR: dietlibc >= 0.32
187
188* Wed Mar 25 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.5.1-1
189- now ash (not maintained anymore?) replaced with dash
190- provide ash/bsh symlinks for compatibility
191- split statically-linked version into subpackage
192
193* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 0.3.8-6vl5
194- applied new versioning policy, spec in utf-8
195
196* Wed Sep 20 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.8-5vl3
197- rebuild to add gpg sign
198
199* Fri Apr 25 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.3.8-5v2
200- rebuild
201
202* Fri Dec 06 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3.8-5vl1
203- based on 0.3.8-5 from Rawhide and built for Vine Linux
204- added Japanese summary and description
205
206* Wed Jul 17 2002 Trond Eivind Glomsr <teg@redhat.com> 0.3.8-5
207- Update to -38 diff
208- man page fixes (#63528)
209
210* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
211- automated rebuild
212
213* Thu May 23 2002 Tim Powers <timp@redhat.com>
214- automated rebuild
215
216* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
217- automated rebuild
218
219* Tue Dec 11 2001 Trond Eivind Glomsr <teg@redhat.com> 0.3.8-1
220- 0.3.8
221- Patch to make it build
222- workaround for oddities in the alpha compiler
223
224* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
225- Bump release + rebuild.
226
227* Mon Jan 08 2001 Preston Brown <pbrown@redhat.com>
228- ported much newer version from Debian
229- alpha is miscompiling mkinit helper utility; work around w/o optimization
230
231* Thu Dec  7 2000 Crutcher Dunnavant <crutcher@redhat.com>
232- intial rebuild for 7.1
233
234* Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
235- rebuild to cope with glibc locale binary incompatibility, again
236
237* Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
238- rebuild to cope with glibc locale binary incompatibility
239
240* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
241- automatic rebuild
242
243* Wed Jun 21 2000 Jakub Jelinek <jakub@redhat.com>
244- mksyntax had undefined behaviour, make it conforming.
245
246* Mon Jun 12 2000 Preston Brown <pbrown@redhat.com>
247- FHS fixes
248- had to disable optimization for sparc, was producing a mksyntax binary that
249  infinitely looped!  FIX ME.
250
251* Wed Mar 29 2000 Bill Nottingham <notting@redhat.com>
252- fix bug in 'ash -e' handling
253
254* Thu Feb 03 2000 Preston Brown <pbrown@redhat.com>
255- gzipped man pages
256
257* Mon Oct 04 1999 Cristian Gafton <gafton@redhat.com>
258- rebuild against the lastest glibc in the sparc tree
259
260* Sat Sep 11 1999 Bill Nottingham <notting@redhat.com>
261- fix bogosity with fd's > 0
262- fix builtin echo to understand -n & -e at the same time
263
264* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
265- auto rebuild in the new build environment (release 17)
266
267* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
268- Injected new description and group.
269
270* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
271- build on glibc 2.1
272
273* Fri Nov 06 1998 Preston Brown <pbrown@redhat.com>
274- updated to correct path on SunSITE.
275
276* Fri Aug 28 1998 Jeff Johnson <jbj@redhat.com>
277- recompile statically linked binary for 5.2/sparc
278
279* Tue May 05 1998 Prospector System <bugs@redhat.com>
280- translations modified for de, fr, tr
281
282* Mon Oct 20 1997 Erik Troan <ewt@redhat.com>
283- made /bin/ash built shared
284- added ash.static
285- uses a buildroot and %attr
286
287* Sun Aug 24 1997 Erik Troan <ewt@redhat.com>
288- built against glibc
289- statically linked
290
291* Wed Apr 16 1997 Erik Troan <ewt@redhat.com>
292- fixed preinstall script to >> /etc/shells for bsh.
Note: See TracBrowser for help on using the repository browser.