source: projects/specs/trunk/c/cyrus-sasl/cyrus-sasl-vl.spec @ 3418

Revision 3418, 23.7 KB checked in by owa, 13 years ago (diff)

rebuild with postgresql-9.0.3

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define cs1_version 1.5.28
4%define _plugindir %{_libdir}/sasl
5%define _plugindir2 %{_libdir}/sasl2
6
7# No package in the current VineSeed tree needs Version 1 support
8%define includev1 0
9
10Summary: The Cyrus SASL library.
11Name: cyrus-sasl
12Version: 2.1.23
13Release: 8%{_dist_release}
14License: BSD
15Group: System Environment/Libraries
16Source0: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz
17Source1: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz.sig
18Source2: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{cs1_version}.tar.gz
19Source3: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{cs1_version}.tar.gz.sig
20Source4: saslauthd.init
21Source5: README.RPM
22Source9: saslauthd.sysconfig
23URL: http://asg.web.cmu.edu/sasl/sasl-library.html
24#
25Patch0: cyrus-sasl-1.5.24-rpath.patch
26Patch1: cyrus-sasl-1.5.28-autoconf25.patch
27Patch2: cyrus-sasl-1.5.28-automake17.patch
28Patch3: cyrus-sasl-1.5.28-automake18.patch
29Patch4: cyrus-sasl-1.5.28-saslauthd2.patch
30Patch5: cyrus-sasl-1.5.28_CVE-2009-0688.patch
31#
32Patch10: cyrus-sasl-2.1.22-db_bundle.patch
33Patch11: cyrus-sasl-2.1.18-no_rpath.patch
34Patch15: cyrus-sasl-2.1.20-saslauthd.conf-path.patch
35Patch24: cyrus-sasl-2.1.21-sizes.patch
36Patch25: cyrus-sasl-2.1.22-typo.patch
37Patch26: cyrus-sasl-2.1.22-digest-commas.patch
38Patch27: cyrus-sasl-2.1.22-automake-1.10.patch
39Patch28: cyrus-sasl-2.1.21-keytab.patch
40
41Patch100: cyrus-sasl-2.1.22-db4.patch
42Patch101: cyrus-sasl-2.1.23-gcc44.patch
43
44Buildroot: %{_tmppath}/%{name}-%{version}-root
45BuildRequires: autoconf, automake, libtool
46# Note: berkeley db for sasl2, gdbm for sasl1.
47BuildRequires: db4-devel, openssl-devel, pam-devel
48%if %{includev1}
49BuildRequires: gdbm-devel
50%endif
51BuildRequires: MySQL-devel, postgresql-devel, openldap-devel, zlib-devel
52BuildRequires: pkgconfig
53BuildRequires: krb5-devel
54BuildRequires: groff
55Requires(post): /sbin/ldconfig, chkconfig
56Requires(postun): /sbin/ldconfig, chkconfig
57
58%description
59The %{name} package contains the Cyrus implementation of SASL.
60SASL is the Simple Authentication and Security Layer, a method for
61adding authentication support to connection-based protocols.
62
63%package devel
64Requires: %{name} = %{version}-%{release}
65Group: Development/Libraries
66Summary: Files needed for developing applications with Cyrus SASL.
67
68%description devel
69The %{name}-devel package contains files needed for developing and
70compiling applications which use the Cyrus SASL library.
71
72%package gssapi
73Requires: %{name} = %{version}-%{release}
74Group: System Environment/Libraries
75Summary: GSSAPI support for Cyrus SASL.
76
77%description gssapi
78The %{name}-gssapi package contains the Cyrus SASL plugins which
79support GSSAPI authentication. GSSAPI is commonly used for Kerberos
80authentication.
81
82%package plain
83Requires: %{name} = %{version}-%{release}
84Group: System Environment/Libraries
85Summary: PLAIN and LOGIN support for Cyrus SASL.
86
87%description plain
88The %{name}-plain package contains the Cyrus SASL plugins which support
89PLAIN and LOGIN authentication schemes.
90
91%package md5
92Requires: %{name} = %{version}-%{release}
93Group: System Environment/Libraries
94Summary: CRAM-MD5 and DIGEST-MD5 support for Cyrus SASL.
95
96%description md5
97The %{name}-md5 package contains the Cyrus SASL plugins which support
98CRAM-MD5 and DIGEST-MD5 authentication schemes.
99
100%package ntlm
101Requires: %{name} = %{version}-%{release}
102Group: System Environment/Libraries
103Summary: NTLM support for Cyrus SASL.
104
105%description ntlm
106The %{name}-ntlm package contains the Cyrus SASL plugin which supports
107the NTLM authentication schemes.
108
109# This would more appropriately be named cyrus-sasl-auxprop-sql.
110%package sql
111#Requires: %{name}-lib = %{version}-%{release}
112Requires: %{name} = %{version}-%{release}
113Group: System Environment/Libraries
114Summary: SQL auxprop support for Cyrus SASL
115
116%description sql
117The %{name}-sql package contains the Cyrus SASL plugin which supports
118using a RDBMS for storing shared secrets.
119
120# This was *almost* named cyrus-sasl-auxprop-ldapdb, but that's a lot of typing.
121%package ldap
122#Requires: %{name}-lib = %{version}-%{release}
123Requires: %{name} = %{version}-%{release}
124Group: System Environment/Libraries
125Summary: LDAP auxprop support for Cyrus SASL
126
127%description ldap
128The %{name}-ldap package contains the Cyrus SASL plugin which supports using
129a directory server, accessed using LDAP, for storing shared secrets.
130
131
132## to build compat32 for x86_64 architecture support
133%package -n compat32-%{name}
134Summary: The Cyrus SASL library.
135Group: System Environment/Libraries
136
137%description -n compat32-%{name}
138The %{name} package contains the Cyrus implementation of SASL.
139SASL is the Simple Authentication and Security Layer, a method for
140adding authentication support to connection-based protocols.
141
142%package -n compat32-%{name}-devel
143Group: Development/Libraries
144Summary: Files needed for developing applications with Cyrus SASL.
145
146%description -n compat32-%{name}-devel
147The %{name}-devel package contains files needed for developing and
148compiling applications which use the Cyrus SASL library.
149
150%package -n compat32-%{name}-gssapi
151Group: System Environment/Libraries
152Summary: GSSAPI support for Cyrus SASL.
153
154%description -n compat32-%{name}-gssapi
155The %{name}-gssapi package contains the Cyrus SASL plugins which
156support GSSAPI authentication. GSSAPI is commonly used for Kerberos
157authentication.
158
159%package -n compat32-%{name}-plain
160Group: System Environment/Libraries
161Summary: PLAIN and LOGIN support for Cyrus SASL.
162
163%description -n compat32-%{name}-plain
164The %{name}-plain package contains the Cyrus SASL plugins which support
165PLAIN and LOGIN authentication schemes.
166
167%package -n compat32-%{name}-md5
168Group: System Environment/Libraries
169Summary: CRAM-MD5 and DIGEST-MD5 support for Cyrus SASL.
170
171%description -n compat32-%{name}-md5
172The %{name}-md5 package contains the Cyrus SASL plugins which support
173CRAM-MD5 and DIGEST-MD5 authentication schemes.
174
175%package -n compat32-%{name}-ntlm
176Group: System Environment/Libraries
177Summary: NTLM support for Cyrus SASL.
178
179%description -n compat32-%{name}-ntlm
180The %{name}-ntlm package contains the Cyrus SASL plugin which supports
181the NTLM authentication schemes.
182
183# %package -n compat32-%{name}-sql
184# Group: System Environment/Libraries
185# Summary: SQL auxprop support for Cyrus SASL
186
187# %description -n compat32-%{name}-sql
188# The %{name}-sql package contains the Cyrus SASL plugin which supports
189# using a RDBMS for storing shared secrets.
190
191%package -n compat32-%{name}-ldap
192Group: System Environment/Libraries
193Summary: LDAP auxprop support for Cyrus SASL
194
195%description -n compat32-%{name}-ldap
196The %{name}-ldap package contains the Cyrus SASL plugin which supports using
197a directory server, accessed using LDAP, for storing shared secrets.
198
199
200
201%prep
202%setup -q -c -a 2
203%if %{includev1}
204pushd cyrus-sasl-%{cs1_version}
205%patch0 -p1 -b .rpath
206%patch1 -p1 -b .autoconf25
207%patch2 -p1 -b .automake17
208%patch3 -p1 -b .automake18
209%patch4 -p1 -b .saslauthd2
210%patch5 -p1 -b .CVE-2009-0688
211libtoolize -f -c
212aclocal -I config -I cmulocal
213automake -a -c -f
214autoheader
215autoconf -f
216popd
217%endif
218
219pushd cyrus-sasl-%{version}
220chmod -x doc/*.html
221chmod -x include/*.h
222%patch10 -p1 -b .db_bundle
223%patch11 -p1 -b .no_rpath
224%patch15 -p1 -b .path
225%patch24 -p1 -b .sizes
226%patch25 -p1 -b .typo
227%patch26 -p2 -b .digest-commas
228%patch27 -p1 -b .automake-1.10
229%patch28 -p1 -b .keytab
230
231%patch100 -p1 -b .db48
232%patch101 -p1 -b .gcc44
233
234# FIXME - we remove these files directly so that we can avoid using the -f
235# flag, which has a nasty habit of overwriting files like COPYING.
236rm -f config/config.guess config/config.sub
237rm -f config/ltconfig config/ltmain.sh config/libtool.m4
238rm -fr autom4te.cache
239libtoolize -c
240aclocal -I config -I cmulocal
241automake -a -c
242autoheader
243autoconf
244
245pushd saslauthd
246rm -f config/config.guess config/config.sub
247rm -f config/ltconfig config/ltmain.sh config/libtool.m4
248rm -fr autom4te.cache
249libtoolize -c
250aclocal -I config -I ../cmulocal -I ../config
251automake -a -c
252autoheader
253autoconf
254popd
255
256%if %{includev1}
257# Sort of merge the docs.
258mkdir cyrus-sasl-%{version}/%{cs1_version}
259mkdir cyrus-sasl-%{version}/%{cs1_version}-devel
260cp %{name}-%{cs1_version}/{AUTHORS,COPYING,NEWS,README,doc/*.html} cyrus-sasl-%{version}/%{cs1_version}
261cp %{name}-%{cs1_version}/doc/*.txt cyrus-sasl-%{version}/%{cs1_version}-devel
262# Remove duplicate RFCs.
263pushd cyrus-sasl-%{version}/%{cs1_version}-devel
264for file in * ; do
265        if [ -f ../doc/${file} ] ; then
266                rm -f ${file}
267        fi
268done
269popd
270%endif
271
272%build
273%if %{includev1}
274pushd cyrus-sasl-%{cs1_version}
275%configure \
276        --enable-static --enable-staticdlopen --with-pic --enable-shared \
277        --with-plugindir=%{_plugindir} \
278        --disable-krb4 \
279        --with-rc4 \
280        --with-dblib=gdbm \
281        --enable-anon \
282        --enable-cram \
283        --enable-digest \
284        --enable-plain \
285        --enable-login
286make %{?_smp_mflags} sasldir=%{_plugindir}
287popd
288%endif
289
290pushd cyrus-sasl-%{version}
291CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
292
293# Find OpenSSL.
294LIBS="-lcrypt"; export LIBS
295if pkg-config openssl ; then
296        CPPFLAGS="`pkg-config --cflags-only-I openssl` $CPPFLAGS"; export CPPFLAGS
297        CFLAGS="`pkg-config --cflags openssl` $CFLAGS"; export CFLAGS
298        LDFLAGS="`pkg-config --libs-only-L openssl` $LDFLAGS"; export LDFLAGS
299fi
300
301# Find the SQL libraries used needed by the SQL auxprop plugin.
302mysql_config=mysql_config
303pg_config=pg_config
304SQL_CFLAGS=`${mysql_config} --cflags`" -I"`${pg_config} --includedir`
305SQL_LIBS=`${mysql_config} --libs`" -L"`${pg_config} --libdir`" -lpq"
306SQL_CFLAGS=`eval echo "$SQL_CFLAGS" | sed -e 's,-I%{_includedir}[^/],,g' -e 's,-I%{_includedir}$,,g' -e 's,[[:blank:]]+, ,g'`
307SQL_LIBS=`eval echo "$SQL_LIBS" | sed -e 's,-L%{_libdir}[^/],,g' -e 's,-L%{_libdir}$,,g' -e 's,[[:blank:]]+, ,g'`
308SQL_LDFLAGS=`eval echo "$SQL_LIBS" | sed -e 's,-[^L][^ ]*,,g'`
309echo $SQL_LDFLAGS
310SQL_LIBS=`eval echo "$SQL_LIBS" | sed -e 's,-[^l][^ ]*,,g'`
311echo $SQL_LIBS
312
313cleanup_flags() {
314        sed -r -e 's,-D_GNU_SOURCE(=[^[:blank:]]+)?,,g' \
315               -e 's,-D_FILE_OFFSET_BITS=[[:digit:]]+,,g' \
316               -e 's,-D_LARGEFILE_SOURCE(=[^[:blank:]]+)?,,g' \
317               -e 's,[[:blank:]]+, ,g'
318}
319CFLAGS=`echo $CFLAGS $SQL_CFLAGS | cleanup_flags`; export CFLAGS
320CPPFLAGS=`echo $CPPFLAGS $SQL_CFLAGS | cleanup_flags`; export CPPFLAGS
321LDFLAGS=`echo $LDFLAGS $SQL_LDFLAGS | cleanup_flags`; export LDFLAGS
322
323%configure \
324        --disable-static --enable-shared --disable-java \
325        --with-plugindir=%{_plugindir2}:%{_sysconfdir}/sasl2 \
326        --disable-krb4 \
327        --with-rc4 \
328        --with-dblib=berkeley \
329        --with-saslauthd=/var/run/saslauthd --without-pwcheck \
330        --with-ldap \
331        --with-devrandom=/dev/urandom \
332        --enable-anon \
333        --enable-cram \
334        --enable-digest \
335        --enable-ntlm \
336        --enable-plain \
337        --enable-login \
338        --disable-otp \
339        --enable-ldapdb \
340        --enable-sql --with-mysql=%{_prefix} --with-pgsql=%{_prefix} \
341        --without-sqlite \
342        "$@"
343        # --enable-auth-sasldb -- EXPERIMENTAL
344make %{?_smp_mflags} sasldir=%{_plugindir2}
345make %{?_smp_mflags} -C saslauthd testsaslauthd
346make -C sample
347popd
348
349%install
350test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
351%if %{includev1}
352pushd cyrus-sasl-%{cs1_version}
353%makeinstall sasldir=$RPM_BUILD_ROOT/%{_plugindir}
354install -m755 -d $RPM_BUILD_ROOT%{_bindir}
355libtool --mode=install \
356install -m755 sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
357libtool --mode=install \
358install -m755 sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
359popd
360%endif
361
362pushd cyrus-sasl-%{version}
363make install DESTDIR=$RPM_BUILD_ROOT sasldir=%{_plugindir2}
364make install DESTDIR=$RPM_BUILD_ROOT sasldir=%{_plugindir2} -C plugins
365
366install -m755 -d $RPM_BUILD_ROOT%{_bindir}
367./libtool --tag=CC --mode=install \
368install -m755 sample/client $RPM_BUILD_ROOT%{_bindir}/sasl2-sample-client
369./libtool --tag=CC --mode=install \
370install -m755 sample/server $RPM_BUILD_ROOT%{_bindir}/sasl2-sample-server
371./libtool --tag=CC --mode=install \
372install -m755 saslauthd/testsaslauthd $RPM_BUILD_ROOT%{_sbindir}/testsaslauthd
373./libtool --tag=CC --mode=install \
374install -m755 utils/dbconverter-2 $RPM_BUILD_ROOT%{_sbindir}/dbconverter-2
375
376# Install the saslauthd mdoc page in the expected location.  Sure, it's not
377# really a man page, but groff seems to be able to cope with it.
378install -m755 -d $RPM_BUILD_ROOT%{_mandir}/man8/
379install -m644 saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
380
381# Create the saslauthd listening directory.
382install -m755 -d $RPM_BUILD_ROOT/var/run/saslauthd
383
384# Install the init script for saslauthd and the init script's config file.
385install -m755 -d $RPM_BUILD_ROOT/etc/rc.d/init.d $RPM_BUILD_ROOT/etc/sysconfig
386install -m755 -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
387install -m644 -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
388popd
389
390# Install the config dirs if they're not already there.
391install -m755 -d $RPM_BUILD_ROOT/%{_sysconfdir}/sasl2
392install -m755 -d $RPM_BUILD_ROOT/%{_plugindir2}
393
394# Remove unpackaged files from the buildroot.
395rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/libotp.*
396rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.a
397rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.la
398rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
399rm -f $RPM_BUILD_ROOT%{_mandir}/cat8/saslauthd.8
400
401%clean
402test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
403
404%post
405/sbin/ldconfig
406/sbin/chkconfig --add saslauthd
407
408%preun
409if [ $1 = 0 ] ; then
410        /sbin/chkconfig --del saslauthd
411fi
412
413%postun
414/sbin/ldconfig
415if [ $1 != 0 ] ; then
416        /sbin/service saslauthd condrestart 2>&1 > /dev/null
417fi
418
419%files
420%defattr(-,root,root)
421%if %{includev1}
422%doc %{name}-%{version}/%{cs1_version}
423%endif
424%doc %{name}-%{version}/{AUTHORS,COPYING,NEWS,README,doc/*.html}
425%doc $RPM_SOURCE_DIR/README.RPM
426%dir %{_sysconfdir}/sasl2
427%{_libdir}/libsasl*.so.*
428%if %{includev1}
429%dir %{_plugindir}/
430%endif
431%dir %{_plugindir2}/
432%if %{includev1}
433%{_plugindir}/*anonymous*.so*
434%{_plugindir}/*anonymous*.la
435%endif
436%{_plugindir2}/*anonymous*.so*
437%{_plugindir2}/*sasldb*.so*
438%{_mandir}/man8/*
439%{_sbindir}/dbconverter-2
440%if %{includev1}
441%{_sbindir}/saslpasswd
442%{_sbindir}/sasldblistusers
443%endif
444%{_sbindir}/saslpasswd2
445%{_sbindir}/sasldblistusers2
446%{_sbindir}/pluginviewer
447%{_sbindir}/saslauthd
448%{_sbindir}/testsaslauthd
449%config(noreplace) /etc/sysconfig/saslauthd
450%config /etc/rc.d/init.d/saslauthd
451/var/run/saslauthd
452
453%files gssapi
454%defattr(-,root,root)
455%{_plugindir2}/*gssapi*.so*
456
457%files plain
458%defattr(-,root,root)
459%if %{includev1}
460%{_plugindir}/*plain*.so*
461%{_plugindir}/*plain*.la
462%{_plugindir}/*login*.so*
463%{_plugindir}/*login*.la
464%endif
465%{_plugindir2}/*plain*.so*
466%{_plugindir2}/*login*.so*
467
468%files md5
469%defattr(-,root,root)
470%if %{includev1}
471%{_plugindir}/*crammd5*.so*
472%{_plugindir}/*crammd5*.la
473%{_plugindir}/*digestmd5*.so*
474%{_plugindir}/*digestmd5*.la
475%endif
476%{_plugindir2}/*crammd5*.so*
477%{_plugindir2}/*digestmd5*.so*
478
479%files ntlm
480%defattr(-,root,root)
481%{_plugindir2}/*ntlm*.so*
482
483%files sql
484%defattr(-,root,root)
485%{_plugindir2}/*sql*.so*
486
487%files ldap
488%defattr(-,root,root)
489%{_plugindir2}/*ldapdb*.so*
490
491%files devel
492%defattr(-,root,root)
493%if %{includev1}
494%doc %{name}-%{version}/%{cs1_version}-devel
495%endif
496%doc %{name}-%{version}/doc/*.txt
497%defattr(-,root,root)
498%if %{includev1}
499%{_bindir}/sasl-sample-client
500%{_bindir}/sasl-sample-server
501%endif
502%{_bindir}/sasl2-sample-client
503%{_bindir}/sasl2-sample-server
504%{_includedir}/*
505%{_libdir}/libsasl*.so
506%if %{includev1}
507%{_plugindir}/*anonymous*.a
508%{_plugindir}/*crammd5*.a
509%{_plugindir}/*digestmd5*.a
510%{_plugindir}/*login*.a
511%{_plugindir}/*plain*.a
512%endif
513%{_mandir}/man3/*
514
515## to build compat32 for x86_64 architecture support
516%if %{build_compat32}
517%files -n compat32-%{name}
518%defattr(-,root,root)
519%{_libdir}/libsasl*.so.*
520%dir %{_plugindir2}/
521%{_plugindir2}/*anonymous*.so*
522%{_plugindir2}/*sasldb*.so*
523
524%files -n compat32-%{name}-gssapi
525%defattr(-,root,root)
526%{_plugindir2}/*gssapi*.so*
527
528%files -n compat32-%{name}-plain
529%defattr(-,root,root)
530%{_plugindir2}/*plain*.so*
531%{_plugindir2}/*login*.so*
532
533%files -n compat32-%{name}-md5
534%defattr(-,root,root)
535%{_plugindir2}/*crammd5*.so*
536%{_plugindir2}/*digestmd5*.so*
537
538%files -n compat32-%{name}-ntlm
539%defattr(-,root,root)
540%{_plugindir2}/*ntlm*.so*
541
542# %files -n compat32-%{name}-sql
543# %defattr(-,root,root)
544# %{_plugindir2}/*sql*.so*
545
546%files -n compat32-%{name}-ldap
547%defattr(-,root,root)
548%{_plugindir2}/*ldapdb*.so*
549
550%files -n compat32-%{name}-devel
551%defattr(-,root,root)
552%{_libdir}/libsasl*.so
553%endif
554
555
556%changelog
557* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.1.23-8
558- rebuilt with postgresql-9.0.3
559
560* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.23-7
561- rebuild with krb5-libs-1.8.2 and openssl-1.0.0d
562
563* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.23-6
564- rebuild with openssl-1.0.0c
565- add BuildRequires: groff
566
567* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.23-5
568- rebuilt with db4-4.8
569- updated Patch100: cyrus-sasl-2.1.22-db4.patch
570- added Patch101: cyrus-sasl-2.1.23-gcc44.patch
571
572* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.1.23-4
573- dropped compat32-%%{name}-sql
574
575* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.1.23-3
576- added compat32 subpackages
577
578* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.23-2
579- rebuilt with MySQL-5.1.34.
580
581* Mon May 18 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.23-1
582- new upstream release with security fix (CVE-2009-0688)
583- add patch5 to fix CVE-2009-0688 issue in 1.5.28 side
584  (No effect in Current VineSeed package)
585
586* Sun Jan 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.22-5
587- rebuilt with openldap-2.4.11
588
589* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.1.22-4
590- s/%%{name}-lib/%%{name}/ at requires of sql, ldap sub-packages
591
592* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1.22-3
593- added gssapi subpackage
594
595* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.22-2
596- rebuilt against db-4.6.21 with Patch100
597- import Patch27 from Fedora
598
599* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.22-1vl5
600- updated to 2.1.22
601- added Patches from Fedora
602  * Tue Jun 20 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.22-2
603  - fix a typo in sasl_client_start(3) (#196066)
604  * Thu Apr 27 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.21-11
605  - add unapplied patch which makes the DIGEST-MD5 plugin omit the realm
606    argument when the environment has $CYRUS_SASL_DIGEST_MD5_OMIT_REALM set
607    to a non-zero value, for testing purposes
608- added subpackages for the ldapdb auxprop support
609- added --disable-static option to %%configure
610
611* Tue May 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.18-0vl8
612- added Patch17: cyrus-sasl-2.1.18-openssl-098.patch
613- rebuilt with openssl-0.9.8
614
615* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.18-0vl7
616- disable version 1 now (no VineSeed package require version 1)
617- enable ntlm subpackage now
618- rebuilt with new toolchain and db4-4.3.x
619
620* Sat Jul  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.18-0vl6
621- rebuilt for VineSeed
622
623* Fri Apr 28 2006 IWAI, Masaharu <iwai@alib.jp> 2.1.18-0vl5
624- SECURITY FIX for Vine 3.2: CVE-2006-1721
625   - add 23_CVE-2006-1721.diff ( Patch16 )
626       from Debian Sarge cyrus-sasl2_2.1.19-1.5sarge1.diff.gz
627
628* Mon Dec 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.18-0vl4
629- rebuild for VineSeed
630
631* Sat Nov 27 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 2.1.18-0vl3
632- added security patch cyrus-sasl-CAN-2004-0884.patch for CAN-2004-0884
633  from Mandrakelinux.
634
635* Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.18-0vl2
636- rebuilt with db4-4.2.52
637
638* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.18-0vl1
639- new upstream release
640- rebuild with openssl-0.9.7d
641- import some patch from fedora package
642
643* Sun Nov 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.15-6vl1
644- new upstream release
645- remove prereq initscripts
646- merged with fedora package
647  * Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-6
648  - use /dev/urandom instead of /dev/random for SASL2 (docs indicate that this is
649  safe if you aren't using OTP or SRP, and we build neither); SASL1 appears to
650  use it to seed the libc RNG only (#103378)
651  * Mon Oct 20 2003 Nalin Dahyabhai <nalin@redhat.com>
652  - obey RPM_OPT_FLAGS again when krb5_prefix != %%{_prefix}
653  * Fri Oct 17 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-5
654  - install saslauthd's mdoc page instead of the pre-formatted man page, which
655    would get formatted again
656  * Mon Sep 15 2003 Nalin Dahyabhai <nalin@redhat.com>
657  - include testsaslauthd
658  - note in the README that the saslauthd protocol is different for v1 and v2,
659    so v1's clients can't talk to the v2 server
660  * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-3
661  - add logic to build with gssapi libs in either /usr or /usr/kerberos
662  * Tue Jul 15 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-1
663  - update to 2.1.15
664  * Mon Jul 14 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.14-1
665  - update to 2.1.14
666
667* Wed May 14 2003 Satoshi MACHINO <machino@vinelinux.org> 2.1.13-3vl1
668- new upstream version
669- merged with rawhide version
670        -- * Fri May  9 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-3
671        -- - change -m argument to saslauthd to be a directory instead of a path
672        -- * Thu May  8 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-2
673        -- - link libsasl2 with -lpthread to ensure that the sasldb plug-in
674             can always be loaded
675        -- * Tue Apr 29 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-1
676        -- - update to 2.1.13
677- disable gssapi because Vine Linux don't support Kerberos
678
679* Sun Dec  9 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.5.27-17vl1
680- upstream release
681- obsoleted cyrus-sasl-1.5.21-des.patch ( upstream merged )
682- obsoleted cyrus-sasl-1.5.24-external.patch ( upstream merged )
683- added BuildPrereq: gdbm-devel, pam-devel
684
685* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
686- 1.5.24-17vl2
687- rebuilt with openssl-0.9.6b
688
689* Wed Apr 11 2001 Satoshi MACHINO <machino@vinelinux.org> 1.5.24-17vl1
690- merged Rawhide Package
691
692* Sat Nov 18 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.5.24-14vl1
693- build for Vine Linux
694- build with gcc-2.95.3
695- removed kerberos and gssapi
696
697* Fri Oct 27 2000 Nalin Dahyabhai <nalin@redhat.com>
698- enable static libraries, but always build with -fPIC
699
700* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
701- make sure the version of 1.5.24 in the package matches the masters (#18968)
702
703* Mon Oct  9 2000 Nalin Dahyabhai <nalin@redhat.com>
704- re-add the libsasl.so symlink to the -devel package (oops)
705
706* Fri Oct  6 2000 Nalin Dahyabhai <nalin@redhat.com>
707- move .so files for modules to their respective packages -- they're not -devel
708  links meant for use by ld anyway
709
710* Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
711- split off -devel subpackage
712- add a -gssapi subpackage for the gssapi plugins
713
714* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
715- fix the summary text
716
717* Sun Aug 13 2000 Nalin Dahyabhai <nalin@redhat.com>
718- re-enable arcfour and CRAM
719
720* Fri Aug  4 2000 Nalin Dahyabhai <nalin@redhat.com>
721- force use of gdbm for database files to avoid DB migration weirdness
722- enable login mechanism
723- disable gssapi until it can coexist peacefully with non-gssapi setups
724- actually do a make in the build section (#15410)
725
726* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
727- update to 1.5.24
728
729* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
730- automatic rebuild
731
732* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
733- rebuild in new environment (release 3)
734
735* Mon Jun 19 2000 Nalin Dahyabhai <nalin@redhat.com>
736- don't muck with syslogd in post
737- remove patch for db-3.0 wackiness, no longer needed
738
739* Thu Jun  8 2000 Nalin Dahyabhai <nalin@redhat.com>
740- FHS cleanup
741- don't strip anything by default
742
743* Fri Feb 11 2000 Tim Powers <timp@redhat.com>
744- fixed man pages not being gzipped
745
746* Tue Nov 16 1999 Tim Powers <timp@redhat.com>
747- incorporated changes from Mads Kiilerich
748- release number is 1, not mk1
749
750* Tue Nov 10 1999 Mads Kiilerich <mads@kiilerich.com>
751- updated to sasl 1.5.11
752- configure --disable-krb4 --without-rc4 --disable-cram
753  because of missing libraries and pine having cram as default...
754- handle changing libsasl.so versions
755
756* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
757- changed group
758
759* Fri Aug 13 1999 Tim Powers <timp@redhat.com>
760- first build for Powertools
Note: See TracBrowser for help on using the repository browser.