source: projects/specs/trunk/c/cyrus-sasl/cyrus-sasl-vl.spec @ 4637

Revision 4637, 23.9 KB checked in by tomop, 13 years ago (diff)

cyrus-sasl-2.1.23-9

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define cs1_version 1.5.28
4%define _plugindir %{_libdir}/sasl
5%define _plugindir2 %{_libdir}/sasl2
6
7# No package in the current VineSeed tree needs Version 1 support
8%define includev1 0
9
10Summary: The Cyrus SASL library.
11Name: cyrus-sasl
12Version: 2.1.23
13Release: 9%{_dist_release}
14License: BSD
15Group: System Environment/Libraries
16Source0: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz
17Source1: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz.sig
18Source2: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{cs1_version}.tar.gz
19Source3: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{cs1_version}.tar.gz.sig
20Source4: saslauthd.init
21Source5: README.RPM
22Source9: saslauthd.sysconfig
23URL: http://asg.web.cmu.edu/sasl/sasl-library.html
24#
25Patch0: cyrus-sasl-1.5.24-rpath.patch
26Patch1: cyrus-sasl-1.5.28-autoconf25.patch
27Patch2: cyrus-sasl-1.5.28-automake17.patch
28Patch3: cyrus-sasl-1.5.28-automake18.patch
29Patch4: cyrus-sasl-1.5.28-saslauthd2.patch
30Patch5: cyrus-sasl-1.5.28_CVE-2009-0688.patch
31#
32Patch10: cyrus-sasl-2.1.22-db_bundle.patch
33Patch11: cyrus-sasl-2.1.18-no_rpath.patch
34Patch15: cyrus-sasl-2.1.20-saslauthd.conf-path.patch
35Patch24: cyrus-sasl-2.1.21-sizes.patch
36Patch25: cyrus-sasl-2.1.22-typo.patch
37Patch26: cyrus-sasl-2.1.22-digest-commas.patch
38Patch27: cyrus-sasl-2.1.22-automake-1.10.patch
39Patch28: cyrus-sasl-2.1.21-keytab.patch
40
41Patch100: cyrus-sasl-2.1.22-db4.patch
42Patch101: cyrus-sasl-2.1.23-gcc44.patch
43
44Patch102: configure.patch
45
46Buildroot: %{_tmppath}/%{name}-%{version}-root
47BuildRequires: autoconf, automake, libtool
48# Note: berkeley db for sasl2, gdbm for sasl1.
49BuildRequires: db4-devel, openssl-devel, pam-devel
50%if %{includev1}
51BuildRequires: gdbm-devel
52%endif
53BuildRequires: MySQL-devel, postgresql-devel, openldap-devel, zlib-devel
54BuildRequires: pkgconfig
55BuildRequires: krb5-devel
56BuildRequires: groff
57Requires(post): /sbin/ldconfig, chkconfig
58Requires(postun): /sbin/ldconfig, chkconfig
59
60%description
61The %{name} package contains the Cyrus implementation of SASL.
62SASL is the Simple Authentication and Security Layer, a method for
63adding authentication support to connection-based protocols.
64
65%package devel
66Requires: %{name} = %{version}-%{release}
67Group: Development/Libraries
68Summary: Files needed for developing applications with Cyrus SASL.
69
70%description devel
71The %{name}-devel package contains files needed for developing and
72compiling applications which use the Cyrus SASL library.
73
74%package gssapi
75Requires: %{name} = %{version}-%{release}
76Group: System Environment/Libraries
77Summary: GSSAPI support for Cyrus SASL.
78
79%description gssapi
80The %{name}-gssapi package contains the Cyrus SASL plugins which
81support GSSAPI authentication. GSSAPI is commonly used for Kerberos
82authentication.
83
84%package plain
85Requires: %{name} = %{version}-%{release}
86Group: System Environment/Libraries
87Summary: PLAIN and LOGIN support for Cyrus SASL.
88
89%description plain
90The %{name}-plain package contains the Cyrus SASL plugins which support
91PLAIN and LOGIN authentication schemes.
92
93%package md5
94Requires: %{name} = %{version}-%{release}
95Group: System Environment/Libraries
96Summary: CRAM-MD5 and DIGEST-MD5 support for Cyrus SASL.
97
98%description md5
99The %{name}-md5 package contains the Cyrus SASL plugins which support
100CRAM-MD5 and DIGEST-MD5 authentication schemes.
101
102%package ntlm
103Requires: %{name} = %{version}-%{release}
104Group: System Environment/Libraries
105Summary: NTLM support for Cyrus SASL.
106
107%description ntlm
108The %{name}-ntlm package contains the Cyrus SASL plugin which supports
109the NTLM authentication schemes.
110
111# This would more appropriately be named cyrus-sasl-auxprop-sql.
112%package sql
113#Requires: %{name}-lib = %{version}-%{release}
114Requires: %{name} = %{version}-%{release}
115Group: System Environment/Libraries
116Summary: SQL auxprop support for Cyrus SASL
117
118%description sql
119The %{name}-sql package contains the Cyrus SASL plugin which supports
120using a RDBMS for storing shared secrets.
121
122# This was *almost* named cyrus-sasl-auxprop-ldapdb, but that's a lot of typing.
123%package ldap
124#Requires: %{name}-lib = %{version}-%{release}
125Requires: %{name} = %{version}-%{release}
126Group: System Environment/Libraries
127Summary: LDAP auxprop support for Cyrus SASL
128
129%description ldap
130The %{name}-ldap package contains the Cyrus SASL plugin which supports using
131a directory server, accessed using LDAP, for storing shared secrets.
132
133
134## to build compat32 for x86_64 architecture support
135%package -n compat32-%{name}
136Summary: The Cyrus SASL library.
137Group: System Environment/Libraries
138
139%description -n compat32-%{name}
140The %{name} package contains the Cyrus implementation of SASL.
141SASL is the Simple Authentication and Security Layer, a method for
142adding authentication support to connection-based protocols.
143
144%package -n compat32-%{name}-devel
145Group: Development/Libraries
146Summary: Files needed for developing applications with Cyrus SASL.
147
148%description -n compat32-%{name}-devel
149The %{name}-devel package contains files needed for developing and
150compiling applications which use the Cyrus SASL library.
151
152%package -n compat32-%{name}-gssapi
153Group: System Environment/Libraries
154Summary: GSSAPI support for Cyrus SASL.
155
156%description -n compat32-%{name}-gssapi
157The %{name}-gssapi package contains the Cyrus SASL plugins which
158support GSSAPI authentication. GSSAPI is commonly used for Kerberos
159authentication.
160
161%package -n compat32-%{name}-plain
162Group: System Environment/Libraries
163Summary: PLAIN and LOGIN support for Cyrus SASL.
164
165%description -n compat32-%{name}-plain
166The %{name}-plain package contains the Cyrus SASL plugins which support
167PLAIN and LOGIN authentication schemes.
168
169%package -n compat32-%{name}-md5
170Group: System Environment/Libraries
171Summary: CRAM-MD5 and DIGEST-MD5 support for Cyrus SASL.
172
173%description -n compat32-%{name}-md5
174The %{name}-md5 package contains the Cyrus SASL plugins which support
175CRAM-MD5 and DIGEST-MD5 authentication schemes.
176
177%package -n compat32-%{name}-ntlm
178Group: System Environment/Libraries
179Summary: NTLM support for Cyrus SASL.
180
181%description -n compat32-%{name}-ntlm
182The %{name}-ntlm package contains the Cyrus SASL plugin which supports
183the NTLM authentication schemes.
184
185# %package -n compat32-%{name}-sql
186# Group: System Environment/Libraries
187# Summary: SQL auxprop support for Cyrus SASL
188
189# %description -n compat32-%{name}-sql
190# The %{name}-sql package contains the Cyrus SASL plugin which supports
191# using a RDBMS for storing shared secrets.
192
193%package -n compat32-%{name}-ldap
194Group: System Environment/Libraries
195Summary: LDAP auxprop support for Cyrus SASL
196
197%description -n compat32-%{name}-ldap
198The %{name}-ldap package contains the Cyrus SASL plugin which supports using
199a directory server, accessed using LDAP, for storing shared secrets.
200
201
202
203%prep
204%setup -q -c -a 2
205%if %{includev1}
206pushd cyrus-sasl-%{cs1_version}
207%patch0 -p1 -b .rpath
208%patch1 -p1 -b .autoconf25
209%patch2 -p1 -b .automake17
210%patch3 -p1 -b .automake18
211%patch4 -p1 -b .saslauthd2
212%patch5 -p1 -b .CVE-2009-0688
213libtoolize -f -c
214aclocal -I config -I cmulocal
215automake -a -c -f
216autoheader
217autoconf -f
218popd
219%endif
220
221pushd cyrus-sasl-%{version}
222chmod -x doc/*.html
223chmod -x include/*.h
224%patch10 -p1 -b .db_bundle
225%patch11 -p1 -b .no_rpath
226%patch15 -p1 -b .path
227%patch24 -p1 -b .sizes
228%patch25 -p1 -b .typo
229%patch26 -p2 -b .digest-commas
230%patch27 -p1 -b .automake-1.10
231%patch28 -p1 -b .keytab
232
233%patch100 -p1 -b .db48
234%patch101 -p1 -b .gcc44
235
236%patch102 -p0 -b .configure
237
238# FIXME - we remove these files directly so that we can avoid using the -f
239# flag, which has a nasty habit of overwriting files like COPYING.
240rm -f config/config.guess config/config.sub
241rm -f config/ltconfig config/ltmain.sh config/libtool.m4
242rm -fr autom4te.cache
243libtoolize -c
244aclocal -I config -I cmulocal
245automake -a -c
246autoheader
247autoconf
248
249pushd saslauthd
250rm -f config/config.guess config/config.sub
251rm -f config/ltconfig config/ltmain.sh config/libtool.m4
252rm -fr autom4te.cache
253libtoolize -c
254aclocal -I config -I ../cmulocal -I ../config
255automake -a -c
256autoheader
257autoconf
258popd
259
260%if %{includev1}
261# Sort of merge the docs.
262mkdir cyrus-sasl-%{version}/%{cs1_version}
263mkdir cyrus-sasl-%{version}/%{cs1_version}-devel
264cp %{name}-%{cs1_version}/{AUTHORS,COPYING,NEWS,README,doc/*.html} cyrus-sasl-%{version}/%{cs1_version}
265cp %{name}-%{cs1_version}/doc/*.txt cyrus-sasl-%{version}/%{cs1_version}-devel
266# Remove duplicate RFCs.
267pushd cyrus-sasl-%{version}/%{cs1_version}-devel
268for file in * ; do
269        if [ -f ../doc/${file} ] ; then
270                rm -f ${file}
271        fi
272done
273popd
274%endif
275
276%build
277%if %{includev1}
278pushd cyrus-sasl-%{cs1_version}
279%configure \
280        --enable-static --enable-staticdlopen --with-pic --enable-shared \
281        --with-plugindir=%{_plugindir} \
282        --disable-krb4 \
283        --with-rc4 \
284        --with-dblib=gdbm \
285        --enable-anon \
286        --enable-cram \
287        --enable-digest \
288        --enable-plain \
289        --enable-login
290make %{?_smp_mflags} sasldir=%{_plugindir}
291popd
292%endif
293
294pushd cyrus-sasl-%{version}
295CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
296
297# Find OpenSSL.
298LIBS="-lcrypt"; export LIBS
299if pkg-config openssl ; then
300        CPPFLAGS="`pkg-config --cflags-only-I openssl` $CPPFLAGS"; export CPPFLAGS
301        CFLAGS="`pkg-config --cflags openssl` $CFLAGS"; export CFLAGS
302        LDFLAGS="`pkg-config --libs-only-L openssl` $LDFLAGS"; export LDFLAGS
303fi
304
305# Find the SQL libraries used needed by the SQL auxprop plugin.
306mysql_config=mysql_config
307pg_config=pg_config
308SQL_CFLAGS=`${mysql_config} --cflags`" -I"`${pg_config} --includedir`
309SQL_LIBS=`${mysql_config} --libs`" -L"`${pg_config} --libdir`" -lpq"
310SQL_CFLAGS=`eval echo "$SQL_CFLAGS" | sed -e 's,-I%{_includedir}[^/],,g' -e 's,-I%{_includedir}$,,g' -e 's,[[:blank:]]+, ,g'`
311SQL_LIBS=`eval echo "$SQL_LIBS" | sed -e 's,-L%{_libdir}[^/],,g' -e 's,-L%{_libdir}$,,g' -e 's,[[:blank:]]+, ,g'`
312SQL_LDFLAGS=`eval echo "$SQL_LIBS" | sed -e 's,-[^L][^ ]*,,g'`
313echo $SQL_LDFLAGS
314SQL_LIBS=`eval echo "$SQL_LIBS" | sed -e 's,-[^l][^ ]*,,g'`
315echo $SQL_LIBS
316
317cleanup_flags() {
318        sed -r -e 's,-D_GNU_SOURCE(=[^[:blank:]]+)?,,g' \
319               -e 's,-D_FILE_OFFSET_BITS=[[:digit:]]+,,g' \
320               -e 's,-D_LARGEFILE_SOURCE(=[^[:blank:]]+)?,,g' \
321               -e 's,[[:blank:]]+, ,g'
322}
323CFLAGS=`echo $CFLAGS $SQL_CFLAGS | cleanup_flags`; export CFLAGS
324CPPFLAGS=`echo $CPPFLAGS $SQL_CFLAGS | cleanup_flags`; export CPPFLAGS
325LDFLAGS=`echo $LDFLAGS $SQL_LDFLAGS | cleanup_flags`; export LDFLAGS
326
327%configure \
328        --disable-static --enable-shared --disable-java \
329        --with-plugindir=%{_plugindir2}:%{_sysconfdir}/sasl2 \
330        --disable-krb4 \
331        --with-rc4 \
332        --with-dblib=berkeley \
333        --with-saslauthd=/var/run/saslauthd --without-pwcheck \
334        --with-ldap \
335        --with-devrandom=/dev/urandom \
336        --enable-anon \
337        --enable-cram \
338        --enable-digest \
339        --enable-ntlm \
340        --enable-plain \
341        --enable-login \
342        --disable-otp \
343        --enable-ldapdb \
344        --enable-sql --with-mysql=%{_prefix} --with-pgsql=%{_prefix} \
345        --without-sqlite \
346        "$@"
347        # --enable-auth-sasldb -- EXPERIMENTAL
348make %{?_smp_mflags} sasldir=%{_plugindir2}
349make %{?_smp_mflags} -C saslauthd testsaslauthd
350make -C sample
351popd
352
353%install
354test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
355%if %{includev1}
356pushd cyrus-sasl-%{cs1_version}
357%makeinstall sasldir=$RPM_BUILD_ROOT/%{_plugindir}
358install -m755 -d $RPM_BUILD_ROOT%{_bindir}
359libtool --mode=install \
360install -m755 sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
361libtool --mode=install \
362install -m755 sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
363popd
364%endif
365
366pushd cyrus-sasl-%{version}
367make install DESTDIR=$RPM_BUILD_ROOT sasldir=%{_plugindir2}
368make install DESTDIR=$RPM_BUILD_ROOT sasldir=%{_plugindir2} -C plugins
369
370install -m755 -d $RPM_BUILD_ROOT%{_bindir}
371./libtool --tag=CC --mode=install \
372install -m755 sample/client $RPM_BUILD_ROOT%{_bindir}/sasl2-sample-client
373./libtool --tag=CC --mode=install \
374install -m755 sample/server $RPM_BUILD_ROOT%{_bindir}/sasl2-sample-server
375./libtool --tag=CC --mode=install \
376install -m755 saslauthd/testsaslauthd $RPM_BUILD_ROOT%{_sbindir}/testsaslauthd
377./libtool --tag=CC --mode=install \
378install -m755 utils/dbconverter-2 $RPM_BUILD_ROOT%{_sbindir}/dbconverter-2
379
380# Install the saslauthd mdoc page in the expected location.  Sure, it's not
381# really a man page, but groff seems to be able to cope with it.
382install -m755 -d $RPM_BUILD_ROOT%{_mandir}/man8/
383install -m644 saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
384
385# Create the saslauthd listening directory.
386install -m755 -d $RPM_BUILD_ROOT/var/run/saslauthd
387
388# Install the init script for saslauthd and the init script's config file.
389install -m755 -d $RPM_BUILD_ROOT/etc/rc.d/init.d $RPM_BUILD_ROOT/etc/sysconfig
390install -m755 -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
391install -m644 -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
392popd
393
394# Install the config dirs if they're not already there.
395install -m755 -d $RPM_BUILD_ROOT/%{_sysconfdir}/sasl2
396install -m755 -d $RPM_BUILD_ROOT/%{_plugindir2}
397
398# Remove unpackaged files from the buildroot.
399rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/libotp.*
400rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.a
401rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.la
402rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
403rm -f $RPM_BUILD_ROOT%{_mandir}/cat8/saslauthd.8
404
405%clean
406test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
407
408%post
409/sbin/ldconfig
410/sbin/chkconfig --add saslauthd
411
412%preun
413if [ $1 = 0 ] ; then
414        /sbin/chkconfig --del saslauthd
415fi
416
417%postun
418/sbin/ldconfig
419if [ $1 != 0 ] ; then
420        /sbin/service saslauthd condrestart 2>&1 > /dev/null
421fi
422
423%files
424%defattr(-,root,root)
425%if %{includev1}
426%doc %{name}-%{version}/%{cs1_version}
427%endif
428%doc %{name}-%{version}/{AUTHORS,COPYING,NEWS,README,doc/*.html}
429%doc $RPM_SOURCE_DIR/README.RPM
430%dir %{_sysconfdir}/sasl2
431%{_libdir}/libsasl*.so.*
432%if %{includev1}
433%dir %{_plugindir}/
434%endif
435%dir %{_plugindir2}/
436%if %{includev1}
437%{_plugindir}/*anonymous*.so*
438%{_plugindir}/*anonymous*.la
439%endif
440%{_plugindir2}/*anonymous*.so*
441%{_plugindir2}/*sasldb*.so*
442%{_mandir}/man8/*
443%{_sbindir}/dbconverter-2
444%if %{includev1}
445%{_sbindir}/saslpasswd
446%{_sbindir}/sasldblistusers
447%endif
448%{_sbindir}/saslpasswd2
449%{_sbindir}/sasldblistusers2
450%{_sbindir}/pluginviewer
451%{_sbindir}/saslauthd
452%{_sbindir}/testsaslauthd
453%config(noreplace) /etc/sysconfig/saslauthd
454%config /etc/rc.d/init.d/saslauthd
455/var/run/saslauthd
456
457%files gssapi
458%defattr(-,root,root)
459%{_plugindir2}/*gssapi*.so*
460
461%files plain
462%defattr(-,root,root)
463%if %{includev1}
464%{_plugindir}/*plain*.so*
465%{_plugindir}/*plain*.la
466%{_plugindir}/*login*.so*
467%{_plugindir}/*login*.la
468%endif
469%{_plugindir2}/*plain*.so*
470%{_plugindir2}/*login*.so*
471
472%files md5
473%defattr(-,root,root)
474%if %{includev1}
475%{_plugindir}/*crammd5*.so*
476%{_plugindir}/*crammd5*.la
477%{_plugindir}/*digestmd5*.so*
478%{_plugindir}/*digestmd5*.la
479%endif
480%{_plugindir2}/*crammd5*.so*
481%{_plugindir2}/*digestmd5*.so*
482
483%files ntlm
484%defattr(-,root,root)
485%{_plugindir2}/*ntlm*.so*
486
487%files sql
488%defattr(-,root,root)
489%{_plugindir2}/*sql*.so*
490
491%files ldap
492%defattr(-,root,root)
493%{_plugindir2}/*ldapdb*.so*
494
495%files devel
496%defattr(-,root,root)
497%if %{includev1}
498%doc %{name}-%{version}/%{cs1_version}-devel
499%endif
500%doc %{name}-%{version}/doc/*.txt
501%defattr(-,root,root)
502%if %{includev1}
503%{_bindir}/sasl-sample-client
504%{_bindir}/sasl-sample-server
505%endif
506%{_bindir}/sasl2-sample-client
507%{_bindir}/sasl2-sample-server
508%{_includedir}/*
509%{_libdir}/libsasl*.so
510%if %{includev1}
511%{_plugindir}/*anonymous*.a
512%{_plugindir}/*crammd5*.a
513%{_plugindir}/*digestmd5*.a
514%{_plugindir}/*login*.a
515%{_plugindir}/*plain*.a
516%endif
517%{_mandir}/man3/*
518
519## to build compat32 for x86_64 architecture support
520%if %{build_compat32}
521%files -n compat32-%{name}
522%defattr(-,root,root)
523%{_libdir}/libsasl*.so.*
524%dir %{_plugindir2}/
525%{_plugindir2}/*anonymous*.so*
526%{_plugindir2}/*sasldb*.so*
527
528%files -n compat32-%{name}-gssapi
529%defattr(-,root,root)
530%{_plugindir2}/*gssapi*.so*
531
532%files -n compat32-%{name}-plain
533%defattr(-,root,root)
534%{_plugindir2}/*plain*.so*
535%{_plugindir2}/*login*.so*
536
537%files -n compat32-%{name}-md5
538%defattr(-,root,root)
539%{_plugindir2}/*crammd5*.so*
540%{_plugindir2}/*digestmd5*.so*
541
542%files -n compat32-%{name}-ntlm
543%defattr(-,root,root)
544%{_plugindir2}/*ntlm*.so*
545
546# %files -n compat32-%{name}-sql
547# %defattr(-,root,root)
548# %{_plugindir2}/*sql*.so*
549
550%files -n compat32-%{name}-ldap
551%defattr(-,root,root)
552%{_plugindir2}/*ldapdb*.so*
553
554%files -n compat32-%{name}-devel
555%defattr(-,root,root)
556%{_libdir}/libsasl*.so
557%endif
558
559
560%changelog
561* Mon Aug 22 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.23-9
562- fixed pam support.
563- fixed MySQL support.
564
565* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.1.23-8
566- rebuilt with postgresql-9.0.3
567
568* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.23-7
569- rebuild with krb5-libs-1.8.2 and openssl-1.0.0d
570
571* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.23-6
572- rebuild with openssl-1.0.0c
573- add BuildRequires: groff
574
575* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.23-5
576- rebuilt with db4-4.8
577- updated Patch100: cyrus-sasl-2.1.22-db4.patch
578- added Patch101: cyrus-sasl-2.1.23-gcc44.patch
579
580* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.1.23-4
581- dropped compat32-%%{name}-sql
582
583* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.1.23-3
584- added compat32 subpackages
585
586* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.23-2
587- rebuilt with MySQL-5.1.34.
588
589* Mon May 18 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.23-1
590- new upstream release with security fix (CVE-2009-0688)
591- add patch5 to fix CVE-2009-0688 issue in 1.5.28 side
592  (No effect in Current VineSeed package)
593
594* Sun Jan 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.22-5
595- rebuilt with openldap-2.4.11
596
597* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.1.22-4
598- s/%%{name}-lib/%%{name}/ at requires of sql, ldap sub-packages
599
600* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1.22-3
601- added gssapi subpackage
602
603* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.22-2
604- rebuilt against db-4.6.21 with Patch100
605- import Patch27 from Fedora
606
607* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.22-1vl5
608- updated to 2.1.22
609- added Patches from Fedora
610  * Tue Jun 20 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.22-2
611  - fix a typo in sasl_client_start(3) (#196066)
612  * Thu Apr 27 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.21-11
613  - add unapplied patch which makes the DIGEST-MD5 plugin omit the realm
614    argument when the environment has $CYRUS_SASL_DIGEST_MD5_OMIT_REALM set
615    to a non-zero value, for testing purposes
616- added subpackages for the ldapdb auxprop support
617- added --disable-static option to %%configure
618
619* Tue May 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.18-0vl8
620- added Patch17: cyrus-sasl-2.1.18-openssl-098.patch
621- rebuilt with openssl-0.9.8
622
623* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.18-0vl7
624- disable version 1 now (no VineSeed package require version 1)
625- enable ntlm subpackage now
626- rebuilt with new toolchain and db4-4.3.x
627
628* Sat Jul  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.18-0vl6
629- rebuilt for VineSeed
630
631* Fri Apr 28 2006 IWAI, Masaharu <iwai@alib.jp> 2.1.18-0vl5
632- SECURITY FIX for Vine 3.2: CVE-2006-1721
633   - add 23_CVE-2006-1721.diff ( Patch16 )
634       from Debian Sarge cyrus-sasl2_2.1.19-1.5sarge1.diff.gz
635
636* Mon Dec 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.18-0vl4
637- rebuild for VineSeed
638
639* Sat Nov 27 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 2.1.18-0vl3
640- added security patch cyrus-sasl-CAN-2004-0884.patch for CAN-2004-0884
641  from Mandrakelinux.
642
643* Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.18-0vl2
644- rebuilt with db4-4.2.52
645
646* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.18-0vl1
647- new upstream release
648- rebuild with openssl-0.9.7d
649- import some patch from fedora package
650
651* Sun Nov 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.15-6vl1
652- new upstream release
653- remove prereq initscripts
654- merged with fedora package
655  * Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-6
656  - use /dev/urandom instead of /dev/random for SASL2 (docs indicate that this is
657  safe if you aren't using OTP or SRP, and we build neither); SASL1 appears to
658  use it to seed the libc RNG only (#103378)
659  * Mon Oct 20 2003 Nalin Dahyabhai <nalin@redhat.com>
660  - obey RPM_OPT_FLAGS again when krb5_prefix != %%{_prefix}
661  * Fri Oct 17 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-5
662  - install saslauthd's mdoc page instead of the pre-formatted man page, which
663    would get formatted again
664  * Mon Sep 15 2003 Nalin Dahyabhai <nalin@redhat.com>
665  - include testsaslauthd
666  - note in the README that the saslauthd protocol is different for v1 and v2,
667    so v1's clients can't talk to the v2 server
668  * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-3
669  - add logic to build with gssapi libs in either /usr or /usr/kerberos
670  * Tue Jul 15 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-1
671  - update to 2.1.15
672  * Mon Jul 14 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.14-1
673  - update to 2.1.14
674
675* Wed May 14 2003 Satoshi MACHINO <machino@vinelinux.org> 2.1.13-3vl1
676- new upstream version
677- merged with rawhide version
678        -- * Fri May  9 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-3
679        -- - change -m argument to saslauthd to be a directory instead of a path
680        -- * Thu May  8 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-2
681        -- - link libsasl2 with -lpthread to ensure that the sasldb plug-in
682             can always be loaded
683        -- * Tue Apr 29 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-1
684        -- - update to 2.1.13
685- disable gssapi because Vine Linux don't support Kerberos
686
687* Sun Dec  9 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.5.27-17vl1
688- upstream release
689- obsoleted cyrus-sasl-1.5.21-des.patch ( upstream merged )
690- obsoleted cyrus-sasl-1.5.24-external.patch ( upstream merged )
691- added BuildPrereq: gdbm-devel, pam-devel
692
693* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
694- 1.5.24-17vl2
695- rebuilt with openssl-0.9.6b
696
697* Wed Apr 11 2001 Satoshi MACHINO <machino@vinelinux.org> 1.5.24-17vl1
698- merged Rawhide Package
699
700* Sat Nov 18 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.5.24-14vl1
701- build for Vine Linux
702- build with gcc-2.95.3
703- removed kerberos and gssapi
704
705* Fri Oct 27 2000 Nalin Dahyabhai <nalin@redhat.com>
706- enable static libraries, but always build with -fPIC
707
708* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
709- make sure the version of 1.5.24 in the package matches the masters (#18968)
710
711* Mon Oct  9 2000 Nalin Dahyabhai <nalin@redhat.com>
712- re-add the libsasl.so symlink to the -devel package (oops)
713
714* Fri Oct  6 2000 Nalin Dahyabhai <nalin@redhat.com>
715- move .so files for modules to their respective packages -- they're not -devel
716  links meant for use by ld anyway
717
718* Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
719- split off -devel subpackage
720- add a -gssapi subpackage for the gssapi plugins
721
722* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
723- fix the summary text
724
725* Sun Aug 13 2000 Nalin Dahyabhai <nalin@redhat.com>
726- re-enable arcfour and CRAM
727
728* Fri Aug  4 2000 Nalin Dahyabhai <nalin@redhat.com>
729- force use of gdbm for database files to avoid DB migration weirdness
730- enable login mechanism
731- disable gssapi until it can coexist peacefully with non-gssapi setups
732- actually do a make in the build section (#15410)
733
734* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
735- update to 1.5.24
736
737* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
738- automatic rebuild
739
740* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
741- rebuild in new environment (release 3)
742
743* Mon Jun 19 2000 Nalin Dahyabhai <nalin@redhat.com>
744- don't muck with syslogd in post
745- remove patch for db-3.0 wackiness, no longer needed
746
747* Thu Jun  8 2000 Nalin Dahyabhai <nalin@redhat.com>
748- FHS cleanup
749- don't strip anything by default
750
751* Fri Feb 11 2000 Tim Powers <timp@redhat.com>
752- fixed man pages not being gzipped
753
754* Tue Nov 16 1999 Tim Powers <timp@redhat.com>
755- incorporated changes from Mads Kiilerich
756- release number is 1, not mk1
757
758* Tue Nov 10 1999 Mads Kiilerich <mads@kiilerich.com>
759- updated to sasl 1.5.11
760- configure --disable-krb4 --without-rc4 --disable-cram
761  because of missing libraries and pine having cram as default...
762- handle changing libsasl.so versions
763
764* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
765- changed group
766
767* Fri Aug 13 1999 Tim Powers <timp@redhat.com>
768- first build for Powertools
Note: See TracBrowser for help on using the repository browser.