source: projects/specs/trunk/c/cyrus-sasl/cyrus-sasl-vl.spec @ 521

Revision 521, 23.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define cs1_version 1.5.28
4%define _plugindir %{_libdir}/sasl
5%define _plugindir2 %{_libdir}/sasl2
6
7# No package in the current VineSeed tree needs Version 1 support
8%define includev1 0
9
10Summary: The Cyrus SASL library.
11Name: cyrus-sasl
12Version: 2.1.23
13Release: 5%{_dist_release}
14License: BSD
15Group: System Environment/Libraries
16Source0: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz
17Source1: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz.sig
18Source2: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{cs1_version}.tar.gz
19Source3: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{cs1_version}.tar.gz.sig
20Source4: saslauthd.init
21Source5: README.RPM
22Source9: saslauthd.sysconfig
23URL: http://asg.web.cmu.edu/sasl/sasl-library.html
24#
25Patch0: cyrus-sasl-1.5.24-rpath.patch
26Patch1: cyrus-sasl-1.5.28-autoconf25.patch
27Patch2: cyrus-sasl-1.5.28-automake17.patch
28Patch3: cyrus-sasl-1.5.28-automake18.patch
29Patch4: cyrus-sasl-1.5.28-saslauthd2.patch
30Patch5: cyrus-sasl-1.5.28_CVE-2009-0688.patch
31#
32Patch10: cyrus-sasl-2.1.22-db_bundle.patch
33Patch11: cyrus-sasl-2.1.18-no_rpath.patch
34Patch15: cyrus-sasl-2.1.20-saslauthd.conf-path.patch
35Patch24: cyrus-sasl-2.1.21-sizes.patch
36Patch25: cyrus-sasl-2.1.22-typo.patch
37Patch26: cyrus-sasl-2.1.22-digest-commas.patch
38Patch27: cyrus-sasl-2.1.22-automake-1.10.patch
39Patch28: cyrus-sasl-2.1.21-keytab.patch
40
41Patch100: cyrus-sasl-2.1.22-db4.patch
42Patch101: cyrus-sasl-2.1.23-gcc44.patch
43
44Buildroot: %{_tmppath}/%{name}-%{version}-root
45BuildRequires: autoconf, automake, libtool
46# Note: berkeley db for sasl2, gdbm for sasl1.
47BuildRequires: db4-devel, openssl-devel, pam-devel
48%if %{includev1}
49BuildRequires: gdbm-devel
50%endif
51BuildRequires: MySQL-devel, postgresql-devel, openldap-devel, zlib-devel
52BuildRequires: pkgconfig
53BuildRequires: krb5-devel
54Requires(post,postun): /sbin/ldconfig, chkconfig
55
56%description
57The %{name} package contains the Cyrus implementation of SASL.
58SASL is the Simple Authentication and Security Layer, a method for
59adding authentication support to connection-based protocols.
60
61%package devel
62Requires: %{name} = %{version}-%{release}
63Group: Development/Libraries
64Summary: Files needed for developing applications with Cyrus SASL.
65
66%description devel
67The %{name}-devel package contains files needed for developing and
68compiling applications which use the Cyrus SASL library.
69
70%package gssapi
71Requires: %{name} = %{version}-%{release}
72Group: System Environment/Libraries
73Summary: GSSAPI support for Cyrus SASL.
74
75%description gssapi
76The %{name}-gssapi package contains the Cyrus SASL plugins which
77support GSSAPI authentication. GSSAPI is commonly used for Kerberos
78authentication.
79
80%package plain
81Requires: %{name} = %{version}-%{release}
82Group: System Environment/Libraries
83Summary: PLAIN and LOGIN support for Cyrus SASL.
84
85%description plain
86The %{name}-plain package contains the Cyrus SASL plugins which support
87PLAIN and LOGIN authentication schemes.
88
89%package md5
90Requires: %{name} = %{version}-%{release}
91Group: System Environment/Libraries
92Summary: CRAM-MD5 and DIGEST-MD5 support for Cyrus SASL.
93
94%description md5
95The %{name}-md5 package contains the Cyrus SASL plugins which support
96CRAM-MD5 and DIGEST-MD5 authentication schemes.
97
98%package ntlm
99Requires: %{name} = %{version}-%{release}
100Group: System Environment/Libraries
101Summary: NTLM support for Cyrus SASL.
102
103%description ntlm
104The %{name}-ntlm package contains the Cyrus SASL plugin which supports
105the NTLM authentication schemes.
106
107# This would more appropriately be named cyrus-sasl-auxprop-sql.
108%package sql
109#Requires: %{name}-lib = %{version}-%{release}
110Requires: %{name} = %{version}-%{release}
111Group: System Environment/Libraries
112Summary: SQL auxprop support for Cyrus SASL
113
114%description sql
115The %{name}-sql package contains the Cyrus SASL plugin which supports
116using a RDBMS for storing shared secrets.
117
118# This was *almost* named cyrus-sasl-auxprop-ldapdb, but that's a lot of typing.
119%package ldap
120#Requires: %{name}-lib = %{version}-%{release}
121Requires: %{name} = %{version}-%{release}
122Group: System Environment/Libraries
123Summary: LDAP auxprop support for Cyrus SASL
124
125%description ldap
126The %{name}-ldap package contains the Cyrus SASL plugin which supports using
127a directory server, accessed using LDAP, for storing shared secrets.
128
129
130## to build compat32 for x86_64 architecture support
131%package -n compat32-%{name}
132Summary: The Cyrus SASL library.
133Group: System Environment/Libraries
134
135%description -n compat32-%{name}
136The %{name} package contains the Cyrus implementation of SASL.
137SASL is the Simple Authentication and Security Layer, a method for
138adding authentication support to connection-based protocols.
139
140%package -n compat32-%{name}-devel
141Group: Development/Libraries
142Summary: Files needed for developing applications with Cyrus SASL.
143
144%description -n compat32-%{name}-devel
145The %{name}-devel package contains files needed for developing and
146compiling applications which use the Cyrus SASL library.
147
148%package -n compat32-%{name}-gssapi
149Group: System Environment/Libraries
150Summary: GSSAPI support for Cyrus SASL.
151
152%description -n compat32-%{name}-gssapi
153The %{name}-gssapi package contains the Cyrus SASL plugins which
154support GSSAPI authentication. GSSAPI is commonly used for Kerberos
155authentication.
156
157%package -n compat32-%{name}-plain
158Group: System Environment/Libraries
159Summary: PLAIN and LOGIN support for Cyrus SASL.
160
161%description -n compat32-%{name}-plain
162The %{name}-plain package contains the Cyrus SASL plugins which support
163PLAIN and LOGIN authentication schemes.
164
165%package -n compat32-%{name}-md5
166Group: System Environment/Libraries
167Summary: CRAM-MD5 and DIGEST-MD5 support for Cyrus SASL.
168
169%description -n compat32-%{name}-md5
170The %{name}-md5 package contains the Cyrus SASL plugins which support
171CRAM-MD5 and DIGEST-MD5 authentication schemes.
172
173%package -n compat32-%{name}-ntlm
174Group: System Environment/Libraries
175Summary: NTLM support for Cyrus SASL.
176
177%description -n compat32-%{name}-ntlm
178The %{name}-ntlm package contains the Cyrus SASL plugin which supports
179the NTLM authentication schemes.
180
181# %package -n compat32-%{name}-sql
182# Group: System Environment/Libraries
183# Summary: SQL auxprop support for Cyrus SASL
184
185# %description -n compat32-%{name}-sql
186# The %{name}-sql package contains the Cyrus SASL plugin which supports
187# using a RDBMS for storing shared secrets.
188
189%package -n compat32-%{name}-ldap
190Group: System Environment/Libraries
191Summary: LDAP auxprop support for Cyrus SASL
192
193%description -n compat32-%{name}-ldap
194The %{name}-ldap package contains the Cyrus SASL plugin which supports using
195a directory server, accessed using LDAP, for storing shared secrets.
196
197
198
199%prep
200%setup -q -c -a 2
201%if %{includev1}
202pushd cyrus-sasl-%{cs1_version}
203%patch0 -p1 -b .rpath
204%patch1 -p1 -b .autoconf25
205%patch2 -p1 -b .automake17
206%patch3 -p1 -b .automake18
207%patch4 -p1 -b .saslauthd2
208%patch5 -p1 -b .CVE-2009-0688
209libtoolize -f -c
210aclocal -I config -I cmulocal
211automake -a -c -f
212autoheader
213autoconf -f
214popd
215%endif
216
217pushd cyrus-sasl-%{version}
218chmod -x doc/*.html
219chmod -x include/*.h
220%patch10 -p1 -b .db_bundle
221%patch11 -p1 -b .no_rpath
222%patch15 -p1 -b .path
223%patch24 -p1 -b .sizes
224%patch25 -p1 -b .typo
225%patch26 -p2 -b .digest-commas
226%patch27 -p1 -b .automake-1.10
227%patch28 -p1 -b .keytab
228
229%patch100 -p1 -b .db48
230%patch101 -p1 -b .gcc44
231
232# FIXME - we remove these files directly so that we can avoid using the -f
233# flag, which has a nasty habit of overwriting files like COPYING.
234rm -f config/config.guess config/config.sub
235rm -f config/ltconfig config/ltmain.sh config/libtool.m4
236rm -fr autom4te.cache
237libtoolize -c
238aclocal -I config -I cmulocal
239automake -a -c
240autoheader
241autoconf
242
243pushd saslauthd
244rm -f config/config.guess config/config.sub
245rm -f config/ltconfig config/ltmain.sh config/libtool.m4
246rm -fr autom4te.cache
247libtoolize -c
248aclocal -I config -I ../cmulocal -I ../config
249automake -a -c
250autoheader
251autoconf
252popd
253
254%if %{includev1}
255# Sort of merge the docs.
256mkdir cyrus-sasl-%{version}/%{cs1_version}
257mkdir cyrus-sasl-%{version}/%{cs1_version}-devel
258cp %{name}-%{cs1_version}/{AUTHORS,COPYING,NEWS,README,doc/*.html} cyrus-sasl-%{version}/%{cs1_version}
259cp %{name}-%{cs1_version}/doc/*.txt cyrus-sasl-%{version}/%{cs1_version}-devel
260# Remove duplicate RFCs.
261pushd cyrus-sasl-%{version}/%{cs1_version}-devel
262for file in * ; do
263        if [ -f ../doc/${file} ] ; then
264                rm -f ${file}
265        fi
266done
267popd
268%endif
269
270%build
271%if %{includev1}
272pushd cyrus-sasl-%{cs1_version}
273%configure \
274        --enable-static --enable-staticdlopen --with-pic --enable-shared \
275        --with-plugindir=%{_plugindir} \
276        --disable-krb4 \
277        --with-rc4 \
278        --with-dblib=gdbm \
279        --enable-anon \
280        --enable-cram \
281        --enable-digest \
282        --enable-plain \
283        --enable-login
284make %{?_smp_mflags} sasldir=%{_plugindir}
285popd
286%endif
287
288pushd cyrus-sasl-%{version}
289CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
290
291# Find OpenSSL.
292LIBS="-lcrypt"; export LIBS
293if pkg-config openssl ; then
294        CPPFLAGS="`pkg-config --cflags-only-I openssl` $CPPFLAGS"; export CPPFLAGS
295        CFLAGS="`pkg-config --cflags openssl` $CFLAGS"; export CFLAGS
296        LDFLAGS="`pkg-config --libs-only-L openssl` $LDFLAGS"; export LDFLAGS
297fi
298
299# Find the SQL libraries used needed by the SQL auxprop plugin.
300mysql_config=mysql_config
301pg_config=pg_config
302SQL_CFLAGS=`${mysql_config} --cflags`" -I"`${pg_config} --includedir`
303SQL_LIBS=`${mysql_config} --libs`" -L"`${pg_config} --libdir`" -lpq"
304SQL_CFLAGS=`eval echo "$SQL_CFLAGS" | sed -e 's,-I%{_includedir}[^/],,g' -e 's,-I%{_includedir}$,,g' -e 's,[[:blank:]]+, ,g'`
305SQL_LIBS=`eval echo "$SQL_LIBS" | sed -e 's,-L%{_libdir}[^/],,g' -e 's,-L%{_libdir}$,,g' -e 's,[[:blank:]]+, ,g'`
306SQL_LDFLAGS=`eval echo "$SQL_LIBS" | sed -e 's,-[^L][^ ]*,,g'`
307echo $SQL_LDFLAGS
308SQL_LIBS=`eval echo "$SQL_LIBS" | sed -e 's,-[^l][^ ]*,,g'`
309echo $SQL_LIBS
310
311cleanup_flags() {
312        sed -r -e 's,-D_GNU_SOURCE(=[^[:blank:]]+)?,,g' \
313               -e 's,-D_FILE_OFFSET_BITS=[[:digit:]]+,,g' \
314               -e 's,-D_LARGEFILE_SOURCE(=[^[:blank:]]+)?,,g' \
315               -e 's,[[:blank:]]+, ,g'
316}
317CFLAGS=`echo $CFLAGS $SQL_CFLAGS | cleanup_flags`; export CFLAGS
318CPPFLAGS=`echo $CPPFLAGS $SQL_CFLAGS | cleanup_flags`; export CPPFLAGS
319LDFLAGS=`echo $LDFLAGS $SQL_LDFLAGS | cleanup_flags`; export LDFLAGS
320
321%configure \
322        --disable-static --enable-shared --disable-java \
323        --with-plugindir=%{_plugindir2}:%{_sysconfdir}/sasl2 \
324        --disable-krb4 \
325        --with-rc4 \
326        --with-dblib=berkeley \
327        --with-saslauthd=/var/run/saslauthd --without-pwcheck \
328        --with-ldap \
329        --with-devrandom=/dev/urandom \
330        --enable-anon \
331        --enable-cram \
332        --enable-digest \
333        --enable-ntlm \
334        --enable-plain \
335        --enable-login \
336        --disable-otp \
337        --enable-ldapdb \
338        --enable-sql --with-mysql=%{_prefix} --with-pgsql=%{_prefix} \
339        --without-sqlite \
340        "$@"
341        # --enable-auth-sasldb -- EXPERIMENTAL
342make %{?_smp_mflags} sasldir=%{_plugindir2}
343make %{?_smp_mflags} -C saslauthd testsaslauthd
344make -C sample
345popd
346
347%install
348test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
349%if %{includev1}
350pushd cyrus-sasl-%{cs1_version}
351%makeinstall sasldir=$RPM_BUILD_ROOT/%{_plugindir}
352install -m755 -d $RPM_BUILD_ROOT%{_bindir}
353libtool --mode=install \
354install -m755 sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
355libtool --mode=install \
356install -m755 sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
357popd
358%endif
359
360pushd cyrus-sasl-%{version}
361make install DESTDIR=$RPM_BUILD_ROOT sasldir=%{_plugindir2}
362make install DESTDIR=$RPM_BUILD_ROOT sasldir=%{_plugindir2} -C plugins
363
364install -m755 -d $RPM_BUILD_ROOT%{_bindir}
365./libtool --tag=CC --mode=install \
366install -m755 sample/client $RPM_BUILD_ROOT%{_bindir}/sasl2-sample-client
367./libtool --tag=CC --mode=install \
368install -m755 sample/server $RPM_BUILD_ROOT%{_bindir}/sasl2-sample-server
369./libtool --tag=CC --mode=install \
370install -m755 saslauthd/testsaslauthd $RPM_BUILD_ROOT%{_sbindir}/testsaslauthd
371./libtool --tag=CC --mode=install \
372install -m755 utils/dbconverter-2 $RPM_BUILD_ROOT%{_sbindir}/dbconverter-2
373
374# Install the saslauthd mdoc page in the expected location.  Sure, it's not
375# really a man page, but groff seems to be able to cope with it.
376install -m755 -d $RPM_BUILD_ROOT%{_mandir}/man8/
377install -m644 saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
378
379# Create the saslauthd listening directory.
380install -m755 -d $RPM_BUILD_ROOT/var/run/saslauthd
381
382# Install the init script for saslauthd and the init script's config file.
383install -m755 -d $RPM_BUILD_ROOT/etc/rc.d/init.d $RPM_BUILD_ROOT/etc/sysconfig
384install -m755 -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
385install -m644 -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
386popd
387
388# Install the config dirs if they're not already there.
389install -m755 -d $RPM_BUILD_ROOT/%{_sysconfdir}/sasl2
390install -m755 -d $RPM_BUILD_ROOT/%{_plugindir2}
391
392# Remove unpackaged files from the buildroot.
393rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/libotp.*
394rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.a
395rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.la
396rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
397rm -f $RPM_BUILD_ROOT%{_mandir}/cat8/saslauthd.8
398
399%clean
400test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
401
402%post
403/sbin/ldconfig
404/sbin/chkconfig --add saslauthd
405
406%preun
407if [ $1 = 0 ] ; then
408        /sbin/chkconfig --del saslauthd
409fi
410
411%postun
412/sbin/ldconfig
413if [ $1 != 0 ] ; then
414        /sbin/service saslauthd condrestart 2>&1 > /dev/null
415fi
416
417%files
418%defattr(-,root,root)
419%if %{includev1}
420%doc %{name}-%{version}/%{cs1_version}
421%endif
422%doc %{name}-%{version}/{AUTHORS,COPYING,NEWS,README,doc/*.html}
423%doc $RPM_SOURCE_DIR/README.RPM
424%dir %{_sysconfdir}/sasl2
425%{_libdir}/libsasl*.so.*
426%if %{includev1}
427%dir %{_plugindir}/
428%endif
429%dir %{_plugindir2}/
430%if %{includev1}
431%{_plugindir}/*anonymous*.so*
432%{_plugindir}/*anonymous*.la
433%endif
434%{_plugindir2}/*anonymous*.so*
435%{_plugindir2}/*sasldb*.so*
436%{_mandir}/man8/*
437%{_sbindir}/dbconverter-2
438%if %{includev1}
439%{_sbindir}/saslpasswd
440%{_sbindir}/sasldblistusers
441%endif
442%{_sbindir}/saslpasswd2
443%{_sbindir}/sasldblistusers2
444%{_sbindir}/pluginviewer
445%{_sbindir}/saslauthd
446%{_sbindir}/testsaslauthd
447%config(noreplace) /etc/sysconfig/saslauthd
448%config /etc/rc.d/init.d/saslauthd
449/var/run/saslauthd
450
451%files gssapi
452%defattr(-,root,root)
453%{_plugindir2}/*gssapi*.so*
454
455%files plain
456%defattr(-,root,root)
457%if %{includev1}
458%{_plugindir}/*plain*.so*
459%{_plugindir}/*plain*.la
460%{_plugindir}/*login*.so*
461%{_plugindir}/*login*.la
462%endif
463%{_plugindir2}/*plain*.so*
464%{_plugindir2}/*login*.so*
465
466%files md5
467%defattr(-,root,root)
468%if %{includev1}
469%{_plugindir}/*crammd5*.so*
470%{_plugindir}/*crammd5*.la
471%{_plugindir}/*digestmd5*.so*
472%{_plugindir}/*digestmd5*.la
473%endif
474%{_plugindir2}/*crammd5*.so*
475%{_plugindir2}/*digestmd5*.so*
476
477%files ntlm
478%defattr(-,root,root)
479%{_plugindir2}/*ntlm*.so*
480
481%files sql
482%defattr(-,root,root)
483%{_plugindir2}/*sql*.so*
484
485%files ldap
486%defattr(-,root,root)
487%{_plugindir2}/*ldapdb*.so*
488
489%files devel
490%defattr(-,root,root)
491%if %{includev1}
492%doc %{name}-%{version}/%{cs1_version}-devel
493%endif
494%doc %{name}-%{version}/doc/*.txt
495%defattr(-,root,root)
496%if %{includev1}
497%{_bindir}/sasl-sample-client
498%{_bindir}/sasl-sample-server
499%endif
500%{_bindir}/sasl2-sample-client
501%{_bindir}/sasl2-sample-server
502%{_includedir}/*
503%{_libdir}/libsasl*.so
504%if %{includev1}
505%{_plugindir}/*anonymous*.a
506%{_plugindir}/*crammd5*.a
507%{_plugindir}/*digestmd5*.a
508%{_plugindir}/*login*.a
509%{_plugindir}/*plain*.a
510%endif
511%{_mandir}/man3/*
512
513## to build compat32 for x86_64 architecture support
514%if %{build_compat32}
515%files -n compat32-%{name}
516%defattr(-,root,root)
517%{_libdir}/libsasl*.so.*
518%dir %{_plugindir2}/
519%{_plugindir2}/*anonymous*.so*
520%{_plugindir2}/*sasldb*.so*
521
522%files -n compat32-%{name}-gssapi
523%defattr(-,root,root)
524%{_plugindir2}/*gssapi*.so*
525
526%files -n compat32-%{name}-plain
527%defattr(-,root,root)
528%{_plugindir2}/*plain*.so*
529%{_plugindir2}/*login*.so*
530
531%files -n compat32-%{name}-md5
532%defattr(-,root,root)
533%{_plugindir2}/*crammd5*.so*
534%{_plugindir2}/*digestmd5*.so*
535
536%files -n compat32-%{name}-ntlm
537%defattr(-,root,root)
538%{_plugindir2}/*ntlm*.so*
539
540# %files -n compat32-%{name}-sql
541# %defattr(-,root,root)
542# %{_plugindir2}/*sql*.so*
543
544%files -n compat32-%{name}-ldap
545%defattr(-,root,root)
546%{_plugindir2}/*ldapdb*.so*
547
548%files -n compat32-%{name}-devel
549%defattr(-,root,root)
550%{_libdir}/libsasl*.so
551%endif
552
553
554%changelog
555* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.23-5
556- rebuilt with db4-4.8
557- updated Patch100: cyrus-sasl-2.1.22-db4.patch
558- added Patch101: cyrus-sasl-2.1.23-gcc44.patch
559
560* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.1.23-4
561- dropped compat32-%%{name}-sql
562
563* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.1.23-3
564- added compat32 subpackages
565
566* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.23-2
567- rebuilt with MySQL-5.1.34.
568
569* Mon May 18 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.23-1
570- new upstream release with security fix (CVE-2009-0688)
571- add patch5 to fix CVE-2009-0688 issue in 1.5.28 side
572  (No effect in Current VineSeed package)
573
574* Sun Jan 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.22-5
575- rebuilt with openldap-2.4.11
576
577* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.1.22-4
578- s/%%{name}-lib/%%{name}/ at requires of sql, ldap sub-packages
579
580* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1.22-3
581- added gssapi subpackage
582
583* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.22-2
584- rebuilt against db-4.6.21 with Patch100
585- import Patch27 from Fedora
586
587* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.22-1vl5
588- updated to 2.1.22
589- added Patches from Fedora
590  * Tue Jun 20 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.22-2
591  - fix a typo in sasl_client_start(3) (#196066)
592  * Thu Apr 27 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.21-11
593  - add unapplied patch which makes the DIGEST-MD5 plugin omit the realm
594    argument when the environment has $CYRUS_SASL_DIGEST_MD5_OMIT_REALM set
595    to a non-zero value, for testing purposes
596- added subpackages for the ldapdb auxprop support
597- added --disable-static option to %%configure
598
599* Tue May 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.18-0vl8
600- added Patch17: cyrus-sasl-2.1.18-openssl-098.patch
601- rebuilt with openssl-0.9.8
602
603* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.18-0vl7
604- disable version 1 now (no VineSeed package require version 1)
605- enable ntlm subpackage now
606- rebuilt with new toolchain and db4-4.3.x
607
608* Sat Jul  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.18-0vl6
609- rebuilt for VineSeed
610
611* Fri Apr 28 2006 IWAI, Masaharu <iwai@alib.jp> 2.1.18-0vl5
612- SECURITY FIX for Vine 3.2: CVE-2006-1721
613   - add 23_CVE-2006-1721.diff ( Patch16 )
614       from Debian Sarge cyrus-sasl2_2.1.19-1.5sarge1.diff.gz
615
616* Mon Dec 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.18-0vl4
617- rebuild for VineSeed
618
619* Sat Nov 27 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 2.1.18-0vl3
620- added security patch cyrus-sasl-CAN-2004-0884.patch for CAN-2004-0884
621  from Mandrakelinux.
622
623* Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.18-0vl2
624- rebuilt with db4-4.2.52
625
626* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.18-0vl1
627- new upstream release
628- rebuild with openssl-0.9.7d
629- import some patch from fedora package
630
631* Sun Nov 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.15-6vl1
632- new upstream release
633- remove prereq initscripts
634- merged with fedora package
635  * Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-6
636  - use /dev/urandom instead of /dev/random for SASL2 (docs indicate that this is
637  safe if you aren't using OTP or SRP, and we build neither); SASL1 appears to
638  use it to seed the libc RNG only (#103378)
639  * Mon Oct 20 2003 Nalin Dahyabhai <nalin@redhat.com>
640  - obey RPM_OPT_FLAGS again when krb5_prefix != %%{_prefix}
641  * Fri Oct 17 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-5
642  - install saslauthd's mdoc page instead of the pre-formatted man page, which
643    would get formatted again
644  * Mon Sep 15 2003 Nalin Dahyabhai <nalin@redhat.com>
645  - include testsaslauthd
646  - note in the README that the saslauthd protocol is different for v1 and v2,
647    so v1's clients can't talk to the v2 server
648  * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-3
649  - add logic to build with gssapi libs in either /usr or /usr/kerberos
650  * Tue Jul 15 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-1
651  - update to 2.1.15
652  * Mon Jul 14 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.14-1
653  - update to 2.1.14
654
655* Wed May 14 2003 Satoshi MACHINO <machino@vinelinux.org> 2.1.13-3vl1
656- new upstream version
657- merged with rawhide version
658        -- * Fri May  9 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-3
659        -- - change -m argument to saslauthd to be a directory instead of a path
660        -- * Thu May  8 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-2
661        -- - link libsasl2 with -lpthread to ensure that the sasldb plug-in
662             can always be loaded
663        -- * Tue Apr 29 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-1
664        -- - update to 2.1.13
665- disable gssapi because Vine Linux don't support Kerberos
666
667* Sun Dec  9 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.5.27-17vl1
668- upstream release
669- obsoleted cyrus-sasl-1.5.21-des.patch ( upstream merged )
670- obsoleted cyrus-sasl-1.5.24-external.patch ( upstream merged )
671- added BuildPrereq: gdbm-devel, pam-devel
672
673* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
674- 1.5.24-17vl2
675- rebuilt with openssl-0.9.6b
676
677* Wed Apr 11 2001 Satoshi MACHINO <machino@vinelinux.org> 1.5.24-17vl1
678- merged Rawhide Package
679
680* Sat Nov 18 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.5.24-14vl1
681- build for Vine Linux
682- build with gcc-2.95.3
683- removed kerberos and gssapi
684
685* Fri Oct 27 2000 Nalin Dahyabhai <nalin@redhat.com>
686- enable static libraries, but always build with -fPIC
687
688* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
689- make sure the version of 1.5.24 in the package matches the masters (#18968)
690
691* Mon Oct  9 2000 Nalin Dahyabhai <nalin@redhat.com>
692- re-add the libsasl.so symlink to the -devel package (oops)
693
694* Fri Oct  6 2000 Nalin Dahyabhai <nalin@redhat.com>
695- move .so files for modules to their respective packages -- they're not -devel
696  links meant for use by ld anyway
697
698* Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
699- split off -devel subpackage
700- add a -gssapi subpackage for the gssapi plugins
701
702* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
703- fix the summary text
704
705* Sun Aug 13 2000 Nalin Dahyabhai <nalin@redhat.com>
706- re-enable arcfour and CRAM
707
708* Fri Aug  4 2000 Nalin Dahyabhai <nalin@redhat.com>
709- force use of gdbm for database files to avoid DB migration weirdness
710- enable login mechanism
711- disable gssapi until it can coexist peacefully with non-gssapi setups
712- actually do a make in the build section (#15410)
713
714* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
715- update to 1.5.24
716
717* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
718- automatic rebuild
719
720* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
721- rebuild in new environment (release 3)
722
723* Mon Jun 19 2000 Nalin Dahyabhai <nalin@redhat.com>
724- don't muck with syslogd in post
725- remove patch for db-3.0 wackiness, no longer needed
726
727* Thu Jun  8 2000 Nalin Dahyabhai <nalin@redhat.com>
728- FHS cleanup
729- don't strip anything by default
730
731* Fri Feb 11 2000 Tim Powers <timp@redhat.com>
732- fixed man pages not being gzipped
733
734* Tue Nov 16 1999 Tim Powers <timp@redhat.com>
735- incorporated changes from Mads Kiilerich
736- release number is 1, not mk1
737
738* Tue Nov 10 1999 Mads Kiilerich <mads@kiilerich.com>
739- updated to sasl 1.5.11
740- configure --disable-krb4 --without-rc4 --disable-cram
741  because of missing libraries and pine having cram as default...
742- handle changing libsasl.so versions
743
744* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
745- changed group
746
747* Fri Aug 13 1999 Tim Powers <timp@redhat.com>
748- first build for Powertools
Note: See TracBrowser for help on using the repository browser.