source: projects/specs/trunk/c/cyrus-sasl/cyrus-sasl-vl.spec @ 2487

Revision 2487, 23.5 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with openssl-1.0.0c

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%define cs1_version 1.5.28
4%define _plugindir %{_libdir}/sasl
5%define _plugindir2 %{_libdir}/sasl2
6
7# No package in the current VineSeed tree needs Version 1 support
8%define includev1 0
9
10Summary: The Cyrus SASL library.
11Name: cyrus-sasl
12Version: 2.1.23
13Release: 6%{_dist_release}
14License: BSD
15Group: System Environment/Libraries
16Source0: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz
17Source1: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{version}.tar.gz.sig
18Source2: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{cs1_version}.tar.gz
19Source3: ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/cyrus-sasl-%{cs1_version}.tar.gz.sig
20Source4: saslauthd.init
21Source5: README.RPM
22Source9: saslauthd.sysconfig
23URL: http://asg.web.cmu.edu/sasl/sasl-library.html
24#
25Patch0: cyrus-sasl-1.5.24-rpath.patch
26Patch1: cyrus-sasl-1.5.28-autoconf25.patch
27Patch2: cyrus-sasl-1.5.28-automake17.patch
28Patch3: cyrus-sasl-1.5.28-automake18.patch
29Patch4: cyrus-sasl-1.5.28-saslauthd2.patch
30Patch5: cyrus-sasl-1.5.28_CVE-2009-0688.patch
31#
32Patch10: cyrus-sasl-2.1.22-db_bundle.patch
33Patch11: cyrus-sasl-2.1.18-no_rpath.patch
34Patch15: cyrus-sasl-2.1.20-saslauthd.conf-path.patch
35Patch24: cyrus-sasl-2.1.21-sizes.patch
36Patch25: cyrus-sasl-2.1.22-typo.patch
37Patch26: cyrus-sasl-2.1.22-digest-commas.patch
38Patch27: cyrus-sasl-2.1.22-automake-1.10.patch
39Patch28: cyrus-sasl-2.1.21-keytab.patch
40
41Patch100: cyrus-sasl-2.1.22-db4.patch
42Patch101: cyrus-sasl-2.1.23-gcc44.patch
43
44Buildroot: %{_tmppath}/%{name}-%{version}-root
45BuildRequires: autoconf, automake, libtool
46# Note: berkeley db for sasl2, gdbm for sasl1.
47BuildRequires: db4-devel, openssl-devel, pam-devel
48%if %{includev1}
49BuildRequires: gdbm-devel
50%endif
51BuildRequires: MySQL-devel, postgresql-devel, openldap-devel, zlib-devel
52BuildRequires: pkgconfig
53BuildRequires: krb5-devel
54BuildRequires: groff
55Requires(post,postun): /sbin/ldconfig, chkconfig
56
57%description
58The %{name} package contains the Cyrus implementation of SASL.
59SASL is the Simple Authentication and Security Layer, a method for
60adding authentication support to connection-based protocols.
61
62%package devel
63Requires: %{name} = %{version}-%{release}
64Group: Development/Libraries
65Summary: Files needed for developing applications with Cyrus SASL.
66
67%description devel
68The %{name}-devel package contains files needed for developing and
69compiling applications which use the Cyrus SASL library.
70
71%package gssapi
72Requires: %{name} = %{version}-%{release}
73Group: System Environment/Libraries
74Summary: GSSAPI support for Cyrus SASL.
75
76%description gssapi
77The %{name}-gssapi package contains the Cyrus SASL plugins which
78support GSSAPI authentication. GSSAPI is commonly used for Kerberos
79authentication.
80
81%package plain
82Requires: %{name} = %{version}-%{release}
83Group: System Environment/Libraries
84Summary: PLAIN and LOGIN support for Cyrus SASL.
85
86%description plain
87The %{name}-plain package contains the Cyrus SASL plugins which support
88PLAIN and LOGIN authentication schemes.
89
90%package md5
91Requires: %{name} = %{version}-%{release}
92Group: System Environment/Libraries
93Summary: CRAM-MD5 and DIGEST-MD5 support for Cyrus SASL.
94
95%description md5
96The %{name}-md5 package contains the Cyrus SASL plugins which support
97CRAM-MD5 and DIGEST-MD5 authentication schemes.
98
99%package ntlm
100Requires: %{name} = %{version}-%{release}
101Group: System Environment/Libraries
102Summary: NTLM support for Cyrus SASL.
103
104%description ntlm
105The %{name}-ntlm package contains the Cyrus SASL plugin which supports
106the NTLM authentication schemes.
107
108# This would more appropriately be named cyrus-sasl-auxprop-sql.
109%package sql
110#Requires: %{name}-lib = %{version}-%{release}
111Requires: %{name} = %{version}-%{release}
112Group: System Environment/Libraries
113Summary: SQL auxprop support for Cyrus SASL
114
115%description sql
116The %{name}-sql package contains the Cyrus SASL plugin which supports
117using a RDBMS for storing shared secrets.
118
119# This was *almost* named cyrus-sasl-auxprop-ldapdb, but that's a lot of typing.
120%package ldap
121#Requires: %{name}-lib = %{version}-%{release}
122Requires: %{name} = %{version}-%{release}
123Group: System Environment/Libraries
124Summary: LDAP auxprop support for Cyrus SASL
125
126%description ldap
127The %{name}-ldap package contains the Cyrus SASL plugin which supports using
128a directory server, accessed using LDAP, for storing shared secrets.
129
130
131## to build compat32 for x86_64 architecture support
132%package -n compat32-%{name}
133Summary: The Cyrus SASL library.
134Group: System Environment/Libraries
135
136%description -n compat32-%{name}
137The %{name} package contains the Cyrus implementation of SASL.
138SASL is the Simple Authentication and Security Layer, a method for
139adding authentication support to connection-based protocols.
140
141%package -n compat32-%{name}-devel
142Group: Development/Libraries
143Summary: Files needed for developing applications with Cyrus SASL.
144
145%description -n compat32-%{name}-devel
146The %{name}-devel package contains files needed for developing and
147compiling applications which use the Cyrus SASL library.
148
149%package -n compat32-%{name}-gssapi
150Group: System Environment/Libraries
151Summary: GSSAPI support for Cyrus SASL.
152
153%description -n compat32-%{name}-gssapi
154The %{name}-gssapi package contains the Cyrus SASL plugins which
155support GSSAPI authentication. GSSAPI is commonly used for Kerberos
156authentication.
157
158%package -n compat32-%{name}-plain
159Group: System Environment/Libraries
160Summary: PLAIN and LOGIN support for Cyrus SASL.
161
162%description -n compat32-%{name}-plain
163The %{name}-plain package contains the Cyrus SASL plugins which support
164PLAIN and LOGIN authentication schemes.
165
166%package -n compat32-%{name}-md5
167Group: System Environment/Libraries
168Summary: CRAM-MD5 and DIGEST-MD5 support for Cyrus SASL.
169
170%description -n compat32-%{name}-md5
171The %{name}-md5 package contains the Cyrus SASL plugins which support
172CRAM-MD5 and DIGEST-MD5 authentication schemes.
173
174%package -n compat32-%{name}-ntlm
175Group: System Environment/Libraries
176Summary: NTLM support for Cyrus SASL.
177
178%description -n compat32-%{name}-ntlm
179The %{name}-ntlm package contains the Cyrus SASL plugin which supports
180the NTLM authentication schemes.
181
182# %package -n compat32-%{name}-sql
183# Group: System Environment/Libraries
184# Summary: SQL auxprop support for Cyrus SASL
185
186# %description -n compat32-%{name}-sql
187# The %{name}-sql package contains the Cyrus SASL plugin which supports
188# using a RDBMS for storing shared secrets.
189
190%package -n compat32-%{name}-ldap
191Group: System Environment/Libraries
192Summary: LDAP auxprop support for Cyrus SASL
193
194%description -n compat32-%{name}-ldap
195The %{name}-ldap package contains the Cyrus SASL plugin which supports using
196a directory server, accessed using LDAP, for storing shared secrets.
197
198
199
200%prep
201%setup -q -c -a 2
202%if %{includev1}
203pushd cyrus-sasl-%{cs1_version}
204%patch0 -p1 -b .rpath
205%patch1 -p1 -b .autoconf25
206%patch2 -p1 -b .automake17
207%patch3 -p1 -b .automake18
208%patch4 -p1 -b .saslauthd2
209%patch5 -p1 -b .CVE-2009-0688
210libtoolize -f -c
211aclocal -I config -I cmulocal
212automake -a -c -f
213autoheader
214autoconf -f
215popd
216%endif
217
218pushd cyrus-sasl-%{version}
219chmod -x doc/*.html
220chmod -x include/*.h
221%patch10 -p1 -b .db_bundle
222%patch11 -p1 -b .no_rpath
223%patch15 -p1 -b .path
224%patch24 -p1 -b .sizes
225%patch25 -p1 -b .typo
226%patch26 -p2 -b .digest-commas
227%patch27 -p1 -b .automake-1.10
228%patch28 -p1 -b .keytab
229
230%patch100 -p1 -b .db48
231%patch101 -p1 -b .gcc44
232
233# FIXME - we remove these files directly so that we can avoid using the -f
234# flag, which has a nasty habit of overwriting files like COPYING.
235rm -f config/config.guess config/config.sub
236rm -f config/ltconfig config/ltmain.sh config/libtool.m4
237rm -fr autom4te.cache
238libtoolize -c
239aclocal -I config -I cmulocal
240automake -a -c
241autoheader
242autoconf
243
244pushd saslauthd
245rm -f config/config.guess config/config.sub
246rm -f config/ltconfig config/ltmain.sh config/libtool.m4
247rm -fr autom4te.cache
248libtoolize -c
249aclocal -I config -I ../cmulocal -I ../config
250automake -a -c
251autoheader
252autoconf
253popd
254
255%if %{includev1}
256# Sort of merge the docs.
257mkdir cyrus-sasl-%{version}/%{cs1_version}
258mkdir cyrus-sasl-%{version}/%{cs1_version}-devel
259cp %{name}-%{cs1_version}/{AUTHORS,COPYING,NEWS,README,doc/*.html} cyrus-sasl-%{version}/%{cs1_version}
260cp %{name}-%{cs1_version}/doc/*.txt cyrus-sasl-%{version}/%{cs1_version}-devel
261# Remove duplicate RFCs.
262pushd cyrus-sasl-%{version}/%{cs1_version}-devel
263for file in * ; do
264        if [ -f ../doc/${file} ] ; then
265                rm -f ${file}
266        fi
267done
268popd
269%endif
270
271%build
272%if %{includev1}
273pushd cyrus-sasl-%{cs1_version}
274%configure \
275        --enable-static --enable-staticdlopen --with-pic --enable-shared \
276        --with-plugindir=%{_plugindir} \
277        --disable-krb4 \
278        --with-rc4 \
279        --with-dblib=gdbm \
280        --enable-anon \
281        --enable-cram \
282        --enable-digest \
283        --enable-plain \
284        --enable-login
285make %{?_smp_mflags} sasldir=%{_plugindir}
286popd
287%endif
288
289pushd cyrus-sasl-%{version}
290CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
291
292# Find OpenSSL.
293LIBS="-lcrypt"; export LIBS
294if pkg-config openssl ; then
295        CPPFLAGS="`pkg-config --cflags-only-I openssl` $CPPFLAGS"; export CPPFLAGS
296        CFLAGS="`pkg-config --cflags openssl` $CFLAGS"; export CFLAGS
297        LDFLAGS="`pkg-config --libs-only-L openssl` $LDFLAGS"; export LDFLAGS
298fi
299
300# Find the SQL libraries used needed by the SQL auxprop plugin.
301mysql_config=mysql_config
302pg_config=pg_config
303SQL_CFLAGS=`${mysql_config} --cflags`" -I"`${pg_config} --includedir`
304SQL_LIBS=`${mysql_config} --libs`" -L"`${pg_config} --libdir`" -lpq"
305SQL_CFLAGS=`eval echo "$SQL_CFLAGS" | sed -e 's,-I%{_includedir}[^/],,g' -e 's,-I%{_includedir}$,,g' -e 's,[[:blank:]]+, ,g'`
306SQL_LIBS=`eval echo "$SQL_LIBS" | sed -e 's,-L%{_libdir}[^/],,g' -e 's,-L%{_libdir}$,,g' -e 's,[[:blank:]]+, ,g'`
307SQL_LDFLAGS=`eval echo "$SQL_LIBS" | sed -e 's,-[^L][^ ]*,,g'`
308echo $SQL_LDFLAGS
309SQL_LIBS=`eval echo "$SQL_LIBS" | sed -e 's,-[^l][^ ]*,,g'`
310echo $SQL_LIBS
311
312cleanup_flags() {
313        sed -r -e 's,-D_GNU_SOURCE(=[^[:blank:]]+)?,,g' \
314               -e 's,-D_FILE_OFFSET_BITS=[[:digit:]]+,,g' \
315               -e 's,-D_LARGEFILE_SOURCE(=[^[:blank:]]+)?,,g' \
316               -e 's,[[:blank:]]+, ,g'
317}
318CFLAGS=`echo $CFLAGS $SQL_CFLAGS | cleanup_flags`; export CFLAGS
319CPPFLAGS=`echo $CPPFLAGS $SQL_CFLAGS | cleanup_flags`; export CPPFLAGS
320LDFLAGS=`echo $LDFLAGS $SQL_LDFLAGS | cleanup_flags`; export LDFLAGS
321
322%configure \
323        --disable-static --enable-shared --disable-java \
324        --with-plugindir=%{_plugindir2}:%{_sysconfdir}/sasl2 \
325        --disable-krb4 \
326        --with-rc4 \
327        --with-dblib=berkeley \
328        --with-saslauthd=/var/run/saslauthd --without-pwcheck \
329        --with-ldap \
330        --with-devrandom=/dev/urandom \
331        --enable-anon \
332        --enable-cram \
333        --enable-digest \
334        --enable-ntlm \
335        --enable-plain \
336        --enable-login \
337        --disable-otp \
338        --enable-ldapdb \
339        --enable-sql --with-mysql=%{_prefix} --with-pgsql=%{_prefix} \
340        --without-sqlite \
341        "$@"
342        # --enable-auth-sasldb -- EXPERIMENTAL
343make %{?_smp_mflags} sasldir=%{_plugindir2}
344make %{?_smp_mflags} -C saslauthd testsaslauthd
345make -C sample
346popd
347
348%install
349test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
350%if %{includev1}
351pushd cyrus-sasl-%{cs1_version}
352%makeinstall sasldir=$RPM_BUILD_ROOT/%{_plugindir}
353install -m755 -d $RPM_BUILD_ROOT%{_bindir}
354libtool --mode=install \
355install -m755 sample/client $RPM_BUILD_ROOT%{_bindir}/sasl-sample-client
356libtool --mode=install \
357install -m755 sample/server $RPM_BUILD_ROOT%{_bindir}/sasl-sample-server
358popd
359%endif
360
361pushd cyrus-sasl-%{version}
362make install DESTDIR=$RPM_BUILD_ROOT sasldir=%{_plugindir2}
363make install DESTDIR=$RPM_BUILD_ROOT sasldir=%{_plugindir2} -C plugins
364
365install -m755 -d $RPM_BUILD_ROOT%{_bindir}
366./libtool --tag=CC --mode=install \
367install -m755 sample/client $RPM_BUILD_ROOT%{_bindir}/sasl2-sample-client
368./libtool --tag=CC --mode=install \
369install -m755 sample/server $RPM_BUILD_ROOT%{_bindir}/sasl2-sample-server
370./libtool --tag=CC --mode=install \
371install -m755 saslauthd/testsaslauthd $RPM_BUILD_ROOT%{_sbindir}/testsaslauthd
372./libtool --tag=CC --mode=install \
373install -m755 utils/dbconverter-2 $RPM_BUILD_ROOT%{_sbindir}/dbconverter-2
374
375# Install the saslauthd mdoc page in the expected location.  Sure, it's not
376# really a man page, but groff seems to be able to cope with it.
377install -m755 -d $RPM_BUILD_ROOT%{_mandir}/man8/
378install -m644 saslauthd/saslauthd.mdoc $RPM_BUILD_ROOT%{_mandir}/man8/saslauthd.8
379
380# Create the saslauthd listening directory.
381install -m755 -d $RPM_BUILD_ROOT/var/run/saslauthd
382
383# Install the init script for saslauthd and the init script's config file.
384install -m755 -d $RPM_BUILD_ROOT/etc/rc.d/init.d $RPM_BUILD_ROOT/etc/sysconfig
385install -m755 -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/saslauthd
386install -m644 -p %{SOURCE9} $RPM_BUILD_ROOT/etc/sysconfig/saslauthd
387popd
388
389# Install the config dirs if they're not already there.
390install -m755 -d $RPM_BUILD_ROOT/%{_sysconfdir}/sasl2
391install -m755 -d $RPM_BUILD_ROOT/%{_plugindir2}
392
393# Remove unpackaged files from the buildroot.
394rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/libotp.*
395rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.a
396rm -f $RPM_BUILD_ROOT%{_libdir}/sasl2/*.la
397rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
398rm -f $RPM_BUILD_ROOT%{_mandir}/cat8/saslauthd.8
399
400%clean
401test "$RPM_BUILD_ROOT" != "/" && rm -rf $RPM_BUILD_ROOT
402
403%post
404/sbin/ldconfig
405/sbin/chkconfig --add saslauthd
406
407%preun
408if [ $1 = 0 ] ; then
409        /sbin/chkconfig --del saslauthd
410fi
411
412%postun
413/sbin/ldconfig
414if [ $1 != 0 ] ; then
415        /sbin/service saslauthd condrestart 2>&1 > /dev/null
416fi
417
418%files
419%defattr(-,root,root)
420%if %{includev1}
421%doc %{name}-%{version}/%{cs1_version}
422%endif
423%doc %{name}-%{version}/{AUTHORS,COPYING,NEWS,README,doc/*.html}
424%doc $RPM_SOURCE_DIR/README.RPM
425%dir %{_sysconfdir}/sasl2
426%{_libdir}/libsasl*.so.*
427%if %{includev1}
428%dir %{_plugindir}/
429%endif
430%dir %{_plugindir2}/
431%if %{includev1}
432%{_plugindir}/*anonymous*.so*
433%{_plugindir}/*anonymous*.la
434%endif
435%{_plugindir2}/*anonymous*.so*
436%{_plugindir2}/*sasldb*.so*
437%{_mandir}/man8/*
438%{_sbindir}/dbconverter-2
439%if %{includev1}
440%{_sbindir}/saslpasswd
441%{_sbindir}/sasldblistusers
442%endif
443%{_sbindir}/saslpasswd2
444%{_sbindir}/sasldblistusers2
445%{_sbindir}/pluginviewer
446%{_sbindir}/saslauthd
447%{_sbindir}/testsaslauthd
448%config(noreplace) /etc/sysconfig/saslauthd
449%config /etc/rc.d/init.d/saslauthd
450/var/run/saslauthd
451
452%files gssapi
453%defattr(-,root,root)
454%{_plugindir2}/*gssapi*.so*
455
456%files plain
457%defattr(-,root,root)
458%if %{includev1}
459%{_plugindir}/*plain*.so*
460%{_plugindir}/*plain*.la
461%{_plugindir}/*login*.so*
462%{_plugindir}/*login*.la
463%endif
464%{_plugindir2}/*plain*.so*
465%{_plugindir2}/*login*.so*
466
467%files md5
468%defattr(-,root,root)
469%if %{includev1}
470%{_plugindir}/*crammd5*.so*
471%{_plugindir}/*crammd5*.la
472%{_plugindir}/*digestmd5*.so*
473%{_plugindir}/*digestmd5*.la
474%endif
475%{_plugindir2}/*crammd5*.so*
476%{_plugindir2}/*digestmd5*.so*
477
478%files ntlm
479%defattr(-,root,root)
480%{_plugindir2}/*ntlm*.so*
481
482%files sql
483%defattr(-,root,root)
484%{_plugindir2}/*sql*.so*
485
486%files ldap
487%defattr(-,root,root)
488%{_plugindir2}/*ldapdb*.so*
489
490%files devel
491%defattr(-,root,root)
492%if %{includev1}
493%doc %{name}-%{version}/%{cs1_version}-devel
494%endif
495%doc %{name}-%{version}/doc/*.txt
496%defattr(-,root,root)
497%if %{includev1}
498%{_bindir}/sasl-sample-client
499%{_bindir}/sasl-sample-server
500%endif
501%{_bindir}/sasl2-sample-client
502%{_bindir}/sasl2-sample-server
503%{_includedir}/*
504%{_libdir}/libsasl*.so
505%if %{includev1}
506%{_plugindir}/*anonymous*.a
507%{_plugindir}/*crammd5*.a
508%{_plugindir}/*digestmd5*.a
509%{_plugindir}/*login*.a
510%{_plugindir}/*plain*.a
511%endif
512%{_mandir}/man3/*
513
514## to build compat32 for x86_64 architecture support
515%if %{build_compat32}
516%files -n compat32-%{name}
517%defattr(-,root,root)
518%{_libdir}/libsasl*.so.*
519%dir %{_plugindir2}/
520%{_plugindir2}/*anonymous*.so*
521%{_plugindir2}/*sasldb*.so*
522
523%files -n compat32-%{name}-gssapi
524%defattr(-,root,root)
525%{_plugindir2}/*gssapi*.so*
526
527%files -n compat32-%{name}-plain
528%defattr(-,root,root)
529%{_plugindir2}/*plain*.so*
530%{_plugindir2}/*login*.so*
531
532%files -n compat32-%{name}-md5
533%defattr(-,root,root)
534%{_plugindir2}/*crammd5*.so*
535%{_plugindir2}/*digestmd5*.so*
536
537%files -n compat32-%{name}-ntlm
538%defattr(-,root,root)
539%{_plugindir2}/*ntlm*.so*
540
541# %files -n compat32-%{name}-sql
542# %defattr(-,root,root)
543# %{_plugindir2}/*sql*.so*
544
545%files -n compat32-%{name}-ldap
546%defattr(-,root,root)
547%{_plugindir2}/*ldapdb*.so*
548
549%files -n compat32-%{name}-devel
550%defattr(-,root,root)
551%{_libdir}/libsasl*.so
552%endif
553
554
555%changelog
556* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.1.23-6
557- rebuild with openssl-1.0.0c
558- add BuildRequires: groff
559
560* Thu Feb 11 2010 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.23-5
561- rebuilt with db4-4.8
562- updated Patch100: cyrus-sasl-2.1.22-db4.patch
563- added Patch101: cyrus-sasl-2.1.23-gcc44.patch
564
565* Sun Jul 05 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.1.23-4
566- dropped compat32-%%{name}-sql
567
568* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.1.23-3
569- added compat32 subpackages
570
571* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.23-2
572- rebuilt with MySQL-5.1.34.
573
574* Mon May 18 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.1.23-1
575- new upstream release with security fix (CVE-2009-0688)
576- add patch5 to fix CVE-2009-0688 issue in 1.5.28 side
577  (No effect in Current VineSeed package)
578
579* Sun Jan 04 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.22-5
580- rebuilt with openldap-2.4.11
581
582* Sun Oct 12 2008 Shu KONNO <owa@bg.wakwak.com> 2.1.22-4
583- s/%%{name}-lib/%%{name}/ at requires of sql, ldap sub-packages
584
585* Sun Oct  5 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.1.22-3
586- added gssapi subpackage
587
588* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.1.22-2
589- rebuilt against db-4.6.21 with Patch100
590- import Patch27 from Fedora
591
592* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.22-1vl5
593- updated to 2.1.22
594- added Patches from Fedora
595  * Tue Jun 20 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.22-2
596  - fix a typo in sasl_client_start(3) (#196066)
597  * Thu Apr 27 2006 Nalin Dahyabhai <nalin@redhat.com> 2.1.21-11
598  - add unapplied patch which makes the DIGEST-MD5 plugin omit the realm
599    argument when the environment has $CYRUS_SASL_DIGEST_MD5_OMIT_REALM set
600    to a non-zero value, for testing purposes
601- added subpackages for the ldapdb auxprop support
602- added --disable-static option to %%configure
603
604* Tue May 22 2007 NAKAMURA Kenta <kenta@vinelinux.org> 2.1.18-0vl8
605- added Patch17: cyrus-sasl-2.1.18-openssl-098.patch
606- rebuilt with openssl-0.9.8
607
608* Thu May 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.18-0vl7
609- disable version 1 now (no VineSeed package require version 1)
610- enable ntlm subpackage now
611- rebuilt with new toolchain and db4-4.3.x
612
613* Sat Jul  1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.1.18-0vl6
614- rebuilt for VineSeed
615
616* Fri Apr 28 2006 IWAI, Masaharu <iwai@alib.jp> 2.1.18-0vl5
617- SECURITY FIX for Vine 3.2: CVE-2006-1721
618   - add 23_CVE-2006-1721.diff ( Patch16 )
619       from Debian Sarge cyrus-sasl2_2.1.19-1.5sarge1.diff.gz
620
621* Mon Dec 26 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.1.18-0vl4
622- rebuild for VineSeed
623
624* Sat Nov 27 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 2.1.18-0vl3
625- added security patch cyrus-sasl-CAN-2004-0884.patch for CAN-2004-0884
626  from Mandrakelinux.
627
628* Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.1.18-0vl2
629- rebuilt with db4-4.2.52
630
631* Thu Aug 19 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.18-0vl1
632- new upstream release
633- rebuild with openssl-0.9.7d
634- import some patch from fedora package
635
636* Sun Nov 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.15-6vl1
637- new upstream release
638- remove prereq initscripts
639- merged with fedora package
640  * Thu Oct 23 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-6
641  - use /dev/urandom instead of /dev/random for SASL2 (docs indicate that this is
642  safe if you aren't using OTP or SRP, and we build neither); SASL1 appears to
643  use it to seed the libc RNG only (#103378)
644  * Mon Oct 20 2003 Nalin Dahyabhai <nalin@redhat.com>
645  - obey RPM_OPT_FLAGS again when krb5_prefix != %%{_prefix}
646  * Fri Oct 17 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-5
647  - install saslauthd's mdoc page instead of the pre-formatted man page, which
648    would get formatted again
649  * Mon Sep 15 2003 Nalin Dahyabhai <nalin@redhat.com>
650  - include testsaslauthd
651  - note in the README that the saslauthd protocol is different for v1 and v2,
652    so v1's clients can't talk to the v2 server
653  * Thu Aug 21 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-3
654  - add logic to build with gssapi libs in either /usr or /usr/kerberos
655  * Tue Jul 15 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.15-1
656  - update to 2.1.15
657  * Mon Jul 14 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.14-1
658  - update to 2.1.14
659
660* Wed May 14 2003 Satoshi MACHINO <machino@vinelinux.org> 2.1.13-3vl1
661- new upstream version
662- merged with rawhide version
663        -- * Fri May  9 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-3
664        -- - change -m argument to saslauthd to be a directory instead of a path
665        -- * Thu May  8 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-2
666        -- - link libsasl2 with -lpthread to ensure that the sasldb plug-in
667             can always be loaded
668        -- * Tue Apr 29 2003 Nalin Dahyabhai <nalin@redhat.com> 2.1.13-1
669        -- - update to 2.1.13
670- disable gssapi because Vine Linux don't support Kerberos
671
672* Sun Dec  9 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.5.27-17vl1
673- upstream release
674- obsoleted cyrus-sasl-1.5.21-des.patch ( upstream merged )
675- obsoleted cyrus-sasl-1.5.24-external.patch ( upstream merged )
676- added BuildPrereq: gdbm-devel, pam-devel
677
678* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
679- 1.5.24-17vl2
680- rebuilt with openssl-0.9.6b
681
682* Wed Apr 11 2001 Satoshi MACHINO <machino@vinelinux.org> 1.5.24-17vl1
683- merged Rawhide Package
684
685* Sat Nov 18 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.5.24-14vl1
686- build for Vine Linux
687- build with gcc-2.95.3
688- removed kerberos and gssapi
689
690* Fri Oct 27 2000 Nalin Dahyabhai <nalin@redhat.com>
691- enable static libraries, but always build with -fPIC
692
693* Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
694- make sure the version of 1.5.24 in the package matches the masters (#18968)
695
696* Mon Oct  9 2000 Nalin Dahyabhai <nalin@redhat.com>
697- re-add the libsasl.so symlink to the -devel package (oops)
698
699* Fri Oct  6 2000 Nalin Dahyabhai <nalin@redhat.com>
700- move .so files for modules to their respective packages -- they're not -devel
701  links meant for use by ld anyway
702
703* Thu Oct  5 2000 Nalin Dahyabhai <nalin@redhat.com>
704- split off -devel subpackage
705- add a -gssapi subpackage for the gssapi plugins
706
707* Wed Aug 16 2000 Nalin Dahyabhai <nalin@redhat.com>
708- fix the summary text
709
710* Sun Aug 13 2000 Nalin Dahyabhai <nalin@redhat.com>
711- re-enable arcfour and CRAM
712
713* Fri Aug  4 2000 Nalin Dahyabhai <nalin@redhat.com>
714- force use of gdbm for database files to avoid DB migration weirdness
715- enable login mechanism
716- disable gssapi until it can coexist peacefully with non-gssapi setups
717- actually do a make in the build section (#15410)
718
719* Fri Jul 21 2000 Nalin Dahyabhai <nalin@redhat.com>
720- update to 1.5.24
721
722* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
723- automatic rebuild
724
725* Tue Jun 27 2000 Nalin Dahyabhai <nalin@redhat.com>
726- rebuild in new environment (release 3)
727
728* Mon Jun 19 2000 Nalin Dahyabhai <nalin@redhat.com>
729- don't muck with syslogd in post
730- remove patch for db-3.0 wackiness, no longer needed
731
732* Thu Jun  8 2000 Nalin Dahyabhai <nalin@redhat.com>
733- FHS cleanup
734- don't strip anything by default
735
736* Fri Feb 11 2000 Tim Powers <timp@redhat.com>
737- fixed man pages not being gzipped
738
739* Tue Nov 16 1999 Tim Powers <timp@redhat.com>
740- incorporated changes from Mads Kiilerich
741- release number is 1, not mk1
742
743* Tue Nov 10 1999 Mads Kiilerich <mads@kiilerich.com>
744- updated to sasl 1.5.11
745- configure --disable-krb4 --without-rc4 --disable-cram
746  because of missing libraries and pine having cram as default...
747- handle changing libsasl.so versions
748
749* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
750- changed group
751
752* Fri Aug 13 1999 Tim Powers <timp@redhat.com>
753- first build for Powertools
Note: See TracBrowser for help on using the repository browser.