source: projects/specs/trunk/c/cvs/cvs-vl.spec @ 3276

Revision 3276, 10.4 KB checked in by iwaim, 13 years ago (diff)

cvs-1.12.13-4vl6

Line 
1%define version 1.12.13
2
3Summary: A version control system.
4Summary(ja): バージョン管理システム
5Name: cvs
6Version: %{version}
7Release: 4%{?_dist_release}
8License: GPL
9Group: Development/Tools
10URL: http://www.cvshome.org/
11Source0: http://ftp.cvshome.org/release/feature/cvs-%{version}/cvs-%{version}.tar.bz2
12Source100: filter-requires-getopts-pl.sh
13Patch2: cvs-1.12.13-authserver.patch
14Patch3: cvs-1.11.2-cvspass.patch
15Patch5: cvs-1.11.2-install.patch
16Patch101: can-2005-2693.patch
17Requires(pre): install-info
18Prefix: %{_prefix}
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20Requires: perl, zlib
21BuildRequires: zlib-devel
22BuildRequires: openssl-devel
23BuildRequires: vim
24
25# for perl
26%define __find_requires %{SOURCE100}
27
28%description
29CVS (Concurrent Version System) is a version control system which can
30record the history of your files (usually, but not always, source
31code). CVS only stores the differences between versions, instead of
32every version of every file you've ever created. CVS also keeps a log
33of who, when and why changes occurred.
34
35CVS is very helpful for managing releases and controlling the
36concurrent editing of source files among multiple authors. Instead of
37providing version control for a collection of files in a single
38directory, CVS provides version control for a hierarchical collection
39of directories consisting of revision controlled files. These
40directories and files can then be combined together to form a software
41release.
42
43Install the cvs package if you need to use a version control system.
44#'
45
46%description -l ja
47CVS (Concurrent Version System) はバージョン管理システムで,
48ファイル (必ずしもそうとは限りませんが多くの場合ソースコード) の
49変更履歴を記録することが出来ます.CVS はファイルの全バージョンを
50保存しておくのではなく,バージョン間の変更差分だけを保存します.
51CVS はまた誰が何故変更を行ったのかのログも記録します.
52
53CVS は,ソースファイルを複数の開発者が同時に編集する際のリリース管理に
54非常に役立ちます.
55
56バージョン管理システムが必要なら cvs パッケージをインストールして下さい.
57
58
59%prep
60%setup -q
61%patch2 -p1 -b .authserver
62%patch3 -p1 -b .cvspass
63%patch5 -p1 -b .install
64%patch101 -p1 -b .can-2005-2693
65
66%build
67%configure --with-external-zlib
68
69make %{?_smp_mflags}
70make -C doc info
71
72
73%install
74[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
75
76%{makeinstall}
77gzip %{buildroot}%{_infodir}/cvs* || true
78
79
80%clean
81[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
82
83
84%post
85/sbin/install-info /%{_infodir}/cvs.info.gz /%{_infodir}/dir
86/sbin/install-info /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
87
88
89%preun
90if [ $1 = 0 ]; then
91    /sbin/install-info --delete /%{_infodir}/cvs.info.gz /%{_infodir}/dir
92    /sbin/install-info --delete /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
93fi
94
95
96%files
97%defattr(-,root,root)
98%doc AUTHORS BUGS COPYING COPYING.LIB ChangeLog ChangeLog.zoo DEVEL-CVS HACKING FAQ INSTALL MINOR-BUGS NEWS PROJECTS TODO README README.VMS
99%doc doc/*.pdf
100%{_bindir}/cvs
101%{_bindir}/cvsbug
102%{_bindir}/rcs2log
103%{_mandir}/man1/cvs.1*
104%{_mandir}/man5/cvs.5*
105%{_mandir}/man8/cvsbug.8*
106%{_infodir}/cvs*
107%{_datadir}/cvs
108
109%changelog
110* Sat Apr  2 2011 IWAI, Masaharu <iwai@alib.jp> 1.12.13-4vl6
111- build with krb5-libs 1.8.2
112- add doc/*.pdf in %%doc
113
114* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.13-3
115- rebuild with openssl-1.0.0c
116- add BuildRequires: openssl-devel, vim
117
118* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.13-2
119- spec in utf-8
120
121* Sat Apr 26 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.12.13-1
122- rebuild with perl-5.10.0-1vl5
123- add filter-requires-getopts-pl.sh (Source100)
124
125* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.13-0vl1
126- new upstream release
127- drop Patch100 which are merged in upstream.
128
129* Mon Jan 30 2006 Shu KONNO <owa@bg.wakwak.com> 1.12.9-0vl4
130- rebuilt with VineSeed
131
132* Fri Aug 26 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.12.9-0vl3.1
133- added a security patch for CAN-2005-2693 (CVS temporary file issue).
134
135* Wed Apr 27 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.12.9-0vl3
136- added a security patch for can-2005-0753 (Buffer Overflow and DoS).
137
138* Thu Jun 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.9-0vl2
139- remove unneeded dependency
140- change Prereq: info to install-info
141- add %%{_smp_mflags} to make option
142
143* Thu Jun 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.9-0vl1
144- new upstream release
145- security update
146  This release fixes several serious security issues in the CVS server
147  executable. It also contains one minor bug fix and the cvs log' and cvs ls'
148  commands now output times in the client's local timezone.
149
150* Thu May 20 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.8-0vl1
151- new upstream release
152- security update
153  This release fixes a serious security issue in the CVS server executable.
154
155* Mon Apr 19 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.7-0vl2
156- fixed typo in description
157
158* Mon Apr 19 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.7-0vl1
159- new upstream release
160- security update
161  This release fixes serious security issues in both the client and
162  server executables. It also contains many bug fixes and support for
163  accessing CVS pservers via intervening HTTP proxies.
164- fixed broken description
165- changed Source0 URL
166
167* Sat Dec 20 2003 Satoshi MACHINO <machino@vinelinux.org> 1.12.5-0vl2
168- fixed typo in changelog
169
170* Fri Dec 19 2003 Satoshi MACHINO <machino@vinelinux.org> 1.12.5-0vl1
171- new upstream release
172- added "--with-external-zlib2" to configure option
173        -- dropped patch4
174
175* Fri Dec 19 2003 Satoshi MACHINO <machino@vinelinux.org> 1.11.11-0vl1
176- new upstream release
177- security update
178  pserver can no longer be configured to run as root via the
179  $CVSROOT/CVSROOT/passwd file, so if your passwd file is compromised, it no
180  longer leads directly to a root hack.  Attempts to root will also be logged
181  via the syslog.
182
183* Tue Dec 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.10-0vl1
184- new upstream release
185- security update
186  This release fixes a security issue with no known exploits that could cause
187  previous versions of CVS to attempt to create files and directories in the
188  filesystem root.
189
190* Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11.9-0vl1
191- new upstream release
192
193* Wed Jan 22 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.11.5-0vl1
194- updated to new upstream release (security update)
195
196* Mon Dec 30 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.4-0vl1
197- new upstream version
198        -- Some minor changes to allow the code to compile on Windows platforms.
199        -- NEWS: Add dummy entry for since 1.11.3.
200        -- configure.in: Update to dev version 1.11.3.
201        -- configure: Regenerated.
202
203* Sat Dec 28 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.3-0vl1
204- new upstream version
205        -- When waiting for another user's lock, the message timestamps are now
206        in UTC rather than the server's local time.
207        -- The options.h file is no longer used.  This fixes a bug that occurred        when 1.11.2 was compiled on Windows platforms.
208        -- standardized on Automake version 1.6.3 and Autoconf version 2.53.
209
210- dropped kbr4 patch
211
212* Thu May 09 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.2-0vl2
213- clean up patch files
214- added some documents files
215
216* Tue May 07 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.2-0vl1
217- updated cvs-1.11.2
218        -- updated cvs-1.11.2-mktemp.patch
219       
220* Tue Mar 12 2002 Toru Sagami <sagami@vinelinux.org> 1.11.1p1-7vl1
221- paches are taken from RHSA-2002:026-35 1.11.1p1-7 with its fixes.
222  The most notable feature is: build with an external zlib
223
224* Mon May 21 2001 Satoshi MACHINO <machino@vinelinux.org> 1.11.1p1-0vl1
225- updated cvs-1.11.1p1
226- removed some patches
227- changed contrib dir to /usr/share from /usr/lib
228
229* Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
230- 1.11-0vl2
231- rebuilt with new %%{_mandir} definition
232- added Japanese summary and description
233
234* Tue Nov 21 2000 Satoshi MACHINO <machino@vinelinux.org> 1.11-0vl1
235- updated 1.11
236- removed auth.patch
237- added errno.patch from rawhide's cvs-1.11-1
238- partially used rpmmacros
239
240* Fri Sep 08 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
241- 1.10.8-0vl3
242- fixed %post and %preun section
243
244- 1.10.8-0vl2
245- removed gzip and strip in %install
246
247* Tue Jul 04 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
248- updated 1.10.8
249- switch to using the system's zlib instead of built-in
250- removed kerberos
251
252* Wed Mar  1 2000 Nalin Dahyabhai <nalin@redhat.com>
253- make kerberos support conditional at build-time
254
255* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
256- integrate kerberos support into main tree
257
258* Mon Feb 14 2000 Nalin Dahyabhai <nalin@redhat.com>
259- build with gssapi auth (--with-gssapi, --with-encryption)
260- apply patch to update libs to krb5 1.1.1
261
262* Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
263- fix the damn info pages too while we're at it.
264- fix description
265- man pages are compressed
266- make sure %post and %preun work okay
267
268* Sun Jan 9 2000  Jim Kingdon <http://bugzilla.redhat.com/bugzilla>
269- update to 1.10.7.
270
271* Wed Jul 14 1999 Jim Kingdon <http://developer.redhat.com>
272- add the patch to make 1.10.6 usable
273  (http://www.cyclic.com/cvs/dev-known.html).
274
275* Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
276- update to 1.10.6.
277
278* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
279- auto rebuild in the new build environment (release 2)
280
281* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
282- updated text in spec file.
283
284* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
285- update to 1.10.5.
286
287* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
288- update to 1.10.4.
289
290* Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
291- update to 1.10.3.
292
293* Mon Sep 28 1998 Jeff Johnson <jbj@redhat.com>
294- update to 1.10.2.
295
296* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
297- remove trailing characters from rcs2log mktemp args
298
299* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
300- update to 1.10.1
301
302* Mon Aug 31 1998 Jeff Johnson <jbj@redhat.com>
303- fix race conditions in cvsbug/rcs2log
304
305* Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
306- update to 1.10.
307
308* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
309- update to 1.9.30.
310
311* Mon Jun 08 1998 Prospector System <bugs@redhat.com>
312- translations modified for de, fr
313
314* Mon Jun  8 1998 Jeff Johnson <jbj@redhat.com>
315- build root
316- update to 1.9.28
317
318* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
319- translations modified for de, fr, tr
320
321* Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
322- added install-info stuff
323- added changelog section
324
Note: See TracBrowser for help on using the repository browser.