source: projects/specs/trunk/c/cvs/cvs-vl.spec @ 11847

Revision 11847, 11.0 KB checked in by ara_t, 5 years ago (diff)

cvs: rebuild with openssl-1.1.1

Line 
1%define version 1.12.13
2
3Summary: A version control system.
4Summary(ja): バージョン管理システム
5Name: cvs
6Version: %{version}
7Release: 8%{?_dist_release}
8License: GPL
9Group: Development/Tools
10URL: http://www.cvshome.org/
11Source0: http://ftp.cvshome.org/release/feature/cvs-%{version}/cvs-%{version}.tar.bz2
12Source100: filter-requires-getopts-pl.sh
13Patch2: cvs-1.12.13-authserver.patch
14Patch3: cvs-1.11.2-cvspass.patch
15Patch5: cvs-1.11.2-install.patch
16Patch101: can-2005-2693.patch
17Patch102: cvs-1.12.13_CVE-2012-0804.patch
18
19Requires(pre): install-info
20Prefix: %{_prefix}
21Buildroot: %{_tmppath}/%{name}-%{version}-root
22Requires: perl, zlib
23BuildRequires: zlib-devel
24BuildRequires: openssl-devel
25BuildRequires: vim
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30# for perl
31%define __find_requires %{SOURCE100}
32
33%description
34CVS (Concurrent Version System) is a version control system which can
35record the history of your files (usually, but not always, source
36code). CVS only stores the differences between versions, instead of
37every version of every file you've ever created. CVS also keeps a log
38of who, when and why changes occurred.
39
40CVS is very helpful for managing releases and controlling the
41concurrent editing of source files among multiple authors. Instead of
42providing version control for a collection of files in a single
43directory, CVS provides version control for a hierarchical collection
44of directories consisting of revision controlled files. These
45directories and files can then be combined together to form a software
46release.
47
48Install the cvs package if you need to use a version control system.
49#'
50
51%description -l ja
52CVS (Concurrent Version System) はバージョン管理システムで,
53ファイル (必ずしもそうとは限りませんが多くの場合ソースコード) の
54変更履歴を記録することが出来ます.CVS はファイルの全バージョンを
55保存しておくのではなく,バージョン間の変更差分だけを保存します.
56CVS はまた誰が何故変更を行ったのかのログも記録します.
57
58CVS は,ソースファイルを複数の開発者が同時に編集する際のリリース管理に
59非常に役立ちます.
60
61バージョン管理システムが必要なら cvs パッケージをインストールして下さい.
62
63
64%prep
65%setup -q
66%patch2 -p1 -b .authserver
67%patch3 -p1 -b .cvspass
68%patch5 -p1 -b .install
69%patch101 -p1 -b .can-2005-2693
70%patch102 -p1 -b .CVE-2012-0804
71
72%build
73%configure --with-external-zlib
74
75make %{?_smp_mflags}
76make -C doc info
77
78
79%install
80[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
81
82%{makeinstall}
83gzip %{buildroot}%{_infodir}/cvs* || true
84rm -f %{buildroot}%{_infodir}/dir
85
86%clean
87[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
88
89
90%post
91/sbin/install-info /%{_infodir}/cvs.info.gz /%{_infodir}/dir
92/sbin/install-info /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
93
94
95%preun
96if [ $1 = 0 ]; then
97    /sbin/install-info --delete /%{_infodir}/cvs.info.gz /%{_infodir}/dir
98    /sbin/install-info --delete /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
99fi
100
101
102%files
103%defattr(-,root,root)
104%doc AUTHORS BUGS COPYING COPYING.LIB ChangeLog ChangeLog.zoo DEVEL-CVS HACKING FAQ INSTALL MINOR-BUGS NEWS PROJECTS TODO README README.VMS
105%doc doc/*.pdf
106%{_bindir}/cvs
107%{_bindir}/cvsbug
108%{_bindir}/rcs2log
109%{_mandir}/man1/cvs.1*
110%{_mandir}/man5/cvs.5*
111%{_mandir}/man8/cvsbug.8*
112%{_infodir}/cvs*
113%{_datadir}/cvs
114
115%changelog
116* Mon Nov 05 2018 Toshiaki Ara <ara_t@384.jp> 1.12.13-8
117- rebuild with openssl-1.1.1
118
119* Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.13-7
120- rebuild with openssl-1.0.2
121
122* Fri Jan  3 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.12.13-6
123- build with current VineSeed
124
125* Fri Feb 10 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>1.12.13-5vl6
126- add patch102 for fix CVE-2012-0804 (heap overflow in the CVS client)
127- add Vendor / Distri Tags
128
129* Sat Apr  2 2011 IWAI, Masaharu <iwai@alib.jp> 1.12.13-4vl6
130- build with krb5-libs 1.8.2
131- add doc/*.pdf in %%doc
132
133* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.13-3
134- rebuild with openssl-1.0.0c
135- add BuildRequires: openssl-devel, vim
136
137* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.13-2
138- spec in utf-8
139
140* Sat Apr 26 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.12.13-1
141- rebuild with perl-5.10.0-1vl5
142- add filter-requires-getopts-pl.sh (Source100)
143
144* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.13-0vl1
145- new upstream release
146- drop Patch100 which are merged in upstream.
147
148* Mon Jan 30 2006 Shu KONNO <owa@bg.wakwak.com> 1.12.9-0vl4
149- rebuilt with VineSeed
150
151* Fri Aug 26 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.12.9-0vl3.1
152- added a security patch for CAN-2005-2693 (CVS temporary file issue).
153
154* Wed Apr 27 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.12.9-0vl3
155- added a security patch for can-2005-0753 (Buffer Overflow and DoS).
156
157* Thu Jun 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.9-0vl2
158- remove unneeded dependency
159- change Prereq: info to install-info
160- add %%{_smp_mflags} to make option
161
162* Thu Jun 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.9-0vl1
163- new upstream release
164- security update
165  This release fixes several serious security issues in the CVS server
166  executable. It also contains one minor bug fix and the cvs log' and cvs ls'
167  commands now output times in the client's local timezone.
168
169* Thu May 20 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.8-0vl1
170- new upstream release
171- security update
172  This release fixes a serious security issue in the CVS server executable.
173
174* Mon Apr 19 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.7-0vl2
175- fixed typo in description
176
177* Mon Apr 19 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.7-0vl1
178- new upstream release
179- security update
180  This release fixes serious security issues in both the client and
181  server executables. It also contains many bug fixes and support for
182  accessing CVS pservers via intervening HTTP proxies.
183- fixed broken description
184- changed Source0 URL
185
186* Sat Dec 20 2003 Satoshi MACHINO <machino@vinelinux.org> 1.12.5-0vl2
187- fixed typo in changelog
188
189* Fri Dec 19 2003 Satoshi MACHINO <machino@vinelinux.org> 1.12.5-0vl1
190- new upstream release
191- added "--with-external-zlib2" to configure option
192        -- dropped patch4
193
194* Fri Dec 19 2003 Satoshi MACHINO <machino@vinelinux.org> 1.11.11-0vl1
195- new upstream release
196- security update
197  pserver can no longer be configured to run as root via the
198  $CVSROOT/CVSROOT/passwd file, so if your passwd file is compromised, it no
199  longer leads directly to a root hack.  Attempts to root will also be logged
200  via the syslog.
201
202* Tue Dec 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.10-0vl1
203- new upstream release
204- security update
205  This release fixes a security issue with no known exploits that could cause
206  previous versions of CVS to attempt to create files and directories in the
207  filesystem root.
208
209* Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11.9-0vl1
210- new upstream release
211
212* Wed Jan 22 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.11.5-0vl1
213- updated to new upstream release (security update)
214
215* Mon Dec 30 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.4-0vl1
216- new upstream version
217        -- Some minor changes to allow the code to compile on Windows platforms.
218        -- NEWS: Add dummy entry for since 1.11.3.
219        -- configure.in: Update to dev version 1.11.3.
220        -- configure: Regenerated.
221
222* Sat Dec 28 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.3-0vl1
223- new upstream version
224        -- When waiting for another user's lock, the message timestamps are now
225        in UTC rather than the server's local time.
226        -- The options.h file is no longer used.  This fixes a bug that occurred        when 1.11.2 was compiled on Windows platforms.
227        -- standardized on Automake version 1.6.3 and Autoconf version 2.53.
228
229- dropped kbr4 patch
230
231* Thu May 09 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.2-0vl2
232- clean up patch files
233- added some documents files
234
235* Tue May 07 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.2-0vl1
236- updated cvs-1.11.2
237        -- updated cvs-1.11.2-mktemp.patch
238       
239* Tue Mar 12 2002 Toru Sagami <sagami@vinelinux.org> 1.11.1p1-7vl1
240- paches are taken from RHSA-2002:026-35 1.11.1p1-7 with its fixes.
241  The most notable feature is: build with an external zlib
242
243* Mon May 21 2001 Satoshi MACHINO <machino@vinelinux.org> 1.11.1p1-0vl1
244- updated cvs-1.11.1p1
245- removed some patches
246- changed contrib dir to /usr/share from /usr/lib
247
248* Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
249- 1.11-0vl2
250- rebuilt with new %%{_mandir} definition
251- added Japanese summary and description
252
253* Tue Nov 21 2000 Satoshi MACHINO <machino@vinelinux.org> 1.11-0vl1
254- updated 1.11
255- removed auth.patch
256- added errno.patch from rawhide's cvs-1.11-1
257- partially used rpmmacros
258
259* Fri Sep 08 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
260- 1.10.8-0vl3
261- fixed %post and %preun section
262
263- 1.10.8-0vl2
264- removed gzip and strip in %install
265
266* Tue Jul 04 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
267- updated 1.10.8
268- switch to using the system's zlib instead of built-in
269- removed kerberos
270
271* Wed Mar  1 2000 Nalin Dahyabhai <nalin@redhat.com>
272- make kerberos support conditional at build-time
273
274* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
275- integrate kerberos support into main tree
276
277* Mon Feb 14 2000 Nalin Dahyabhai <nalin@redhat.com>
278- build with gssapi auth (--with-gssapi, --with-encryption)
279- apply patch to update libs to krb5 1.1.1
280
281* Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
282- fix the damn info pages too while we're at it.
283- fix description
284- man pages are compressed
285- make sure %post and %preun work okay
286
287* Sun Jan 9 2000  Jim Kingdon <http://bugzilla.redhat.com/bugzilla>
288- update to 1.10.7.
289
290* Wed Jul 14 1999 Jim Kingdon <http://developer.redhat.com>
291- add the patch to make 1.10.6 usable
292  (http://www.cyclic.com/cvs/dev-known.html).
293
294* Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
295- update to 1.10.6.
296
297* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
298- auto rebuild in the new build environment (release 2)
299
300* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
301- updated text in spec file.
302
303* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
304- update to 1.10.5.
305
306* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
307- update to 1.10.4.
308
309* Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
310- update to 1.10.3.
311
312* Mon Sep 28 1998 Jeff Johnson <jbj@redhat.com>
313- update to 1.10.2.
314
315* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
316- remove trailing characters from rcs2log mktemp args
317
318* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
319- update to 1.10.1
320
321* Mon Aug 31 1998 Jeff Johnson <jbj@redhat.com>
322- fix race conditions in cvsbug/rcs2log
323
324* Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
325- update to 1.10.
326
327* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
328- update to 1.9.30.
329
330* Mon Jun 08 1998 Prospector System <bugs@redhat.com>
331- translations modified for de, fr
332
333* Mon Jun  8 1998 Jeff Johnson <jbj@redhat.com>
334- build root
335- update to 1.9.28
336
337* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
338- translations modified for de, fr, tr
339
340* Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
341- added install-info stuff
342- added changelog section
343
Note: See TracBrowser for help on using the repository browser.