source: projects/specs/trunk/c/cvs/cvs-vl.spec @ 521

Revision 521, 10.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define version 1.12.13
2
3Summary: A version control system.
4Summary(ja): バージョン管理システム
5Name: cvs
6Version: %{version}
7Release: 2%{?_dist_release}
8License: GPL
9Group: Development/Tools
10URL: http://www.cvshome.org/
11Source0: http://ftp.cvshome.org/release/feature/cvs-%{version}/cvs-%{version}.tar.bz2
12Source100: filter-requires-getopts-pl.sh
13Patch2: cvs-1.12.13-authserver.patch
14Patch3: cvs-1.11.2-cvspass.patch
15Patch5: cvs-1.11.2-install.patch
16Patch101: can-2005-2693.patch
17Prereq: install-info
18Prefix: %{_prefix}
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20Requires: perl, zlib
21BuildPreReq: zlib-devel
22
23# for perl
24%define __find_requires %{SOURCE100}
25
26%description
27CVS (Concurrent Version System) is a version control system which can
28record the history of your files (usually, but not always, source
29code). CVS only stores the differences between versions, instead of
30every version of every file you've ever created. CVS also keeps a log
31of who, when and why changes occurred.
32
33CVS is very helpful for managing releases and controlling the
34concurrent editing of source files among multiple authors. Instead of
35providing version control for a collection of files in a single
36directory, CVS provides version control for a hierarchical collection
37of directories consisting of revision controlled files. These
38directories and files can then be combined together to form a software
39release.
40
41Install the cvs package if you need to use a version control system.
42#'
43
44%description -l ja
45CVS (Concurrent Version System) はバージョン管理システムで,
46ファイル (必ずしもそうとは限りませんが多くの場合ソースコード) の
47変更履歴を記録することが出来ます.CVS はファイルの全バージョンを
48保存しておくのではなく,バージョン間の変更差分だけを保存します.
49CVS はまた誰が何故変更を行ったのかのログも記録します.
50
51CVS は,ソースファイルを複数の開発者が同時に編集する際のリリース管理に
52非常に役立ちます.
53
54バージョン管理システムが必要なら cvs パッケージをインストールして下さい.
55
56
57%prep
58%setup -q
59%patch2 -p1 -b .authserver
60%patch3 -p1 -b .cvspass
61%patch5 -p1 -b .install
62%patch101 -p1 -b .can-2005-2693
63
64%build
65%configure --with-external-zlib
66
67make %{?_smp_mflags}
68make -C doc info
69
70
71%install
72[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
73
74%{makeinstall}
75gzip %{buildroot}%{_infodir}/cvs* || true
76
77
78%clean
79[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
80
81
82%post
83/sbin/install-info /%{_infodir}/cvs.info.gz /%{_infodir}/dir
84/sbin/install-info /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
85
86
87%preun
88if [ $1 = 0 ]; then
89    /sbin/install-info --delete /%{_infodir}/cvs.info.gz /%{_infodir}/dir
90    /sbin/install-info --delete /%{_infodir}/cvsclient.info.gz /%{_infodir}/dir
91fi
92
93
94%files
95%defattr(-,root,root)
96%doc AUTHORS BUGS COPYING COPYING.LIB ChangeLog ChangeLog.zoo DEVEL-CVS HACKING FAQ INSTALL MINOR-BUGS NEWS PROJECTS TODO README README.VMS
97%doc doc/*.ps
98%{_bindir}/cvs
99%{_bindir}/cvsbug
100%{_bindir}/rcs2log
101%{_mandir}/man1/cvs.1*
102%{_mandir}/man5/cvs.5*
103%{_mandir}/man8/cvsbug.8*
104%{_infodir}/cvs*
105%{_datadir}/cvs
106
107%changelog
108* Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> %{version}-2
109- spec in utf-8
110
111* Sat Apr 26 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.12.13-1
112- rebuild with perl-5.10.0-1vl5
113- add filter-requires-getopts-pl.sh (Source100)
114
115* Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.13-0vl1
116- new upstream release
117- drop Patch100 which are merged in upstream.
118
119* Mon Jan 30 2006 Shu KONNO <owa@bg.wakwak.com> 1.12.9-0vl4
120- rebuilt with VineSeed
121
122* Fri Aug 26 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.12.9-0vl3.1
123- added a security patch for CAN-2005-2693 (CVS temporary file issue).
124
125* Wed Apr 27 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.12.9-0vl3
126- added a security patch for can-2005-0753 (Buffer Overflow and DoS).
127
128* Thu Jun 17 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.9-0vl2
129- remove unneeded dependency
130- change Prereq: info to install-info
131- add %%{_smp_mflags} to make option
132
133* Thu Jun 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.9-0vl1
134- new upstream release
135- security update
136  This release fixes several serious security issues in the CVS server
137  executable. It also contains one minor bug fix and the cvs log' and cvs ls'
138  commands now output times in the client's local timezone.
139
140* Thu May 20 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.8-0vl1
141- new upstream release
142- security update
143  This release fixes a serious security issue in the CVS server executable.
144
145* Mon Apr 19 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.7-0vl2
146- fixed typo in description
147
148* Mon Apr 19 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.12.7-0vl1
149- new upstream release
150- security update
151  This release fixes serious security issues in both the client and
152  server executables. It also contains many bug fixes and support for
153  accessing CVS pservers via intervening HTTP proxies.
154- fixed broken description
155- changed Source0 URL
156
157* Sat Dec 20 2003 Satoshi MACHINO <machino@vinelinux.org> 1.12.5-0vl2
158- fixed typo in changelog
159
160* Fri Dec 19 2003 Satoshi MACHINO <machino@vinelinux.org> 1.12.5-0vl1
161- new upstream release
162- added "--with-external-zlib2" to configure option
163        -- dropped patch4
164
165* Fri Dec 19 2003 Satoshi MACHINO <machino@vinelinux.org> 1.11.11-0vl1
166- new upstream release
167- security update
168  pserver can no longer be configured to run as root via the
169  $CVSROOT/CVSROOT/passwd file, so if your passwd file is compromised, it no
170  longer leads directly to a root hack.  Attempts to root will also be logged
171  via the syslog.
172
173* Tue Dec 09 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.11.10-0vl1
174- new upstream release
175- security update
176  This release fixes a security issue with no known exploits that could cause
177  previous versions of CVS to attempt to create files and directories in the
178  filesystem root.
179
180* Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.11.9-0vl1
181- new upstream release
182
183* Wed Jan 22 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.11.5-0vl1
184- updated to new upstream release (security update)
185
186* Mon Dec 30 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.4-0vl1
187- new upstream version
188        -- Some minor changes to allow the code to compile on Windows platforms.
189        -- NEWS: Add dummy entry for since 1.11.3.
190        -- configure.in: Update to dev version 1.11.3.
191        -- configure: Regenerated.
192
193* Sat Dec 28 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.3-0vl1
194- new upstream version
195        -- When waiting for another user's lock, the message timestamps are now
196        in UTC rather than the server's local time.
197        -- The options.h file is no longer used.  This fixes a bug that occurred        when 1.11.2 was compiled on Windows platforms.
198        -- standardized on Automake version 1.6.3 and Autoconf version 2.53.
199
200- dropped kbr4 patch
201
202* Thu May 09 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.2-0vl2
203- clean up patch files
204- added some documents files
205
206* Tue May 07 2002 Satoshi MACHINO <machino@vinelinux.org> 1.11.2-0vl1
207- updated cvs-1.11.2
208        -- updated cvs-1.11.2-mktemp.patch
209       
210* Tue Mar 12 2002 Toru Sagami <sagami@vinelinux.org> 1.11.1p1-7vl1
211- paches are taken from RHSA-2002:026-35 1.11.1p1-7 with its fixes.
212  The most notable feature is: build with an external zlib
213
214* Mon May 21 2001 Satoshi MACHINO <machino@vinelinux.org> 1.11.1p1-0vl1
215- updated cvs-1.11.1p1
216- removed some patches
217- changed contrib dir to /usr/share from /usr/lib
218
219* Thu Dec 28 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
220- 1.11-0vl2
221- rebuilt with new %%{_mandir} definition
222- added Japanese summary and description
223
224* Tue Nov 21 2000 Satoshi MACHINO <machino@vinelinux.org> 1.11-0vl1
225- updated 1.11
226- removed auth.patch
227- added errno.patch from rawhide's cvs-1.11-1
228- partially used rpmmacros
229
230* Fri Sep 08 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
231- 1.10.8-0vl3
232- fixed %post and %preun section
233
234- 1.10.8-0vl2
235- removed gzip and strip in %install
236
237* Tue Jul 04 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
238- updated 1.10.8
239- switch to using the system's zlib instead of built-in
240- removed kerberos
241
242* Wed Mar  1 2000 Nalin Dahyabhai <nalin@redhat.com>
243- make kerberos support conditional at build-time
244
245* Wed Mar  1 2000 Bill Nottingham <notting@redhat.com>
246- integrate kerberos support into main tree
247
248* Mon Feb 14 2000 Nalin Dahyabhai <nalin@redhat.com>
249- build with gssapi auth (--with-gssapi, --with-encryption)
250- apply patch to update libs to krb5 1.1.1
251
252* Fri Feb 04 2000 Cristian Gafton <gafton@redhat.com>
253- fix the damn info pages too while we're at it.
254- fix description
255- man pages are compressed
256- make sure %post and %preun work okay
257
258* Sun Jan 9 2000  Jim Kingdon <http://bugzilla.redhat.com/bugzilla>
259- update to 1.10.7.
260
261* Wed Jul 14 1999 Jim Kingdon <http://developer.redhat.com>
262- add the patch to make 1.10.6 usable
263  (http://www.cyclic.com/cvs/dev-known.html).
264
265* Tue Jun  1 1999 Jeff Johnson <jbj@redhat.com>
266- update to 1.10.6.
267
268* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
269- auto rebuild in the new build environment (release 2)
270
271* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
272- updated text in spec file.
273
274* Mon Feb 22 1999 Jeff Johnson <jbj@redhat.com>
275- update to 1.10.5.
276
277* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
278- update to 1.10.4.
279
280* Tue Oct 20 1998 Jeff Johnson <jbj@redhat.com>
281- update to 1.10.3.
282
283* Mon Sep 28 1998 Jeff Johnson <jbj@redhat.com>
284- update to 1.10.2.
285
286* Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
287- remove trailing characters from rcs2log mktemp args
288
289* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
290- update to 1.10.1
291
292* Mon Aug 31 1998 Jeff Johnson <jbj@redhat.com>
293- fix race conditions in cvsbug/rcs2log
294
295* Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
296- update to 1.10.
297
298* Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
299- update to 1.9.30.
300
301* Mon Jun 08 1998 Prospector System <bugs@redhat.com>
302- translations modified for de, fr
303
304* Mon Jun  8 1998 Jeff Johnson <jbj@redhat.com>
305- build root
306- update to 1.9.28
307
308* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
309- translations modified for de, fr, tr
310
311* Wed Oct 29 1997 Otto Hammersmith <otto@redhat.com>
312- added install-info stuff
313- added changelog section
314
Note: See TracBrowser for help on using the repository browser.