source: projects/specs/trunk/c/curl/curl-vl.spec @ 7033

Revision 7033, 9.7 KB checked in by daisuke, 12 years ago (diff)

curl:

  • update to 7.28.0
  • add configure options
    • --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  • add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.28.0
7Release: 1%{?_dist_release}
8License: MIT/X
9Group: Applications/Internet
10Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
11URL: http://curl.haxx.se/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: openssl-devel libidn-devel zlib-devel
15BuildRequires: openldap-devel gnutls-devel
16BuildRequires: libssh2-devel
17BuildRequires: openssh-clients
18BuildRequires: openssh-server
19BuildRequires: pkgconfig
20Requires: ca-certificates
21
22Vendor: Project Vine
23Distribution: Vine Linux
24Packager: daisuke
25
26%description
27cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
28Dict servers, using any of the supported protocols. cURL is designed
29to work without user interaction or any kind of interactivity. cURL
30offers many useful capabilities, like proxy support, user
31authentication, FTP upload, HTTP post, and file transfer resume.
32
33%package devel
34Summary: Files needed for building applications with libcurl.
35Group: Development/Libraries
36Requires: %{name} = %{version}-%{release}
37Requires: openssl-devel libidn-devel zlib-devel
38
39%description devel
40cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
41Dict servers, using any of the supported protocols. The curl-devel
42package includes files needed for developing applications which can
43use cURL's capabilities internally.
44#'
45
46
47## to build compat32 for x86_64 architecture support
48%package -n compat32-%{name}
49Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
50Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
51Group: System Environment/Libraries
52
53%description -n compat32-%{name}
54cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
55Dict servers, using any of the supported protocols. cURL is designed
56to work without user interaction or any kind of interactivity. cURL
57offers many useful capabilities, like proxy support, user
58authentication, FTP upload, HTTP post, and file transfer resume.
59
60%package -n compat32-%{name}-devel
61Summary: Files needed for building applications with libcurl.
62Group: Development/Libraries
63
64%description -n compat32-%{name}-devel
65cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
66Dict servers, using any of the supported protocols. The curl-devel
67package includes files needed for developing applications which can
68use cURL's capabilities internally.
69#'
70
71%prep
72%setup -q
73
74%build
75%configure \
76  --with-ssl=%{_prefix} \
77  --with-gnutls \
78  --with-libidn \
79  --enable-ipv6 \
80  --enable-threaded-resolver \
81  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
82  --with-libssh2 \
83  --enable-ldaps \
84  --disable-static
85
86make %{?_smp_mflags}
87
88%install
89rm -rf $RPM_BUILD_ROOT
90make DESTDIR=$RPM_BUILD_ROOT install
91
92rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
93
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%post -p /sbin/ldconfig
98
99%postun -p /sbin/ldconfig
100
101%files
102%defattr(-,root,root)
103%doc CHANGES COPYING README
104%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
105%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
106%doc docs/TheArtOfHttpScripting docs/TODO
107%{_bindir}/curl
108#{_datadir}/curl/*
109%{_libdir}/*.so.*
110%{_mandir}/man1/*.1*
111
112%files devel
113%defattr(-,root,root)
114%{_bindir}/curl-config
115%{_includedir}/curl
116%{_libdir}/*.so
117%{_libdir}/pkgconfig/*.pc
118%{_mandir}/man1/curl-config.1*
119%{_mandir}/man3/*
120
121
122## to build compat32 for x86_64 architecture support
123%if %{build_compat32}
124%files -n compat32-%{name}
125%defattr(-,root,root)
126%{_libdir}/*.so.*
127
128%files -n compat32-%{name}-devel
129%defattr(-,root,root)
130%{_libdir}/*.so
131%{_libdir}/pkgconfig/*.pc
132%endif
133
134%changelog
135* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
136- update to 7.28.0
137- add configure options
138  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
139- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
140 
141- use ca-certificates package
142  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
143  - R: ca-certificates
144
145* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
146- new upstream release
147
148* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
149- add patch100 for fix CVE-2011-2192 (gssapi)
150- add Vendor/Distri tags
151
152* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
153- rebuild with openssl-1.0.0c
154
155* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
156- rebuilt with rpm-4.8.1 for pkg-config
157
158* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
159- new upstream release
160
161* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
162- new upstream release with security fix
163
164* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
165- added compat32 subpackages
166
167* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
168- new upstream release
169- use "_smp_mflags" flag
170
171* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
172- rebuild with openldap-2.4.11
173- add BR: openldap-devel
174- remove static library
175
176* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
177- new upstream release with security fix (CVE-2009-0037)
178
179* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
180- new upstream release
181
182* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
183- new upstream release
184
185* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
186- new upstream release
187
188* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
189- new upstream release
190
191* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
192- new upstream release
193
194* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
195- rebuilt with openssl-0.9.8e
196
197* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
198- new upstream release
199
200* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
201- new upstream release
202
203* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
204- new upstream release
205- add pkgconfig file to devel package
206
207* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
208- new upstream release
209
210* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
211- new upstream release
212
213* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
214- new upstream release
215
216* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
217- added libidn, zlib in Requires
218- added libidn-devel, zlib-devel in BuildPrereq
219- added zlib-devel in curl-devel's Requires
220
221* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
222- added openssl-devel, libidn-devel in curl-devel's Requires
223
224* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
225- new upstream release
226
227* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
228- new upstream release
229- rebuild with openssl-0.9.7d
230
231* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
232- upstream release
233
234* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
235- add %%{_datadir}/curl/* to %%files section
236
237* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
238- source upgrade
239
240* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
241- source upgrade
242- add PreReq: ldconfig
243- add %%{_libdir}/*.la to %%files devel section
244
245* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
246- build for VineSeed
247- add Requires: openssl
248
249* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
250- automated rebuild
251
252* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
253- 7.9.2
254
255* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
256- include curl-config in curl-devel
257- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
258
259* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
260- added openssl-devel build req
261
262* Mon May 21 2001 Tim Powers <timp@redhat.com>
263- built for the distro
264
265* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
266- upgrade to curl-7.7.2.
267- enable IPv6.
268
269* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
270- rebuilt against openssl-0.9.6-1
271
272* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
273- fixed mising ldconfigs
274- updated to 7.5.2, bug fixes
275
276* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
277- updated to 7.5.1
278
279* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
280- update to 7.4.1 to fix bug #20337, problems with curl -c
281- not using patch anymore, it's included in the new source. Keeping
282  for reference
283
284* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
285- fix bogus req in -devel package
286
287* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
288- devel package needed defattr so that root owns the files
289
290* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
291- update to 7.3
292- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
293
294* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
295- enable SSL support
296- fix packager tag
297- move buildroot to %%{_tmppath}
298
299* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
300- fixed vendor tag for bug #15028
301
302* Mon Jul 24 2000 Prospector <prospector@redhat.com>
303- rebuilt
304
305* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
306- workaround alpha build problems with optimizations
307
308* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
309- rebuilt
310
311* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
312- put man pages in correct place
313- use %%makeinstall
314
315* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
316- updated to 6.5.2
317
318* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
319- updated sources to 6.2
320- gzip man page
321
322* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
323- changed group
324
325* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
326- changelog started
327- general cleanups, changed prefix to /usr, added manpage to files section
328- including in Powertools
Note: See TracBrowser for help on using the repository browser.