source: projects/specs/trunk/c/curl/curl-vl.spec @ 5734

Revision 5734, 9.2 KB checked in by kenta, 12 years ago (diff)

curl: new upstream release

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.24.0
7Release: 1%{?_dist_release}
8License: MIT/X
9Group: Applications/Internet
10Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
11URL: http://curl.haxx.se/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: openssl-devel libidn-devel zlib-devel
15BuildRequires: openldap-devel gnutls-devel
16Requires: openssl libidn zlib
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%description
22cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
23Dict servers, using any of the supported protocols. cURL is designed
24to work without user interaction or any kind of interactivity. cURL
25offers many useful capabilities, like proxy support, user
26authentication, FTP upload, HTTP post, and file transfer resume.
27
28%package devel
29Summary: Files needed for building applications with libcurl.
30Group: Development/Libraries
31Requires: %{name} = %{version}-%{release}
32Requires: openssl-devel libidn-devel zlib-devel
33
34%description devel
35cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
36Dict servers, using any of the supported protocols. The curl-devel
37package includes files needed for developing applications which can
38use cURL's capabilities internally.
39#'
40
41
42## to build compat32 for x86_64 architecture support
43%package -n compat32-%{name}
44Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
45Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
46Group: System Environment/Libraries
47
48%description -n compat32-%{name}
49cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
50Dict servers, using any of the supported protocols. cURL is designed
51to work without user interaction or any kind of interactivity. cURL
52offers many useful capabilities, like proxy support, user
53authentication, FTP upload, HTTP post, and file transfer resume.
54
55%package -n compat32-%{name}-devel
56Summary: Files needed for building applications with libcurl.
57Group: Development/Libraries
58
59%description -n compat32-%{name}-devel
60cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
61Dict servers, using any of the supported protocols. The curl-devel
62package includes files needed for developing applications which can
63use cURL's capabilities internally.
64#'
65
66%prep
67%setup -q
68
69%build
70%configure --with-ssl=%{_prefix} --with-gnutls --with-libidn --enable-ipv6 --disable-static
71%ifarch alpha
72make %{?_smp_mflags} CFLAGS=""
73%else
74make %{?_smp_mflags}
75%endif
76
77%install
78rm -rf $RPM_BUILD_ROOT
79make DESTDIR=$RPM_BUILD_ROOT install
80
81rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post -p /sbin/ldconfig
87
88%postun -p /sbin/ldconfig
89
90%files
91%defattr(-,root,root)
92%doc CHANGES COPYING README
93%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
94%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
95%doc docs/TheArtOfHttpScripting docs/TODO
96%{_bindir}/curl
97#{_datadir}/curl/*
98%{_libdir}/*.so.*
99%{_mandir}/man1/curl.1*
100
101%files devel
102%defattr(-,root,root)
103%{_bindir}/curl-config
104%{_includedir}/curl
105%{_libdir}/*.so
106%{_libdir}/pkgconfig/*.pc
107%{_mandir}/man1/curl-config.1*
108%{_mandir}/man3/*
109
110
111## to build compat32 for x86_64 architecture support
112%if %{build_compat32}
113%files -n compat32-%{name}
114%defattr(-,root,root)
115%{_libdir}/*.so.*
116
117%files -n compat32-%{name}-devel
118%defattr(-,root,root)
119%{_libdir}/*.so
120%{_libdir}/pkgconfig/*.pc
121%endif
122
123%changelog
124* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
125- new upstream release
126
127* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
128- add patch100 for fix CVE-2011-2192 (gssapi)
129- add Vendor/Distri tags
130
131* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
132- rebuild with openssl-1.0.0c
133
134* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
135- rebuilt with rpm-4.8.1 for pkg-config
136
137* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
138- new upstream release
139
140* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
141- new upstream release with security fix
142
143* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
144- added compat32 subpackages
145
146* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
147- new upstream release
148- use "_smp_mflags" flag
149
150* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
151- rebuild with openldap-2.4.11
152- add BR: openldap-devel
153- remove static library
154
155* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
156- new upstream release with security fix (CVE-2009-0037)
157
158* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
159- new upstream release
160
161* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
162- new upstream release
163
164* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
165- new upstream release
166
167* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
168- new upstream release
169
170* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
171- new upstream release
172
173* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
174- rebuilt with openssl-0.9.8e
175
176* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
177- new upstream release
178
179* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
180- new upstream release
181
182* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
183- new upstream release
184- add pkgconfig file to devel package
185
186* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
187- new upstream release
188
189* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
190- new upstream release
191
192* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
193- new upstream release
194
195* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
196- added libidn, zlib in Requires
197- added libidn-devel, zlib-devel in BuildPrereq
198- added zlib-devel in curl-devel's Requires
199
200* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
201- added openssl-devel, libidn-devel in curl-devel's Requires
202
203* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
204- new upstream release
205
206* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
207- new upstream release
208- rebuild with openssl-0.9.7d
209
210* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
211- upstream release
212
213* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
214- add %%{_datadir}/curl/* to %%files section
215
216* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
217- source upgrade
218
219* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
220- source upgrade
221- add PreReq: ldconfig
222- add %%{_libdir}/*.la to %%files devel section
223
224* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
225- build for VineSeed
226- add Requires: openssl
227
228* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
229- automated rebuild
230
231* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
232- 7.9.2
233
234* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
235- include curl-config in curl-devel
236- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
237
238* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
239- added openssl-devel build req
240
241* Mon May 21 2001 Tim Powers <timp@redhat.com>
242- built for the distro
243
244* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
245- upgrade to curl-7.7.2.
246- enable IPv6.
247
248* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
249- rebuilt against openssl-0.9.6-1
250
251* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
252- fixed mising ldconfigs
253- updated to 7.5.2, bug fixes
254
255* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
256- updated to 7.5.1
257
258* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
259- update to 7.4.1 to fix bug #20337, problems with curl -c
260- not using patch anymore, it's included in the new source. Keeping
261  for reference
262
263* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
264- fix bogus req in -devel package
265
266* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
267- devel package needed defattr so that root owns the files
268
269* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
270- update to 7.3
271- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
272
273* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
274- enable SSL support
275- fix packager tag
276- move buildroot to %%{_tmppath}
277
278* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
279- fixed vendor tag for bug #15028
280
281* Mon Jul 24 2000 Prospector <prospector@redhat.com>
282- rebuilt
283
284* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
285- workaround alpha build problems with optimizations
286
287* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
288- rebuilt
289
290* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
291- put man pages in correct place
292- use %%makeinstall
293
294* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
295- updated to 6.5.2
296
297* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
298- updated sources to 6.2
299- gzip man page
300
301* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
302- changed group
303
304* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
305- changelog started
306- general cleanups, changed prefix to /usr, added manpage to files section
307- including in Powertools
Note: See TracBrowser for help on using the repository browser.