source: projects/specs/trunk/c/curl/curl-vl.spec @ 4261

Revision 4261, 9.2 KB checked in by iwamoto, 13 years ago (diff)

curl: add patch100 for fix CVE-2011-2192 (gssapi)

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.20.1
7Release: 4%{?_dist_release}
8License: MIT/X
9Group: Applications/Internet
10Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
11URL: http://curl.haxx.se/
12# Security
13Patch100: curl-7.19.6_CVE-2011-2192.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: openssl-devel libidn-devel zlib-devel
17BuildRequires: openldap-devel gnutls-devel
18Requires: openssl libidn zlib
19
20Vendor: Project Vine
21Distribution: Vine Linux
22
23%description
24cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
25Dict servers, using any of the supported protocols. cURL is designed
26to work without user interaction or any kind of interactivity. cURL
27offers many useful capabilities, like proxy support, user
28authentication, FTP upload, HTTP post, and file transfer resume.
29
30%package devel
31Summary: Files needed for building applications with libcurl.
32Group: Development/Libraries
33Requires: %{name} = %{version}-%{release}
34Requires: openssl-devel libidn-devel zlib-devel
35
36%description devel
37cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
38Dict servers, using any of the supported protocols. The curl-devel
39package includes files needed for developing applications which can
40use cURL's capabilities internally.
41#'
42
43
44## to build compat32 for x86_64 architecture support
45%package -n compat32-%{name}
46Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
47Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
48Group: System Environment/Libraries
49
50%description -n compat32-%{name}
51cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
52Dict servers, using any of the supported protocols. cURL is designed
53to work without user interaction or any kind of interactivity. cURL
54offers many useful capabilities, like proxy support, user
55authentication, FTP upload, HTTP post, and file transfer resume.
56
57%package -n compat32-%{name}-devel
58Summary: Files needed for building applications with libcurl.
59Group: Development/Libraries
60
61%description -n compat32-%{name}-devel
62cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
63Dict servers, using any of the supported protocols. The curl-devel
64package includes files needed for developing applications which can
65use cURL's capabilities internally.
66#'
67
68%prep
69%setup -q
70%patch100 -p1 -b .CVE-2011-2192
71
72%build
73%configure --with-ssl=%{_prefix} --with-gnutls --with-libidn --enable-ipv6 --disable-static
74%ifarch alpha
75make %{?_smp_mflags} CFLAGS=""
76%else
77make %{?_smp_mflags}
78%endif
79
80%install
81rm -rf $RPM_BUILD_ROOT
82make DESTDIR=$RPM_BUILD_ROOT install
83
84rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%post -p /sbin/ldconfig
90
91%postun -p /sbin/ldconfig
92
93%files
94%defattr(-,root,root)
95%doc CHANGES COPYING README
96%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
97%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
98%doc docs/TheArtOfHttpScripting docs/TODO
99%{_bindir}/curl
100#{_datadir}/curl/*
101%{_libdir}/*.so.*
102%{_mandir}/man1/curl.1*
103
104%files devel
105%defattr(-,root,root)
106%{_bindir}/curl-config
107%{_includedir}/curl
108%{_libdir}/*.so
109%{_libdir}/pkgconfig/*.pc
110%{_mandir}/man1/curl-config.1*
111%{_mandir}/man3/*
112
113
114## to build compat32 for x86_64 architecture support
115%if %{build_compat32}
116%files -n compat32-%{name}
117%defattr(-,root,root)
118%{_libdir}/*.so.*
119
120%files -n compat32-%{name}-devel
121%defattr(-,root,root)
122%{_libdir}/*.so
123%{_libdir}/pkgconfig/*.pc
124%endif
125
126%changelog
127* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
128- add patch100 for fix CVE-2011-2192 (gssapi)
129- add Vendor/Distri tags
130
131* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
132- rebuild with openssl-1.0.0c
133
134* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
135- rebuilt with rpm-4.8.1 for pkg-config
136
137* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
138- new upstream release
139
140* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
141- new upstream release with security fix
142
143* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
144- added compat32 subpackages
145
146* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
147- new upstream release
148- use "_smp_mflags" flag
149
150* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
151- rebuild with openldap-2.4.11
152- add BR: openldap-devel
153- remove static library
154
155* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
156- new upstream release with security fix (CVE-2009-0037)
157
158* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
159- new upstream release
160
161* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
162- new upstream release
163
164* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
165- new upstream release
166
167* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
168- new upstream release
169
170* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
171- new upstream release
172
173* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
174- rebuilt with openssl-0.9.8e
175
176* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
177- new upstream release
178
179* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
180- new upstream release
181
182* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
183- new upstream release
184- add pkgconfig file to devel package
185
186* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
187- new upstream release
188
189* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
190- new upstream release
191
192* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
193- new upstream release
194
195* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
196- added libidn, zlib in Requires
197- added libidn-devel, zlib-devel in BuildPrereq
198- added zlib-devel in curl-devel's Requires
199
200* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
201- added openssl-devel, libidn-devel in curl-devel's Requires
202
203* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
204- new upstream release
205
206* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
207- new upstream release
208- rebuild with openssl-0.9.7d
209
210* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
211- upstream release
212
213* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
214- add %%{_datadir}/curl/* to %%files section
215
216* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
217- source upgrade
218
219* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
220- source upgrade
221- add PreReq: ldconfig
222- add %%{_libdir}/*.la to %%files devel section
223
224* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
225- build for VineSeed
226- add Requires: openssl
227
228* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
229- automated rebuild
230
231* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
232- 7.9.2
233
234* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
235- include curl-config in curl-devel
236- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
237
238* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
239- added openssl-devel build req
240
241* Mon May 21 2001 Tim Powers <timp@redhat.com>
242- built for the distro
243
244* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
245- upgrade to curl-7.7.2.
246- enable IPv6.
247
248* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
249- rebuilt against openssl-0.9.6-1
250
251* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
252- fixed mising ldconfigs
253- updated to 7.5.2, bug fixes
254
255* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
256- updated to 7.5.1
257
258* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
259- update to 7.4.1 to fix bug #20337, problems with curl -c
260- not using patch anymore, it's included in the new source. Keeping
261  for reference
262
263* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
264- fix bogus req in -devel package
265
266* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
267- devel package needed defattr so that root owns the files
268
269* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
270- update to 7.3
271- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
272
273* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
274- enable SSL support
275- fix packager tag
276- move buildroot to %%{_tmppath}
277
278* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
279- fixed vendor tag for bug #15028
280
281* Mon Jul 24 2000 Prospector <prospector@redhat.com>
282- rebuilt
283
284* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
285- workaround alpha build problems with optimizations
286
287* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
288- rebuilt
289
290* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
291- put man pages in correct place
292- use %%makeinstall
293
294* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
295- updated to 6.5.2
296
297* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
298- updated sources to 6.2
299- gzip man page
300
301* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
302- changed group
303
304* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
305- changelog started
306- general cleanups, changed prefix to /usr, added manpage to files section
307- including in Powertools
Note: See TracBrowser for help on using the repository browser.