source: projects/specs/trunk/c/curl/curl-vl.spec @ 2487

Revision 2487, 8.9 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with openssl-1.0.0c

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.20.1
7Release: 3%{?_dist_release}
8License: MIT/X
9Group: Applications/Internet
10Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
11URL: http://curl.haxx.se/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: openssl-devel libidn-devel zlib-devel
15BuildRequires: openldap-devel gnutls-devel
16Requires: openssl libidn zlib
17
18%description
19cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
20Dict servers, using any of the supported protocols. cURL is designed
21to work without user interaction or any kind of interactivity. cURL
22offers many useful capabilities, like proxy support, user
23authentication, FTP upload, HTTP post, and file transfer resume.
24
25%package devel
26Summary: Files needed for building applications with libcurl.
27Group: Development/Libraries
28Requires: %{name} = %{version}-%{release}
29Requires: openssl-devel libidn-devel zlib-devel
30
31%description devel
32cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
33Dict servers, using any of the supported protocols. The curl-devel
34package includes files needed for developing applications which can
35use cURL's capabilities internally.
36#'
37
38
39## to build compat32 for x86_64 architecture support
40%package -n compat32-%{name}
41Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
42Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
43Group: System Environment/Libraries
44
45%description -n compat32-%{name}
46cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
47Dict servers, using any of the supported protocols. cURL is designed
48to work without user interaction or any kind of interactivity. cURL
49offers many useful capabilities, like proxy support, user
50authentication, FTP upload, HTTP post, and file transfer resume.
51
52%package -n compat32-%{name}-devel
53Summary: Files needed for building applications with libcurl.
54Group: Development/Libraries
55
56%description -n compat32-%{name}-devel
57cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
58Dict servers, using any of the supported protocols. The curl-devel
59package includes files needed for developing applications which can
60use cURL's capabilities internally.
61#'
62
63
64%prep
65%setup -q
66
67%build
68%configure --with-ssl=%{_prefix} --with-gnutls --with-libidn --enable-ipv6 --disable-static
69%ifarch alpha
70make %{?_smp_mflags} CFLAGS=""
71%else
72make %{?_smp_mflags}
73%endif
74
75%install
76rm -rf $RPM_BUILD_ROOT
77make DESTDIR=$RPM_BUILD_ROOT install
78
79rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post -p /sbin/ldconfig
85
86%postun -p /sbin/ldconfig
87
88%files
89%defattr(-,root,root)
90%doc CHANGES COPYING README
91%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
92%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
93%doc docs/TheArtOfHttpScripting docs/TODO
94%{_bindir}/curl
95#{_datadir}/curl/*
96%{_libdir}/*.so.*
97%{_mandir}/man1/curl.1*
98
99%files devel
100%defattr(-,root,root)
101%{_bindir}/curl-config
102%{_includedir}/curl
103%{_libdir}/*.so
104%{_libdir}/pkgconfig/*.pc
105%{_mandir}/man1/curl-config.1*
106%{_mandir}/man3/*
107
108
109## to build compat32 for x86_64 architecture support
110%if %{build_compat32}
111%files -n compat32-%{name}
112%defattr(-,root,root)
113%{_libdir}/*.so.*
114
115%files -n compat32-%{name}-devel
116%defattr(-,root,root)
117%{_libdir}/*.so
118%{_libdir}/pkgconfig/*.pc
119%endif
120
121%changelog
122* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
123- rebuild with openssl-1.0.0c
124
125* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
126- rebuilt with rpm-4.8.1 for pkg-config
127
128* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
129- new upstream release
130
131* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
132- new upstream release with security fix
133
134* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
135- added compat32 subpackages
136
137* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
138- new upstream release
139- use "_smp_mflags" flag
140
141* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
142- rebuild with openldap-2.4.11
143- add BR: openldap-devel
144- remove static library
145
146* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
147- new upstream release with security fix (CVE-2009-0037)
148
149* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
150- new upstream release
151
152* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
153- new upstream release
154
155* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
156- new upstream release
157
158* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
159- new upstream release
160
161* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
162- new upstream release
163
164* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
165- rebuilt with openssl-0.9.8e
166
167* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
168- new upstream release
169
170* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
171- new upstream release
172
173* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
174- new upstream release
175- add pkgconfig file to devel package
176
177* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
178- new upstream release
179
180* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
181- new upstream release
182
183* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
184- new upstream release
185
186* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
187- added libidn, zlib in Requires
188- added libidn-devel, zlib-devel in BuildPrereq
189- added zlib-devel in curl-devel's Requires
190
191* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
192- added openssl-devel, libidn-devel in curl-devel's Requires
193
194* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
195- new upstream release
196
197* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
198- new upstream release
199- rebuild with openssl-0.9.7d
200
201* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
202- upstream release
203
204* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
205- add %%{_datadir}/curl/* to %%files section
206
207* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
208- source upgrade
209
210* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
211- source upgrade
212- add PreReq: ldconfig
213- add %%{_libdir}/*.la to %%files devel section
214
215* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
216- build for VineSeed
217- add Requires: openssl
218
219* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
220- automated rebuild
221
222* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
223- 7.9.2
224
225* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
226- include curl-config in curl-devel
227- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
228
229* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
230- added openssl-devel build req
231
232* Mon May 21 2001 Tim Powers <timp@redhat.com>
233- built for the distro
234
235* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
236- upgrade to curl-7.7.2.
237- enable IPv6.
238
239* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
240- rebuilt against openssl-0.9.6-1
241
242* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
243- fixed mising ldconfigs
244- updated to 7.5.2, bug fixes
245
246* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
247- updated to 7.5.1
248
249* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
250- update to 7.4.1 to fix bug #20337, problems with curl -c
251- not using patch anymore, it's included in the new source. Keeping
252  for reference
253
254* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
255- fix bogus req in -devel package
256
257* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
258- devel package needed defattr so that root owns the files
259
260* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
261- update to 7.3
262- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
263
264* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
265- enable SSL support
266- fix packager tag
267- move buildroot to %%{_tmppath}
268
269* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
270- fixed vendor tag for bug #15028
271
272* Mon Jul 24 2000 Prospector <prospector@redhat.com>
273- rebuilt
274
275* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
276- workaround alpha build problems with optimizations
277
278* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
279- rebuilt
280
281* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
282- put man pages in correct place
283- use %%makeinstall
284
285* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
286- updated to 6.5.2
287
288* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
289- updated sources to 6.2
290- gzip man page
291
292* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
293- changed group
294
295* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
296- changelog started
297- general cleanups, changed prefix to /usr, added manpage to files section
298- including in Powertools
Note: See TracBrowser for help on using the repository browser.