source: projects/specs/trunk/c/curl/curl-vl.spec @ 890

Revision 890, 8.7 KB checked in by inagaki, 14 years ago (diff)

updated: check, curl, gperf, glpk, gsl

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.20.1
7Release: 1%{?_dist_release}
8License: MIT/X
9Group: Applications/Internet
10Source: http://curl.haxx.se/download/%{name}-%{version}.tar.bz2
11URL: http://curl.haxx.se/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: openssl-devel libidn-devel zlib-devel
15BuildRequires: openldap-devel gnutls-devel
16Requires: openssl libidn zlib
17
18%description
19cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
20Dict servers, using any of the supported protocols. cURL is designed
21to work without user interaction or any kind of interactivity. cURL
22offers many useful capabilities, like proxy support, user
23authentication, FTP upload, HTTP post, and file transfer resume.
24
25%package devel
26Summary: Files needed for building applications with libcurl.
27Group: Development/Libraries
28Requires: %{name} = %{version}-%{release}
29Requires: openssl-devel libidn-devel zlib-devel
30
31%description devel
32cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
33Dict servers, using any of the supported protocols. The curl-devel
34package includes files needed for developing applications which can
35use cURL's capabilities internally.
36#'
37
38
39## to build compat32 for x86_64 architecture support
40%package -n compat32-%{name}
41Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
42Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
43Group: System Environment/Libraries
44
45%description -n compat32-%{name}
46cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
47Dict servers, using any of the supported protocols. cURL is designed
48to work without user interaction or any kind of interactivity. cURL
49offers many useful capabilities, like proxy support, user
50authentication, FTP upload, HTTP post, and file transfer resume.
51
52%package -n compat32-%{name}-devel
53Summary: Files needed for building applications with libcurl.
54Group: Development/Libraries
55
56%description -n compat32-%{name}-devel
57cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
58Dict servers, using any of the supported protocols. The curl-devel
59package includes files needed for developing applications which can
60use cURL's capabilities internally.
61#'
62
63
64%prep
65%setup -q
66
67%build
68%configure --with-ssl=%{_prefix} --with-gnutls --with-libidn --enable-ipv6 --disable-static
69%ifarch alpha
70make %{?_smp_mflags} CFLAGS=""
71%else
72make %{?_smp_mflags}
73%endif
74
75%install
76rm -rf $RPM_BUILD_ROOT
77make DESTDIR=$RPM_BUILD_ROOT install
78
79rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84%post -p /sbin/ldconfig
85
86%postun -p /sbin/ldconfig
87
88%files
89%defattr(-,root,root)
90%doc CHANGES COPYING README
91%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
92%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
93%doc docs/TheArtOfHttpScripting docs/TODO
94%{_bindir}/curl
95#{_datadir}/curl/*
96%{_libdir}/*.so.*
97%{_mandir}/man1/curl.1*
98
99%files devel
100%defattr(-,root,root)
101%{_bindir}/curl-config
102%{_includedir}/curl
103%{_libdir}/*.so
104%{_libdir}/pkgconfig/*.pc
105%{_mandir}/man1/curl-config.1*
106%{_mandir}/man3/*
107
108
109## to build compat32 for x86_64 architecture support
110%if %{build_compat32}
111%files -n compat32-%{name}
112%defattr(-,root,root)
113%{_libdir}/*.so.*
114
115%files -n compat32-%{name}-devel
116%defattr(-,root,root)
117%{_libdir}/*.so
118%{_libdir}/pkgconfig/*.pc
119%endif
120
121%changelog
122* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
123- new upstream release
124
125* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
126- new upstream release with security fix
127
128* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
129- added compat32 subpackages
130
131* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
132- new upstream release
133- use "_smp_mflags" flag
134
135* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
136- rebuild with openldap-2.4.11
137- add BR: openldap-devel
138- remove static library
139
140* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
141- new upstream release with security fix (CVE-2009-0037)
142
143* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
144- new upstream release
145
146* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
147- new upstream release
148
149* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
150- new upstream release
151
152* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
153- new upstream release
154
155* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
156- new upstream release
157
158* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
159- rebuilt with openssl-0.9.8e
160
161* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
162- new upstream release
163
164* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
165- new upstream release
166
167* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
168- new upstream release
169- add pkgconfig file to devel package
170
171* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
172- new upstream release
173
174* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
175- new upstream release
176
177* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
178- new upstream release
179
180* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
181- added libidn, zlib in Requires
182- added libidn-devel, zlib-devel in BuildPrereq
183- added zlib-devel in curl-devel's Requires
184
185* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
186- added openssl-devel, libidn-devel in curl-devel's Requires
187
188* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
189- new upstream release
190
191* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
192- new upstream release
193- rebuild with openssl-0.9.7d
194
195* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
196- upstream release
197
198* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
199- add %%{_datadir}/curl/* to %%files section
200
201* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
202- source upgrade
203
204* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
205- source upgrade
206- add PreReq: ldconfig
207- add %%{_libdir}/*.la to %%files devel section
208
209* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
210- build for VineSeed
211- add Requires: openssl
212
213* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
214- automated rebuild
215
216* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
217- 7.9.2
218
219* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
220- include curl-config in curl-devel
221- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
222
223* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
224- added openssl-devel build req
225
226* Mon May 21 2001 Tim Powers <timp@redhat.com>
227- built for the distro
228
229* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
230- upgrade to curl-7.7.2.
231- enable IPv6.
232
233* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
234- rebuilt against openssl-0.9.6-1
235
236* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
237- fixed mising ldconfigs
238- updated to 7.5.2, bug fixes
239
240* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
241- updated to 7.5.1
242
243* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
244- update to 7.4.1 to fix bug #20337, problems with curl -c
245- not using patch anymore, it's included in the new source. Keeping
246  for reference
247
248* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
249- fix bogus req in -devel package
250
251* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
252- devel package needed defattr so that root owns the files
253
254* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
255- update to 7.3
256- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
257
258* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
259- enable SSL support
260- fix packager tag
261- move buildroot to %%{_tmppath}
262
263* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
264- fixed vendor tag for bug #15028
265
266* Mon Jul 24 2000 Prospector <prospector@redhat.com>
267- rebuilt
268
269* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
270- workaround alpha build problems with optimizations
271
272* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
273- rebuilt
274
275* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
276- put man pages in correct place
277- use %%makeinstall
278
279* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
280- updated to 6.5.2
281
282* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
283- updated sources to 6.2
284- gzip man page
285
286* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
287- changed group
288
289* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
290- changelog started
291- general cleanups, changed prefix to /usr, added manpage to files section
292- including in Powertools
Note: See TracBrowser for help on using the repository browser.