source: projects/specs/trunk/c/curl/curl-vl.spec @ 12131

Revision 12131, 13.9 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
10Version: 7.65.3
11Release: 1%{?_dist_release}
12
13License: MIT
14Group: Applications/Internet
15URL: http://curl.haxx.se/
16Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
17
18# improve handling of gss_init_sec_context() failures
19Patch1:   0001-curl-7.65.3-negotiate-fails.patch
20
21# avoid reporting spurious error in the HTTP2 framing layer (#1690971)
22Patch2:   0002-curl-7.65.3-h2-framing-layer-error.patch
23
24# patch making libcurl multilib ready
25Patch101: 0101-curl-7.32.0-multilib.patch
26
27# prevent configure script from discarding -g in CFLAGS (#496778)
28Patch102: 0102-curl-7.36.0-debug.patch
29
30# migrate tests/http_pipe.py to Python 3
31Patch103: 0103-curl-7.59.0-python3.patch
32
33# use localhost6 instead of ip6-localhost in the curl test-suite
34Patch104: 0104-curl-7.19.7-localhost6.patch
35
36# prevent valgrind from reporting false positives on x86_64
37Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40BuildRequires: openssl-devel
41BuildRequires: gnutls-devel
42BuildRequires: libidn-devel zlib-devel
43BuildRequires: openldap-devel
44BuildRequires: openssh-server
45BuildRequires: openssh-clients
46BuildRequires: pkgconfig
47%if "%{?_dist_release}" != "vl6"
48BuildRequires: libssh2-devel
49%endif
50%if 0%{?with_http2}
51BuildRequires: libnghttp2-devel
52%endif
53
54Requires: ca-certificates
55
56Vendor: Project Vine
57Distribution: Vine Linux
58Packager: daisuke
59
60%description
61cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
62Dict servers, using any of the supported protocols. cURL is designed
63to work without user interaction or any kind of interactivity. cURL
64offers many useful capabilities, like proxy support, user
65authentication, FTP upload, HTTP post, and file transfer resume.
66
67%package devel
68Summary: Files needed for building applications with libcurl.
69Group: Development/Libraries
70Requires: %{name} = %{version}-%{release}
71Requires: openssl-devel libidn-devel zlib-devel
72
73%description devel
74cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
75Dict servers, using any of the supported protocols. The curl-devel
76package includes files needed for developing applications which can
77use cURL's capabilities internally.
78#'
79
80
81## to build compat32 for x86_64 architecture support
82%package -n compat32-%{name}
83Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
84Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
85Group: System Environment/Libraries
86
87%description -n compat32-%{name}
88cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
89Dict servers, using any of the supported protocols. cURL is designed
90to work without user interaction or any kind of interactivity. cURL
91offers many useful capabilities, like proxy support, user
92authentication, FTP upload, HTTP post, and file transfer resume.
93
94%package -n compat32-%{name}-devel
95Summary: Files needed for building applications with libcurl.
96Group: Development/Libraries
97
98%description -n compat32-%{name}-devel
99cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
100Dict servers, using any of the supported protocols. The curl-devel
101package includes files needed for developing applications which can
102use cURL's capabilities internally.
103#'
104
105%prep
106%setup -q
107
108# upstream patches
109%patch1 -p1
110%patch2 -p1
111
112# Fedora patches
113%patch101 -p1
114%patch102 -p1
115#patch103 -p1
116%patch104 -p1
117%patch105 -p1
118
119# make tests/*.py use Python 3
120sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
121
122# regenerate Makefile.in files
123aclocal -I m4
124automake
125
126# disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
127# with errno 98: Address already in use' in Koji environment), and test 1801
128# <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
129# and test 1900, which is flaky and covers a deprecated feature of libcurl
130# <https://github.com/curl/curl/pull/2705>
131printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
132
133# disable test 1319 on ppc64 (server times out)
134%ifarch ppc64
135echo "1319" >> tests/data/DISABLED
136%endif
137
138# temporarily disable test 582 on s390x (client times out)
139%ifarch s390x
140echo "582" >> tests/data/DISABLED
141%endif
142
143# adapt test 323 for updated OpenSSL
144sed -e 's/^35$/35,52/' -i tests/data/test323
145
146%build
147%configure \
148  --with-ssl=%{_prefix} \
149  --with-libidn \
150  --enable-ipv6 \
151  --enable-threaded-resolver \
152  --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
153%if "%{?_dist_release}" != "vl6"
154  --with-libssh2 \
155%endif
156%if 0%{?with_http2}
157  --with-nghttp2 \
158%endif
159  --enable-ldaps \
160  --disable-static \
161  --enable-hidden-symbols
162
163make %{?_smp_mflags}
164
165%install
166rm -rf $RPM_BUILD_ROOT
167make DESTDIR=$RPM_BUILD_ROOT install
168
169rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
170
171%clean
172rm -rf $RPM_BUILD_ROOT
173
174%post -p /sbin/ldconfig
175
176%postun -p /sbin/ldconfig
177
178%files
179%defattr(-,root,root)
180%{!?_licensedir:%global license %%doc}
181%license COPYING
182%doc CHANGES README
183%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
184%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
185%doc docs/TheArtOfHttpScripting docs/TODO
186%{_bindir}/curl
187#{_datadir}/curl/*
188%{_libdir}/*.so.*
189%{_mandir}/man1/*.1*
190
191%files devel
192%defattr(-,root,root)
193%{_bindir}/curl-config
194%{_includedir}/curl
195%{_libdir}/*.so
196%{_libdir}/pkgconfig/*.pc
197%{_mandir}/man1/curl-config.1*
198%{_mandir}/man3/*
199%{_datadir}/aclocal/libcurl.m4
200
201
202## to build compat32 for x86_64 architecture support
203%if %{build_compat32}
204%files -n compat32-%{name}
205%defattr(-,root,root)
206%{_libdir}/*.so.*
207
208%files -n compat32-%{name}-devel
209%defattr(-,root,root)
210%{_libdir}/*.so
211%{_libdir}/pkgconfig/*.pc
212%endif
213
214%changelog
215* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
216- new upstream release.
217- updated patches.
218- imported Patch1, 2 and 105 from rawhide.
219
220* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
221- new upstream release.
222- imported patches from rawhide.
223
224* Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
225- new upstream release.
226- imported Patch1 and 103 from rawhide.
227
228* Wed Feb  7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
229- new upstream release with security fix
230- update patch101
231
232* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
233- new upstream release.
234- updated Patch101-104.
235- dropped Patch107.
236
237* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
238- new upstream release.
239
240* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
241- new upstream release.
242
243* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
244- new upstream release.
245
246* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
247- new upstream release.
248- disabled HTTP/2 on Vine6.
249
250* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
251- added HTTP/2 support.
252
253* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
254- new upstream release with security fix.
255
256* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
257- new upstream release.
258
259* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
260- new upstream release
261- built with openssl 1.0.2g
262
263* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
264- new upstream release with security fix .
265- removed Patch108 (fixed in upstream).
266
267* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
268- new upstream release with security fix
269
270* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
271- new upstream release
272- add libcurl.m4 to -devel package
273
274* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
275- new upstream release
276- import upstream/fedora patches
277- disable libssh2 on Vine Linux 6
278
279* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
280- new upstream reelase
281
282* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
283- update to 7.28.0
284- add configure options
285  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
286- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
287 
288- use ca-certificates package
289  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
290  - R: ca-certificates
291
292* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
293- new upstream release
294
295* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
296- add patch100 for fix CVE-2011-2192 (gssapi)
297- add Vendor/Distri tags
298
299* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
300- rebuild with openssl-1.0.0c
301
302* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
303- rebuilt with rpm-4.8.1 for pkg-config
304
305* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
306- new upstream release
307
308* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
309- new upstream release with security fix
310
311* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
312- added compat32 subpackages
313
314* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
315- new upstream release
316- use "_smp_mflags" flag
317
318* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
319- rebuild with openldap-2.4.11
320- add BR: openldap-devel
321- remove static library
322
323* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
324- new upstream release with security fix (CVE-2009-0037)
325
326* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
327- new upstream release
328
329* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
330- new upstream release
331
332* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
333- new upstream release
334
335* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
336- new upstream release
337
338* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
339- new upstream release
340
341* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
342- rebuilt with openssl-0.9.8e
343
344* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
345- new upstream release
346
347* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
348- new upstream release
349
350* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
351- new upstream release
352- add pkgconfig file to devel package
353
354* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
355- new upstream release
356
357* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
358- new upstream release
359
360* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
361- new upstream release
362
363* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
364- added libidn, zlib in Requires
365- added libidn-devel, zlib-devel in BuildPrereq
366- added zlib-devel in curl-devel's Requires
367
368* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
369- added openssl-devel, libidn-devel in curl-devel's Requires
370
371* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
372- new upstream release
373
374* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
375- new upstream release
376- rebuild with openssl-0.9.7d
377
378* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
379- upstream release
380
381* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
382- add %%{_datadir}/curl/* to %%files section
383
384* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
385- source upgrade
386
387* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
388- source upgrade
389- add PreReq: ldconfig
390- add %%{_libdir}/*.la to %%files devel section
391
392* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
393- build for VineSeed
394- add Requires: openssl
395
396* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
397- automated rebuild
398
399* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
400- 7.9.2
401
402* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
403- include curl-config in curl-devel
404- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
405
406* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
407- added openssl-devel build req
408
409* Mon May 21 2001 Tim Powers <timp@redhat.com>
410- built for the distro
411
412* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
413- upgrade to curl-7.7.2.
414- enable IPv6.
415
416* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
417- rebuilt against openssl-0.9.6-1
418
419* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
420- fixed mising ldconfigs
421- updated to 7.5.2, bug fixes
422
423* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
424- updated to 7.5.1
425
426* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
427- update to 7.4.1 to fix bug #20337, problems with curl -c
428- not using patch anymore, it's included in the new source. Keeping
429  for reference
430
431* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
432- fix bogus req in -devel package
433
434* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
435- devel package needed defattr so that root owns the files
436
437* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
438- update to 7.3
439- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
440
441* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
442- enable SSL support
443- fix packager tag
444- move buildroot to %%{_tmppath}
445
446* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
447- fixed vendor tag for bug #15028
448
449* Mon Jul 24 2000 Prospector <prospector@redhat.com>
450- rebuilt
451
452* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
453- workaround alpha build problems with optimizations
454
455* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
456- rebuilt
457
458* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
459- put man pages in correct place
460- use %%makeinstall
461
462* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
463- updated to 6.5.2
464
465* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
466- updated sources to 6.2
467- gzip man page
468
469* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
470- changed group
471
472* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
473- changelog started
474- general cleanups, changed prefix to /usr, added manpage to files section
475- including in Powertools
Note: See TracBrowser for help on using the repository browser.