source: projects/specs/trunk/c/curl/curl-vl.spec @ 11725

Revision 11725, 12.8 KB checked in by tomop, 6 years ago (diff)

curl-7.59.0-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
10Version: 7.59.0
11Release: 1%{?_dist_release}
12
13License: MIT
14Group: Applications/Internet
15URL: http://curl.haxx.se/
16Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
17
18# ftp: fix typo in recursive callback detection for seeking
19Patch1: 0001-curl-7.58.0-ftp-typo-in-recursive-callback-detection.patch
20
21# patch making libcurl multilib ready
22Patch101: 0101-curl-7.58.0-multilib.patch
23# prevent configure script from discarding -g in CFLAGS (#496778)
24Patch102: 0102-curl-7.36.0-debug.patch
25# migrate tests/http_pipe.py to Python 3
26Patch103: 0103-curl-7.59.0-python3.patch
27# use localhost6 instead of ip6-localhost in the curl test-suite
28Patch104: 0104-curl-7.19.7-localhost6.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: openssl-devel
32BuildRequires: gnutls-devel
33BuildRequires: libidn-devel zlib-devel
34BuildRequires: openldap-devel
35BuildRequires: openssh-server
36BuildRequires: openssh-clients
37BuildRequires: pkgconfig
38%if "%{?_dist_release}" != "vl6"
39BuildRequires: libssh2-devel
40%endif
41%if 0%{?with_http2}
42BuildRequires: libnghttp2-devel
43%endif
44
45Requires: ca-certificates
46
47Vendor: Project Vine
48Distribution: Vine Linux
49Packager: daisuke
50
51%description
52cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
53Dict servers, using any of the supported protocols. cURL is designed
54to work without user interaction or any kind of interactivity. cURL
55offers many useful capabilities, like proxy support, user
56authentication, FTP upload, HTTP post, and file transfer resume.
57
58%package devel
59Summary: Files needed for building applications with libcurl.
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
62Requires: openssl-devel libidn-devel zlib-devel
63
64%description devel
65cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
66Dict servers, using any of the supported protocols. The curl-devel
67package includes files needed for developing applications which can
68use cURL's capabilities internally.
69#'
70
71
72## to build compat32 for x86_64 architecture support
73%package -n compat32-%{name}
74Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
75Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
76Group: System Environment/Libraries
77
78%description -n compat32-%{name}
79cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
80Dict servers, using any of the supported protocols. cURL is designed
81to work without user interaction or any kind of interactivity. cURL
82offers many useful capabilities, like proxy support, user
83authentication, FTP upload, HTTP post, and file transfer resume.
84
85%package -n compat32-%{name}-devel
86Summary: Files needed for building applications with libcurl.
87Group: Development/Libraries
88
89%description -n compat32-%{name}-devel
90cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
91Dict servers, using any of the supported protocols. The curl-devel
92package includes files needed for developing applications which can
93use cURL's capabilities internally.
94#'
95
96%prep
97%setup -q
98
99# upstream patches
100%patch1 -p1
101
102# Fedora patches
103%patch101 -p1
104%patch102 -p1
105%patch103 -p1
106%patch104 -p1
107
108# make tests/*.py use Python 3
109sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
110
111# disable test 1112 (#565305) and test 1801
112# <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
113printf "1112\n1801\n" >> tests/data/DISABLED
114
115%build
116%configure \
117  --with-ssl=%{_prefix} \
118  --with-libidn \
119  --enable-ipv6 \
120  --enable-threaded-resolver \
121  --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
122%if "%{?_dist_release}" != "vl6"
123  --with-libssh2 \
124%endif
125%if 0%{?with_http2}
126  --with-nghttp2 \
127%endif
128  --enable-ldaps \
129  --disable-static \
130  --enable-hidden-symbols
131
132make %{?_smp_mflags}
133
134%install
135rm -rf $RPM_BUILD_ROOT
136make DESTDIR=$RPM_BUILD_ROOT install
137
138rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
139
140%clean
141rm -rf $RPM_BUILD_ROOT
142
143%post -p /sbin/ldconfig
144
145%postun -p /sbin/ldconfig
146
147%files
148%defattr(-,root,root)
149%{!?_licensedir:%global license %%doc}
150%license COPYING
151%doc CHANGES README
152%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
153%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
154%doc docs/TheArtOfHttpScripting docs/TODO
155%{_bindir}/curl
156#{_datadir}/curl/*
157%{_libdir}/*.so.*
158%{_mandir}/man1/*.1*
159
160%files devel
161%defattr(-,root,root)
162%{_bindir}/curl-config
163%{_includedir}/curl
164%{_libdir}/*.so
165%{_libdir}/pkgconfig/*.pc
166%{_mandir}/man1/curl-config.1*
167%{_mandir}/man3/*
168%{_datadir}/aclocal/libcurl.m4
169
170
171## to build compat32 for x86_64 architecture support
172%if %{build_compat32}
173%files -n compat32-%{name}
174%defattr(-,root,root)
175%{_libdir}/*.so.*
176
177%files -n compat32-%{name}-devel
178%defattr(-,root,root)
179%{_libdir}/*.so
180%{_libdir}/pkgconfig/*.pc
181%endif
182
183%changelog
184* Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
185- new upstream release.
186- imported Patch1 and 103 from rawhide.
187
188* Wed Feb  7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
189- new upstream release with security fix
190- update patch101
191
192* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
193- new upstream release.
194- updated Patch101-104.
195- dropped Patch107.
196
197* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
198- new upstream release.
199
200* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
201- new upstream release.
202
203* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
204- new upstream release.
205
206* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
207- new upstream release.
208- disabled HTTP/2 on Vine6.
209
210* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
211- added HTTP/2 support.
212
213* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
214- new upstream release with security fix.
215
216* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
217- new upstream release.
218
219* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
220- new upstream release
221- built with openssl 1.0.2g
222
223* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
224- new upstream release with security fix .
225- removed Patch108 (fixed in upstream).
226
227* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
228- new upstream release with security fix
229
230* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
231- new upstream release
232- add libcurl.m4 to -devel package
233
234* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
235- new upstream release
236- import upstream/fedora patches
237- disable libssh2 on Vine Linux 6
238
239* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
240- new upstream reelase
241
242* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
243- update to 7.28.0
244- add configure options
245  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
246- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
247 
248- use ca-certificates package
249  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
250  - R: ca-certificates
251
252* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
253- new upstream release
254
255* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
256- add patch100 for fix CVE-2011-2192 (gssapi)
257- add Vendor/Distri tags
258
259* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
260- rebuild with openssl-1.0.0c
261
262* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
263- rebuilt with rpm-4.8.1 for pkg-config
264
265* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
266- new upstream release
267
268* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
269- new upstream release with security fix
270
271* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
272- added compat32 subpackages
273
274* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
275- new upstream release
276- use "_smp_mflags" flag
277
278* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
279- rebuild with openldap-2.4.11
280- add BR: openldap-devel
281- remove static library
282
283* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
284- new upstream release with security fix (CVE-2009-0037)
285
286* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
287- new upstream release
288
289* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
290- new upstream release
291
292* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
293- new upstream release
294
295* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
296- new upstream release
297
298* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
299- new upstream release
300
301* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
302- rebuilt with openssl-0.9.8e
303
304* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
305- new upstream release
306
307* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
308- new upstream release
309
310* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
311- new upstream release
312- add pkgconfig file to devel package
313
314* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
315- new upstream release
316
317* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
318- new upstream release
319
320* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
321- new upstream release
322
323* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
324- added libidn, zlib in Requires
325- added libidn-devel, zlib-devel in BuildPrereq
326- added zlib-devel in curl-devel's Requires
327
328* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
329- added openssl-devel, libidn-devel in curl-devel's Requires
330
331* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
332- new upstream release
333
334* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
335- new upstream release
336- rebuild with openssl-0.9.7d
337
338* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
339- upstream release
340
341* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
342- add %%{_datadir}/curl/* to %%files section
343
344* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
345- source upgrade
346
347* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
348- source upgrade
349- add PreReq: ldconfig
350- add %%{_libdir}/*.la to %%files devel section
351
352* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
353- build for VineSeed
354- add Requires: openssl
355
356* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
357- automated rebuild
358
359* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
360- 7.9.2
361
362* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
363- include curl-config in curl-devel
364- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
365
366* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
367- added openssl-devel build req
368
369* Mon May 21 2001 Tim Powers <timp@redhat.com>
370- built for the distro
371
372* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
373- upgrade to curl-7.7.2.
374- enable IPv6.
375
376* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
377- rebuilt against openssl-0.9.6-1
378
379* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
380- fixed mising ldconfigs
381- updated to 7.5.2, bug fixes
382
383* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
384- updated to 7.5.1
385
386* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
387- update to 7.4.1 to fix bug #20337, problems with curl -c
388- not using patch anymore, it's included in the new source. Keeping
389  for reference
390
391* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
392- fix bogus req in -devel package
393
394* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
395- devel package needed defattr so that root owns the files
396
397* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
398- update to 7.3
399- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
400
401* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
402- enable SSL support
403- fix packager tag
404- move buildroot to %%{_tmppath}
405
406* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
407- fixed vendor tag for bug #15028
408
409* Mon Jul 24 2000 Prospector <prospector@redhat.com>
410- rebuilt
411
412* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
413- workaround alpha build problems with optimizations
414
415* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
416- rebuilt
417
418* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
419- put man pages in correct place
420- use %%makeinstall
421
422* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
423- updated to 6.5.2
424
425* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
426- updated sources to 6.2
427- gzip man page
428
429* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
430- changed group
431
432* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
433- changelog started
434- general cleanups, changed prefix to /usr, added manpage to files section
435- including in Powertools
Note: See TracBrowser for help on using the repository browser.