source: projects/specs/trunk/c/curl/curl-vl.spec @ 10632

Revision 10632, 11.4 KB checked in by tomop, 8 years ago (diff)

curl-7.49.1-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.49.1
7Release: 2%{?_dist_release}
8
9License: MIT
10Group: Applications/Internet
11URL: http://curl.haxx.se/
12Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
13
14# patch making libcurl multilib ready
15Patch101: 0101-curl-7.32.0-multilib.patch
16# prevent configure script from discarding -g in CFLAGS (#496778)
17Patch102: 0102-curl-7.36.0-debug.patch
18# use localhost6 instead of ip6-localhost in the curl test-suite
19Patch104: 0104-curl-7.19.7-localhost6.patch
20# work around valgrind bug (#678518)
21Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: libnghttp2-devel
25BuildRequires: openssl-devel libidn-devel zlib-devel
26BuildRequires: openldap-devel gnutls-devel
27BuildRequires: openssh-server
28BuildRequires: openssh-clients
29BuildRequires: pkgconfig
30%if "%{?_dist_release}" != "vl6"
31BuildRequires: libssh2-devel
32%endif
33Requires: ca-certificates
34
35Vendor: Project Vine
36Distribution: Vine Linux
37Packager: daisuke
38
39%description
40cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
41Dict servers, using any of the supported protocols. cURL is designed
42to work without user interaction or any kind of interactivity. cURL
43offers many useful capabilities, like proxy support, user
44authentication, FTP upload, HTTP post, and file transfer resume.
45
46%package devel
47Summary: Files needed for building applications with libcurl.
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: openssl-devel libidn-devel zlib-devel
51
52%description devel
53cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
54Dict servers, using any of the supported protocols. The curl-devel
55package includes files needed for developing applications which can
56use cURL's capabilities internally.
57#'
58
59
60## to build compat32 for x86_64 architecture support
61%package -n compat32-%{name}
62Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
63Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
64Group: System Environment/Libraries
65
66%description -n compat32-%{name}
67cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
68Dict servers, using any of the supported protocols. cURL is designed
69to work without user interaction or any kind of interactivity. cURL
70offers many useful capabilities, like proxy support, user
71authentication, FTP upload, HTTP post, and file transfer resume.
72
73%package -n compat32-%{name}-devel
74Summary: Files needed for building applications with libcurl.
75Group: Development/Libraries
76
77%description -n compat32-%{name}-devel
78cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
79Dict servers, using any of the supported protocols. The curl-devel
80package includes files needed for developing applications which can
81use cURL's capabilities internally.
82#'
83
84%prep
85%setup -q
86
87# Fedora patches
88%patch101 -p1
89%patch102 -p1
90%patch104 -p1
91%patch107 -p1
92
93%build
94%configure \
95  --with-ssl=%{_prefix} \
96  --with-gnutls \
97  --with-libidn \
98  --with-nghttp2 \
99  --enable-ipv6 \
100  --enable-threaded-resolver \
101  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
102%if "%{?_dist_release}" != "vl6"
103  --with-libssh2 \
104%endif
105  --enable-ldaps \
106  --disable-static \
107  --enable-hidden-symbols
108
109make %{?_smp_mflags}
110
111%install
112rm -rf $RPM_BUILD_ROOT
113make DESTDIR=$RPM_BUILD_ROOT install
114
115rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%post -p /sbin/ldconfig
121
122%postun -p /sbin/ldconfig
123
124%files
125%defattr(-,root,root)
126%license COPYING
127%doc CHANGES README
128%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
129%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
130%doc docs/TheArtOfHttpScripting docs/TODO
131%{_bindir}/curl
132#{_datadir}/curl/*
133%{_libdir}/*.so.*
134%{_mandir}/man1/*.1*
135
136%files devel
137%defattr(-,root,root)
138%{_bindir}/curl-config
139%{_includedir}/curl
140%{_libdir}/*.so
141%{_libdir}/pkgconfig/*.pc
142%{_mandir}/man1/curl-config.1*
143%{_mandir}/man3/*
144%{_datadir}/aclocal/libcurl.m4
145
146
147## to build compat32 for x86_64 architecture support
148%if %{build_compat32}
149%files -n compat32-%{name}
150%defattr(-,root,root)
151%{_libdir}/*.so.*
152
153%files -n compat32-%{name}-devel
154%defattr(-,root,root)
155%{_libdir}/*.so
156%{_libdir}/pkgconfig/*.pc
157%endif
158
159%changelog
160* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
161- added HTTP/2 support.
162
163* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
164- new upstream release with security fix.
165
166* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
167- new upstream release.
168
169* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
170- new upstream release
171- built with openssl 1.0.2g
172
173* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
174- new upstream release with security fix .
175- removed Patch108 (fixed in upstream).
176
177* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
178- new upstream release with security fix
179
180* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
181- new upstream release
182- add libcurl.m4 to -devel package
183
184* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
185- new upstream release
186- import upstream/fedora patches
187- disable libssh2 on Vine Linux 6
188
189* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
190- new upstream reelase
191
192* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
193- update to 7.28.0
194- add configure options
195  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
196- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
197 
198- use ca-certificates package
199  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
200  - R: ca-certificates
201
202* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
203- new upstream release
204
205* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
206- add patch100 for fix CVE-2011-2192 (gssapi)
207- add Vendor/Distri tags
208
209* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
210- rebuild with openssl-1.0.0c
211
212* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
213- rebuilt with rpm-4.8.1 for pkg-config
214
215* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
216- new upstream release
217
218* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
219- new upstream release with security fix
220
221* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
222- added compat32 subpackages
223
224* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
225- new upstream release
226- use "_smp_mflags" flag
227
228* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
229- rebuild with openldap-2.4.11
230- add BR: openldap-devel
231- remove static library
232
233* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
234- new upstream release with security fix (CVE-2009-0037)
235
236* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
237- new upstream release
238
239* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
240- new upstream release
241
242* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
243- new upstream release
244
245* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
246- new upstream release
247
248* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
249- new upstream release
250
251* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
252- rebuilt with openssl-0.9.8e
253
254* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
255- new upstream release
256
257* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
258- new upstream release
259
260* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
261- new upstream release
262- add pkgconfig file to devel package
263
264* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
265- new upstream release
266
267* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
268- new upstream release
269
270* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
271- new upstream release
272
273* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
274- added libidn, zlib in Requires
275- added libidn-devel, zlib-devel in BuildPrereq
276- added zlib-devel in curl-devel's Requires
277
278* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
279- added openssl-devel, libidn-devel in curl-devel's Requires
280
281* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
282- new upstream release
283
284* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
285- new upstream release
286- rebuild with openssl-0.9.7d
287
288* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
289- upstream release
290
291* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
292- add %%{_datadir}/curl/* to %%files section
293
294* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
295- source upgrade
296
297* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
298- source upgrade
299- add PreReq: ldconfig
300- add %%{_libdir}/*.la to %%files devel section
301
302* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
303- build for VineSeed
304- add Requires: openssl
305
306* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
307- automated rebuild
308
309* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
310- 7.9.2
311
312* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
313- include curl-config in curl-devel
314- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
315
316* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
317- added openssl-devel build req
318
319* Mon May 21 2001 Tim Powers <timp@redhat.com>
320- built for the distro
321
322* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
323- upgrade to curl-7.7.2.
324- enable IPv6.
325
326* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
327- rebuilt against openssl-0.9.6-1
328
329* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
330- fixed mising ldconfigs
331- updated to 7.5.2, bug fixes
332
333* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
334- updated to 7.5.1
335
336* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
337- update to 7.4.1 to fix bug #20337, problems with curl -c
338- not using patch anymore, it's included in the new source. Keeping
339  for reference
340
341* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
342- fix bogus req in -devel package
343
344* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
345- devel package needed defattr so that root owns the files
346
347* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
348- update to 7.3
349- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
350
351* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
352- enable SSL support
353- fix packager tag
354- move buildroot to %%{_tmppath}
355
356* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
357- fixed vendor tag for bug #15028
358
359* Mon Jul 24 2000 Prospector <prospector@redhat.com>
360- rebuilt
361
362* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
363- workaround alpha build problems with optimizations
364
365* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
366- rebuilt
367
368* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
369- put man pages in correct place
370- use %%makeinstall
371
372* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
373- updated to 6.5.2
374
375* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
376- updated sources to 6.2
377- gzip man page
378
379* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
380- changed group
381
382* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
383- changelog started
384- general cleanups, changed prefix to /usr, added manpage to files section
385- including in Powertools
Note: See TracBrowser for help on using the repository browser.