source: projects/specs/trunk/c/curl/curl-vl.spec @ 10418

Revision 10418, 11.3 KB checked in by tomop, 8 years ago (diff)

curl-7.49.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
4Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
5Name: curl
6Version: 7.49.1
7Release: 1%{?_dist_release}
8
9License: MIT
10Group: Applications/Internet
11URL: http://curl.haxx.se/
12Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
13
14# patch making libcurl multilib ready
15Patch101: 0101-curl-7.32.0-multilib.patch
16# prevent configure script from discarding -g in CFLAGS (#496778)
17Patch102: 0102-curl-7.36.0-debug.patch
18# use localhost6 instead of ip6-localhost in the curl test-suite
19Patch104: 0104-curl-7.19.7-localhost6.patch
20# work around valgrind bug (#678518)
21Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: openssl-devel libidn-devel zlib-devel
25BuildRequires: openldap-devel gnutls-devel
26BuildRequires: openssh-server
27BuildRequires: openssh-clients
28BuildRequires: pkgconfig
29%if "%{?_dist_release}" != "vl6"
30BuildRequires: libssh2-devel
31%endif
32Requires: ca-certificates
33
34Vendor: Project Vine
35Distribution: Vine Linux
36Packager: daisuke
37
38%description
39cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
40Dict servers, using any of the supported protocols. cURL is designed
41to work without user interaction or any kind of interactivity. cURL
42offers many useful capabilities, like proxy support, user
43authentication, FTP upload, HTTP post, and file transfer resume.
44
45%package devel
46Summary: Files needed for building applications with libcurl.
47Group: Development/Libraries
48Requires: %{name} = %{version}-%{release}
49Requires: openssl-devel libidn-devel zlib-devel
50
51%description devel
52cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
53Dict servers, using any of the supported protocols. The curl-devel
54package includes files needed for developing applications which can
55use cURL's capabilities internally.
56#'
57
58
59## to build compat32 for x86_64 architecture support
60%package -n compat32-%{name}
61Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
62Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
63Group: System Environment/Libraries
64
65%description -n compat32-%{name}
66cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
67Dict servers, using any of the supported protocols. cURL is designed
68to work without user interaction or any kind of interactivity. cURL
69offers many useful capabilities, like proxy support, user
70authentication, FTP upload, HTTP post, and file transfer resume.
71
72%package -n compat32-%{name}-devel
73Summary: Files needed for building applications with libcurl.
74Group: Development/Libraries
75
76%description -n compat32-%{name}-devel
77cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
78Dict servers, using any of the supported protocols. The curl-devel
79package includes files needed for developing applications which can
80use cURL's capabilities internally.
81#'
82
83%prep
84%setup -q
85
86# Fedora patches
87%patch101 -p1
88%patch102 -p1
89%patch104 -p1
90%patch107 -p1
91
92%build
93%configure \
94  --with-ssl=%{_prefix} \
95  --with-gnutls \
96  --with-libidn \
97  --enable-ipv6 \
98  --enable-threaded-resolver \
99  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
100%if "%{?_dist_release}" != "vl6"
101  --with-libssh2 \
102%endif
103  --enable-ldaps \
104  --disable-static \
105  --enable-hidden-symbols
106
107make %{?_smp_mflags}
108
109%install
110rm -rf $RPM_BUILD_ROOT
111make DESTDIR=$RPM_BUILD_ROOT install
112
113rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
114
115%clean
116rm -rf $RPM_BUILD_ROOT
117
118%post -p /sbin/ldconfig
119
120%postun -p /sbin/ldconfig
121
122%files
123%defattr(-,root,root)
124%doc CHANGES COPYING README
125%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
126%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
127%doc docs/TheArtOfHttpScripting docs/TODO
128%{_bindir}/curl
129#{_datadir}/curl/*
130%{_libdir}/*.so.*
131%{_mandir}/man1/*.1*
132
133%files devel
134%defattr(-,root,root)
135%{_bindir}/curl-config
136%{_includedir}/curl
137%{_libdir}/*.so
138%{_libdir}/pkgconfig/*.pc
139%{_mandir}/man1/curl-config.1*
140%{_mandir}/man3/*
141%{_datadir}/aclocal/libcurl.m4
142
143
144## to build compat32 for x86_64 architecture support
145%if %{build_compat32}
146%files -n compat32-%{name}
147%defattr(-,root,root)
148%{_libdir}/*.so.*
149
150%files -n compat32-%{name}-devel
151%defattr(-,root,root)
152%{_libdir}/*.so
153%{_libdir}/pkgconfig/*.pc
154%endif
155
156%changelog
157* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
158- new upstream release with security fix.
159
160* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
161- new upstream release.
162
163* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
164- new upstream release
165- built with openssl 1.0.2g
166
167* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
168- new upstream release with security fix .
169- removed Patch108 (fixed in upstream).
170
171* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
172- new upstream release with security fix
173
174* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
175- new upstream release
176- add libcurl.m4 to -devel package
177
178* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
179- new upstream release
180- import upstream/fedora patches
181- disable libssh2 on Vine Linux 6
182
183* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
184- new upstream reelase
185
186* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
187- update to 7.28.0
188- add configure options
189  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
190- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
191 
192- use ca-certificates package
193  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
194  - R: ca-certificates
195
196* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
197- new upstream release
198
199* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
200- add patch100 for fix CVE-2011-2192 (gssapi)
201- add Vendor/Distri tags
202
203* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
204- rebuild with openssl-1.0.0c
205
206* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
207- rebuilt with rpm-4.8.1 for pkg-config
208
209* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
210- new upstream release
211
212* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
213- new upstream release with security fix
214
215* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
216- added compat32 subpackages
217
218* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
219- new upstream release
220- use "_smp_mflags" flag
221
222* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
223- rebuild with openldap-2.4.11
224- add BR: openldap-devel
225- remove static library
226
227* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
228- new upstream release with security fix (CVE-2009-0037)
229
230* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
231- new upstream release
232
233* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
234- new upstream release
235
236* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
237- new upstream release
238
239* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
240- new upstream release
241
242* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
243- new upstream release
244
245* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
246- rebuilt with openssl-0.9.8e
247
248* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
249- new upstream release
250
251* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
252- new upstream release
253
254* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
255- new upstream release
256- add pkgconfig file to devel package
257
258* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
259- new upstream release
260
261* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
262- new upstream release
263
264* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
265- new upstream release
266
267* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
268- added libidn, zlib in Requires
269- added libidn-devel, zlib-devel in BuildPrereq
270- added zlib-devel in curl-devel's Requires
271
272* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
273- added openssl-devel, libidn-devel in curl-devel's Requires
274
275* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
276- new upstream release
277
278* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
279- new upstream release
280- rebuild with openssl-0.9.7d
281
282* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
283- upstream release
284
285* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
286- add %%{_datadir}/curl/* to %%files section
287
288* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
289- source upgrade
290
291* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
292- source upgrade
293- add PreReq: ldconfig
294- add %%{_libdir}/*.la to %%files devel section
295
296* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
297- build for VineSeed
298- add Requires: openssl
299
300* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
301- automated rebuild
302
303* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
304- 7.9.2
305
306* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
307- include curl-config in curl-devel
308- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
309
310* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
311- added openssl-devel build req
312
313* Mon May 21 2001 Tim Powers <timp@redhat.com>
314- built for the distro
315
316* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
317- upgrade to curl-7.7.2.
318- enable IPv6.
319
320* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
321- rebuilt against openssl-0.9.6-1
322
323* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
324- fixed mising ldconfigs
325- updated to 7.5.2, bug fixes
326
327* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
328- updated to 7.5.1
329
330* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
331- update to 7.4.1 to fix bug #20337, problems with curl -c
332- not using patch anymore, it's included in the new source. Keeping
333  for reference
334
335* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
336- fix bogus req in -devel package
337
338* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
339- devel package needed defattr so that root owns the files
340
341* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
342- update to 7.3
343- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
344
345* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
346- enable SSL support
347- fix packager tag
348- move buildroot to %%{_tmppath}
349
350* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
351- fixed vendor tag for bug #15028
352
353* Mon Jul 24 2000 Prospector <prospector@redhat.com>
354- rebuilt
355
356* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
357- workaround alpha build problems with optimizations
358
359* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
360- rebuilt
361
362* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
363- put man pages in correct place
364- use %%makeinstall
365
366* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
367- updated to 6.5.2
368
369* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
370- updated sources to 6.2
371- gzip man page
372
373* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
374- changed group
375
376* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
377- changelog started
378- general cleanups, changed prefix to /usr, added manpage to files section
379- including in Powertools
Note: See TracBrowser for help on using the repository browser.