source: projects/specs/trunk/c/curl/curl-vl.spec @ 11840

Revision 11840, 13.4 KB checked in by tomop, 6 years ago (diff)

curl-7.62.0-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
10Version: 7.62.0
11Release: 1%{?_dist_release}
12
13License: MIT
14Group: Applications/Internet
15URL: http://curl.haxx.se/
16Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
17
18# patch making libcurl multilib ready
19Patch101: 0101-curl-7.32.0-multilib.patch
20
21# prevent configure script from discarding -g in CFLAGS (#496778)
22Patch102: 0102-curl-7.36.0-debug.patch
23
24# migrate tests/http_pipe.py to Python 3
25Patch103: 0103-curl-7.59.0-python3.patch
26
27# use localhost6 instead of ip6-localhost in the curl test-suite
28Patch104: 0104-curl-7.19.7-localhost6.patch
29
30BuildRoot: %{_tmppath}/%{name}-%{version}-root
31BuildRequires: openssl-devel
32BuildRequires: gnutls-devel
33BuildRequires: libidn-devel zlib-devel
34BuildRequires: openldap-devel
35BuildRequires: openssh-server
36BuildRequires: openssh-clients
37BuildRequires: pkgconfig
38%if "%{?_dist_release}" != "vl6"
39BuildRequires: libssh2-devel
40%endif
41%if 0%{?with_http2}
42BuildRequires: libnghttp2-devel
43%endif
44
45Requires: ca-certificates
46
47Vendor: Project Vine
48Distribution: Vine Linux
49Packager: daisuke
50
51%description
52cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
53Dict servers, using any of the supported protocols. cURL is designed
54to work without user interaction or any kind of interactivity. cURL
55offers many useful capabilities, like proxy support, user
56authentication, FTP upload, HTTP post, and file transfer resume.
57
58%package devel
59Summary: Files needed for building applications with libcurl.
60Group: Development/Libraries
61Requires: %{name} = %{version}-%{release}
62Requires: openssl-devel libidn-devel zlib-devel
63
64%description devel
65cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
66Dict servers, using any of the supported protocols. The curl-devel
67package includes files needed for developing applications which can
68use cURL's capabilities internally.
69#'
70
71
72## to build compat32 for x86_64 architecture support
73%package -n compat32-%{name}
74Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
75Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
76Group: System Environment/Libraries
77
78%description -n compat32-%{name}
79cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
80Dict servers, using any of the supported protocols. cURL is designed
81to work without user interaction or any kind of interactivity. cURL
82offers many useful capabilities, like proxy support, user
83authentication, FTP upload, HTTP post, and file transfer resume.
84
85%package -n compat32-%{name}-devel
86Summary: Files needed for building applications with libcurl.
87Group: Development/Libraries
88
89%description -n compat32-%{name}-devel
90cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
91Dict servers, using any of the supported protocols. The curl-devel
92package includes files needed for developing applications which can
93use cURL's capabilities internally.
94#'
95
96%prep
97%setup -q
98
99# upstream patches
100# (none)
101
102# Fedora patches
103%patch101 -p1
104%patch102 -p1
105#patch103 -p1
106%patch104 -p1
107
108# make tests/*.py use Python 3
109sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
110
111# regenerate Makefile.in files
112aclocal -I m4
113automake
114
115# disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
116# with errno 98: Address already in use' in Koji environment), and test 1801
117# <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
118# and test 1900, which is flaky and covers a deprecated feature of libcurl
119# <https://github.com/curl/curl/pull/2705>
120printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
121
122# disable test 1319 on ppc64 (server times out)
123%ifarch ppc64
124echo "1319" >> tests/data/DISABLED
125%endif
126
127# temporarily disable test 582 on s390x (client times out)
128%ifarch s390x
129echo "582" >> tests/data/DISABLED
130%endif
131
132# adapt test 323 for updated OpenSSL
133sed -e 's/^35$/35,52/' -i tests/data/test323
134
135%build
136%configure \
137  --with-ssl=%{_prefix} \
138  --with-libidn \
139  --enable-ipv6 \
140  --enable-threaded-resolver \
141  --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
142%if "%{?_dist_release}" != "vl6"
143  --with-libssh2 \
144%endif
145%if 0%{?with_http2}
146  --with-nghttp2 \
147%endif
148  --enable-ldaps \
149  --disable-static \
150  --enable-hidden-symbols
151
152make %{?_smp_mflags}
153
154%install
155rm -rf $RPM_BUILD_ROOT
156make DESTDIR=$RPM_BUILD_ROOT install
157
158rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
159
160%clean
161rm -rf $RPM_BUILD_ROOT
162
163%post -p /sbin/ldconfig
164
165%postun -p /sbin/ldconfig
166
167%files
168%defattr(-,root,root)
169%{!?_licensedir:%global license %%doc}
170%license COPYING
171%doc CHANGES README
172%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
173%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
174%doc docs/TheArtOfHttpScripting docs/TODO
175%{_bindir}/curl
176#{_datadir}/curl/*
177%{_libdir}/*.so.*
178%{_mandir}/man1/*.1*
179
180%files devel
181%defattr(-,root,root)
182%{_bindir}/curl-config
183%{_includedir}/curl
184%{_libdir}/*.so
185%{_libdir}/pkgconfig/*.pc
186%{_mandir}/man1/curl-config.1*
187%{_mandir}/man3/*
188%{_datadir}/aclocal/libcurl.m4
189
190
191## to build compat32 for x86_64 architecture support
192%if %{build_compat32}
193%files -n compat32-%{name}
194%defattr(-,root,root)
195%{_libdir}/*.so.*
196
197%files -n compat32-%{name}-devel
198%defattr(-,root,root)
199%{_libdir}/*.so
200%{_libdir}/pkgconfig/*.pc
201%endif
202
203%changelog
204* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
205- new upstream release.
206- imported patches from rawhide.
207
208* Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
209- new upstream release.
210- imported Patch1 and 103 from rawhide.
211
212* Wed Feb  7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
213- new upstream release with security fix
214- update patch101
215
216* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
217- new upstream release.
218- updated Patch101-104.
219- dropped Patch107.
220
221* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
222- new upstream release.
223
224* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
225- new upstream release.
226
227* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
228- new upstream release.
229
230* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
231- new upstream release.
232- disabled HTTP/2 on Vine6.
233
234* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
235- added HTTP/2 support.
236
237* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
238- new upstream release with security fix.
239
240* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
241- new upstream release.
242
243* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
244- new upstream release
245- built with openssl 1.0.2g
246
247* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
248- new upstream release with security fix .
249- removed Patch108 (fixed in upstream).
250
251* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
252- new upstream release with security fix
253
254* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
255- new upstream release
256- add libcurl.m4 to -devel package
257
258* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
259- new upstream release
260- import upstream/fedora patches
261- disable libssh2 on Vine Linux 6
262
263* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
264- new upstream reelase
265
266* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
267- update to 7.28.0
268- add configure options
269  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
270- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
271 
272- use ca-certificates package
273  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
274  - R: ca-certificates
275
276* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
277- new upstream release
278
279* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
280- add patch100 for fix CVE-2011-2192 (gssapi)
281- add Vendor/Distri tags
282
283* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
284- rebuild with openssl-1.0.0c
285
286* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
287- rebuilt with rpm-4.8.1 for pkg-config
288
289* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
290- new upstream release
291
292* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
293- new upstream release with security fix
294
295* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
296- added compat32 subpackages
297
298* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
299- new upstream release
300- use "_smp_mflags" flag
301
302* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
303- rebuild with openldap-2.4.11
304- add BR: openldap-devel
305- remove static library
306
307* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
308- new upstream release with security fix (CVE-2009-0037)
309
310* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
311- new upstream release
312
313* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
314- new upstream release
315
316* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
317- new upstream release
318
319* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
320- new upstream release
321
322* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
323- new upstream release
324
325* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
326- rebuilt with openssl-0.9.8e
327
328* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
329- new upstream release
330
331* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
332- new upstream release
333
334* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
335- new upstream release
336- add pkgconfig file to devel package
337
338* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
339- new upstream release
340
341* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
342- new upstream release
343
344* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
345- new upstream release
346
347* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
348- added libidn, zlib in Requires
349- added libidn-devel, zlib-devel in BuildPrereq
350- added zlib-devel in curl-devel's Requires
351
352* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
353- added openssl-devel, libidn-devel in curl-devel's Requires
354
355* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
356- new upstream release
357
358* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
359- new upstream release
360- rebuild with openssl-0.9.7d
361
362* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
363- upstream release
364
365* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
366- add %%{_datadir}/curl/* to %%files section
367
368* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
369- source upgrade
370
371* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
372- source upgrade
373- add PreReq: ldconfig
374- add %%{_libdir}/*.la to %%files devel section
375
376* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
377- build for VineSeed
378- add Requires: openssl
379
380* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
381- automated rebuild
382
383* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
384- 7.9.2
385
386* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
387- include curl-config in curl-devel
388- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
389
390* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
391- added openssl-devel build req
392
393* Mon May 21 2001 Tim Powers <timp@redhat.com>
394- built for the distro
395
396* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
397- upgrade to curl-7.7.2.
398- enable IPv6.
399
400* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
401- rebuilt against openssl-0.9.6-1
402
403* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
404- fixed mising ldconfigs
405- updated to 7.5.2, bug fixes
406
407* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
408- updated to 7.5.1
409
410* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
411- update to 7.4.1 to fix bug #20337, problems with curl -c
412- not using patch anymore, it's included in the new source. Keeping
413  for reference
414
415* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
416- fix bogus req in -devel package
417
418* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
419- devel package needed defattr so that root owns the files
420
421* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
422- update to 7.3
423- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
424
425* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
426- enable SSL support
427- fix packager tag
428- move buildroot to %%{_tmppath}
429
430* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
431- fixed vendor tag for bug #15028
432
433* Mon Jul 24 2000 Prospector <prospector@redhat.com>
434- rebuilt
435
436* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
437- workaround alpha build problems with optimizations
438
439* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
440- rebuilt
441
442* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
443- put man pages in correct place
444- use %%makeinstall
445
446* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
447- updated to 6.5.2
448
449* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
450- updated sources to 6.2
451- gzip man page
452
453* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
454- changed group
455
456* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
457- changelog started
458- general cleanups, changed prefix to /usr, added manpage to files section
459- including in Powertools
Note: See TracBrowser for help on using the repository browser.