source: projects/specs/trunk/c/curl/curl-vl.spec @ 10933

Revision 10933, 11.9 KB checked in by tomop, 7 years ago (diff)

curl-7.53.1-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
10Version: 7.53.1
11Release: 1%{?_dist_release}
12
13License: MIT
14Group: Applications/Internet
15URL: http://curl.haxx.se/
16Source: http://curl.haxx.se/download/%{name}-%{version}.tar.lzma
17
18# patch making libcurl multilib ready
19Patch101: 0101-curl-7.32.0-multilib.patch
20# prevent configure script from discarding -g in CFLAGS (#496778)
21Patch102: 0102-curl-7.36.0-debug.patch
22# use localhost6 instead of ip6-localhost in the curl test-suite
23Patch104: 0104-curl-7.19.7-localhost6.patch
24# work around valgrind bug (#678518)
25Patch107: 0107-curl-7.21.4-libidn-valgrind.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: openssl-devel libidn-devel zlib-devel
29BuildRequires: openldap-devel gnutls-devel
30BuildRequires: openssh-server
31BuildRequires: openssh-clients
32BuildRequires: pkgconfig
33%if "%{?_dist_release}" != "vl6"
34BuildRequires: libssh2-devel
35%endif
36%if 0%{?with_http2}
37BuildRequires: libnghttp2-devel
38%endif
39
40Requires: ca-certificates
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: daisuke
45
46%description
47cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
48Dict servers, using any of the supported protocols. cURL is designed
49to work without user interaction or any kind of interactivity. cURL
50offers many useful capabilities, like proxy support, user
51authentication, FTP upload, HTTP post, and file transfer resume.
52
53%package devel
54Summary: Files needed for building applications with libcurl.
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: openssl-devel libidn-devel zlib-devel
58
59%description devel
60cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
61Dict servers, using any of the supported protocols. The curl-devel
62package includes files needed for developing applications which can
63use cURL's capabilities internally.
64#'
65
66
67## to build compat32 for x86_64 architecture support
68%package -n compat32-%{name}
69Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
70Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
71Group: System Environment/Libraries
72
73%description -n compat32-%{name}
74cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
75Dict servers, using any of the supported protocols. cURL is designed
76to work without user interaction or any kind of interactivity. cURL
77offers many useful capabilities, like proxy support, user
78authentication, FTP upload, HTTP post, and file transfer resume.
79
80%package -n compat32-%{name}-devel
81Summary: Files needed for building applications with libcurl.
82Group: Development/Libraries
83
84%description -n compat32-%{name}-devel
85cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
86Dict servers, using any of the supported protocols. The curl-devel
87package includes files needed for developing applications which can
88use cURL's capabilities internally.
89#'
90
91%prep
92%setup -q
93
94# Fedora patches
95%patch101 -p1
96%patch102 -p1
97%patch104 -p1
98%patch107 -p1
99
100%build
101%configure \
102  --with-ssl=%{_prefix} \
103  --with-gnutls \
104  --with-libidn \
105  --enable-ipv6 \
106  --enable-threaded-resolver \
107  --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
108%if "%{?_dist_release}" != "vl6"
109  --with-libssh2 \
110%endif
111%if 0%{?with_http2}
112  --with-nghttp2 \
113%endif
114  --enable-ldaps \
115  --disable-static \
116  --enable-hidden-symbols
117
118make %{?_smp_mflags}
119
120%install
121rm -rf $RPM_BUILD_ROOT
122make DESTDIR=$RPM_BUILD_ROOT install
123
124rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
133%files
134%defattr(-,root,root)
135%{!?_licensedir:%global license %%doc}
136%license COPYING
137%doc CHANGES README
138%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
139%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
140%doc docs/TheArtOfHttpScripting docs/TODO
141%{_bindir}/curl
142#{_datadir}/curl/*
143%{_libdir}/*.so.*
144%{_mandir}/man1/*.1*
145
146%files devel
147%defattr(-,root,root)
148%{_bindir}/curl-config
149%{_includedir}/curl
150%{_libdir}/*.so
151%{_libdir}/pkgconfig/*.pc
152%{_mandir}/man1/curl-config.1*
153%{_mandir}/man3/*
154%{_datadir}/aclocal/libcurl.m4
155
156
157## to build compat32 for x86_64 architecture support
158%if %{build_compat32}
159%files -n compat32-%{name}
160%defattr(-,root,root)
161%{_libdir}/*.so.*
162
163%files -n compat32-%{name}-devel
164%defattr(-,root,root)
165%{_libdir}/*.so
166%{_libdir}/pkgconfig/*.pc
167%endif
168
169%changelog
170* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
171- new upstream release.
172
173* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
174- new upstream release.
175
176* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
177- new upstream release.
178- disabled HTTP/2 on Vine6.
179
180* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
181- added HTTP/2 support.
182
183* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
184- new upstream release with security fix.
185
186* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
187- new upstream release.
188
189* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
190- new upstream release
191- built with openssl 1.0.2g
192
193* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
194- new upstream release with security fix .
195- removed Patch108 (fixed in upstream).
196
197* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
198- new upstream release with security fix
199
200* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
201- new upstream release
202- add libcurl.m4 to -devel package
203
204* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
205- new upstream release
206- import upstream/fedora patches
207- disable libssh2 on Vine Linux 6
208
209* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
210- new upstream reelase
211
212* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
213- update to 7.28.0
214- add configure options
215  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
216- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
217 
218- use ca-certificates package
219  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
220  - R: ca-certificates
221
222* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
223- new upstream release
224
225* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
226- add patch100 for fix CVE-2011-2192 (gssapi)
227- add Vendor/Distri tags
228
229* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
230- rebuild with openssl-1.0.0c
231
232* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
233- rebuilt with rpm-4.8.1 for pkg-config
234
235* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
236- new upstream release
237
238* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
239- new upstream release with security fix
240
241* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
242- added compat32 subpackages
243
244* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
245- new upstream release
246- use "_smp_mflags" flag
247
248* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
249- rebuild with openldap-2.4.11
250- add BR: openldap-devel
251- remove static library
252
253* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
254- new upstream release with security fix (CVE-2009-0037)
255
256* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
257- new upstream release
258
259* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
260- new upstream release
261
262* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
263- new upstream release
264
265* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
266- new upstream release
267
268* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
269- new upstream release
270
271* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
272- rebuilt with openssl-0.9.8e
273
274* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
275- new upstream release
276
277* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
278- new upstream release
279
280* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
281- new upstream release
282- add pkgconfig file to devel package
283
284* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
285- new upstream release
286
287* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
288- new upstream release
289
290* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
291- new upstream release
292
293* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
294- added libidn, zlib in Requires
295- added libidn-devel, zlib-devel in BuildPrereq
296- added zlib-devel in curl-devel's Requires
297
298* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
299- added openssl-devel, libidn-devel in curl-devel's Requires
300
301* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
302- new upstream release
303
304* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
305- new upstream release
306- rebuild with openssl-0.9.7d
307
308* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
309- upstream release
310
311* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
312- add %%{_datadir}/curl/* to %%files section
313
314* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
315- source upgrade
316
317* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
318- source upgrade
319- add PreReq: ldconfig
320- add %%{_libdir}/*.la to %%files devel section
321
322* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
323- build for VineSeed
324- add Requires: openssl
325
326* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
327- automated rebuild
328
329* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
330- 7.9.2
331
332* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
333- include curl-config in curl-devel
334- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
335
336* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
337- added openssl-devel build req
338
339* Mon May 21 2001 Tim Powers <timp@redhat.com>
340- built for the distro
341
342* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
343- upgrade to curl-7.7.2.
344- enable IPv6.
345
346* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
347- rebuilt against openssl-0.9.6-1
348
349* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
350- fixed mising ldconfigs
351- updated to 7.5.2, bug fixes
352
353* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
354- updated to 7.5.1
355
356* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
357- update to 7.4.1 to fix bug #20337, problems with curl -c
358- not using patch anymore, it's included in the new source. Keeping
359  for reference
360
361* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
362- fix bogus req in -devel package
363
364* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
365- devel package needed defattr so that root owns the files
366
367* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
368- update to 7.3
369- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
370
371* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
372- enable SSL support
373- fix packager tag
374- move buildroot to %%{_tmppath}
375
376* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
377- fixed vendor tag for bug #15028
378
379* Mon Jul 24 2000 Prospector <prospector@redhat.com>
380- rebuilt
381
382* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
383- workaround alpha build problems with optimizations
384
385* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
386- rebuilt
387
388* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
389- put man pages in correct place
390- use %%makeinstall
391
392* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
393- updated to 6.5.2
394
395* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
396- updated sources to 6.2
397- gzip man page
398
399* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
400- changed group
401
402* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
403- changelog started
404- general cleanups, changed prefix to /usr, added manpage to files section
405- including in Powertools
Note: See TracBrowser for help on using the repository browser.