source: projects/specs/trunk/c/curl/curl-vl.spec @ 12223

Revision 12223, 13.9 KB checked in by tomop, 5 years ago (diff)

curl-7.66.0-1

RevLine 
[521]1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
[10740]3%if %{?_dist_release} != "vl6"
4%global with_http2 1
5%endif
6
[521]7Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
8Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
9Name: curl
[12223]10Version: 7.66.0
[10740]11Release: 1%{?_dist_release}
[7833]12
13License: MIT
[521]14Group: Applications/Internet
15URL: http://curl.haxx.se/
[11316]16Source: http://curl.haxx.se/download/%{name}-%{version}.tar.xz
[7833]17
[12131]18# avoid reporting spurious error in the HTTP2 framing layer (#1690971)
19Patch2:   0002-curl-7.65.3-h2-framing-layer-error.patch
20
[11840]21# patch making libcurl multilib ready
22Patch101: 0101-curl-7.32.0-multilib.patch
[11725]23
[7833]24# prevent configure script from discarding -g in CFLAGS (#496778)
[10071]25Patch102: 0102-curl-7.36.0-debug.patch
[11840]26
[11725]27# migrate tests/http_pipe.py to Python 3
28Patch103: 0103-curl-7.59.0-python3.patch
[11840]29
[7833]30# use localhost6 instead of ip6-localhost in the curl test-suite
31Patch104: 0104-curl-7.19.7-localhost6.patch
32
[12131]33# prevent valgrind from reporting false positives on x86_64
34Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
35
[521]36BuildRoot: %{_tmppath}/%{name}-%{version}-root
[11316]37BuildRequires: openssl-devel
38BuildRequires: gnutls-devel
39BuildRequires: libidn-devel zlib-devel
40BuildRequires: openldap-devel
[7833]41BuildRequires: openssh-server
[7033]42BuildRequires: openssh-clients
43BuildRequires: pkgconfig
[7833]44%if "%{?_dist_release}" != "vl6"
45BuildRequires: libssh2-devel
46%endif
[10740]47%if 0%{?with_http2}
48BuildRequires: libnghttp2-devel
49%endif
50
[7033]51Requires: ca-certificates
[521]52
[4261]53Vendor: Project Vine
54Distribution: Vine Linux
[7033]55Packager: daisuke
[4261]56
[521]57%description
58cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
59Dict servers, using any of the supported protocols. cURL is designed
60to work without user interaction or any kind of interactivity. cURL
61offers many useful capabilities, like proxy support, user
62authentication, FTP upload, HTTP post, and file transfer resume.
63
64%package devel
[890]65Summary: Files needed for building applications with libcurl.
[521]66Group: Development/Libraries
67Requires: %{name} = %{version}-%{release}
68Requires: openssl-devel libidn-devel zlib-devel
69
70%description devel
71cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
72Dict servers, using any of the supported protocols. The curl-devel
73package includes files needed for developing applications which can
74use cURL's capabilities internally.
75#'
76
77
78## to build compat32 for x86_64 architecture support
79%package -n compat32-%{name}
80Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
81Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
82Group: System Environment/Libraries
83
84%description -n compat32-%{name}
85cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
86Dict servers, using any of the supported protocols. cURL is designed
87to work without user interaction or any kind of interactivity. cURL
88offers many useful capabilities, like proxy support, user
89authentication, FTP upload, HTTP post, and file transfer resume.
90
91%package -n compat32-%{name}-devel
92Summary: Files needed for building applications with libcurl.
93Group: Development/Libraries
94
95%description -n compat32-%{name}-devel
96cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
97Dict servers, using any of the supported protocols. The curl-devel
98package includes files needed for developing applications which can
99use cURL's capabilities internally.
100#'
101
102%prep
103%setup -q
104
[11725]105# upstream patches
106
[7833]107# Fedora patches
108%patch101 -p1
109%patch102 -p1
[11840]110#patch103 -p1
[7833]111%patch104 -p1
[12131]112%patch105 -p1
[7833]113
[11725]114# make tests/*.py use Python 3
115sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
116
[11840]117# regenerate Makefile.in files
118aclocal -I m4
119automake
120
121# disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
122# with errno 98: Address already in use' in Koji environment), and test 1801
[11725]123# <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
[11840]124# and test 1900, which is flaky and covers a deprecated feature of libcurl
125# <https://github.com/curl/curl/pull/2705>
126printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
[11725]127
[11840]128# disable test 1319 on ppc64 (server times out)
129%ifarch ppc64
130echo "1319" >> tests/data/DISABLED
131%endif
132
133# temporarily disable test 582 on s390x (client times out)
134%ifarch s390x
135echo "582" >> tests/data/DISABLED
136%endif
137
138# adapt test 323 for updated OpenSSL
139sed -e 's/^35$/35,52/' -i tests/data/test323
140
[521]141%build
[7033]142%configure \
143  --with-ssl=%{_prefix} \
144  --with-libidn \
145  --enable-ipv6 \
146  --enable-threaded-resolver \
[11316]147  --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
[7833]148%if "%{?_dist_release}" != "vl6"
[7033]149  --with-libssh2 \
[7833]150%endif
[10740]151%if 0%{?with_http2}
152  --with-nghttp2 \
153%endif
[7033]154  --enable-ldaps \
[8211]155  --disable-static \
156  --enable-hidden-symbols
[7033]157
[521]158make %{?_smp_mflags}
159
160%install
161rm -rf $RPM_BUILD_ROOT
162make DESTDIR=$RPM_BUILD_ROOT install
163
164rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
165
166%clean
167rm -rf $RPM_BUILD_ROOT
168
169%post -p /sbin/ldconfig
170
171%postun -p /sbin/ldconfig
172
173%files
174%defattr(-,root,root)
[10740]175%{!?_licensedir:%global license %%doc}
[10632]176%license COPYING
177%doc CHANGES README
[521]178%doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
179%doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
180%doc docs/TheArtOfHttpScripting docs/TODO
181%{_bindir}/curl
182#{_datadir}/curl/*
183%{_libdir}/*.so.*
[7033]184%{_mandir}/man1/*.1*
[521]185
186%files devel
187%defattr(-,root,root)
188%{_bindir}/curl-config
189%{_includedir}/curl
190%{_libdir}/*.so
191%{_libdir}/pkgconfig/*.pc
192%{_mandir}/man1/curl-config.1*
193%{_mandir}/man3/*
[8211]194%{_datadir}/aclocal/libcurl.m4
[521]195
196
197## to build compat32 for x86_64 architecture support
198%if %{build_compat32}
199%files -n compat32-%{name}
200%defattr(-,root,root)
201%{_libdir}/*.so.*
202
203%files -n compat32-%{name}-devel
204%defattr(-,root,root)
205%{_libdir}/*.so
206%{_libdir}/pkgconfig/*.pc
207%endif
208
209%changelog
[12223]210* Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
211- new upstream release.
212- dropped Patch1 and 2: fixed in upstream.
213
[12131]214* Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
215- new upstream release.
216- updated patches.
217- imported Patch1, 2 and 105 from rawhide.
218
[11840]219* Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
220- new upstream release.
221- imported patches from rawhide.
222
[11725]223* Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
224- new upstream release.
225- imported Patch1 and 103 from rawhide.
226
[11470]227* Wed Feb  7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
228- new upstream release with security fix
229- update patch101
230
[11316]231* Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
232- new upstream release.
233- updated Patch101-104.
234- dropped Patch107.
235
[11062]236* Mon May  1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
237- new upstream release.
238
[10933]239* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
240- new upstream release.
241
[10847]242* Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
243- new upstream release.
244
[10740]245* Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
246- new upstream release.
247- disabled HTTP/2 on Vine6.
248
[10632]249* Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
250- added HTTP/2 support.
251
[10418]252* Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
253- new upstream release with security fix.
254
[10302]255* Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
256- new upstream release.
257
[10071]258* Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
259- new upstream release
260- built with openssl 1.0.2g
261
[9628]262* Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
263- new upstream release with security fix .
264- removed Patch108 (fixed in upstream).
265
[9068]266* Sun Nov  9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
267- new upstream release with security fix
268
[8211]269* Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
270- new upstream release
271- add libcurl.m4 to -devel package
272
[7833]273* Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
274- new upstream release
275- import upstream/fedora patches
276- disable libssh2 on Vine Linux 6
277
[7175]278* Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
279- new upstream reelase
280
[7033]281* Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
282- update to 7.28.0
283- add configure options
284  - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
285- add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
286 
287- use ca-certificates package
288  - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
289  - R: ca-certificates
290
[5734]291* Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
292- new upstream release
293
[4261]294* Sun Jul  3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
295- add patch100 for fix CVE-2011-2192 (gssapi)
296- add Vendor/Distri tags
297
[2487]298* Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
299- rebuild with openssl-1.0.0c
300
[1919]301* Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
302- rebuilt with rpm-4.8.1 for pkg-config
303
[890]304* Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
305- new upstream release
306
[521]307* Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
308- new upstream release with security fix
309
310* Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
311- added compat32 subpackages
312
313* Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
314- new upstream release
315- use "_smp_mflags" flag
316
317* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
318- rebuild with openldap-2.4.11
319- add BR: openldap-devel
320- remove static library
321
322* Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
323- new upstream release with security fix (CVE-2009-0037)
324
325* Sun Jul  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
326- new upstream release
327
328* Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
329- new upstream release
330
331* Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
332- new upstream release
333
334* Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
335- new upstream release
336
337* Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
338- new upstream release
339
340* Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
341- rebuilt with openssl-0.9.8e
342
343* Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
344- new upstream release
345
346* Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
347- new upstream release
348
349* Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
350- new upstream release
351- add pkgconfig file to devel package
352
353* Wed Dec  7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
354- new upstream release
355
356* Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
357- new upstream release
358
359* Fri Sep  2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
360- new upstream release
361
362* Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
363- added libidn, zlib in Requires
364- added libidn-devel, zlib-devel in BuildPrereq
365- added zlib-devel in curl-devel's Requires
366
367* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
368- added openssl-devel, libidn-devel in curl-devel's Requires
369
370* Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
371- new upstream release
372
373* Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
374- new upstream release
375- rebuild with openssl-0.9.7d
376
377* Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
378- upstream release
379
380* Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
381- add %%{_datadir}/curl/* to %%files section
382
383* Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
384- source upgrade
385
386* Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
387- source upgrade
388- add PreReq: ldconfig
389- add %%{_libdir}/*.la to %%files devel section
390
391* Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
392- build for VineSeed
393- add Requires: openssl
394
395* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
396- automated rebuild
397
398* Wed Jan  9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
399- 7.9.2
400
401* Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
402- include curl-config in curl-devel
403- update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
404
405* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
406- added openssl-devel build req
407
408* Mon May 21 2001 Tim Powers <timp@redhat.com>
409- built for the distro
410
411* Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
412- upgrade to curl-7.7.2.
413- enable IPv6.
414
415* Fri Mar  2 2001 Tim Powers <timp@redhat.com>
416- rebuilt against openssl-0.9.6-1
417
418* Thu Jan  4 2001 Tim Powers <timp@redhat.com>
419- fixed mising ldconfigs
420- updated to 7.5.2, bug fixes
421
422* Mon Dec 11 2000 Tim Powers <timp@redhat.com>
423- updated to 7.5.1
424
425* Mon Nov  6 2000 Tim Powers <timp@redhat.com>
426- update to 7.4.1 to fix bug #20337, problems with curl -c
427- not using patch anymore, it's included in the new source. Keeping
428  for reference
429
430* Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
431- fix bogus req in -devel package
432
433* Fri Oct 20 2000 Tim Powers <timp@redhat.com>
434- devel package needed defattr so that root owns the files
435
436* Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
437- update to 7.3
438- apply vsprintf/vsnprintf patch from Colin Phipps via Debian
439
440* Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
441- enable SSL support
442- fix packager tag
443- move buildroot to %%{_tmppath}
444
445* Tue Aug 1 2000 Tim Powers <timp@redhat.com>
446- fixed vendor tag for bug #15028
447
448* Mon Jul 24 2000 Prospector <prospector@redhat.com>
449- rebuilt
450
451* Tue Jul 11 2000 Tim Powers <timp@redhat.com>
452- workaround alpha build problems with optimizations
453
454* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
455- rebuilt
456
457* Mon Jun 5 2000 Tim Powers <timp@redhat.com>
458- put man pages in correct place
459- use %%makeinstall
460
461* Mon Apr 24 2000 Tim Powers <timp@redhat.com>
462- updated to 6.5.2
463
464* Wed Nov 3 1999 Tim Powers <timp@redhat.com>
465- updated sources to 6.2
466- gzip man page
467
468* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
469- changed group
470
471* Thu Aug 26 1999 Tim Powers <timp@redhat.com>
472- changelog started
473- general cleanups, changed prefix to /usr, added manpage to files section
474- including in Powertools
Note: See TracBrowser for help on using the repository browser.